• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][STOCK][Silent OS 3.0.14] Blackphone 2 (BP2) + ROOT

Search This thread


Senior Member
Dec 6, 2008
I don't know what's happening but root doesn't work!!!
I don't have twrp (black screen) so i'm using command
fastboot.exe boot twrp-3.4.0-0-bp2.img
to just run it.
Then i put Magisk-v21.0.zip on sdcard and use command
twrp install /sdcard/Magisk-v21.0.zip
from adb shell

Everything goes well. I can open Magisk manager and it says that module installed. Also I have security alert that i have active root and it's dangerous blablabla.
But it doesn't work!
Total commander, root uninstaller, lucky patcher, titanium backup they all says me "you don't have root".

How it's possible? It's just for a first time for me. Usually it works like 1..2...3... done!

Tried 3.0.14 version. Flashed reflashed a few times. Tried BP2-OTA-3.0.7-RC3-candidate-ROW-1482330514.zip
the same here.

Appreciate any help!
Thanks in advance!

Top Liked Posts