• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] STRATOSfied AmazFit | AmazFit 2 / AmazFit STRATOS | rel 28 | 2.0.55.0

Search This thread

Neuer_User

Senior Member
Jul 16, 2010
1,090
2,524
NOTE: I am currently extremely busy with work. Therefore, I can only irregularly participate here and updates will currently not be on a weekly basis.

Please take also note, that I currently only very rarely read my PMs. Best way to contact me concerning any contributions or bug reports is via the Gitlab repo.


Dear all

This is a custom ROM for the Huami AmazFit Smartwatch 2 (A1609) and the international Xiaomi AmazFit STRATOS (A1619).
The ROM is fully functional, but may contain bugs.

FEATURES:
  • Based on Chinese firmware everest-2.0.55.0 development firmware
  • additional translations:
    - Italian (thanks to Nicola and @N3OMOD)
    - Slovak (thanks to @jasterica, @rbt07(rbarat) and @morgan_007(Roman))
    - Polish (thanks to @Kaudii)
    - Czech (thanks to @zbani and @rbt07(rbarat))
    - Spanish (thanks to @Alain and @saratoga)
    - Russian (thanks to @silver-alx and @Kagashini)
    - French (Thanks to ericmo and Cyril)
    - German (Thanks to Klaus H. and others)
    - Hungarian (Thanks to gidano)
    - Brazilian
    - Basque (thanks to @iker)
    - Hebrew (thanks to Uri and @1immortal)
    - first Dutch translation (thanks to Ronny Gyles)
    - Turkish (Thanks to ygecesefa and @HiddeNKinG)
  • additional fonts added
    - Hebrew font (thanks to @itsay)
    - Arabic fonts (thanks to @1immortal) -> re-added
    - Tamil fonts (thanks to @madtech360)
    - Thai fonts
    - Korean fonts
    - Khmer fonts (thanks to Piseth)
    - updated fonts for Bidirectional language support with enable/disable function (see FAQ #14)
    - additional (missing) UTF-8 characters for the standby screen (thanks to Roman)
  • rootable with su pre-installed (call "root_amazfit" to enable or disable)
  • English voices in Sports app (thanks to @Fabien and Luiz Felipe)
  • Updated tzdata (thanks to Alvaro)
  • command to change Bluetooth max volume to maximum (btVolBoost)
  • initd system to run customer script upon boot
  • uses old key mapping logic (thanks to @Saratoga79) (if you prefer the new mapping, please tell me)

PERMANENT INSTALL:
Please find all information here: https://gitlab.com/Neuer_User/PACEfied_AmazFit/wikis/permanent-install

ATTENTION: You need to have an unlocked bootloader or run on a rooted ROM (such as PACEfied) for installing this ROM.

Community Project code:
The source code used to build the translated apps is available on the following GitLab repo:
https://gitlab.com/Neuer_User/PACEfied_AmazFit
If people want to contribute, log in, have a look around, download the files you want to translate, and send me the translated files, so I can include them.

Downloads:
Rel 28: Full install Version 2.0.55.0: https://mega.nz/#!JQ9QgCAT!CTgUQ4nwSOk3g9Nk7N08MM4Jg4yQ2D9mXMhMtMq4rKQ


Older versions:
Rel 27: Full install Version 2.0.53.0: https://mega.nz/#!McsWEASD!yvMJw6HxpsWTVaCTKoOZ1jxRX6Zx-6ILwd2rYmAfIEc
Rel 26: Full install Version 2.0.52.0: https://mega.nz/#!ZY0BQCaZ!cQkrXY1DwMbYkDbFL-AfCaVg8qKqdMx-6o1Q1Lnw1uA
Rel 25: Full install Version 2.0.51.0: https://mega.nz/#!MIVXnIjI!GKOq-4cv92W7MHo_OWeftLo3EVwLofwr_oev-0tyPcM
Rel 24: Full install Version 2.0.46.0: https://mega.nz/#!lQsAUQRS!rJE0snFwhiDKpivtR_axCTDybkSVz6dvvvH0Cx2Kue0
Rel 22: Full install Version 2.0.43.0: https://mega.nz/#!BA0xyKLL!xnf7rJXgDmc9XtFsFKvR-KDiRSK7e3S77z6Rnb0gswM
Rel 21: Full install Version 2.0.42.0: https://mega.nz/#!tYd2GIqL!4DI68IPj64vh-mNtH8qZFipviOrfjcOqoNeon19CprU
Rel 20: Full install Version 2.0.41.0: https://mega.nz/#!pcsjBQIS!gbR-B-22AqDgqBk7ZRIWU5IT5Sy-BPLFV0n46VgpTHg
Rel 19: Full install Version 2.0.38.1: https://mega.nz/#!9ZUUDaJb!ZpF0UMy-4lv9vofHl7vkfnwAYAGEALRSPmd9gq0xw84
Rel 18: Full install Version 2.0.37.0: https://mega.nz/#!1ZET3IJZ!95tuSk5IXrvGXO_o-Q3b3-JRCmYI2Qt3AcrftVJTJqc
Rel 17: Full install Version 2.0.36.0: https://mega.nz/#!BZVFHAIS!xIerjt76Z9E1ZcCe8F0EDjPOJQ6HDNgXW7mByZyoVmY
Rel 16: Full install Version 2.0.35.0: https://mega.nz/#!pE9x1aZI!pAbuabwb9ZduewK4Sq3v7mQY2U3TyrNX67HC4YsTzoE
Rel 15: Full install Version 2.0.34.0: https://mega.nz/#!QVEUWSyI!AyOiBfyEvVIFExx6JT0G2Hb8V330r2vMj_3HlscTVAk
Rel 14: Full install Version 2.0.32.0: https://mega.nz/#!AMNwBSjZ!DNg-GjAxaf2pR1oNoislxMa6k9-Uk7WPykTv9LN_wPY
Rel 13: Full install Version 2.0.29.0: https://mega.nz/#!AdMWDYrJ!kxv2cejmXHH1EOa9x4dJc9XWRGTy8xjokZVy-DV33u0
Rel 12: Full install Version 2.0.28.0: https://mega.nz/#!IFlymYYS!l0E9OHIVExE7KPq_VBBYW0ym23RzZE0yigKkv4Xc_1M
Rel 11: Full install Version 2.0.27.0: https://mega.nz/#!dEsXUTLb!7KbWkcTg4kCM3ocwKTNNhzP9m-DKTq3_uHLBiC_SoS0
Rel 10: Full install Version 2.0.24.0: https://mega.nz/#!RcMVnAoR!K3eVKbdtinJFRB5HyII0IMntES1hn0uhAdXj8gSEwXo
Rel 8: Full install Version 2.0.22.0: https://mega.nz/#!hQkmBTjJ!7ktECZVsI5vUxxKkR6-wkXBFEURmTUX3OKcwUSgBDEg
Rel 7: Full install Version 2.0.17.1: https://mega.nz/#!BF9kgbpT!oa5DTtOM2AMPCB-MERhp3Z_CNmJfAeHM7YBpl7sqOrA
Rel 6: Full install Version 2.0.15.0: https://mega.nz/#!5VliyDwC!MkbbW_pL1TkJmRhOLIL9dX0WbkcPd-PT7TLBR80jQ4A
Update from Rel 5 to Rel 6: https://mega.nz/#!NMMkwQ6a!iRflTU_V8sMVxgW6E5LPX4VFQKxjKpSiW6B41IosjbY
Rel 5: Full install Version 2.0.14.0: https://mega.nz/#!8Js2iI7Z!jng4DfeL5hkGJjSSIPtEJNpxiu1IOjKpoI3K_K3rods
Update from Rel 4 to Rel 5: https://mega.nz/#!JMMj2SSZ!DgXuk-9CPAjESZcVf4t1xIE7hSR3ZWHFq6y_yj46sns
Rel 4: Full install Version 2.0.13.0: https://mega.nz/#!URlj1YBB!dt1kCysDX4Fl0SyFmdhwkDpW_nTpI3ynKDjPXRSbz4g
Rel 3: Full install Version 2.0.11.1: https://mega.nz/#!VZc3gRBI!4Scb1CBh6ApuoQ6BiNDanS8GWvGyOpJPc_-YyWjt4cs
Update from Rel 2 to Rel 3: https://mega.nz/#!RMElGIZI!Tk9Bmil8t1rlUUvQRqT-4_4KyXFGeL7gxcCuXH7Qy9A
Rel 2: Full install Version 2.0.10.0: https://mega.nz/#!IQNVBLqC!bZM8CgQ5qvALCoCR-jsEihAUXsBeyelB2TXW8YO26Rw
Update from Rel 1 to Rel 2: https://mega.nz/#!sFVymaYa!y5wmz5Llt8PHsUHnKRyN85AtTU3vQzbNz8_28upWiAY
Rel 1: Full install Version 2.0.9.0: https://mega.nz/#!URs33QpZ!B5nabel1OgcOjmf7xlI2V59EVCVeKmfFYaf8WsjPdVk
 
Last edited:

Neuer_User

Senior Member
Jul 16, 2010
1,090
2,524
I am unable to boot(stuck in the spinning circles for 15 min).I flashed after clearing data from Stratos 1 rom.Any ideas?
Yes, could be a signature problem. Try this:
Code:
adb root
adb shell rm /data/system/packages.xml
adb reboot

EDIT: I did not have that problem, and @1immortal also not. But he came from Nicolas ROM and needed to do a factory reset.

I tried to run the ROM on the PACE, too. There I needed to remove the package signatures (with above rm command). Therefore, maybe you also have that issue.
 
Last edited:
  • Like
Reactions: Raptor84

Neuer_User

Senior Member
Jul 16, 2010
1,090
2,524
Will you be able to take advantage of some translations from Pace to Stratos 2?

Yes, all translations are taken from the PACEfied project.

I am thinking how I can best ensure stability and keep the translations in sync in the future. I have some ideas, but all of them take quite some time (which, as always, is very limited for me).
 

Talleco16

Member
Jul 10, 2017
12
0
Yes, all translations are taken from the PACEfied project.

I am thinking how I can best ensure stability and keep the translations in sync in the future. I have some ideas, but all of them take quite some time (which, as always, is very limited for me).

Is installation process equal to pace 1? If you install this beta, will you get the PT BR?
 

Lumpka21

Member
Aug 31, 2016
18
2
adb shell setprop persist.sys.language en
adb shell setprop persist.sys.country PL

At the begging it didnt work, but looks like it works now. Thanks man.

---------- Post added at 08:38 PM ---------- Previous post was at 07:54 PM ----------

Okay, i have problem that i didnt have before the update. Watch work almost perfectly, but the the backlight is not turning on when unlocking the watch.

Found out the resolution, few reboots helped.
 
Last edited:

erykosky

New member
Mar 5, 2018
1
0
Also stuck on spinning circles

Hey, i'm also stuck in spinning circles screen. Trying to delete packages.xml didn't help. Is there any logs i can look into or any things to do?
 

Top Liked Posts