• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][T320][T325][UNOFFICIAL] LineageOS 17.1 | Android 10.0 Q 20210419

Search This thread

bbiigg

Member
Dec 8, 2015
36
0
Los Angeles
Wow! Just brought my Tab pro back to life. I was using RR rom a while back and it just kept giving me problems w booting. Since then Twrp has stepped up to image flashing and, well... Amazing. So much more usability. Flashed the latest Lineage 18.1 I believe. Had trouble finding the right gapps, bitgapps finally worked and everything is pretty smooth so far. I'm gonna have to play with it for a while. So much has changed since my last flash. Do we still need Supersu? Can you flash from within the OS? There's an app for Twrp!? I'm so out of date its a miracle I got it up n running.
 

myarnav

Member
Mar 15, 2014
8
0
As I wrote, if Lineage recovery can flash a .zip onto its own partition, this should work.
TWRP can overwrite its own version.
Maybe you're the first to try.
Haven't much to loose, have you?
As long as it isn't found by Odin via USB you can't even go back to stock in order to start from scratch.
Can you post a pic of lineage recovery options?

Edit as I've found a pic: advanced options are which?

Thanks for the response. Earlier I was seeing "Enable adb" in advanced boot options, now this is not showing.

I was able to flash LIneage 17 Rom with BiTGApps: https://forum.xda-developers.com/t/custom-gapps-bitgapps-for-android.4012165/ and avoid the system memory issues (Error 70) faced while installing Gapps.

Now the tablet is booting and functioning well with
1. No mic
2. No usb connection except charging
3. Noticed battery backup has reduced from 8+ hours screentime to 4+ hours screentime with same conditions
 

myarnav

Member
Mar 15, 2014
8
0
@myarnav Gapps are not! needed for booting the system.
If it doesn't boot, it's not installed correctly.
Tried flashing another ROM/download?
And please provide more information about settings.
KIES installed?
Which Odin used?
Tried full wipe + "Format Data" or equivalent in Lineage recovery before flashing?
Thanks for helping @bmwdroid. I was able to flash lineage recovery, after flashing some other rom. Not sure why this was not flashing earlier. Also I looked up LIneage os 18 thread and found BitGapps and was able to flash Lineage 17 with BitGapps. Thanks so much for help.

Used odin 3.13.1
no kies installed, will try installing this
Yes tried full wipe + format data wiht lineage recovery but this did not solve for Error 70 (only way out was installing BitGapps which takes ~80 MB as opposed to ~125MB taken by Gapps Pico build)

Still in this Rom I do not have
1. working mic for hangouts / telegram calls etc.
2. Reduced battery (maybe its because of BitGapps)
3. No Twrp as recovery option
4. No root since unable to flash Magisk ( getting Error 21 saying Signature verification failed > with Lineage OS recovery)

Scared to flash twrp.zip file with lineage recovery , and what will happen as a result?
 
Last edited:
Thanks for helping @bmwdroid. I was able to flash lineage recovery, after flashing some other rom. Not sure why this was not flashing earlier. Also I looked up LIneage os 18 thread and found BitGapps and was able to flash Lineage 17 with BitGapps. Thanks so much for help.

Used odin 3.13.1
no kies installed, will try installing this
Yes tried full wipe + format data wiht lineage recovery but this did not solve for Error 70 (only way out was installing BitGapps which takes ~80 MB as opposed to ~125MB taken by Gapps Pico build)

Still in this Rom I do not have
1. working mic for hangouts / telegram calls etc.
2. Reduced battery (maybe its because of BitGapps)
3. No Twrp as recovery option
4. No root since unable to flash Magisk ( getting Error 21 saying Signature verification failed > with Lineage OS recovery)

Scared to flash twrp.zip file with lineage recovery , and what will happen as a result?
DON'T INSTALL KIES, I wasn't recommending it just wanted to know if it's installed.

Btw. nobody! can tell what "will" happen, only what should or is hoped to.

Didn't answer my question for Lineage recovery "advanced options" a few posts before.
I just know that TWRP asks to which partition (boot or recovery) you wanna flash another TWRP version but lineage recovery idk.

Which Magisk did you try? I recommend 20.4 and update afterwards.

Why are you insisting on 17.1 as 18.1 is out?
 
  • Like
Reactions: pocketrule

myarnav

Member
Mar 15, 2014
8
0
DON'T INSTALL KIES, I wasn't recommending it just wanted to know if it's installed.

Btw. nobody! can tell what "will" happen, only what should or is hoped to.

Didn't answer my question for Lineage recovery "advanced options" a few posts before.
I just know that TWRP asks to which partition (boot or recovery) you wanna flash another TWRP version but lineage recovery idk.

Which Magisk did you try? I recommend 20.4 and update afterwards.

Why are you insisting on 17.1 as 18.1 is out?

Since I am not able to clear system partition using lineage os recovery I am not sure whether I will be able to install bitgapps again

I notice my tab is running CPU at 100 percent at all times hence battery is reducing 1 percent every 2 minutes
 

Attachments

  • Screenshot_20210605-111636_Cpu_Monitor.png
    Screenshot_20210605-111636_Cpu_Monitor.png
    363 KB · Views: 21

myarnav

Member
Mar 15, 2014
8
0
DON'T INSTALL KIES, I wasn't recommending it just wanted to know if it's installed.

Btw. nobody! can tell what "will" happen, only what should or is hoped to.

Didn't answer my question for Lineage recovery "advanced options" a few posts before.
I just know that TWRP asks to which partition (boot or recovery) you wanna flash another TWRP version but lineage recovery idk.

Which Magisk did you try? I recommend 20.4 and update afterwards.

Why are you insisting on 17.1 as 18.1 is out?
I tried magisk version 23

Advanced recovery I see 1. Boot to bootloader 2. Boot to recovery 3. Enable adb ( only with recovery when lineage 11 is installed ) 4. Wipe system ( only with lineage 11 recovery) 5. Wipe data &cache

On your suggestion installed lineage 11 with bitgapps and again the battery consumption was very high (1% loss every 2 mins ). I think bitgapps has some battery issues when used with lineage , not sure but definitely an issue on my tablet.

Finally I tried lineage 16 and with it I am able to install gapps pico. Battery backup is the best I seen to date ( 8-10% per hour, 1% use every 4- 7 minutes in battery saving mode) . with this I am getting a screen on time of 7-10 hours even more than what I was getting when I purchased this tablet

Lineage 16 also has root hence i got even twrp back as revovery using twrp app.

Thanks a ton for helping , I guess the mic is still not great will check with mix path file change
 
Last edited:

Mr.Norton

New member
Dec 16, 2020
4
0
Dear developers, please fix the sound error in 3D games, after watching ads in the game and returning to the game, the sound doubles, after watching ads, the sound triples and slows down a little, you can hear a quiet intermittent crackling in the speakers. After a few seconds, it looks like a multiple echo. Colt OS 6.5 is the same. Both are based on android 10. Everything is fine on Lienage OS16. Tested on three t320s and one t325. I reflashed it several times. Thanks for your work!
 

tamtam22

New member
Jun 24, 2021
1
0
Hello everybody,
I have set up LineageOS 17.1 on my T320 and unfortunately cannot connect to the 2.4ghz wlan.
The 5 ghz wlan works perfectly but the range is very limited for me. Therefore I would like to use the 2.4 GHz. Since I have already checked my router and the connection to other devices works perfectly. I assume that it is due to the system. I hope you can help me or give me a few tips.
Best regards

tamtam22
 

genericfu

Member
Apr 11, 2015
34
36
Dear developers, please fix the sound error in 3D games, after watching ads in the game and returning to the game, the sound doubles, after watching ads, the sound triples and slows down a little, you can hear a quiet intermittent crackling in the speakers. After a few seconds, it looks like a multiple echo. Colt OS 6.5 is the same. Both are based on android 10. Everything is fine on Lienage OS16. Tested on three t320s and one t325. I reflashed it several times. Thanks for your work!
See if turning off AudioFX helps:
 
Last edited:
  • Like
Reactions: pocketrule

Top Liked Posts