[ROM][T820][8.x] LineageOS 15.1 20180614

Search This thread

bonuzzz

Senior Member
Apr 1, 2005
770
1,760
I'm not responsible for any damage to your device of any sort.
By flashing this you take responsibility of anything that happens.
Process at your own risk!


LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community

Requirements:
- oreo bootloader
- twrp 3.2.0+
- backup everything before install
- wipe data before upgrading from LineageOS 14.1 or stock rom

Install:
- Flash zip in TWRP
- Don't forget about gapps (arm64 8.1)
- Root not included. Flash magisk before first start.

Google apps should be installed via recovery immediately after installing ROM.
If you reboot into ROM before installing Google apps, you must factory reset and then install them, otherwise expect crashes.

Not working:
gps
bt audio
stuff, I haven't checked

I broke my tablet. There are no more updates here further.

Download:
T820: https://drive.google.com/open?id=1ql4VIjTsSHNwzsoJm3Yb8wt0RW9OJerE

Device initial config sources:
https://github.com/bonuzzz
 
Last edited:

Kagathblade

New member
Jun 14, 2018
1
0
I was about to sell tablet...and get pixil c. Tablet is extremely laggy on stock Oreo. Switched back to your lineage 14.1 build which runs well but realized it was no longer supported. Very happy with your work! Thanks!
 

JWnSC

Senior Member
Jul 9, 2010
506
278
Virginia Beach
I'll give it a go when I get home. Thanks for supporting our device!

I did switch off WiFi upon initial setup, didn't seem to be liking 5g. After setup I switched to 5g WiFi but it kept showing no internet. My other devices don't have this problem. Not a big deal, just giving a heads up. I switched to 2g WiFi and all is well. Wayyyy smoother than stock Oreo. Didn't test gps, I know you said it wasn't working. I don't use GPS on my tablet so no loss there. Thanks again!

For gapps it shows "arm 8.1" it should be "arm64 8.1"

Edit: 5g seems to be working fine after a resetting WiFi, mobile & Bluetooth. Still can't seem to get audio playing through Bluetooth even though it's connected.
 
Last edited:

PuDLeZ

New member
Apr 23, 2017
3
3
Cool! I will be installing this shortly. I was going to switch the the tweaked stock Oreo but will much rather use Lineage since I prefer more of a "vanilla Android" over Samsung's version.

P.S. I recently got myself a pixelbook for chromeos+android+linux and I find myself using that way more than my tab s3. If you need anyone to test something that doesn't really care about stability, let me know!


Edit:
Just wanted to let people know of what I've initially noticed and tested.
* Not laggy like stock is
* Able to format sd card for internal storage
* Official Keyboard case works (didn't use much before)
- show/hide key for virtual keyboard and Lang key don't do anything (at least it appears that way)
- Left 'alt' brings up emoji, right 'alt' brings up symbols on virtual keyboard.
* Auto wake/sleep works with 3rd party case (assume all work since it's just a magnet)
* Auto brightness works but I tested it with a flash light.
 
Last edited:
  • Like
Reactions: VVombat and JWnSC

HardWorker79

New member
Jan 10, 2018
4
3
I liked the 14.1 version and I seem to like this version as well. It is to early to say more, but why can't you share this with lineage? It would be a dream, if this would be official and we would recieve updates. And maybe they will help you with the missing GPS?
 

Veritas06

Senior Member
Mar 17, 2008
598
36
v3ritas.tech
Thanks so much for this. I've been wanting to get an Oreo ROM like this for my S3

EDIT: Is there any chance you could just give a dump of your terminal session of the build? I had started to try & build 15.1 for the S3 WiFi, based on your work for the LTE version, but wasn't having any luck. I'm hoping that if you could provide a terminal dump, it could help me work through my issues to get the build working as well. Would appreciate it =]

Regardless, thanks for taking the time to build this for us WiFi owners! =D
 
Last edited:

VVombat

Senior Member
Oct 6, 2012
52
14
Thank you so much for this! Testing this weekend.
Just wanted to let people know of what I've initially noticed and tested.
* Not laggy like stock is
* Able to format sd card for internal storage
* Official Keyboard case works (didn't use much before)
- show/hide key for virtual keyboard and Lang key don't do anything (at least it appears that way)
- Left 'alt' brings up emoji, right 'alt' brings up symbols on virtual keyboard.
* Auto wake/sleep works with 3rd party case (assume all work since it's just a magnet)
* Auto brightness works but I tested it with a flash light.
Did you test the spen by any chance?
 

PuDLeZ

New member
Apr 23, 2017
3
3
Thank you so much for this! Testing this weekend.

Did you test the spen by any chance?

I didn't have software installed that I could use it in but I did put it to the home screen and got the circle indicator of where the tip is so it registers. Of course, there was no Samsung menu... Anything specific you want me to try this evening?
 
  • Like
Reactions: VVombat

VVombat

Senior Member
Oct 6, 2012
52
14
I didn't have software installed that I could use it in but I did put it to the home screen and got the circle indicator of where the tip is so it registers. Of course, there was no Samsung menu... Anything specific you want me to try this evening?

Mhm I'm using mainly Squid and Xodo to annotate and notate stuff. If you have them laying around anyways that would be nice, but if not no need to install and waste your time if I'll install tomorrow anyways. Thank you for your answer!
 

Comses

Member
Mar 28, 2013
8
2
Good afternoon. Everything works fine, the stylus in all orientations, the AnTuTu test runs fine and there is no understating of indicators on both stock, Wi-Fi is excellent, both 2.4 GHz and 5 GHz.

There are only 2 inconveniences
- Stereo sound from speakers is only in portrait orientation, and landscape channels do not change. Can you make a patch or fix yourself, you can not even change the channels when you turn, but only make a stereo Sound in landscape orientation (videos and movies often look into it);
- No sound goes to the Bluetooth headphones.

In any case, the firmware is super, thank you very much for the work done.
 
  • Like
Reactions: Phyck Yiu

bonuzzz

Senior Member
Apr 1, 2005
770
1,760
For gapps it shows "arm 8.1" it should be "arm64 8.1"

Edit: 5g seems to be working fine after a resetting WiFi, mobile & Bluetooth. Still can't seem to get audio playing through Bluetooth even though it's connected.
edited, thanks
yes, bt audio doesn't work. seems I broke it in last moment...

Just wanted to let people know of what I've initially noticed and tested.
* Not laggy like stock is
* Able to format sd card for internal storage
* Official Keyboard case works (didn't use much before)
- show/hide key for virtual keyboard and Lang key don't do anything (at least it appears that way)
- Left 'alt' brings up emoji, right 'alt' brings up symbols on virtual keyboard.
* Auto wake/sleep works with 3rd party case (assume all work since it's just a magnet)
* Auto brightness works but I tested it with a flash light.
I have official keyboard case too. Unfortunately it's almost unusable in aosp if you need more than one keylayout. What about special keys, aosp doesn't have that triggers what stock rom has. I only could advice 3rd party app, but paid https://forum.xda-developers.com/showthread.php?t=1541916

I liked the 14.1 version and I seem to like this version as well. It is to early to say more, but why can't you share this with lineage? It would be a dream, if this would be official and we would recieve updates. And maybe they will help you with the missing GPS?
Nothing will change with official status except It would create more troubles and bureaucracy there.
Nobody will help. Believe me.
 

bonuzzz

Senior Member
Apr 1, 2005
770
1,760
Good afternoon. Everything works fine, the stylus in all orientations, the AnTuTu test runs fine and there is no understating of indicators on both stock, Wi-Fi is excellent, both 2.4 GHz and 5 GHz.

There are only 2 inconveniences
- Stereo sound from speakers is only in portrait orientation, and landscape channels do not change. Can you make a patch or fix yourself, you can not even change the channels when you turn, but only make a stereo Sound in landscape orientation (videos and movies often look into it);
- No sound goes to the Bluetooth headphones.

In any case, the firmware is super, thank you very much for the work done.

I have an issue somewhere in audio behavior. Will check it deeper.

Another problem, the sound slows down and stutters in applications (heavy or simple games)
in games only? I've not noticed anything in videos.

Doesn't work for me.

What I did from Lineage 14.1:

- Upgraded TWRP to v3.2.1.1
- Wiped eveything
- Downloaded BRE2 firmware for my country
- Extracted BL....tar.md5 and flashed it with Odin v3.13.1
- Rebooted in recovery mode to be sure of... still don't know what
- Flashed Lineage 15.1
Then I could see the logo animation until the end, just before the system starts, then 3 boot loops and it went to recovery mode
I repeated the exact same sequence and flashed SuperSU v2.82-SR5, same result.

So...:
- Wipe everything
- Flash BL, CSC and CSC_HOME (no need of AP, system partition) with Odin
- Format/Erase Data
- Flash Lineage 15.1
Again a boot loop, this time without going back automaticaly to recovery mode.
Tried with SuperSU, boot loop...

So... This time I flashed eveything, reboot with Samsung Android, test a little bit, then:
- Flash TWRP v3.2.1.1
- Immediatly reboot to recovery mode
- Format/Erase Data
- Wipe everything
- Flash Lineage 15.1
Boot loop...
Tried with SuperSU, boot loop...

I was able to restore a full backup of my previous Lineage 14.1 installation.

What did I do wrong and which kind of logs do you need to help me to understand?

Thank you and thank you to have integrated S-Pen support, I love this thing. I don't realy need GPS.

Edit: in case it was mandatory I tried with Magisk v16.0 and v16.4 instead of SuperSU. Same boot loop.

If it's because I didn't flash the GAPPS, well... nevermind... I'll wait for something else.
Magisk is needed for device certification in Play store. That's because it should be flashed with gapps before first boot. So, rom works without gapps and root well.
For what region you downloaded oreo stock rom? I doubt but maybe samsung has different logic in bootloader for relocatable kernel stuff. It's strange how you restored lineage nougat, because that kernel shouldn't work with oreo bootloader.

edit: i'm wrong about bootloader and nougat, because I use now old twrp with nougat kernel.
 
Last edited:

samsuffit

Member
Dec 12, 2017
19
12
Hello @bonuzzz, thank you for the reply.

I was able to restore my Lineage 14.1 because I flashed the ARA2 boot loader (tried with Odin the first time, then with my TWRP backup, same result)

If someone used or uses lineageos 14.1, is speaker rotation work there or not?

Only with VLC. Stuck in portrait mode with stock player. I don't have any games... :)



The last thing I need to try is installing the GAPPS... Like I said, I don't want to, so if the problem comes from this, I'll pass. But I have to try to be sure...

In this order from TWRP:
- Flash BRE2 boot loader
- Format Data and wipe everything
- Flash Lineage 15.1
- Flash openGAPPS nano arm64 8.1
- Flash Magisk 16.4

And... It's working...

Well... :D

I want to cry...

So the GAPPS are mandatory.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 21
    I'm not responsible for any damage to your device of any sort.
    By flashing this you take responsibility of anything that happens.
    Process at your own risk!


    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community

    Requirements:
    - oreo bootloader
    - twrp 3.2.0+
    - backup everything before install
    - wipe data before upgrading from LineageOS 14.1 or stock rom

    Install:
    - Flash zip in TWRP
    - Don't forget about gapps (arm64 8.1)
    - Root not included. Flash magisk before first start.

    Google apps should be installed via recovery immediately after installing ROM.
    If you reboot into ROM before installing Google apps, you must factory reset and then install them, otherwise expect crashes.

    Not working:
    gps
    bt audio
    stuff, I haven't checked

    I broke my tablet. There are no more updates here further.

    Download:
    T820: https://drive.google.com/open?id=1ql4VIjTsSHNwzsoJm3Yb8wt0RW9OJerE

    Device initial config sources:
    https://github.com/bonuzzz
    8
    I broke my tablet last weekend, so no more updates here anymore.

    Can you share any other sources you might have used to build for the 820? I know you linked to your GitHub, but anything else would be appreciated. Would love to keep this going for the group of us that have the 820.

    Thanks for giving us Lineage 14.1 & 15.1 in the first place! :D
    4
    I broke my tablet last weekend, so no more updates here anymore.
    3
    Hello @bonuzzz, thank you for the reply.

    I was able to restore my Lineage 14.1 because I flashed the ARA2 boot loader (tried with Odin the first time, then with my TWRP backup, same result)

    If someone used or uses lineageos 14.1, is speaker rotation work there or not?

    Only with VLC. Stuck in portrait mode with stock player. I don't have any games... :)



    The last thing I need to try is installing the GAPPS... Like I said, I don't want to, so if the problem comes from this, I'll pass. But I have to try to be sure...

    In this order from TWRP:
    - Flash BRE2 boot loader
    - Format Data and wipe everything
    - Flash Lineage 15.1
    - Flash openGAPPS nano arm64 8.1
    - Flash Magisk 16.4

    And... It's working...

    Well... :D

    I want to cry...

    So the GAPPS are mandatory.
    3
    For gapps it shows "arm 8.1" it should be "arm64 8.1"

    Edit: 5g seems to be working fine after a resetting WiFi, mobile & Bluetooth. Still can't seem to get audio playing through Bluetooth even though it's connected.
    edited, thanks
    yes, bt audio doesn't work. seems I broke it in last moment...

    Just wanted to let people know of what I've initially noticed and tested.
    * Not laggy like stock is
    * Able to format sd card for internal storage
    * Official Keyboard case works (didn't use much before)
    - show/hide key for virtual keyboard and Lang key don't do anything (at least it appears that way)
    - Left 'alt' brings up emoji, right 'alt' brings up symbols on virtual keyboard.
    * Auto wake/sleep works with 3rd party case (assume all work since it's just a magnet)
    * Auto brightness works but I tested it with a flash light.
    I have official keyboard case too. Unfortunately it's almost unusable in aosp if you need more than one keylayout. What about special keys, aosp doesn't have that triggers what stock rom has. I only could advice 3rd party app, but paid https://forum.xda-developers.com/showthread.php?t=1541916

    I liked the 14.1 version and I seem to like this version as well. It is to early to say more, but why can't you share this with lineage? It would be a dream, if this would be official and we would recieve updates. And maybe they will help you with the missing GPS?
    Nothing will change with official status except It would create more troubles and bureaucracy there.
    Nobody will help. Believe me.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone