[ROM] [TREBLE] [8.1] [Official] AICP 13.1 (Pro3 aka zl1, zl0, X727,X720,X722)

Search This thread

mosimchah

Senior Member
Dec 7, 2014
4,193
9,423


logo_black.png


AICP
Android Ice Cold Project

AICP is known by everyone as the "Ice Cold Project" that started on a Desire HD years ago (2012) and since then has evolved into a mature ROM with the BEST community that you can find!!!

Until Lollipop, the Rom has always been based on AOKP. Unfortunately, since AOKP stopped development (but made a comeback later), we changed our base to CM.
With the re-brand of CM to LineageOS (LAOS) we are now LAOS based with some tweaks from AOSP.

If there are any bugs, either we will sort them out or the LAOS team will if it concerns their code base. This rom isn't LAOS supported, so no need to report errors/bugs to them!!


Code:
#include <std_disclaimer.h>

/*
 * Your warranty is now void.
 *
 * We are not responsible for bricked devices, dead SD cards,
 * thermonuclear war or you getting fired because the alarm app failed. Please
 * do some research if you have any concerns about features included in this ROM
 * before flashing it! YOU are choosing to make these modifications, and if
 * you point the finger at us for messing up your device, we will laugh at you. Hard & a lot.
 *
 */

features.png

Feature list (rough Overview)


credits.png


In the beginning we would like to thank:

LineageOS & CM (R.I.P.) team
@maxwen and the rest of the OmniRom team
DU team
SlimRoms team
Resurrection Remix team
Community
...

team.png


@LorD ClockaN
@zipsnet
@eyosen
@semdoc
@Drgravy
@Hashbang173
@SpiritCroc
@wartomato
@eboye
plus the rest of the crazy bunch that we call "team"
...


donations.png


We are paying for servers that build nightlies/weeklies and everything that comes with it, so EVERY DONATION will really be appreciated and be used to cover those expenses.
Thank you!!



downloads.png


Latest Release Version 13.1

Download link: http://dwnld.aicp-rom.com

Official builds will be deleted from our servers every month due to maintenance services.
We advise everyone to keep at least the latest or best working build on their device as a backup.
Maybe copy it to a cloud service or USB too.


Mirror of the last official build https://www.androidfilehost.com/?fid=1395089523397908095
Test builds:
https://www.androidfilehost.com/?w=files&flid=236177
when android file host is acting up I upload them here https://drive.google.com/open?id=1UjLmmu4cxGiu9iJf_eRNCTYgzK8ajKgF

My test builds have experimental changes that might not appear in official releases for a while, or ever if they're not stable, my test builds do not show up as OTA updates, if stability is your main priority I would recommend staying on the official releases unless if you're testing a specific fix or something, but if you want all the latest features, fixes, and improvements before they're deemed to be stable, then the test builds are for you

20s firmware https://androidfilehost.com/?w=files&flid=165490
If you're dirty flashing, you might need to delete the locksettings.db file in /data/system

Google Apps:
Your choice,
1. I have tested these gapps https://www.androidfilehost.com/?fid=817906626617953499
2. Official open gapps http://opengapps.org/
3. Lineage gapps https://androidfilehost.com/?fid=962187416754462508

Gcam (Some people like it better than the included camera app) https://www.celsoazevedo.com/files/android/google-camera/f/skulshady_gcam_5.1.018_Mod_Full_Auto.apk

BlackScreen kernel builds: https://forum.xda-developers.com/le-pro3/development/kernel-8-x-blackscreen-pro3-aka-zl1-t3698177

Button remap: https://forum.xda-developers.com/le-pro3/themes/mod-button-remap-t3614367

TWRP:
zl1 (x720,x727): https://sourceforge.net/projects/lineageos-on-leeco/files/twrp/zl1/

zl0 (x722): https://sourceforge.net/projects/lineageos-on-leeco/files/twrp/zl0/

changelog.png


Full Changelog link: http://dwnld.aicp-rom.com/

issues.png

You tell... :p

Things that work
rotation
wifi
setup wizard
ril
4k video recording
Netflix
Snapchat
GPS
SmartcardService?
Camera
Camera zoom
Fingerprint
Notification LED
IR
NFC
Live display
Nightlight
Tethering
Volte
WiFi calling
Wireguard


instructions.png

The ROM should contain everything you need to enjoy Android Oreo. You don't need to install any Add-on's, simply download the latest ROM, GApps, flash it and go!
If you want the device to run the ROM "rooted", you can flash a root solution of your choice after the ROM Zipfile.

It is STRONGLY recommended to fully wipe your device before flashing and please avoid restoring system apps and system data with Titanium Backup as this can cause stability issues that are very hard to debug.
If you believe you know what you're doing - then fine, go ahead, but please don't complain if you experience any strange behavior.
How to flash:
(Again: Don't do it if you don't know it!)

1. Download the ROM and GApps and transfer them to your device.
2. Boot to recovery (TWRP recommended).
3. Wipe the System, Cache, Data and ART/Dalvik cache.
4. Flash the ROM Zipfile.
5. Flash the GApps (optional, needed for e.g. Google Playstore to work).
6. Flash the root solution of your choice (optional).
7. Reboot your device.

The ROM has GApps persistence in between dirty flashes, so you only have to flash them once!
The root solution should be flashed together with every OTA update (= ROM Update)



Currently Supported Root Solutions:

Magisk stable

KERNEL:
The kernel in this ROM follows LAOS source with custom additions.

PREREQUISITE FOR OTA:
To be able to flash using the built-in OTA app, TWRP recovery is needed.
You can still use the LAOS recovery and OTA app, but you will need to download the zip file and flash it manually from within your recovery. The Zipfile gets saved in the "aicp_ota" folder on your internal storage.
Please be sure that you are on the latest TWRP recovery. Keep in mind that this could also be an unofficial version!​

If you want to contribute to the AICP or want see what is being worked on/merged, feel free to visit our Gerrit code review system. (Link is at the bottom!!!)

sources.png


Kernel source:
https://github.com/AICP/kernel_leeco_msm8996/tree/o8.1

Device trees:
https://github.com/AICP/device_leeco_zl1/tree/o8.1
https://github.com/AICP/device_leeco_msm8996-common/tree/o8.1

Vendor:
https://github.com/AICP/proprietary_vendor_leeco/tree/o8.1

ROM & Additional links:
AICP Gerrit Code Review
AICP on Github


AICP G+ community

Le pro3 telegram group https://t.me/leecolepro3roms

Contributors
andr68rus,
infrag,
darkobas,
jrior001,
codeworkx,
villarleg,
wartomato,
mosimchah

XDA:DevDB Information
[ROM] [8.1] [Official] [weekly] AICP 13.1 (Pro3 aka zl1, X727,X720), ROM for the LeEco Le Pro3

ROM OS Version: 8.1 Oreo
Kernel: Linux 3.18.122

Version Information
Status: Stable
Stable Release Date: 2018-1-31

Created 2017-10-31
Last Updated 2018-9-13

You want to see a "normal" night at the "DEV office", click here!!
 
Last edited:

mosimchah

Senior Member
Dec 7, 2014
4,193
9,423
Note: Make sure you use the recommended twrp
FAQ:
Before using the ROM:
Q. Can I have an ETA for the next build?
A. Yes, it will be every week on Thursday
Q. Does this ROM support custom kernels?
A. No. You can still use them, but discussion should go in the thread of the respective kernel. We don't offer support for bugs you might encounter while using them!

Q. Why doesn't this ROM support Xposed?
A. Xposed is a hack that is geared towards AOSP, custom ROM's modify the framework a lot, so Xposed can cause a ton of issues on custom ROM's. Now it might work for you, however it is not to be discussed in this thread, and you should refrain from posting bug reports.

Q. Alright, but I still want to flash Xposed, so which version do I need to install?
A. You will need to use the version arm64 for SDK 27.

Flashing the ROM:
Q. What do I need to know before flashing?
A. Check the install instructions in the first post...

Q. Can the builds be dirty flashed over each other?
A. Yes, however make a nandroid backup first as there is a chance of getting a bootloop or encountering bugs. Also bugs may only be reported on a clean flash.

Q. How do I dirty flash builds?
A. Wipe the System, Cache and ART/Dalvik cache. Flash the ROM, GApps (only needed if you wipe the system), your preferred root solution and reboot. Or just use the OTA app to preform that task for you.

Q. How do I flash kernel builds?
A1. If it's a .img file, boot into TWRP and go to the install page in TWRP, in the bottom right corner select "install image", select the desired kernel, then select "boot", then swipe to flash, then go back to the install screen and install your root method again, if you don't want to loose root and reboot.
A2. If it's a flashable ZIP, you can flash it together with a ROM update or separately. Go to the install page in TWRP, choose the kernel zip (or add it to the flash queue right after the ROM zip). Then add your root method to the queue if you don't want to loose root. Now swipe to flash, and then reboot.

Using the ROM:
Q. How do I enable software buttons?
A. Go to Aicp Extras/Navigation bar, and enable it.

Q. I installed a bad theme and now I'm getting a bootloop, how do I fix it?
A. In TWRP, flash the substratum rescue zip that's in the substratum folder on the internal storage.

Q. I keep losing root with Magisk, how do I fix it?
A. Check this out. If that doesn't work for you, ask for help in this thread, read or ask in the Magisk thread on XDA or just re-flash Magisk!

Q. I'm having issues with WhatsApp, how do I fix it?
A. Read this

Q. Do I need to provide a logcat if I'm reporting a bug?
A. If you want it to be fixed faster (or at all) then yes, you should definitely provide a logcat. (Note: Please just link the logcat from your GDrive, Dropbox, etc. and do not post the content here. Thanks.

Q. How do I get a logcat, what type should I get and more questions that can conveniently be answered by my pre-determined answer?
A1. Read this thoroughly. Also, here's a good app for getting logs: https://play.google.com/store/apps/details?id=com.tortel.syslog (Root needed).
A2. If you are already rooted, you can use the built-in feature to make a logcat and provide that. Just look into the others section in the AICP Extras main page.
 
Last edited:

derfraenk

Senior Member
May 12, 2017
231
119
Confirmed opengapps nano work. I also see the heating up and throttling, so far still there after 10 minutes. I'll probably do a reboot soon and see if it gets better.

Builtin Camera does not seem to be working on first start, see attached screen shot. Well try again.

After flashing and rebooting from twrp, the phone hung on the leeco screen for minutes. I was worried and tried to force shut down, but it rebooted and then successfully started AICP. That was weird, but it seems to be working normally now.

I love the brightness preview when using the brightness slider.

This is all not meant as criticism. I'm so happy to be able to try this. Thank you so much for all the continued hard work.

Phone is pretty hot now just from writing this - rebooting. :)
 

Attachments

  • Screenshot_20171101-000324.jpg
    Screenshot_20171101-000324.jpg
    256.1 KB · Views: 1,494

derfraenk

Senior Member
May 12, 2017
231
119
After rebooting the heat issue is gone and lagginess is gone. Maybe some process hangs after the initial setup?

All in all it feels really good already, very usable.

The builtin camera preview is still messed up, but the camera does take pictures. I briefly tried Open Camera; it just crashes with "serious camera error". :)

I know it's super minor at this point, but casting to Chromecast does not work.
 

Redhawk2000

Senior Member
Jun 1, 2016
845
462
Not able to pair with my skullcandy BT headphones for some reason.

Edit I'm an idiot. It might help to enter pairing mode since it's a new connection. Tried 2 other devices and did a dirty flash again without success before I realized I need sleep....


Also I tested the alarm (phone on) and it worked fine.
Night light doesn't work.
Double tap on status bar to sleep doesn't work.
Video attempts cause app to crash.

Audio plays fine via speakers but after connecting with BT and playing then disconnecting BT then audio won't play via speakers (Spotify or google play music - the files won't even process) but reconnecting to BT allows audio to play again. ===> Edit: I haven't been able to recreate this.....

I appreciate that the status bar indicates when a BT connection is present :good:
 
Last edited:

derfraenk

Senior Member
May 12, 2017
231
119
Update: these are all only quick tests, but I find the following to be working:
* Calling and receiving calls, but only with the built in app, the Google phone app from the play store crashes on start
* SMS
* GPS in maps, I only had to calibrate the compass once to get direction
* Pairing Bluetooth headset and using it for a call
 

Top Liked Posts