[ROM+TWRP][UNOFFICIAL][oxygen][8.1.0] LineageOS 15.1

Search This thread


Senior Member
Feb 21, 2017
Alright, let me break the silence. Here's a build made from @eva0034 's AEX sources (quickly adapted for LOS) and AceKernel (I noticed quite some scrolling lag with Hardrock). Bugs should be the same as on that side. Slight UI changes but shouldn't bother.
Just for playing around with, I don't take responsibility for it, and don't expect me to maintain it (not capable of fixing stuff).
I upgraded my own device and used it for a few days without noticing issues.

Note that the "bottom navbar" change in the below screenshot is not included - I changed that for personal use.

awesome.. I installed your rom and tested..works flawlessly, I also appreciate for the integration of the latest security patch and Trust; new feature of lineage.
In addition to that I personally tested with Hardrock's kernel v8 and xposed modules, it also worked :good::good:

much appreciated for your hardwork. thank you...!:highfive:


Nov 16, 2014
awesome.. I installed your rom and tested..works flawlessly, I also appreciate for the integration of the latest security patch and Trust; new feature of lineage.
In addition to that I personally tested with Hardrock's kernel v8 and xposed modules, it also worked :good::good:

much appreciated for your hardwork. thank you...!:highfive:
Does the file system exFat work with memory cards?

Sent from my Xiaomi MI MAX 2 using XDA Labs


Senior Member
Sep 30, 2017
Inam on aosp Extended rpm on mi max 2,what is the procedure to install this ROM? As I have installed custom ROM for the first time and I don't know how to switch as it might have changed something in mobile..!!
  • Like
Reactions: tombassi


Senior Member
Sep 30, 2017
I flashed it now,I am having the sound problem on speaker,call and headphones, please fix this,ROM is awesome,thanks


Jan 23, 2006
being using 7.1.2 lineageos 14 on mimax2. Considering upgrading to lineage 15. any noticeable improvement if i did a upgrade, or its a degradation of performance?


New member
Aug 24, 2018
Fresh install first problem


I just flashed lineage from stock and unlike before my earpiece doesnt produce sound while on speaker mode in calls due to which the volume of the speakers have reduced tremendously. Installing Gapps, will update if i find more problems.

Top Liked Posts

  • There are no posts matching your filters.
  • 109

    LineageOS is a free, community built, aftermarket firmware distribution of Android 8.1.0 (Oreo), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's working :
    • Boots
    • Wifi
    • Bluetooth
    • Camera ( Videos And Photos )
    • Video Playback
    • Audio ( Record and Playback )
    • Audio Jack
    • Sensors
    • GPS
    • VoLTE
    • IR Blaster
    • Fingerprint Sensor
    • Tap To Wake
    • On-screen keys <-> hw keys toggle
    • Notification LED
    • No more weird colour profile issue

    TODO :
    • Enforcing SELinux

    Instructions :
    • Download the latest build and gapps.
    • Make sure you are on the latest TWRP build from this thread.
    • Make sure you are on the latest Global Developer Firmware
    • Reboot to recovery
    • Flash the latest build and gapps
    • Reboot

    Downloads :

    Source Code :

    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg . (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
     restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Donate :
    If you like my work, consider getting me a beer:

    XDA:DevDB Information
    LineageOS 15.1, ROM for the Xiaomi Mi Max 2

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 3.x

    Version Information
    Status: Testing

    Created 2018-03-31
    Last Updated 2018-04-02

    -> 20180331:
    * Initial Release
    Guys, I'm having exams going on, so couldn't really allocate time for this project. I will work on this whenever I have some free time...
    After a bit more use and tweaking for about a day now since last night, here is a list of issues/bugs and workarounds found in my use: (almost the same i posted earlier, but now with workarounds)
    • Distorted/cracking noise on phone speaker if using full volume - Workaround: Use one step lower volume, doesn't seem to happen at that level for me, phone is still audible
    • AudioFx has no effect on at least wired headphones and phone speaker (did work on bluetooth speaker however) - Workaround: Use Viper4Android, the one available in Magisk works fine and it's actually pretty good, I wonder why I didnt use it before in my life! (I also had to apply this fix https://forum.xda-developers.com/android/general/v4a-fix-processing-using-magisk-t3572819)
    • In-Call volume can not be adjusted, the volume bar moves but no effect - I havent found a workaround for this
    • With dual SIM, after you enter first SIM PIN, and then start typing the second SIM PIN, the prompt might disappear and you can continue using the phone, but your second SIM is locked and you cant use the network with the second SIM and need to reboot to get back to SIM PIN prompt. Happens rarely, and if I wait just 1-2 seconds after entering first SIM PIN, the second SIM PIN prompt disappears for a second and comes back and has no issues, so I believe the workaround is to not immediately start typing the PIN for second SIM, wait for the prompt to disappear and appear again, and then do it.

    All of these happened on clean flash too when I tested it quickly, and I use 8.3.29 Global Dev FW
    Other things I use is Camera2API enabler in Magisk, and Arnova's v7beta9 gcam which seems to work quite well with this ROM (except had to disable Motion or it wouldnt save pictures sometimes)

    Overall as I have before said, it's a very good ROM for a first release of a new Android version, few quirks but nothing major which would prevent daily use. I'm sure it will get near perfection over time, I haven't at least myself yet noticed other issues. Unfortunately no logcats at the moment, but I will get on that when I have more free time in near days hopefully and figure it out how to do it
    Cant say anything else than a big thank you for op's hard work and just wanted to make people aware of the issues and possible workarounds if they happen to them, I am not sure do these happen for everyone or no