[ROM][Ubuntu Touch - Vivid][10-02-2017] Ubuntu Touch for titan

walidham

Senior Member
Nov 27, 2011
273
206
63
Code:
#include <std_disclaimer.h>
/*
* Your warranty is now void.
*
* I am not responsible for bricked devices, dead SD cards, thermonuclear war, 
* or you getting fired because the alarm app failed. Please do some research 
* if you have any concerns about features included in this ROM
* before flashing it! YOU are choosing to make these modifications, and if
* you point the finger at me for messing up your device, I will laugh at you.
*/


WARNING : This ROM is a "Work In Progress" : this ROM is experimental, Only tested in xt1068,flash it only if you know what you are doing

Version 10-02-2017
Downloads

Ubuntu Touch Titan Version 10-02-2017
ubports-touch.rootfs-armhf.tar.gz

Kernel source
Device tree


Changelog:
version 05-19-2017
- First build

version 05-24-2017
- wifi
- SMS (RIL work but call no, need fix audio)
- Camera (photo only)
- Click packages with apparmor patched
- Ubuntu Store
- Synchronization with Google account
- GPS (need test)
- 3G data (need test)

version 06-10-2017
- audio
- call , incomming not properly work

version 07-10-2017
- fix kernek crash
- fix audio call

version 09-042014
- fix vibrator
- fix notification leds

version 09-092014
- Bluetooth
- Restart/Shutdown button

version 10-02-2017
- Video record
- More stable

Note : use UTmedia to play video, ubuntu touch media player don't (knowing bug will be fix in the future)

Bugs to fix in next build
- Audio
- Call
- Bluetooth
- System sometimes crash and reboot (need more test)
- Video

How to install

Do not forget to do a NANDROID backup before flashing anything.
You need to use Ubuntu AND a Motorola Moto G (2014) Unlocked

That's only flashable on Ubuntu/Linux because the rootstock software (flashing tool) doesn't exist on Windows OS

First if your data partition is F2FS you must change it to EXT4
Also i recommanded to use TWRP.

Flash on you device,

1. Download boot.img, system.zip (extract it), rootstock-ng-master.zip and device_titan_devel.tar.xz
2. Reboot the device into fastboot mode
3. Flash boot.img

Code :
Code:
fastboot flash boot boot.img
4. Boot the device back to recovery
5. Wait until adb has started (use "adb devices" to check if it has started)
6. Wipe system, cache and data partition

7. Flash ubuntu root system and system.img using rootstock installer
Code:
Code:
./rootstock-touch-install ubports-touch.rootfs-armhf.tar.gz system.img --custom device_titan_devel.tar.xz
8. After that it may boot ubuntu.

How change data partition
1. Reboot your phone to recovery mode
2. use TWRP to change data partition
3. To be sure that your partion is changed install any custom cm-13 or Lineageos rom

If you want use Ubuntu Touch with android, then just install any custom rom without wipe data partition, and just run this command in fastboot mode to start ubuntu
Code:
fastboot boot boot.img
Updated 05-02-2018
Now you can install xenial version(WIP, not yet stable) . To do it :
1- You need Ubuntu
2- reboot your device into bootloader mode
3- run this code

Code:
sudo apt-get install ubuntu-device-flash
sudo ubuntu-device-flash --verbose --server=https://system-image.ubports.com touch --device=titan --channel=16.04/community/walid/devel --bootstrap
Then, will download the files, and flash new recovery for ubuntu touch systems, soo wait a moment (10~15mins: network )
When all is done your device is reboot(so wait 5mins).
Note this will wipe your phone, and install Ubuntu Touch recovery.
Thank you
If you want suport this project you can donate
 
Last edited:

zitronenmelissa

Senior Member
Feb 23, 2011
284
120
73
Germany
Good project, thanks :good:

But: It didn't work for me.
I'm on arch linux, all binaries are present and flashing seems to work quite well:

Code:
[[email protected] Ubuntu]$ sudo ./rootstock-touch-install vivid-preinstalled-touch-armhf.tar.gz system.img --custom device_titan_devel.tar.xz
transfering rootfs tarball ... [done]
transferring custom tarball[done]
preparing system-image on device ... [done]
unpacking rootfs tarball to system-image ... [done]
unpacking custom tarball[done]
adding android system image to installation ... [done]
enabling Mir ... [done]
cleaning up on device ... [done]
rebooting device
On my first try i got these errors:

Code:
mount: mounting /dev/block/mmcblk0p35 on /cache failed: Device or resource busy
mount: mounting /dev/block/mmcblk0p38 on /data failed: Device or resource busy
I umounted /cache /data /system in twrp, and the errors disappear on my second try. I tried with and without sudo.

I'm stuck at boot logo, sudo fastboot boot boot.img doesn't work either.
What am I doing wrong? :confused:
 
  • Like
Reactions: Chemoman

walidham

Senior Member
Nov 27, 2011
273
206
63
link is not working, found it anyway :)

I tried it 4 times, no errors - but still stuck at boot logo. Do I have to flash device_titan_devel.tar.xz uploaded at May 18, 2017 | 10:44PM or May 18, 2017 | 10:38PM, there are two files.
Try now to download files.
You must download all files, extract system.zip and rootstock-ng-master.zip in same folder.
Then run this command

Code:
./rootstock-touch-install vivid-preinstalled-touch-armhf.tar.gz system.img --custom device_titan_devel.tar.xz
 
  • Like
Reactions: zitronenmelissa

walidham

Senior Member
Nov 27, 2011
273
206
63
@walidham yes, people atention on "First if your data partition is F2FS you must change it to EXT4
Also i recommanded to use TWRP." , installed, more no run wlan, simcard, camera ok, thanks, good work, waiting for fix..
Thanks, i will start fixing RIL and WIFI and i need help to do it.
For extt4, yes its important because ubuntu try to mount data partition as ext4.
TWRP juts recommendation , people can use any other recovery (cwm, ...)

BTW, if you want keep your ubuntu installation and install android, so just install any custom rom without wipe data partition, then run this command in fastboot mode : fastboot boot boot.img
or if you want wipe your phone, so before do it , copy system.img :
Code:
adb pull /data/system.img
after android installation
Code:
adb push system.img /data/
 

saurabh.k

Senior Member
Apr 20, 2017
50
11
0
Can u please make a simple zip file of Ubuntu touch so that we can flash it easily like other rom

I will be very thankful if u do this bcoz I love Ubuntu OS