• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][Ubuntu Touch - Vivid][10-02-2017] Ubuntu Touch for titan

Search This thread

walidham

Senior Member
Nov 27, 2011
279
209
I have made new version based on stock blobs (5.0.1), just for test

I uploaded preinstalled System image, so no need to flash just do this :
0- Download boot.img and system.zip
1- Extract system.zip
2- reboot to recovery mode
3- run this command : adb push system.img /data/
4- reboot to bootloader mode
5- run this command : fastboot boot boot.img

You can test this rom without wipe your phone (just be sure data partition is ext4)

Files to downloads
 

The_0N3

Senior Member
Feb 14, 2017
83
26
Help Ubuntu flash

Can anyone upload a video of all this flashing n all ?
I have never used GUI version of Ubuntu , have used only cli version and that also with help of YouTube n Google.

So it would be good if anyone can make a video !

Also is it possible to do all this without pc ? I have rooted phone and using resurrectionremix ROM with magisk pre-installed .
 
Last edited:
  • Like
Reactions: james11705

walidham

Senior Member
Nov 27, 2011
279
209
Multiwindow can be enabled

Ubuntu Touch with Unity8 distinguishes 2 modes of operation: Staged and Windowed
Open terminal and execute this commands :

#for Windowed mode:
gsettings set com.canonical.Unity8 usage-mode Windowed
#for Staged mode:
gsettings set com.canonical.Unity8 usage-mode Staged

For more details read this blog

Screenshots
 
Last edited:
  • Like
Reactions: nqkoidrug

riccardo9101

Member
Mar 7, 2015
6
0
When I run the command "./rootstock-touch-install ubports-touch.rootfs-armhf.tar.gz system.img --custom device_titan_devel.tar.xz" I received this error message on my laptop: "sudo: ./rootstock-touch-install: command not found"
What's the problem?
 

walidham

Senior Member
Nov 27, 2011
279
209
When I run the command "./rootstock-touch-install ubports-touch.rootfs-armhf.tar.gz system.img --custom device_titan_devel.tar.xz" I received this error message on my laptop: "sudo: ./rootstock-touch-install: command not found"
What's the problem?

Use PC wich have Ubuntu installed and extract rootstock-ng-master.zip, then put all files in same folder.

Or you can use an other method see post #101
 

walidham

Senior Member
Nov 27, 2011
279
209
Hi @walidham any progress with halium?

Halium-5.1 (based on android 5.1) boot, lxc-container start just no graphics , i will test new rootfs (xenial 16.04) this week hope get graphics
Halium-7.1 (based on android 7.1) boot, lxc-container start but many service crash and also no graphics
I think the best is to continue work on Halium-5.1 until we have stable version for Halium-7.1

BR
 

riccardo9101

Member
Mar 7, 2015
6
0
Verif if your data partition is ext4 (ubuntu touch don't support f2fs type)
If its ext4, flash boot.img and verif if there is ystem.img in data partition
How can verify if system.img is in data partition?

EDIT: It started!!! Thank you so much!
Inviato dal mio ONEPLUS A3003 utilizzando Tapatalk
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 29
    Code:
    #include <std_disclaimer.h>
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards, thermonuclear war, 
    * or you getting fired because the alarm app failed. Please do some research 
    * if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    */
    uv1rT


    WARNING : This ROM is a "Work In Progress" : this ROM is experimental, Only tested in xt1068,flash it only if you know what you are doing

    Version 10-02-2017
    Downloads

    Ubuntu Touch Titan Version 10-02-2017
    ubports-touch.rootfs-armhf.tar.gz

    Kernel source
    Device tree


    Changelog:
    version 05-19-2017
    - First build

    version 05-24-2017
    - wifi
    - SMS (RIL work but call no, need fix audio)
    - Camera (photo only)
    - Click packages with apparmor patched
    - Ubuntu Store
    - Synchronization with Google account
    - GPS (need test)
    - 3G data (need test)

    version 06-10-2017
    - audio
    - call , incomming not properly work

    version 07-10-2017
    - fix kernek crash
    - fix audio call

    version 09-042014
    - fix vibrator
    - fix notification leds

    version 09-092014
    - Bluetooth
    - Restart/Shutdown button

    version 10-02-2017
    - Video record
    - More stable

    Note : use UTmedia to play video, ubuntu touch media player don't (knowing bug will be fix in the future)

    Bugs to fix in next build
    - Audio
    - Call
    - Bluetooth
    - System sometimes crash and reboot (need more test)
    - Video

    How to install

    Do not forget to do a NANDROID backup before flashing anything.
    You need to use Ubuntu AND a Motorola Moto G (2014) Unlocked

    That's only flashable on Ubuntu/Linux because the rootstock software (flashing tool) doesn't exist on Windows OS

    First if your data partition is F2FS you must change it to EXT4
    Also i recommanded to use TWRP.

    Flash on you device,

    1. Download boot.img, system.zip (extract it), rootstock-ng-master.zip and device_titan_devel.tar.xz
    2. Reboot the device into fastboot mode
    3. Flash boot.img

    Code :
    Code:
    fastboot flash boot boot.img

    4. Boot the device back to recovery
    5. Wait until adb has started (use "adb devices" to check if it has started)
    6. Wipe system, cache and data partition

    7. Flash ubuntu root system and system.img using rootstock installer
    Code:
    Code:
    ./rootstock-touch-install ubports-touch.rootfs-armhf.tar.gz system.img --custom device_titan_devel.tar.xz

    8. After that it may boot ubuntu.

    How change data partition
    1. Reboot your phone to recovery mode
    2. use TWRP to change data partition
    3. To be sure that your partion is changed install any custom cm-13 or Lineageos rom

    If you want use Ubuntu Touch with android, then just install any custom rom without wipe data partition, and just run this command in fastboot mode to start ubuntu
    Code:
    fastboot boot boot.img
    Updated 05-02-2018
    Now you can install xenial version(WIP, not yet stable) . To do it :
    1- You need Ubuntu
    2- reboot your device into bootloader mode
    3- run this code

    Code:
    sudo apt-get install ubuntu-device-flash
    sudo ubuntu-device-flash --verbose --server=https://system-image.ubports.com touch --device=titan --channel=16.04/community/walid/devel --bootstrap
    Then, will download the files, and flash new recovery for ubuntu touch systems, soo wait a moment (10~15mins: network )
    When all is done your device is reboot(so wait 5mins).
    Note this will wipe your phone, and install Ubuntu Touch recovery.
    Thank you
    If you want suport this project you can donate
    6
    managed to install it a few days ago. I'm so excited!
    i'm about to try anbox to run apps such as WhatsApp.

    Aaaaand i'm having some issues about updates and OpenStore. Both seems to be in some kind of loop

    I'm working now for port halium-7.1 based on cm-14.1 , what work
    - BT
    - Wifi
    - RIL
    - Sound
    - Camera (yes camera juts got it work now, need more test to make it stable)

    for anbox, must patch kernel and some steps to make it work i will do it after fix camera (take me 1 month to resolve it)
    Again sorry for this late, i just got my old phone Moto G 2014 1 month ago
    This device will be support
    6
    GPS (need test) - 3G data (need test)

    GPS not working... Both Sims are working and 3g data on 1st sim is working....
    4
    Current state :
    Wifi work
    Kernel patched to support ubuntu apparmor
    clicks packages work
    ubuntu store work (facebook, twiter; file manager ... work well)
    I'm trying to fix audio and ril / ofono
    I will upload new version when ril /audio work.
    So please wait me i work hard for it.