• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] [unlocked] [douglas,giza] [OTAs] Lineage-15.1 [12 SEP 2021]

Search This thread

Rortiz2

Senior Member
Mar 1, 2018
2,232
1,518
Barcelona
Hi guys do you know if it is possible to install microg on it ? Right now i'm on Slimlp but i think android 5 is a bit too old for thirdy-part-app compatibility,some of them can't really work
Hi,

Unfortunately I haven't included the MicroG patch into this ROM. I'll include it in the next update.

Regards.
 

Tensa.53

Member
Jun 17, 2018
5
1
Hi,

Unfortunately I haven't included the MicroG patch into this ROM. I'll include it in the next update.

Regards.
Hi thank you for all your hard work,i will really appreciate to enable the microg support in the next build without the need using Xposed or Magisk. So I'll take an eye on the next release (are there OTAs ?) and thank you again

Edit : Oh i have another question,is the HW acceleration for 1080p videos broken on all ROMS (including Slimlp,LOS12.1,14.1) or just in this one ?
 
Last edited:

anujdatar

Member
Apr 3, 2018
25
5
  • Are you using douglas (2017 version) or giza (2016 version)?
  • So, exFat SD cards never worked in lineage-14.1 either?
  • I thought WiFi drops were solved long time ago (when I switched to prebuilt MTK WiFi HAL), are you using 5GHz networks?
  • Oh sorry, should have mentioned, douglas (2017)
  • exFat did not work on one of the first few builds of lineage-14.1. But it worked later after an update, don't remember which. I think I had posted a comment in that thread too at the time, but I think you had already patched it by the next update, let me go look that up.
  • Hmm. I am using 5GHz. I just tried rebooting my modem and routers (should have tried this in the first place). I still have some drops, but downloading is much better, I could install apps this time.
 

anujdatar

Member
Apr 3, 2018
25
5
Quick question, what file system does this rom format your SD card to? iirc it uses FAT32. I remember having trouble copying a video file greater than 4GB in the past. I just reverted back to FireOS last night, because I wanted to check something, and noticed FireOS uses exFAT for SD cards.

I remember the rom not recognizing my old SD card because that was exFAT, so i formatted it from the storage settings tab, and it formatted to FAT32.
This was July 7th 2021. So one of the roms before that. Because I went back to lineage after this comment and exFat worked. So you had already fixed that, I just didn't know it. I may have been using a January build of lineage-14 when I encountered this initially I guess.


But now exFat is not working for me on the latest lineage-15 build.
 

Rortiz2

Senior Member
Mar 1, 2018
2,232
1,518
Barcelona
Hi thank you for all your hard work,i will really appreciate to enable the microg support in the next build without the need using Xposed or Magisk. So I'll take an eye on the next release (are there OTAs ?) and thank you again

Edit : Oh i have another question,is the HW acceleration for 1080p videos broken on all ROMS (including Slimlp,LOS12.1,14.1) or just in this one ?
HW acceleration only works in Android 5.1 based ROMs (LOS 12.1 and SlimLP).
 

Rortiz2

Senior Member
Mar 1, 2018
2,232
1,518
Barcelona
This was July 7th 2021. So one of the roms before that. Because I went back to lineage after this comment and exFat worked. So you had already fixed that, I just didn't know it. I may have been using a January build of lineage-14 when I encountered this initially I guess.


But now exFat is not working for me on the latest lineage-15 build.
Alright, thanks for the information. I guess I'll need to update the exFat kernel driver.
 

pom532

Member
Aug 19, 2008
10
1
Anyone else having difficulty charging sometimes? Sometimes it charges fine, other times it still drops when plugged in (especially when it's below 50%).
 

mh1983

Member
Nov 5, 2012
36
5
Anyone else having difficulty charging sometimes? Sometimes it charges fine, other times it still drops when plugged in (especially when it's below 50%).
Yes, big time. We try everything: different cables, chargers, positions for the tablet. I even took it apart and tried this fix:

Improved things a bit but it's still finicky. Seems like a known issue with these tablets. (Nothing to do with this awesome custom rom, of course, as I observed this issue on the old FireOS stock rom too.)
 
Last edited:

pashtun

Senior Member
Apr 26, 2012
61
2
Just installed this to replace the older SlimOS that I had previously installed on the tablet. All seems good but I get a 'Trust - System security' notification every time I reboot the tablet saying 'SELinux is not enforcing, your security has been weakened' - is this normal? Is there a fix? Many thanks.
 

Rortiz2

Senior Member
Mar 1, 2018
2,232
1,518
Barcelona
Just installed this to replace the older SlimOS that I had previously installed on the tablet. All seems good but I get a 'Trust - System security' notification every time I reboot the tablet saying 'SELinux is not enforcing, your security has been weakened' - is this normal? Is there a fix? Many thanks.
Yes, that's an expected behavior since SELinux is configured in permissive mode (temporarily, until all bugs and policies are fixed). You can either disable Trust, disable its notifications or ignore them.
 

moore.bryan

Senior Member
Apr 26, 2011
564
55
Thanks for all your hard work and time you put in on this @Rortiz2!

Can I assume the inability to playback videos—be that in HBO, Netflix, or FuboTV—without them being choppy as all get out is related to the known "Hardware Decoding (OMX - 1080p video playback" issue?
 

Rortiz2

Senior Member
Mar 1, 2018
2,232
1,518
Barcelona
Thanks for all your hard work and time you put in on this @Rortiz2!

Can I assume the inability to playback videos—be that in HBO, Netflix, or FuboTV—without them being choppy as all get out is related to the known "Hardware Decoding (OMX -080p video playback" issue?
I guess so, I never tried streaming apps personally since I don't have accounts to do so.
 
  • Like
Reactions: moore.bryan

moore.bryan

Senior Member
Apr 26, 2011
564
55
I'm reinstalling your Lineage 14.1 to see if it's there, but I'm also willing to come back to 15.1 and troubleshoot if you are willing to walk me through it.
 

Rortiz2

Senior Member
Mar 1, 2018
2,232
1,518
Barcelona
I'm reinstalling your Lineage 14.1 to see if it's there, but I'm also willing to come back to 15.1 and troubleshoot if you are willing to walk me through it.
Hi,

Thanks for your interest, I will let you know if I need some people to test me these streaming apps.

No, the bug is also present on LineageOS 14.1 (it has never been fixed in ROMs that are Android 6 or newer).

Unfortunately, as I have mentioned a lot of times, fixing OMX will be the hardest part since we're using outdated Android Lollipop (5.1) proprietary blobs.

I have found a possible solution for this problem, but it will take me some time to fully fix it since I need to upgrade the OMX stack to Android 8.1 (and probably the graphics stack + the kernel drivers).

I've also updated a lot of stuff since the latest release of the ROM (and I still have a lot of work to do before releasing the next version of lineage-15.1).
 

moore.bryan

Senior Member
Apr 26, 2011
564
55
What I should have wrote was that I was reinstalling because it isn't there; that is, I was using 14.1 before upgrading to 15.1 and there was no choppiness... And that leads me to believe it might have nothing to do with the OMX piece.

Again, thanks for helping to keep this device relevant!
 

Rortiz2

Senior Member
Mar 1, 2018
2,232
1,518
Barcelona
What I should have wrote was that I was reinstalling because it isn't there; that is, I was using 14.1 before upgrading to 15.1 and there was no choppiness... And that leads me to believe it might have nothing to do with the OMX piece.

Again, thanks for helping to keep this device relevant!
I see, I guess it isn't related at all with OMX then. Would you mind getting logs from both 14.1 and 15.1?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 10
    Good news to everyone. I partially fixed HW decoding (and this includes Video Recording) ;)

    EDIT: It fully works now
    10
    New build is up.

    2021-11-07 [douglas] [giza]

    • Fixed Video Recording.
    • Partially fixed Hardware Decoding/Encoding.
    NOTE: 1080p it's still laggy.
    2
    Great work. Everything is working fine.Now, only need to fix is deep sleep. Then this ROM will be perfect. My battery drained from 74% to 62% overnight(7 hrs) with WIFI turned OFF. Keep the good work.
    1
    Hi there,

    I thought this problem was fixed previously but looks like it wasn't. Did camera ever work on giza? Just asking since maybe I broke something with the latest updates (since I've been playing around with vendor blobs). As you already know, I only own douglas so I can't really test giza builds.

    Anyway, it would be interesting to see at which point it dies. Can you provide a boot log please? You can use the command to generate a full log (which will include the kernel logs as well):​
    • adb logcat -b all > log.txt

    By the way, an unrelated question to this problem (asking to everyone who watches/follows this thread). Do you think it would be a good idea to create a Telegram group to discuss about douglas and giza?

    Regards.
    Yes, when you open Telegram group, I immediately join.
    1
    Just checking if you've gotten to this yet ? Thanks. :)
    Unfortunately I couldn't get it to work. I'm still looking forward to find a fix.

    I installed this rom a couple of versions ago, and am overall much happier with it than the Fire OS nonsense from amazon. But I noticed today that there seems to be no "hidden network" option in the wifi settings. Is it possible to add?
    The device will let you configure a connection to a hidden network, but without that option, it will not connect. Is there any workaround?
    Yes, that's a known bug. I still need to figure out why wpa_supplicant isn't happy about hidden SSIDs.

    Not sure if the log made it across, but here are some key log items related to camera:

    11-11 23:24:55.733 322 322 I <0> (0)[322: mediaserver][name:camera_isp&][Camera-ISP][ISP_EnableClock]En (1),g_EnableClkCnt(0) 11-11 23:24:55.733 322 322 W <0> (0)[322: mediaserver][name:domain&]isp: Power-on latency exceeded, new value 5846 ns 11-11 23:24:55.734 322 322 I <0> (0)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [kdSetSensorMclk] [CAMERA SENSOR] kdSetSensorMclk on=1, freq= 1 11-11 23:24:55.734 322 322 I <0> (0)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [kdSetSensorMclk] [CAMERA SENSOR] kdSetSensorMclk on=1, freq= 1 11-11 23:24:55.744 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.745 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.745 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.745 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.755 278 370 D AudioALSAParamTuner: create AudioALSAParamTuner instance -- 11-11 23:24:55.755 278 370 D AudioALSAParamTuner: AudioALSAParamTuner in + 11-11 23:24:55.755 278 370 D AudioALSAParamTuner: AudioALSAParamTuner: default mic gain-mormal:144;handsfree:180, receiver gain:112, headset Gain:76 11-11 23:24:55.755 278 370 D AudioALSAParamTuner: create AudioALSAParamTuner instance ++ 11-11 23:24:55.755 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.755 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.756 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.756 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.756 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.756 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.756 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][kdSetDriver] ERROR:kdSetDriver() 11-11 23:24:55.759 370 370 W <0> (2)[370: HwBinder:278_1][name:AudDrv_Ana&]Ana_Set_Reg offset= 0x10a, value = 0x100 mask = 0x100 ret = 0 Reg_Value = 0x0 11-11 23:24:55.759 370 370 W <0> (2)[370: HwBinder:278_1][name:mt_soc_codec_63xx&]TopCkCount <0 =0 11-11 23:24:55.759 0 0 W : <0> 11-11 23:24:55.759 370 370 W <0> (2)[370: HwBinder:278_1][name:mt_soc_afe_control&]SetMemoryPathEnable Aud_block = 12 mUserCount = 0 mState = 0 11-11 23:24:55.759 370 370 W <0> (2)[370: HwBinder:278_1][name:mt_soc_afe_control&]SetMemoryPathEnable Aud_block = 0 mUserCount = 0 mState = 0 11-11 23:24:55.770 370 370 I auditd : type=1400 audit(0.0:44): avc: denied { call } for comm="HwBinder:278_1" scontext=u:r:hal_audio_default:s0 tcontext=u:r:servicemanager:s0 tclass=binder permissive=1 11-11 23:24:55.770 370 370 I auditd : type=1400 audit(0.0:45): avc: denied { transfer } for comm="HwBinder:278_1" scontext=u:r:hal_audio_default:s0 tcontext=u:r:servicemanager:s0 tclass=binder permissive=1 11-11 23:24:55.770 184 184 I auditd : type=1400 audit(0.0:46): avc: denied { search } for comm="servicemanager" name="278" dev="proc" ino=9472 scontext=u:r:servicemanager:s0 tcontext=u:r:hal_audio_default:s0 tclass=dir permissive=1 11-11 23:24:55.770 184 184 I auditd : type=1400 audit(0.0:47): avc: denied { read } for comm="servicemanager" name="current" dev="proc" ino=10702 scontext=u:r:servicemanager:s0 tcontext=u:r:hal_audio_default:s0 tclass=file permissive=1 11-11 23:24:55.770 184 184 I auditd : type=1400 audit(0.0:48): avc: denied { open } for comm="servicemanager" path="/proc/278/attr/current" dev="proc" ino=10702 scontext=u:r:servicemanager:s0 tcontext=u:r:hal_audio_default:s0 tclass=file permissive=1 11-11 23:24:55.770 184 184 I auditd : type=1400 audit(0.0:49): avc: denied { getattr } for comm="servicemanager" scontext=u:r:servicemanager:s0 tcontext=u:r:hal_audio_default:s0 tclass=process permissive=1 11-11 23:24:55.777 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.777 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.777 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.777 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.784 184 184 I auditd : avc: denied { add } for service=audiosignalprocessor pid=278 uid=1041 scontext=u:r:hal_audio_default:s0 tcontext=u:eek:bject_r:default_android_service:s0 tclass=service_manager permissive=1 ------- 11-11 23:24:55.788 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.788 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.788 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.788 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.788 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.789 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.789 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][kdSetDriver] ERROR:kdSetDriver() 11-11 23:24:55.795 322 322 I MtkCam/Utils/Profile: {CamProfile}[CamDeviceManagerBase::getNumberOfDevices] : (0-th) ===> [start-->now: 67 ms] 11-11 23:24:55.795 322 322 I [email protected]: Loaded "MediaTek Camera Module" camera module 11-11 23:24:55.795 322 322 D MtkCam/Metadata: [clear] pid:322 tid:322 ----- 11-11 23:24:55.799 322 322 I <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][Pre]w=0x0, h = 0x0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Lim_Const 0 11-11 23:24:55.799 322 322 I <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][Full]w=0x26, h = 0x0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Lim_Delay 0 11-11 23:24:55.799 322 322 I <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][VD]w=0x2300, h = 0x50ec 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Sep_LR_Filter 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Att_Time[0][0] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Rel_Time[0][0] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Att_Time[0][1] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Rel_Time[0][1] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Att_Time[0][2] = 0 11-11 23:24:55.799 322 322 I <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][Pre]w=0x0, h = 0x0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Rel_Time[0][2] = 0 11-11 23:24:55.799 322 322 I <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][Full]w=0x26, h = 0x0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Att_Time[0][3] = 0 11-11 23:24:55.799 322 322 I <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][VD]w=0x2900, h = 0x50ec 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Rel_Time[0][3] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Att_Time[0][4] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Rel_Time[0][4] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Att_Time[0][5] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: Rel_Time[0][5] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: DRC_Th[0][0] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: DRC_Gn[0][0] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: DRC_Th[0][1] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: DRC_Gn[0][1] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: DRC_Th[0][2] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: DRC_Gn[0][2] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: DRC_Th[0][3] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: DRC_Gn[0][3] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: DRC_Th[0][4] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: DRC_Gn[0][4] = 0 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: -SetParameter() 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: BesSound Ver : 0x54b 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: BesSound FlushOutSampleCount : 0x40 11-11 23:24:55.799 278 370 D AMZ-MtkAudioLoud: NvRam Format : V5 11-11 23:24:55.799 278 370 D AudioMTKFilterManager: init() fixedParam 0 11-11 23:24:55.800 322 322 I <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [kdSetSensorMclk] [CAMERA SENSOR] kdSetSensorMclk on=0, freq= 1 11-11 23:24:55.800 322 322 I <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [kdSetSensorMclk] [CAMERA SENSOR] kdSetSensorMclk on=0, freq= 1 11-11 23:24:55.800 322 322 I <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [kdSetSensorGpio] [CAMERA SENSOR] kdSetSensorGpio enable=0, type=0 11-11 23:24:55.800 313 313 I AudioFlinger: HAL output buffer size 1536 frames, normal sink buffer size 1536 frames 11-11 23:24:55.800 322 322 I <0> (3)[322: mediaserver][name:camera_isp&][Camera-ISP][ISP_release]+ Curr UserCount(1->0), (process, pid, tgid)=(mediaserver, 322, 322), last user 11-11 23:24:55.800 322 322 I <0> (3)[322: mediaserver][name:camera_isp&][Camera-ISP][ISP_EnableClock]En (0),g_EnableClkCnt(1) 11-11 23:24:55.801 185 185 I snet_event_log: [121035042,-1,] 11-11 23:24:55.801 322 322 I <0> (3)[322: mediaserver][name:camera_isp&][Camera-ISP][ISP_EnableClock]En (1),g_EnableClkCnt(0) 11-11 23:24:55.801 322 322 I <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [kdSetSensorMclk] [CAMERA SENSOR] kdSetSensorMclk on=1, freq= 1 11-11 23:24:55.801 322 322 I <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [kdSetSensorMclk] [CAMERA SENSOR] kdSetSensorMclk on=1, freq= 1 11-11 23:24:55.812 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.812 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.812 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.812 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.823 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.823 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.823 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.823 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.823 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.823 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.823 322 322 E <0> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][kdSetDriver] ERROR:kdSetDriver() 11-11 23:24:55.844 322 322 E <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.844 322 322 E <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.844 322 322 E <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.844 322 322 E <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.855 322 322 E <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.855 322 322 E <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.855 322 322 E <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.855 322 322 E <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.855 322 322 E <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf0 11-11 23:24:55.855 322 322 E <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][iReadRegI2C] [CAMERA SENSOR] I2C send failed!!, Addr = 0xf1 11-11 23:24:55.855 322 322 E <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist][kdSetDriver] ERROR:kdSetDriver() 11-11 23:24:55.862 322 322 I MtkCam/Utils/Profile: {CamProfile}[CamDeviceManagerBase::getNumberOfDevices] : (0-th) ===> [start-->now: 66 ms] 11-11 23:24:55.863 322 322 I CameraProviderManager: Connecting to new camera provider: legacy/0, isRemote? 0 11-11 23:24:55.863 322 322 I CameraProviderManager: Camera provider legacy/0 ready with 0 camera devices 11-11 23:24:55.866 322 322 I <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][Pre]w=0x0, h = 0x0 11-11 23:24:55.866 322 322 I <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][Full]w=0x26, h = 0x0 11-11 23:24:55.866 322 322 I <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][VD]w=0x8200, h = 0x4692 11-11 23:24:55.866 322 322 I <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][Pre]w=0x0, h = 0x0 11-11 23:24:55.866 322 322 I <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][Full]w=0x26, h = 0x0 11-11 23:24:55.866 322 322 I <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [adopt_CAMERA_HW_GetInfo2] [CAMERA_HW][VD]w=0x8000, h = 0x4692 11-11 23:24:55.866 322 322 I <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [kdSetSensorMclk] [CAMERA SENSOR] kdSetSensorMclk on=0, freq= 1 11-11 23:24:55.867 322 322 I <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [kdSetSensorMclk] [CAMERA SENSOR] kdSetSensorMclk on=0, freq= 1 11-11 23:24:55.867 322 322 I <2> (3)[322: mediaserver][name:kd_sensorlist&][kd_sensorlist] [kdSetSensorGpio] [CAMERA SENSOR] kdSetSensorGpio enable=0, type=0 11-11 23:24:55.867 322 322 I <2> (3)[322: mediaserver][name:camera_isp&][Camera-ISP][ISP_release]+ Curr UserCount(1->0), (process, pid, tgid)=(mediaserver, 322, 322), last user 11-11 23:24:55.867 322 322 I <2> (3)[322: mediaserver][name:camera_isp&][Camera-ISP][ISP_EnableClock]En (0),g_EnableClkCnt(1) 11-11 23:24:55.901 278 370 E EffectsFactoryConfigLoader: Could not dlopen library /system/lib/soundfx/libaudiofx.so: dlopen failed: "/system/lib/libaudiostream.so" is 64-bit instead of 32-bit 11-11 23:24:55.902 278 370 D AMZ-DlbDlbEffect: getDescriptor(uuid=9D4921DA-8225-4F29-AEFA-39537A04BCAA, pDescriptor=0xf6943a80) 11-11 23:24:55.902 278 370 D AMZ-DlbDlbEffect: getDescriptor() Returning descriptor for DAP 11-11 23:24:55.902 278 370 E EffectsFactoryConfigLoader: Could not find library audiofx to load effect audiocapture 11-11 23:24:55.902 278 370 E EffectsFactoryConfigLoader: 2 errors during loading of configuration: /vendor/etc/audio_effects.xml 11-11 23:24:55.902 278 370 E EffectsFactory: Effect config is partially invalid, skipped 2 elements 11-11 23:24:55.902 313 313 I BufferProvider: found effect "Multichannel Downmix To Stereo" from The Android Open Source Project 11-11 23:24:55.902 313 420 I AudioFlinger: AudioFlinger's thread 0xf4b037c0 tid=420 ready to run 11-11 23:24:55.902 313 420 W AudioFlinger: no wake lock to update, system not ready yet 11-11 23:24:55.903 313 313 I AudioFlinger: Using module 10 as the primary audio interface
    Thanks for the log. Looks like something is messed up in the kernel side. I'll take a look as soon as I can.

    To everyone, I will be inactive for a few weeks due to personal problems. When I'm back I'll update the ROM.

    Regards.
  • 19
    320px-Lineage_OS_Logo.png

    LineageOS 15.1 (Android 8.1.0) for the Amazon Fire HD8 2016/2017

    Disclaimer:
    Code:
    /*
    * Your warranty is... still valid?
    * I am not responsible for bricked devices, dead SD cards, thermonuclear war,
    * or you getting fired because the alarm app failed.
    * Please do some research if you have any concerns about features included
    * in the products you find here before flashing it!
    * YOU are choosing to make these modifications.
    */

    LineageOS is a free, community built, aftermarket firmware distribution of Android, which is designed to increase performance and reliability over stock Android for your device. All the source code for LineageOS is available in the LineageOS Github repo. If you would like to contribute to LineageOS, please visit our Gerrit Code Review.​

    IMPORTANT NOTES BEFORE INSTALLING THE ROM:
    • As usual, you need to be unlocked to install this ROM.
    • This ROM is in beta status so don't expect 100% stable ROM.
    • This ROM is only compatible with the Fire HD8 2017 (douglas) and the Fire HD8 2016 (giza). All questions related to other devices will be reported and ignored.
    KNOWN ISSUES:
    • Deep Sleep.
    • USB Tethering.
    • Hidden SSIDs.
    • [giza] Camera.
    INSTALLATION:
    • Boot to TWRP.
    • Wipe system, cache and userdata.
    • Install the ROM zip.
    • (OPTIONAL): Flash G-Apps package.
    • (OPTIONAL): Flash root (Magisk/SuperSU).
    • Wipe Dalvik Cache.
    • Reboot and enjoy!
    DOWNLOADS:
    Source Code:
    Special Thanks:
    13
    New build is up.

    2021-10-31 [douglas] [giza]

    • Resolved missing {drm,omx} symbols ({TimedEventQueue,EVP}).
    • Added MicroG support (Signature Spoofing).
    • Added exFAT support (included new kernel driver).
    • Fixed audio stream (amazon proprietary libraries).
    • Added GPU Extension Device ("GED") support.
    • Updated the security patch to October 2021.
    PS: Happy Halloween!
    10
    Good news to everyone. I partially fixed HW decoding (and this includes Video Recording) ;)

    EDIT: It fully works now
    10
    New build is up.

    2021-09-16 [douglas] [giza]


    • Fixed camera.
    • Fixed internal storage (OBB) issues.
    NOTE: Video recording isn't working at all, it crashes with the stock camera app but it works with some third-party apps (such as Telegram).
    NOTE: Let me know if obb issues are fully gone (I basically reverted the sdcardfs squash update). Try to clean flash the ROM as well before reporting if the bug it's still present.
    10
    New build is up.

    2021-10-03 [douglas] [giza]

    • Updated vcodec libraries.
    • Fixed internal storage issues (disabled sdcardFS).
    • Removed amazon/mediatek kernel logging.
    • Resolved missing libraries/symbols.
    • Converted audio_effects.conf to audio_effects.xml.
    • Switched back to stock libcam.utils.sensorlistener.so.
    • Introduced Sensors MultiHAL.