[ROM][UNOFFICIAL][10.0.0][apollopro] LineageOS 17.1

Search This thread

desertdweller31

New member
Apr 20, 2021
1
0
This has worked beautifully for a week now with no issues.

Thank you to the user who pointed out that in Lineage Recovery you need to select Apply Update -> Apply from ADB, because I could not figure out why the sideload step wasn't working, nor could I find any online tutorials on how to use Lineage Recovery. First time using an unofficial lineage build (used offical builds before plenty of times) and it seems to be working well!
 

Dobsgw

Senior Member
Dec 16, 2015
2,134
1,705
It it allowed to ask here where can I find this or at least sources + instructions on how to build it?
 
  • Like
Reactions: jamescalow

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    It it allowed to ask here where can I find this or at least sources + instructions on how to build it?
  • 18
    http%3A%2F%2Ffiles.paulfasola.fr%2FCyanogenMod%2FLineageOS.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build
    • $ adb reboot bootloader
    • $ fastboot erase userdata (this will wipe your data)
    • $ fastboot flash recovery lineagerecovery_apollopro.img
    • Now boot to Recovery
    • Wipe Data in Lineage Recovery
    • $ adb sideload zipname.zip
    • Flash Gapps [Recommended Gapps Arm64 Pico]
    • Reboot to System

    Bugs:
    DT2W Feature isnt Functional
    Permissive Selinux

    Downloads :

    Telegram Group For Support

    PS : Please Flash the latest Stable Miui Fastboot Package rom for eg: If you device is eea so flash stable fastboot rom of your region, the same applies to other regions. Dont ever cross flash fastboot roms, vendors and firmwares. To use this rom please Flash Android 10 Latest Fastboot Package

    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    reboot after having the issue:
    
    Are you using--
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Credits:
    1. Xiaomi
    2. akhilnarang [For helping in Refresh rate values]
    3. SebaUbuntu [For his sm8250-common device tree]
    4. CryllicBuster273
    5. Aayush [For Testing and Reporting Issues]

    For Donations Message me on Telegram or XDA :
    Feel free to donate.

    Right now the project uses Prebuilt kernel - https://bigota.d.miui.com/V12.0.7.0...M_20201111.0000.00_10.0_global_c2bc57807e.tgz

    XDA:DevDB Information
    LineageOs, ROM for the Xiaomi Mi 10T / 10T Pro

    Contributors
    Revanth_24
    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x
    ROM Firmware Required: Stock Firmware of Your Region

    Version Information
    Status:
    Beta

    Created 2020-11-28
    Last Updated 2020-11-28
    5
    Hey, it's working perfectly except for one thing that bothers me quite a bit, I think it's when i play a video (newPipe in my case), after the video , it's like the screen in locked at the video's framerate (24fps ? ) and it gives this laggy feeling ... Is there a way to fix this ? Thanks in advance

    Anyone else facing the refresh rate issue ? After I open an app randomly, doesn't even matter what app, my refresh rate changes back to 60.
    This happens randomly. Sometimes it happens and sometimes it doesnt.

    The refresh rate issues should be fixed in the New build. Keep an eye on our Telegram Group or the XDA thread.

    Hi Guys,
    Please reviews full reviews about LineageOS 17.1 for Mi 10T Pro please, I don't see any screenshot or video of Mi 10T Pro in this thread. Thanks
    Review and Installation video will be uploaded very soon.

    Missed the kernel release last month, hoping this leads to a non-permissive selinux build somewhere in the future. Ty for the current builds though!

    A developer has already booted the kernel. And the latest build will come with the source built kernel
    5
    and we are back
    5
    Updates Tracker!


    Initial Build - 25/11/2020


    Changelog:
    • Initial Build
    • Added Screen Refresh Rate switch under settings->Display->Refresh Rate Changer
    • You can change the screen refresh rate to 60,90,120,144Hz

    Notes:
    • Gapps are not Pre-installed.


    12/12/2020 - Build


    Changelog:
    • Sync with lineage sources
    • Fix issues with 5Ghz Wifi
    • Updated Overlays
    • Patch ims.apk to remove HD Icon from Notification
    • Fix Charging Issues

    Notes:
    • Check Flashing Guide on XDA Thread
    • Gapps are not Pre-installed.
    • Don't report bugs without logs.
    4
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone