[ROM][UNOFFICIAL][10.0.0_r2][ham] LineageOS 17.0

Search This thread

shubhambhise

Senior Member
Aug 16, 2016
331
1,576
Pune
2z8dpw1.jpg

Code:
/*
 * I'm not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed (like it did for me...)
 * Please do some research if you have any concerns about features included in the products you find here before flashing it! 
 * YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you. 
 * Your warranty will be void if you tamper with any part of your device / software.
 * Same statement for XDA.
 */

LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (pie), which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.


What's working :
  • Boots
  • RIL (Calls, SMS, Data)
  • Fingerprint
  • Wi-Fi
  • Bluetooth
  • Camera
  • Camcorder
  • Video Playback
  • Audio
  • Sensors
  • Flash
  • LED
  • GPS


Instructions :
  • Download the latest build, GApps and Magisk (Optional)
  • Reboot to recovery
  • Flash the latest build and GApps
  • Flash Magisk (Optional)
  • Reboot

Note: You must have at least nougat firmware (ZUI) to load sensors and other stuff properly. Also, when reverting to pie flash the same firmware.

Downloads :
Build : AFH Page
Gapps: BiTGApps
Magisk: Unofficial Build
firmware-files: firmware-files.zip

XDA:DevDB Information
[ROM][UNOFFICIAL][10.0.0_r2][ham] LineageOS 17.0, ROM for the Lenovo Zuk Z1

Contributors
shubhambhise
Source Code: http://github.com/LineageOS

ROM OS Version: Android 10
ROM Firmware Required: Unlocked Bootloader, TWRP Recovery
Based On: LineageOS

Version Information
Status: Alpha

Created 2019-10-05
Last Updated 2019-10-05
 

Nabeel840

Senior Member
Apr 29, 2015
73
10
32
sialkot
Dear Bro

Thanks a lot for providing us such a great software experience.
great job, keep it up.

bro i want to send you gift. please let me know how can i do this from my country.

thanks again

Mr Qurashi

---------- Post added at 07:15 AM ---------- Previous post was at 07:14 AM ----------

Bro rom is woring fine for now.

i will use this for some time and let you know if i face any issue.

Regards... thanks ... good work
 
  • Like
Reactions: abdo ahmad

Sharma_Ji

Senior Member
Oct 17, 2016
898
305
Bikaner
Screens :-
 

Attachments

  • Screenshot_20191006-145413_Quickstep.png
    Screenshot_20191006-145413_Quickstep.png
    137.5 KB · Views: 3,321
  • Screenshot_20191006-145407_Settings.png
    Screenshot_20191006-145407_Settings.png
    127.3 KB · Views: 3,313
  • Screenshot_20191006-145355_Settings.png
    Screenshot_20191006-145355_Settings.png
    108.6 KB · Views: 3,196
  • Screenshot_20191006-145348_Settings.png
    Screenshot_20191006-145348_Settings.png
    159.4 KB · Views: 3,096
  • Screenshot_20191006-145300_Settings.png
    Screenshot_20191006-145300_Settings.png
    122.8 KB · Views: 3,044
  • Screenshot_20191006-145257_Settings.png
    Screenshot_20191006-145257_Settings.png
    126 KB · Views: 3,023
  • Screenshot_20191006-145244_Quickstep.jpg
    Screenshot_20191006-145244_Quickstep.jpg
    134.8 KB · Views: 3,073

Rey__

New member
Dec 3, 2017
2
0
I tried installation numerous time but still i am stuck in bootloop. Any tips...?
 

Nabeel840

Senior Member
Apr 29, 2015
73
10
32
sialkot
Dear bro.

I have reinstall rom for review.
Have performed clean flash.
Having latest recovery.
Flash provided latest firmware before rom flashing.
First boot up time was with beta opengapps 71 seconds.

Your provided gapps were unable to flash. they give some error which i did not note.
Beta opengapps were released today was working fine .

Having following issues.

1= Check Drawer Screenshot. Where search bar is going??.
2= Dark mode can be enable only from in display settings or qs toggle. Not from in style section. Is it work in same way?
3= Accent colors. Only one color is there? Is it should be like this? In screens provided by Sharma g it show purple accent.
4= Battery percentage is showing up in status bar.
5= There is no option i found to change launcher icons and qs toggles icons shape. In screens provided by Sharma g there is different shapes shows for both.

There are also some little bit issues but they are not noticeable. Hope those issues will fixed by time in upcoming builds.

Overall rom was working fine. Its really good for first build.

Good work keep it up.

Regards...

Mr. Qurashi
 

Attachments

  • Screenshot_20191007-234354_Quickstep.jpg
    Screenshot_20191007-234354_Quickstep.jpg
    106.1 KB · Views: 1,480
  • Screenshot_20191007-234346_Quickstep.jpg
    Screenshot_20191007-234346_Quickstep.jpg
    84.1 KB · Views: 1,461
  • Screenshot_20191007-234734_LineageOS_Settings.png
    Screenshot_20191007-234734_LineageOS_Settings.png
    55.3 KB · Views: 1,452
  • Screenshot_20191007-234126_LineageOS_Settings.png
    Screenshot_20191007-234126_LineageOS_Settings.png
    55.7 KB · Views: 1,384
  • Screenshot_20191007-234610.png
    Screenshot_20191007-234610.png
    100.8 KB · Views: 1,340
Last edited:

himanshu fulmali

Senior Member
Apr 4, 2017
559
108
Dear bro.

I have reinstall rom for review.
Have performed clean flash.
Having latest recovery.
Flash provided latest firmware before rom flashing.
First boot up time was with beta opengapps 71 seconds.

Your provided gapps were unable to flash. they give some error which i did not note.
Beta opengapps were released today was working fine .

Having following issues.

1= Check Drawer Screenshot. Where search bar is going??.
2= Dark mode can be enable only from in display settings or qs toggle. Not from in style section. Is it work in same way?
3= Accent colors. Only one color is there? Is it should be like this? In screens provided by Sharma g it show purple accent.
4= Battery percentage is showing up in status bar.
5= There is no option i found to change launcher icons and qs toggles icons shape. In screens provided by Sharma g there is different shapes shows for both.

There are also some little bit issues but they are not noticeable. Hope those issues will fixed by time in upcoming builds.

Overall rom was working fine. Its really good for first build.

Good work keep it up.

Regards...

Mr. Qurashi
Color accent option is in the developer options, at bottom.
 
  • Like
Reactions: m00sab

Sharma_Ji

Senior Member
Oct 17, 2016
898
305
Bikaner
Dear bro.

I have reinstall rom for review.
Have performed clean flash.
Having latest recovery.
Flash provided latest firmware before rom flashing.
First boot up time was with beta opengapps 71 seconds.

Your provided gapps were unable to flash. they give some error which i did not note.
Beta opengapps were released today was working fine .

Having following issues.

1= Check Drawer Screenshot. Where search bar is going??.
2= Dark mode can be enable only from in display settings or qs toggle. Not from in style section. Is it work in same way?
3= Accent colors. Only one color is there? Is it should be like this? In screens provided by Sharma g it show purple accent.
4= Battery percentage is showing up in status bar.
5= There is no option i found to change launcher icons and qs toggles icons shape. In screens provided by Sharma g there is different shapes shows for both.

There are also some little bit issues but they are not noticeable. Hope those issues will fixed by time in upcoming builds.

Overall rom was working fine. Its really good for first build.

Good work keep it up.

Regards...

Mr. Qurashi
And same, icon shape is in dev options too.
 
  • Like
Reactions: m00sab

Rajathaadri

Member
Feb 20, 2019
13
1
Dear bro.

I have reinstall rom for review.
Have performed clean flash.
Having latest recovery.
Flash provided latest firmware before rom flashing.
First boot up time was with beta opengapps 71 seconds.

Your provided gapps were unable to flash. they give some error which i did not note.
Beta opengapps were released today was working fine .

Having following issues.

1= Check Drawer Screenshot. Where search bar is going??.
2= Dark mode can be enable only from in display settings or qs toggle. Not from in style section. Is it work in same way?
3= Accent colors. Only one color is there? Is it should be like this? In screens provided by Sharma g it show purple accent.
4= Battery percentage is showing up in status bar.
5= There is no option i found to change launcher icons and qs toggles icons shape. In screens provided by Sharma g there is different shapes shows for both.

There are also some little bit issues but they are not noticeable. Hope those issues will fixed by time in upcoming builds.

Overall rom was working fine. Its really good for first build.

Good work keep it up.

Regards...

Mr. Qurashi


Can you please share the link to opengapps beta?
 

Abdulhasiib

Member
May 10, 2018
16
4
Kudos to you Shubham for keeping an old war horse alive and updated this far. Downloading builds now, will give it a try. Thanks a lot mate.
 
Last edited:
  • Like
Reactions: shubhambhise

Abdulhasiib

Member
May 10, 2018
16
4
Screenshots:
 

Attachments

  • Screenshot_20191010-123133_Settings.png
    Screenshot_20191010-123133_Settings.png
    156.8 KB · Views: 562
  • Screenshot_20191010-123008_Quickstep.jpg
    Screenshot_20191010-123008_Quickstep.jpg
    110.6 KB · Views: 558
  • Screenshot_20191010-122957_Settings.png
    Screenshot_20191010-122957_Settings.png
    118.3 KB · Views: 556
  • Screenshot_20191010-122924_Settings.png
    Screenshot_20191010-122924_Settings.png
    142.4 KB · Views: 541
  • Screenshot_20191010-122910_Settings.png
    Screenshot_20191010-122910_Settings.png
    142.7 KB · Views: 535
  • Screenshot_20191010-122900_Quickstep.png
    Screenshot_20191010-122900_Quickstep.png
    132.1 KB · Views: 523

Abdulhasiib

Member
May 10, 2018
16
4
Some minor issues observed so far:
1. Swipe from edges doesn't work if on screen nav bar isn't enabled.
2. Unable to change battery icon and percentage.
3. Notification sound starts suddenly sometimes.
4. Enabling dark mode black colour force stops sometimes.

Looks stable for a beta. My battery is already messed up, so can't say anything about battery life.
 

Nabeel840

Senior Member
Apr 29, 2015
73
10
32
sialkot
Hay ,

Hope you are fine.

my zuk just bricked today morning. it just simply stuck a while and reboot.

screen was flicking. i thought there must be some corruption in system or boot storage.

i wipe all phone re flash recovery because no zip file was installing. it shows installing but when screen flicks while process its stuck.

i was looking for factory image which can be flash through fast boot.

in all this circumstance i mistakenly flash wrong img from fast boot as recovery. no my gate to boot loader are closed.

can you help me to enter in boot loader mod because i am unable to do so. or guide me to flash factory firmware to fix this issue.

regards...

Nabeel
 

Nabeel840

Senior Member
Apr 29, 2015
73
10
32
sialkot
Hay ,

Hope you are fine.

my zuk just bricked today morning. it just simply stuck a while and reboot.

screen was flicking. i thought there must be some corruption in system or boot storage.

i wipe all phone re flash recovery because no zip file was installing. it shows installing but when screen flicks while process its stuck.

i was looking for factory image which can be flash through fast boot.

in all this circumstance i mistakenly flash wrong img from fast boot as recovery. no my gate to boot loader are closed.

can you help me to enter in boot loader mod because i am unable to do so. or guide me to flash factory firmware to fix this issue.

regards...

Nabeel

I have solve issue and open gates for boot loader. i am on now TWRP with latest FW. but main issue is same screen flicks while installing ZIP. and having error whit installing zips. i have manually flashed provided firmware via fast boot but same issue facing.

i think its hardware problem??? may be chip was over.
 

Attachments

  • Screenshot_1970-01-01-06-05-12.png
    Screenshot_1970-01-01-06-05-12.png
    201.5 KB · Views: 364
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 25
    2z8dpw1.jpg

    Code:
    /*
     * I'm not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed (like it did for me...)
     * Please do some research if you have any concerns about features included in the products you find here before flashing it! 
     * YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you. 
     * Your warranty will be void if you tamper with any part of your device / software.
     * Same statement for XDA.
     */

    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.


    What's working :
    • Boots
    • RIL (Calls, SMS, Data)
    • Fingerprint
    • Wi-Fi
    • Bluetooth
    • Camera
    • Camcorder
    • Video Playback
    • Audio
    • Sensors
    • Flash
    • LED
    • GPS


    Instructions :
    • Download the latest build, GApps and Magisk (Optional)
    • Reboot to recovery
    • Flash the latest build and GApps
    • Flash Magisk (Optional)
    • Reboot

    Note: You must have at least nougat firmware (ZUI) to load sensors and other stuff properly. Also, when reverting to pie flash the same firmware.

    Downloads :
    Build : AFH Page
    Gapps: BiTGApps
    Magisk: Unofficial Build
    firmware-files: firmware-files.zip

    XDA:DevDB Information
    [ROM][UNOFFICIAL][10.0.0_r2][ham] LineageOS 17.0, ROM for the Lenovo Zuk Z1

    Contributors
    shubhambhise
    Source Code: http://github.com/LineageOS

    ROM OS Version: Android 10
    ROM Firmware Required: Unlocked Bootloader, TWRP Recovery
    Based On: LineageOS

    Version Information
    Status: Alpha

    Created 2019-10-05
    Last Updated 2019-10-05
    4
    Lineage-17.1-20200303-UNOFFICIAL-ham

    Hi guys! :cool:
    I compiled a new build today. All patches have been applied from the March 3, 2020 of the Lineage-17.1 repository.
    Lineage-17.1-20200303-UNOFFICIAL-ham
    3
    Dear bro.

    I have reinstall rom for review.
    Have performed clean flash.
    Having latest recovery.
    Flash provided latest firmware before rom flashing.
    First boot up time was with beta opengapps 71 seconds.

    Your provided gapps were unable to flash. they give some error which i did not note.
    Beta opengapps were released today was working fine .

    Having following issues.

    1= Check Drawer Screenshot. Where search bar is going??.
    2= Dark mode can be enable only from in display settings or qs toggle. Not from in style section. Is it work in same way?
    3= Accent colors. Only one color is there? Is it should be like this? In screens provided by Sharma g it show purple accent.
    4= Battery percentage is showing up in status bar.
    5= There is no option i found to change launcher icons and qs toggles icons shape. In screens provided by Sharma g there is different shapes shows for both.

    There are also some little bit issues but they are not noticeable. Hope those issues will fixed by time in upcoming builds.

    Overall rom was working fine. Its really good for first build.

    Good work keep it up.

    Regards...

    Mr. Qurashi