• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][10.0] LineageOS 17.1 for UMIDIGI F1 and F1 PLAY

Search This thread

Crhada17

Member
Jun 5, 2021
29
0
Any chance to fix it myself? I got it from libmtk-ril.so stock rom. Do I need to put libmtk-ril.so in lib64 folder or lib folder? (lineage os)
 

Crhada17

Member
Jun 5, 2021
29
0
im sorry for waiting you can fix it yourself until i upload the next version

you have to go to vendor/lib64 and copy libmtk-ril.so to system_root/system/lib64 and reboot

it will work
I tried it gives an access denied error :(

Then I wanted to do it in the rom file, but there were files with the extension dat.br, I edited it by converting it to an img file, but I did not understand how to make dat.br, and I installed it as system.img and the result was brick. I reinstalled the stock rom. Best I guess I'll have to wait for you to post the fixed version
 

Crhada17

Member
Jun 5, 2021
29
0
so sorry for the inconvinience but access denied is caused by TWRP

you have 2 choices

you install lineageos recovery and access denied will disappear

or you instal TWRP 3.3.1 and go to file manager in twrp and do the copying
I tried the twrp method first, I entered the system root folder, but when the files did not appear, I installed lineage os recovery, then I installed root explorer, then I said the system_root folder does not exist, so I said I should do this system folder, but again, it said, access is denied, there is an error every time, what should I do now?
 

Shadow Of Leaf

Senior Member
Jul 28, 2014
518
364
Casablanca
I tried the twrp method first, I entered the system root folder, but when the files did not appear, I installed lineage os recovery, then I installed root explorer, then I said the system_root folder does not exist, so I said I should do this system folder, but again, it said, access is denied, there is an error every time, what should I do now?
install twrp 3.3.1 and go to TWRP File manager not root explorer in system and copy the file to system/lib64
 

Crhada17

Member
Jun 5, 2021
29
0

Crhada17

Member
Jun 5, 2021
29
0
sorry bro i keep you busy again but i managed to put the lib file in system_root/system/lib64 and /vendor/lib64 and /system/lib64 but incoming call still didn't fix (I think the lib is incompatible)
 

Crhada17

Member
Jun 5, 2021
29
0
sorry for waiting , i build for f1 and f1 play that why

try now and see if still the call in bug in
Yes It Works But I Found Other Bugs


Vibration not working in Battery Saver Mode

And after using it for a few hours, suddenly the phone turned off and twrp started booting non-stop. Even though I selected and started the system, twrp was always on, the phone would not turn off. I Restored Backup. Chrome Was Open During This Crash But I don't think it's relevant but I don't know why

My Device: Umidigi F1 Play

Used Lineage OShttps://www.mediafire.com/file/5jjq0gjkx13mdqo/lineage-17.1-20210621-UNOFFICIAL-F1_Play.zip/file

Gapps
open_gapps-arm64-10.0-pico-20210619

Sorry Couldn't Recover Logs :(
 
Last edited:

Top Liked Posts

  • 1
    I went from that 'Tee Google' watermark to the Lineage ROM and didn't try to remove the watermarks but I think the watermarks are there to make you upgrade the stock ROM. I don't have the link in front of me but there is a video on the Umidigi forums showing how to upgrade over the air (OTA?), you have to disable the existing OTA and install another version, that might get rid of the 'Tee Google' watermark.
    i have bought a *anycast streamer but on the unofficiel rom mirra and the bluetooth doesent work. on the unofficiel rom. 4g do not work too. so iam gone back to the factory stock rom but there was the *watermarks and the watermarks disturb me so much that iam gone back to the unofficiel rom. X)
  • 1
    I finally flashed your rom and tried for today.
    Issues that I encountered are:
    There's a 4/5sec delay when you turn off a call and it effectively don't display anything about active call
    Screen recording feature is broken, only black screen (talking about native recorded of course)
    Ringtone are played at very high level of audio even put on lowest setting possible, I waked up all the pharmacy with my Ringtone :-D
    Also, when on call, if I put the speaker on the volume is abnormally high, again I made people trigger at me for that issue :-D
    And then that's all, all round is a good rom with good battery life and nice things like Android 10, I am looking forward for new releases of course.
    Thank you for your work B-)
    for the abnormal volume you can disable besloudness (there is an app to do it)
    for the delay i have that too i will see what i can do
    1
    I think the sudden shutdown problem still persists, when we enter a twitter page in chrome, if we play two videos together, the device restarts itself. (This error may be caused by me, I made a few changes in the system. You will have to test)



    and Miravision is necessary for me. Is there an application where I can adjust settings such as the contrast setting? I searched but couldn't find it, if not, unfortunately I will have to go back to stock rom, I don't want it at all :(



    Lineage Os:lineage-17.1-20210819-UNOFFICIAL-F1_EEA
    use firefox for now chrome cause soft reboot (not sudden shutdown) due to video codec

    miravision need a lot of work to implement it and i dont have source code for that

    you can use this application https://play.google.com/store/apps/details?id=co.uk.quickdoc.screenbalance&hl=en

    also you can return to stockrom anytime
    1
    Thank you for this. I have had a good installation experience. I had to disable MAC randomising as this was blocking my router on reconnect. I also had to manually copy the adbkey for adb debugging. Otherwise it all seems good.
    1
    Hi, I have an Umidigi F1 and was thinking of flashing this Lineage OS 17.1 image but reading the comments it seems as there are a few bugs - it says VoLTE doesn't work - what is the result of that? I use my phone for 4G USB tethering a lot and need that to work.
    volte is not working but tethering is working
    1
    n
    Do you still get 4g data speeds? I thought telcos were phasing out non Volte infrastructure, it might make the phone 1/2 useless?
    volte means voice over lte an enhacement of calling voice using internet LTE
    it does not have any relation data connection and you will get 4g data speeds
  • 1
    Lineage_OS_Logo.jpg

    Code:
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Not Working
    • VoLTE (and will not be fixed due to MTK's proprietary extensions)
    • Selinux is permissive
    • FM Radio is Working But No Sound
    • Sudden Shutdown

    Instructions :
    • Flash your phone with the latest stock rom version (20190903 download link )
    • Boot your F1 Play to the official OS.
    • Go to `Settings > About phone`, tap `build number` several times to enable developer settings.
    • Go to `Settings > System > Developer Settings`, enable `OEM unlocking` and `ADB debugging`.
    • Connect your phone to your PC and open a terminal or a command line window.
    • Run `adb reboot bootloader` on your PC (there is no way to enter bootloader directly, only possible through adb).
    • Run `fastboot flashing unlock` and comfirm unlock on device (THIS WILL WIPE ALL DATA!).
    • Run `fastboot reboot` to reboot your device and now you should see an unlocked warning during boot screen with orange state.
    • Download the latest build and gapps
    • Power off
    • Press on Power+Volume up button to boot up to Fastboot
    • Execute "fastboot flash recovery TWRP 3.3.1-0 Umidigi F1 Play.img"
    • Wait to Finish And Execute "fastboot reboot recovery"
    • Wipe Data,System,Cache
    • Flash the latest build
    • Flash gapps(optional)
    • Flash Magisk(optional)
    • Reboot
    Downloads :
    F1 : https://www.mediafire.com/file/7nar8rms5twoist/lineage-17.1-20210821-UNOFFICIAL-F1.zip/file
    F1 Play : https://www.mediafire.com/file/5e87kyoyho6eo8n/lineage-17.1-20210821-UNOFFICIAL-F1_EEA.zip/file
    Gapps : https://opengapps.org/
    TWRP 3.5.2 Recovery for F1 Play: https://forum.xda-developers.com/t/...wrp-3-5-2-for-umidigi-f1-and-f1-play.4287017/
    TWRP 3.5.2 Recovery for F1 : https://forum.xda-developers.com/t/...wrp-3-5-2-for-umidigi-f1-and-f1-play.4287017/
    TWRP 3.3.1 Recovery for F1 Play : https://www.mediafire.com/file/okky2dmgd5zupql/TWRP-3.3.1-F1_Play.img/file
    TWRP 3.3.1 Recovery for F1 : https://www.mediafire.com/file/ei83p1lwjupavdd/TWRP-3.3.1-F1.img/file
    LineageOS Recovery F1 Play : https://www.mediafire.com/file/6vpoghb3lqjt1dg/Lineage-recovery_F1_Play.img/file
    LineageOS Recovery F1 : https://www.mediafire.com/file/2heu9amxid6azj7/LineageOS+Recovery+F1.img/file
    Magisk : https://github.com/topjohnwu/Magisk/releases/download/v21.4/Magisk-v21.4.zip

    Reporting Bugs

    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.


    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:

    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:

    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:

    Changelog:
    - 07-02-2021 : Initial build

    - 20-03-2021 :
    *Fix display Lags
    *Added Material Files and GoCamera
    *Fix GoCamera Video Recording bug
    *Added F1 Build
    *Fix 'dev/fm' Permission Error
    *Fix Incoming Call Bug

    - 24-04-2021 :
    *Fix Incoming call bug (now really fixed)
    *Add LiveDisplay (but it not working cause of kernel)
    *Back to LineageOS Charge Animation
    *Fix Some Carriers does not Work
    *Fix "Stuck at SIM Card Pin"
    *Fix Random Reboot and recovery loop (I Think because of TWRP if you have this issue flash LineageOS Recovery)
    *Add Face Unlock
    *Add DT2W (double tap to wake)
    *Fix Write Access to System partition (you need to flash LineageOS Recovery)

    - 3-06-2021 :
    Build TWRP 3.5.2 For both devices from scratch

    - 17-07-2021 :
    * Fix in call bug in F1 and F1 play (my mistake)
    * Update some system Apps
    * For NOW use TWRP 3.3.1 Cause it Works well with Data Encryption

    - 28-07-2021 :
    * Fix Recovery Loop on TWRP 3.3.1 on F1 and F1 Play (flash the newest recovery to fix recovery loop)
    * For NOW use TWRP 3.3.1 Cause it Work well with Data Encryption

    - 06-08-2021 :
    - Fix FM Radio (finally)
    - Add Chromuim instead of jelly
    - Fix Video Encoding on Chromuim Based Browsers
    - Disable LiveDisplay (not entirely there is in settings)
    - Revert back to Snap ( LineageOS Camera) instead of Google Camera Go (to fix video recording issue)

    - 10-08-2021 :
    - Revert Back to Jelly Browser (Chromuim has some issues)
    - Fix Sound Distortion via Besloudness Settings APP (you can still enable/disable Besloudness audio Feature)
    - Use LineageOS NFC Stacks instead of Prebuilted One from Vendor (fix Random shutdown)

    - 19-08-2021 :
    - add support AOD (Always on Display)
    - Remove LiveDisplay(now is removed from settings)
    - add support Night Light and fix the flicker when enabled
    - Add MiraVision(not working for now)
    - Improve System Stability and performance
    - Enable insecure ADB for debugging

    21-8-2021 :
    - Fix Besloudness Settings not found
    - Fix low brightness is still not low
    - Drop MiraVision Support(need a lot of mediatek properties that are closed source code)


    For Donations:

    Feel free to donate to support this project.

    Credits:
    1. UMIDIGI
    2. PeterCxy [for his device tree for f1]
    3. a-dead-trousers[For some code from his device tree]
    XDA:DevDB Information
    LineageOS 17.1 for UMIDIGI F1 and F1 Play, ROM for Miscellaneous Android Development

    Contributors

    Shadow Of Leaf
    Source Code: https://github.com/Shadowofleaf/android_device_umidgi_f1_play

    ROM OS Version: Android 10
    ROM Kernel: Linux 4.x
    Based On: LineageOS

    Version Information
    Status:
    Beta

    Created 2021-02-07
    Last Updated 2021-03-24
    1
    I'd love to put Lineage on an unused Umidigi F1 that I have, but I'm struggling.

    ADB works fine while the phone's turned on, I've added all the drivers I've seen suggested, and it shows up as "F1" in device manager. But when I put it into fastboot mode, the computer (Windows 10) can no longer connect to it. Nothing shows up when I type "fastboot devices".

    I've tried the SP Flash approach too, but TWRP never seems to be loaded onto the phone. I reset back to the stock firmware, turned on OEM unlocking and USB debugging, then switched the phone off. Used the scatter file from the stock firmware, added the TWRP file for recovery (v 3.5.2), hit download and plugged the phone in.

    SP Flash looks like it downloads the recovery just fine. It goes through the motions and gives me the big green tick. But afterwards, no TWRP. I'm holding volume up as it powers on, but it just goes to Android recovery, and no sign of TWRP. The first time I reboot after trying to flash TWRP I get a message saying "Red Status - Your device has failed verification and may not work properly. Please download recovery image with correct signature or disable verified boot."

    If anyone has any advice, that'd be awesome! Thanks!

    Edit: Oh, and now I'm also seeing "TEE" and "Google" along with some Chinese characters in the top right corner of the screen permanently now, so I obviously got something pretty wrong here! Any way to get rid of that? Would getting Lineage on there remove it?
    1
    This ROM is above great, it transformed my F1 Play into a proper smartphone.
    It has some basic problem in being unable to make/receive calls in SIM1. Solved putting the simcard into SIM2 tray, but still unable to receive calls.
    Camera I updated it with the attached one that works like a charm.
    Arguably now I have a BETTER camera than with the original ROM.
    1M Thanks to the dev for the hard work, and praying he has some spare time to iron out the remaining telephony service bug.

    MGC_8.1.101_A9_GV1b_snap.apk

    PS: I managed to notice that the problem apparently was due to my new provider's signal at home, as today at work I received calls normally. Hurra!
    thanks for test this rom out

    if all features in this camera work i will make it the default camera in lineageos

    thanks again
    1
    I noticed some problem with the config for the selfie camera, it takes videos but taking pics it does not work, takes two shots and can't get stored correctly, while portrait mode just killed the app. The back camera otherwise works everything like a charm even in night mode! I didn't noticed all this until now as I'm not a selfie lover anyway...
    ok thanks i will update the google camera go to newest version
    1
    test this new releases and report back for bugs