• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM] [UNOFFICIAL] [10.0] [pyxis] LineageOS 17.1 [MAR SECURITY PATCH]

Search This thread

balcis

Member
May 31, 2011
35
17
Has anyone else had trouble installing gapps? I've tried installing from internal storage and sd card. I've reflashed the ROM along with reflashing gapps and it still won't install. I've tried both nano and pico packages arm64 Android 10 from the official GAPPS site.

Edit: It always says installed. It gives no errors. Yet, no signs of gapps installed. I can't use Yalp store. I even tried downloading google playstore apk, but it doesn't work.

Having problem with any ROM which needs gapps; bliss, lineage etc.

Notify me if you solve it, pls.
 

balcis

Member
May 31, 2011
35
17
I was able to install nano package after installation.
format -> reboot to recovery -> wipe 3 and system -> reboot to system
-> reboot to recovery -> adb push gapps nano package -> wipe cache -> reboot and it worked.

trying to flash gapps stock package, will edit after that.

edit: couldn't get the gapps stock pack work in anyways.
 
Last edited:

odschlegel

New member
Feb 23, 2021
1
0
LineageOS version: trying to install 17.1
LineageOS Download url: link from OP: https://drive.google.com/file/d/1edQGnLv5zCJOLe0LrfmUWXZixuuVq-sH/view
Gapps version: from opengapps.org: arm64, 10.0, stock

Im stuck in a bootloop. Im pretty new to custom ROM's so im not shure what infos you need. I will list what i have done.

1. Unlocked bootloader and installed TWRP (twrp-3.5.0_9-0-pyxis.img) with https://www.xiaomitool.com/V2/
2. Copied
Mi 9 Lite GlobalStableFastbootV12.0.5.0.QFCMIXM10.03.2 GB2020-12-09
from https://xiaomifirmwareupdater.com/archive/miui/pyxis/ onto device and installed with TWRP.
3. Booted device and did the setup.
4. Copied LineageOS 17.1 rom from op and gapps from open gapps (Arm64, 10.0, stock) on to device.
5. Booted into TWRP and factory reset
6. Installed LineageOS 17.1 with TWRP
7. Reboot into TWRP installed Gapps with TWRP
8. Reboot device and here it is stuck in a bootloop

Any advice and help greatly would be greatly appreciated
 

gringo80

Senior Member
Jun 8, 2018
663
619
LineageOS version: trying to install 17.1
LineageOS Download url: link from OP: https://drive.google.com/file/d/1edQGnLv5zCJOLe0LrfmUWXZixuuVq-sH/view
Gapps version: from opengapps.org: arm64, 10.0, stock

Im stuck in a bootloop. Im pretty new to custom ROM's so im not shure what infos you need. I will list what i have done.

1. Unlocked bootloader and installed TWRP (twrp-3.5.0_9-0-pyxis.img) with https://www.xiaomitool.com/V2/
2. Copied
Mi 9 Lite GlobalStableFastbootV12.0.5.0.QFCMIXM10.03.2 GB2020-12-09
from https://xiaomifirmwareupdater.com/archive/miui/pyxis/ onto device and installed with TWRP.
3. Booted device and did the setup.
4. Copied LineageOS 17.1 rom from op and gapps from open gapps (Arm64, 10.0, stock) on to device.
5. Booted into TWRP and factory reset
6. Installed LineageOS 17.1 with TWRP
7. Reboot into TWRP installed Gapps with TWRP
8. Reboot device and here it is stuck in a bootloop

Any advice and help greatly would be greatly appreciated

Factory Reset option doesn't exist in TWRP. Forget it !

There is 2 options :

1. wipe > advanced wipe > data
2. wipe > format data > type yes with keyboard popup, and reboot recovery again and make option 1, and boot to system

- Coming from MIUI : choose option 2
 

marcobuu

Senior Member
Feb 21, 2017
62
7
LineageOS version: trying to install 17.1
LineageOS Download url: link from OP: https://drive.google.com/file/d/1edQGnLv5zCJOLe0LrfmUWXZixuuVq-sH/view
Gapps version: from opengapps.org: arm64, 10.0, stock

Im stuck in a bootloop. Im pretty new to custom ROM's so im not shure what infos you need. I will list what i have done.

1. Unlocked bootloader and installed TWRP (twrp-3.5.0_9-0-pyxis.img) with https://www.xiaomitool.com/V2/
2. Copied
Mi 9 Lite GlobalStableFastbootV12.0.5.0.QFCMIXM10.03.2 GB2020-12-09
from https://xiaomifirmwareupdater.com/archive/miui/pyxis/ onto device and installed with TWRP.
3. Booted device and did the setup.
4. Copied LineageOS 17.1 rom from op and gapps from open gapps (Arm64, 10.0, stock) on to device.
5. Booted into TWRP and factory reset
6. Installed LineageOS 17.1 with TWRP
7. Reboot into TWRP installed Gapps with TWRP
8. Reboot device and here it is stuck in a bootloop

Any advice and help greatly would be greatly appreciated
why do you want to install that year old rom when you have a great Los 18.1 from a couple of days ago without a single bug?
 

marcobuu

Senior Member
Feb 21, 2017
62
7
Screenshot_20210414-201542_Settings.png
 

Tomek0000

Senior Member
Jun 14, 2015
414
115
why do you want to install that year old rom when you have a great Los 18.1 from a couple of days ago without a single bug?
I confirm . I installed this image and all seems to work , good work except sensors.
( Sensors directory disaperaed from persist partition. I flushed persist.img from my old backup in TWRP and fixed the problem).
The problem is with gcam. Only 6.2 works (MGC_6.2.030_MI9SE_V4_plus2.apk). If I try 7.x it freezes and looks like not working. When I install buffer fix for a11 in magisk, I am not able to start any gcam, each one crashes during start.
 
Last edited:

marcobuu

Senior Member
Feb 21, 2017
62
7
I confirm . I installed this image and all seems to work , good work except sensors.
( Sensors directory disaperaed from persist partition. I flushed persist.img from my old backup in TWRP and fixed the problem).
The problem is with gcam. Only 6.2 works (MGC_6.2.030_MI9SE_V4_plus2.apk). If I try 7.x it freezes and looks like not working. When I install buffer fix for a11 in magisk, I am not able to start any gcam, each one crashes during start.
You need buffer fix for android 10 for that build for working gcam 7+ or 8+...
Or you update to last Los version
 

__-_-_-__

Senior Member
Nov 23, 2011
66
4
Xiaomi Mi CC9 / Mi 9 Lite
I confirm . I installed this image and all seems to work , good work except sensors.
( Sensors directory disaperaed from persist partition. I flushed persist.img from my old backup in TWRP and fixed the problem).
The problem is with gcam. Only 6.2 works (MGC_6.2.030_MI9SE_V4_plus2.apk). If I try 7.x it freezes and looks like not working. When I install buffer fix for a11 in magisk, I am not able to start any gcam, each one crashes during start.
how did you do that? can you share persist.img file? thank you
 

Tomek0000

Senior Member
Jun 14, 2015
414
115
I had old backup of system and installed only persist.img from backup in twrp. If you do not have the backup, you can use stock image and decompress this file from it. I am not sure if this is in recovery versio or only in fastboot version.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 85
    https%3A%2F%2Fi.imgur.com%2Fk5tUT1V.png

    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download and flash last firmware
    • Download the latest build and bitgapps
    • Boot to recovery
    • Do FACTORY RESET
    • Flash the latest build
    • Boot to recovery again
    • Flash gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:


    Paypal for donation [email protected]


    Contributors
    coderzs and thanks to ktommy for helping with kernel and very much to all donators . I love you guys :)
    Source Code: https://github.com/LineageOS
    Source Code: https://github.com/coderzstas
    ROM OS Version: Windows 8 Mobile

    Version Information
    Status: Testing

    Created 2020-01-08
    Last Updated 2020-03-22
    23
    BUGS :
    Selinux permissive
    Maybe more
    17
    Updated.

    Changelog :
    Fixed SystemUI Freezes
    Notch overlay updated
    Added livedisplay
    Buiding more blobs from source
    AutoBrightness things updated
    New Light Hal
    Display Hal builded from sources
    Fixed sdcards
    Fixed offline charging
    Alot of cleanups
    Lineage upstream changes
    Google Jan security patch
    Maybe more ...
    12
    bump . updated.

    changelog :
    fixed ui lags
    updated some blobs
    updated audio configs
    added HotwordEnrollment blobs
    added codec2 policy
    added stock gps configs
    swiched to AOSP implementation for sw effects
    updated powerhal
    removed unused blobs
    fixed some fod issues
    added support for auto brightness in aod
    upstream lineage changes
    some kernel fixes
    [temp] disabled fp unlock on aod
    12
    bump . updated

    ril fixed
    ui bugs fixed
    bluetooth fixed
    cleanup
    upstream changes