• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][UNOFFICIAL][10.0][tb8703f/x/r/n] LineageOS 17.1 for Lenovo TAB 3 8 plus P8

Search This thread

highwaystar_ru

Senior Member
Sep 17, 2016
342
2,352
http%3A%2F%2Ffiles.paulfasola.fr%2FCyanogenMod%2FLineageOS.png


Code:
/*
 * I'm not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed (like it did for me...). 
 * Please do some research if you have any concerns about features included in the products you find here before flashing it! 
 * YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you. 
 * Your warranty will be void if you tamper with any part of your device / software.
 * Same statement for XDA.
 */

LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.


What works:
Calls/SMS/Mobile data
Wifi
Bluetooth
GPS
Camera
Audio
FM radio
Torchlight
USB and WLAN tethering

Broken
You tell me

Source code:
device : https://github.com/lenovo-devs/android_device_lenovo_TB8703
device tb-comon https://github.com/lenovo-devs/android_device_lenovo_tb-common
kernel: https://github.com/lenovo-devs/android_kernel_lenovo_msm8953
vendor: https://github.com/lenovo-devs/proprietary_vendor_lenovo

2020-09-06
  • Updated lineage code
  • Fixed FM radio
  • dpm daemon disabled for wifi version, hope this will resolve issues with wifi only tablet version (please report, I dont have wifi version to test)
mailru: lineage-17.1-20200906-UNOFFICIAL-TB8703.zip
gdrive: lineage-17.1-20200906-UNOFFICIAL-TB8703.zip


2020-06-01
  • Fixed boot on 8703f (wifi tablet version)
mailru: lineage-17.1-20200601-UNOFFICIAL-TB8703.zip
gdrive: lineage-17.1-20200601-UNOFFICIAL-TB8703.zip


Previous versions:

2020-05-31
  • Updated Lineage code
  • Updated system graphics and media binaries
  • selinux enforcing
mailru: lineage-17.1-20200531-UNOFFICIAL-TB8703.zip
gdrive: lineage-17.1-20200531-UNOFFICIAL-TB8703.zip

2020-03-31
  • Fixed boot issue on TB8703F (Wifi only version)
mailru: lineage-17.1-20200331-UNOFFICIAL-TB8703.zip
gdrive: lineage-17.1-20200331-UNOFFICIAL-TB8703.zip

2020-03-29
  • Fixed error message on boot on WiFi only tablet
  • Fixed issues with WiFi and Bluetooth MAC addresses
  • fixed other minor issues
  • Updated Lineage code
mailru: lineage-17.1-20200329-UNOFFICIAL-TB8703.zip
gdrive: lineage-17.1-20200329-UNOFFICIAL-TB8703.zip

2020-02-22
  • Initial release
mailru: lineage-17.1-20200222-UNOFFICIAL-TB8703.zip
gdrive: lineage-17.1-20200222-UNOFFICIAL-TB8703.zip

How to install
To install this you have to install TWRP using by QFIL utility, follow this instruction: https://forum.xda-developers.com/general/general/twrp-lenovo-p8-tb-8703f-tb-8703x-t3689442/post76277192

Special TWRP build
To install and boot any custom roms and to boot it after installing mods that change boot partitition like Magisk please use this TWRP:
2018-08-25
  • Fixed long time to wakeup screen in TWRP
  • Added NTFS filesystem for sdcards
mailru: twrp-tb8703-3.2.1-20180825-bootsign.img
gdrive: twrp-tb8703-3.2.1-20180825-bootsign.img

Previous version

[*] Первая версия
mailru: twrp-tb8703-3.2.1-bootsign.img
gdrive: twrp-tb8703-3.2.1-bootsign.img

This TWRP build has special function Sign boot which you have to click after install new version of ROM or mod like Magisk. It will append stock boot signature to your boot partition. This allows to boot with locked bootloader.
TWRP with Boot Sign function screenshots:

Fortunately you dont need to unlock bootloader, because not every Lenovo tab can be unlocked. Custom kernel and ROM can be runned by appending boot.sig signature extracted from stock rom to boot.img like
Code:
cat boot.img boot.sig > boot-signed.img
It still cant be loaded by fastboot, but you always can flash it from TWRP. You can get boot.sig in my repo https://github.com/HighwayStar/android_device_lenovo_TB8703/blob/cm-14.1/twrp/recovery/root/boot.sig

XDA:DevDB Information
[ROM][UNOFFICIAL][10.0][tb8703f/x/r/n] LineageOS 17.1 for Lenovo TAB 3 8 plus P8, ROM for the Lenovo Thinkpad Tablet

Contributors
highwaystar_ru
Source Code: https://github.com/lenovo-devs/android_kernel_lenovo_msm8953

ROM OS Version: Android 10
ROM Kernel: Linux 3.10.x
Based On: LineageOs

Version Information
Status: Testing

Created 2020-02-22
Last Updated 2020-03-31
 
Last edited:

marcurelio

Member
Nov 15, 2012
41
1
Just installed it. Upon boot, a message poped up saying there's an internal error in the device, and that I should contact the maker (Lenovo). The message appeared once more before setup. Let's see how it goes now. Has someone else experienced this?
 

Catscratch

Senior Member
Mar 10, 2012
657
151
Same error message for me. Upgraded from 16.
Installed Rom, gapps, magisk.

But then it's working. But performance seems worse compared to 16. I will give the system a little bit to settle down and check performance again.
 
  • Like
Reactions: marcurelio

marcurelio

Member
Nov 15, 2012
41
1
Same error message for me. Upgraded from 16.
Installed Rom, gapps, magisk.

But then it's working. But performance seems worse compared to 16. I will give the system a little bit to settle down and check performance again.

I had 15, 16 didn't work for me. But I did a factory reset, and then installed. Everything seems fine now, but performance appears to be worse off.
 

Catscratch

Senior Member
Mar 10, 2012
657
151
BTW. The error message appears on every boot for me. I also did a clean flash with factory reset.

Otherwise I can tell that a clean flash helped for most of the problems. When I upgraded from 16 I had visual glitches and system ui freezing sometimes. These problems are completely gone after doing the clean flash. Only thing that remains is the error message. But this message does not seem to effect the daily work.
 
  • Like
Reactions: ArchibaldWu

zephyrus_kk

New member
Mar 17, 2020
1
0
@highwaystar_ru
Hi,Can you help me ,i try to build crdroid with your device tree.But it miss dsp label.I try to add this label to file_context,failed with the message
Code:
Abort message: 'Error creating cache dir /data/dalvik-cache/arm64 : No such file or directory'
Thanks
 

Top Liked Posts