• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][10.0][tb8703f/x/r/n] LineageOS 17.1 for Lenovo TAB 3 8 plus P8

Search This thread

greatbal

Senior Member
Mar 18, 2006
1,527
75
Hi.

Can you tell me how you got ddp working?

Did you installed viper first and then which version of ddp?

I installed Ddp first and then Viper4android magisk modules consecutively and then reboot. And Ddp works fine.

---------- Post added at 03:27 PM ---------- Previous post was at 03:25 PM ----------

Thanks you so much highwaystar_ru. My TB-8703f was born again by LOS17.1.

How to install Magisk? At TWRP, install process showed no errors, but tab stopped at the first Lenovo logo. Magisk manager does not install Magisk. Please help.

After installing magisk.zip via twrp, you have to sign boot image again.
 

Catscratch

Senior Member
Mar 10, 2012
657
151
I installed Ddp first and then Viper4android magisk modules consecutively and then reboot. And Ddp works fine.

---------- Post added at 03:27 PM ---------- Previous post was at 03:25 PM ----------



After installing magisk.zip via twrp, you have to sign boot image again.

How can I test it?

I got both installed. But the viper app says it can't do anything because busybox is missing.

And the Dolby app crashs often when I try to use it for setting profiles etc.

Which versions are you using?

I have:
- ddp 7.3
- viper 1.6 (2.1.0.2-1)
 

Thickweeds

New member
Jun 27, 2020
4
3
Oh!
the twrp updated now.
and the los.
thanks.

---------- Post added at 10:15 AM ---------- Previous post was at 09:26 AM ----------

i just installed the los.
there is no play store?
where do i get the apps from?
thanks.

Good to hear your inatalling LOS17.
Please go to https://opengapps.org/
Select ARM64, Android10, and a variant you want.
I choiced mini.
Save the file in SD and install via TWRP.
Good luck!

---------- Post added at 10:35 AM ---------- Previous post was at 10:31 AM ----------

I installed Ddp first and then Viper4android magisk modules consecutively and then reboot. And Ddp works fine.

---------- Post added at 03:27 PM ---------- Previous post was at 03:25 PM ----------



After installing magisk.zip via twrp, you have to sign boot image again.

Thanks you for your reply.
Could you teach me the way to do sign boot image in detail.

Oh! I got it ? "sign boot" means item in TWRP after install of Magisk, right?
Now, Magisk works fine and my tab is rooted.
Thanks so much for your help, greatbal.
 
Last edited:

greatbal

Senior Member
Mar 18, 2006
1,527
75
How can I test it?

I got both installed. But the viper app says it can't do anything because busybox is missing.

And the Dolby app crashs often when I try to use it for setting profiles etc.

Which versions are you using?

I have:
- ddp 7.3
- viper 1.6 (2.1.0.2-1)

I never launched viper. Just the ddp. I used the version of ddp with filename [Q-10]Dolby Digital Plus_v.7.2-[MMT Ex]-20200222.zip

I haven't tried version 7.3
 

greatbal

Senior Member
Mar 18, 2006
1,527
75
I tried 7.2. Doesn't work either. Did you started the Dolby app and tried to use it? Like setting profiles and switching them etc?

Yes. I'm using Dolby. Always did. I need and want it that's why I always install it everytime I change roms.

Is there any error messages on the screen when you install ddp and viper thru Magisk? If viper doesn't work for you, you could try Audio Modification magisk module.
 

carlosgreg88

Member
Jul 1, 2019
6
0
Guys, good night.
can you help me?
I have installed the rom pixel for a long time, but I have several problems with storage and I believe it is a problem with Rom. I would like to install this Lineage.
How should I do it?
I have doubts about how I should get the device ready to install lineage.
What is this magisk for?
 

leonardoaraujo85

New member
Feb 20, 2017
2
0
Bluetooth and WiFi error after install

Hi!

Thanks for this rom!!!

In my TB8703F (wifi only), after install, show a bluetooth error message and WIFI dont starts (no MAC Address appears) after install the lastest rom (01/06)
Anyone help me?

Thanks again.
 

greatbal

Senior Member
Mar 18, 2006
1,527
75
Hi!

Thanks for this rom!!!

In my TB8703F (wifi only), after install, show a bluetooth error message and WIFI dont starts (no MAC Address appears) after install the lastest rom (01/06)
Anyone help me?

Thanks again.

This happened to me. I was coming from 17.1 build 20200331 and trying to fresh install 17.1 build 20200601. I tried a few times even downloaded a fresh copy of the installer. Still having problems with BT error upon first boot and no WiFi. What I did was to install the boot image of build 20200331 I backed up before proceeding with the newer build. It worked for me in solving the BT and wiFi issues. I don't know the long term impact but I'm using the rom for 2 months with no issues.
 

ralph.rebello

New member
Aug 26, 2020
1
0
Hi, may name is Ralph and i installed the rom on my lenovo p8 8703f. installed the normal 17.1 lineageos rom and also the gapps in the mini version.
When you restart the screen it just flashes and goes out. So I installed the superSU via TWRP and now the Lineageos load screen appears but it is infinitely loading. What can I do?
 

inaiat

New member
Dec 10, 2010
1
0
Hi, may name is Ralph and i installed the rom on my lenovo p8 8703f. installed the normal 17.1 lineageos rom and also the gapps in the mini version.
When you restart the screen it just flashes and goes out. So I installed the superSU via TWRP and now the Lineageos load screen appears but it is infinitely loading. What can I do?

Hi Ralph. After install superSu or magisk, You have to sign boot imagem again on TWRP.
 

s3medo

New member
Jun 17, 2013
0
0
Hi Ralph. After install superSu or magisk, You have to sign boot imagem again on TWRP.

Please, can someone explain what is "You have to sign boot imagem again on TWRP"?
Thank you

Edit: It means: If you dnt know what is "sign boot" is because you have the "wrong" TWRP.
The correct one is:
mailru: twrp-tb8703-3.2.1-bootsign.img / see the original post
gdrive: twrp-tb8703-3.2.1-bootsign.img / see the original post

Install the correct image(select recovery) with your TWRP.img
reboot to recovery (without SU)
Done!
Now you have the option "Sign Boot"

Thank you very much Developers <3
("Thanks" me if i help you)
 
Last edited:

highwaystar_ru

Senior Member
Sep 17, 2016
342
2,355
2020-09-06
  • Updated lineage code
  • Fixed FM radio
  • dpm daemon disabled for wifi version, hope this will resolve issues with wifi only tablet version (please report, I dont have wifi version to test)
 

kuzu115

Member
Jan 6, 2015
26
3
Hi!
BIG thanks for update!
Dirty installed on my wifi version tab and everythings looks o.k.
Process: reboot to TWRP, install rom and Gapps, wipe cache and dalvik, sign boot, reboot system.
Regards
 

Top Liked Posts