• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][UNOFFICIAL][10.0][tb8704f/x/v] LineageOS 17.1 for Lenovo TAB 4 8 plus

Search This thread
Lineage 17.1 update
2020-09-06
  • Update Lineage code
  • Fixed FM radio issue
  • Fixed issues on 8704F (wifi only version), when charger cable unplugged (please report if it really works this time, I dont have wifi only tablet to test)

I have the TB-8704F wifi only. It was running stock Lenovo Oreo, latest row version from 2019. Yesterday I factory reset it and then installed TWRP, this Lineageos 17.1
and opengapps nano. The radio works fine. There are no issues with charging or disconnecting from power. I charge my Tab from a 3rd party QC 3 compatible charger. *Everything* works except tap to wake so I'm very impressed. I installed Better Battery Stats and there is no problem with battery life, it's great. Fingerprint reader and power button works just the same as stock Lenovo, GPS works quickly, adoptable storage works great, wireguard VPN to my home VPN server is working perfectly. I have a lot of games, kodi connecting to my tvheadend server, UPnP renderer apps, banking apps, paypal etc and zero problems. Great ROM!

Btw in Lineageos apps like Neutron Music Player and UAPP can take exclusive control of the audio system, bypass Android's 48 KHz limitation and software resampler, and do proper bit perfect audio playback up to 24-bit 192 KHz, so called Hi-Res audio. I verified this by checking the output of "dumpsys media.audio_flinger" in adb shell.
 
Battery Life

I attached a screenshot of Better Battery Stats. I bought this TB-8704F refurbished in February 2019 and have used it for several hours daily since, so that is a minimum of 18 months of regular use. Usage is mostly a mix of web browsing, some 2D games and some 3D games. You can see that this ROM performs really well on battery life. No surprises. OK, one surprise: it's much better than the stock Lenovo Oreo. I don't run Magisk or xposed or any superuser mod. I was thinking I might need to buy a newer tablet in the next few months but now I feel confident I can use this same hardware for another year at least.
 

Attachments

  • Screenshot_20200914-194723_BBS.png
    Screenshot_20200914-194723_BBS.png
    161.2 KB · Views: 94

Phoebus89

New member
Jul 29, 2019
4
0
Please, please, please fix the USB hub issue. The tablet will not charge through any USB C hub but it does work on Lineage OS 16 with no problems. Please fix this it Highwaystar. I have tried over ten USB C hubs and none of them can charge the tablet on LOS 17.1
 
Please, please, please fix the USB hub issue. The tablet will not charge through any USB C hub but it does work on Lineage OS 16 with no problems. Please fix this it Highwaystar. I have tried over ten USB C hubs and none of them can charge the tablet on LOS 17.1

I just checked with my Tab and can confirm this bug. It charges fine from USB from PC motherboard but not from USB hub. My hub is not Type C, it is a USB 3.0 hub attached to my PC's USB 3.0 motherboard rear port.
 

dahawthorne

Senior Member
Nov 15, 2014
1,989
1,835
Brighton
I have to disagree. I've just plugged my TB8704F (LineageOS 17.1 20200906) into my Anker 7+3 hub (7 USB connection ports plus 3 charging-only ports, mains power) using my Anker USB3 cable and both types of ports work absolutely fine.
Sorry, guys, it's not the ROM, it's your hardware or installation that's at fault. There is no USB hub problem.
 

Phoebus89

New member
Jul 29, 2019
4
0
I have to disagree. I've just plugged my TB8704F (LineageOS 17.1 20200906) into my Anker 7+3 hub (7 USB connection ports plus 3 charging-only ports, mains power) using my Anker USB3 cable and both types of ports work absolutely fine.
Sorry, guys, it's not the ROM, it's your hardware or installation that's at fault. There is no USB hub problem.
Mains powered hub buddy. Completely different from what I mean. I mean a USB type C hub like one would use on a macbook pro for example. It has to be the software as the same hub works if you roll back to lineageos 16.
 
Mains powered hub buddy. Completely different from what I mean. I mean a USB type C hub like one would use on a macbook pro for example. It has to be the software as the same hub works if you roll back to lineageos 16.

Yes, agreed. If rolling back the OS software makes the problem disappear then it's not a hardware problem. My tab charges perfectly on a multiport USB QC 3 mains charger, perfectly on direct connection to a PC's USB ports but it does not charge when connected to a USB hub which connects to a PC's USB port.
 

enigmo

Member
Oct 19, 2007
27
7
Does anyone know if there's still a live link to lineage-17.1-20200601-UNOFFICIAL-TB8704.zip?
The mail.ru one on OP links to 20200531 and the gdrive link is dead
I'm trying to install lineage-17.1-20200906-UNOFFICIAL-TB8704 using @lancebuks TWRP v3.4.0.0 and just hit a never ending LineageOS boot animation. If 20200601 works better on an 8704f then I'd like to give it a go.
 

snyderjw

New member
Sep 19, 2020
1
0
8704v issues

Does anyone have an 8704v with functional bluetooth? I've lost a lot of hair to getting as far as I have, but unfortunately I'm trying all of this to make an emulator console - and the lack of bluetooth is probably what will put me over the edge of going back to stock. I keep getting "bluetooth keeps stopping." The v model is complicated to say the least, but I would LOVE any advice anyone might offer on this issue before I futz around only to lose everything I have worked for up to this point. FWIW, I am on the newest ROM (20200906), and TWRP 3.2.3.0. I haven't tried 3.3.1.0, though I am not sure why that would make a difference. Open to ANY ideas. Thank you!
 

Eisbaer2

Member
Jun 10, 2016
24
1
Does anyone know if there's still a live link to lineage-17.1-20200601-UNOFFICIAL-TB8704.zip?
The mail.ru one on OP links to 20200531 and the gdrive link is dead
I'm trying to install lineage-17.1-20200906-UNOFFICIAL-TB8704 using @lancebuks TWRP v3.4.0.0 and just hit a never ending LineageOS boot animation. If 20200601 works better on an 8704f then I'd like to give it a go.

Why not using the latest one? Works very good with the 8704f
 

enigmo

Member
Oct 19, 2007
27
7
Why not using the latest one? Works very good with the 8704f

Because I've tried flashing:
lineage-17.1-20200906-UNOFFICIAL-TB8704
lineage-17.1-20200610-UNOFFICIAL-TB8704
lineage-17.1-20200531-UNOFFICIAL-TB8704
and
lineage-16.0-20200320-UNOFFICIAL-TB8704

Using:
TWRP 3.3.1
TWRP 3.4.0

I've wiped:
Dalvik
System
Data
Internal Storage
Cache

before installing, and after install wiped Dalvik and cache again, and I'm still getting a never-ending Lineage boot animation on every try. I have no reason to think another older version will work, but failing any other ideas it's something else to try.

Edit: Wait, wait, wait! It is possible that I am a donkey. I forgot to fully format Data. It's just booted properly after installing
 
Last edited:

WiteWulf

Member
Mar 31, 2020
49
17
Btw in Lineageos apps like Neutron Music Player and UAPP can take exclusive control of the audio system, bypass Android's 48 KHz limitation and software resampler, and do proper bit perfect audio playback up to 24-bit 192 KHz, so called Hi-Res audio. I verified this by checking the output of "dumpsys media.audio_flinger" in adb shell.

Oh, that's very interesting! I was trying to find out what the capabilities of the onboard audio chip were as I have a decent library of HD audio. I'll give those apps a try, thanks :good:
 
Oh, that's very interesting! I was trying to find out what the capabilities of the onboard audio chip were as I have a decent library of HD audio. I'll give those apps a try, thanks :good:
Correction: NeutronMP does play back bit perfect, direct to hardware bypassing all audio effects & mixer, but UAPP does not do so with this device (yet)*. This device supports 44100, 48000, 88200, 96000, 176400 & 192000 16-bit and 24-bit when using wired headphones. It also seems to have extremely low output impedance although I'm unable to measure that. My Massdrop Plus (multi balanced armature) earphones are extremely sensitive to output impedance and sound quite different on devices with different OI, getting a very exaggerated bass if the OI is not very low indeed. By comparing with hardware with known specs I'd guess the Tab's OI is 1 ohm or lower.

*it's possible the developer could add support.
 

TcT

Senior Member
Jan 10, 2006
58
1
I flashed the 2020-09-06 build on my Wifi only version and it seems to work great. I've tested browsing, gmail, youtube and a few other apps without a problem. It's great to have a current OS on this older device, which is otherwise still working great.

The only very minor issue I've found is that it still includes the phone app, sms app and SIM settings on the Wifi only device. Would be nice to get rid of that if would be easy. If it's to much a hassle it's fine as it is.
 

Top Liked Posts