[ROM][UNOFFICIAL][10] LineageOS 17.0 for K-touch i9 mini-phone (Anica i9) (MT6739)

flinkerhase

New member
Jan 14, 2020
1
0
0
By me the google play store is causing big system problems, it freezes the screen and phones reboots. It starts just by the login page, so often no chance to enter the pin. Could you upload a version of google apps which works with k-touch?
I think i would need something like a pico-version.
 

free30

Member
May 24, 2016
17
1
0
Does anyone know how to update this version of android 10?
Or how to install the gsi version instead to be able to get updates.
Any clues would be great :)
 

Bublik82

New member
Apr 29, 2020
1
0
0
hi guys .. I need the original preloader along with the scater file .. when I try to install the killed phone and not turning on now .. the flash tool sees and sews but doesn’t want to turn on without the original ... share the stock firmware .. thanks
I10 touch
Mt6739/v
3/32
 
Last edited:

Carrillo

Member
Aug 14, 2008
5
1
0
always stock recovery

According the instruccions:
1. Unlock the phone (reboot to bootloader by holding volume up on boot, run `fastboot flashing unlock` and confirm)
2. Flash TWRP image from here
3. Reboot to recovery (hold volume up and choose Recovery accordingly)
4. Backup all stock partitions whatever way you like (especially boot / vendor)
5. Flash this LOS 17 port image and format data
6. Reboot and enjoy

Question:

Hello, I would like to update my anika i9, but I have a problem with the TWRP.
1 - I have download the indicated in the post.
2 - Then, I install the TWRP with the comand ADB (previously I have unlocked the phone).
3 - In the terminal, appear the correct message OK.
4 - But when I reboot the phone, the recovery is ALWAYS de stock


SOLUTION: I have tried to install TWRP again, and now it is ok. The problem was: is IMPORTANT that after you install the TWRP, the next boot should be in TWRP. If not, the stock recovery is installed again.
 
Last edited:
Aug 4, 2020
7
0
0
i10 roms?

I've ported TWRP for the MT6580 version of the K-Touch I9. You can find it here:
Thanks so much! was pulling my hair out getting a newer TWRP to work.

I have another problem though: my MT6580 is the i10 not the i9, build h06_anica_i9_m8128_v0.8_20190902, kernel 3.18... Tried to install this lineage rom and I get error 255, obviously since this is not for the MT6580... I tried a few other older lineageOS roms and they installed but bootlooped... do you have a working Lineage OS for the Mt6580 variant that would run on the i10? I ask because the stock rom has Spyware/Adware/Trojans installed. I am about to install magisk to see if they can at least be removed to make the phone usable.. but would love a newer android or rom on the on the phone to be honest.

Thanks for this btw. thanks so much. :cowboy:

edit: um, you ported it but didn't bother to set the resolution to fit the screen dude.
 
Last edited:

cin242

New member
Sep 24, 2020
1
0
0
MT6580 – Anica i10s

hi Ierlanfdan,

Thank you very much for your efforts & everything you have done here so far!

Unfortunately I’ve got the same result with the setup above (MT6580 – Anica i10s, build h06_anica_i9_m8128_v0.8_20190902, kernel 3.18): Installation of LineageOS ended with error 255.

If you have an idea how to fix this, pls. let us know, thank you!!
 

plumpkibbles

New member
Sep 14, 2020
4
0
0
I have the Anica i10 - I believe another variant of the i9, this one I bought was listed as an i9s in the specs - listed as i10. I don't have any biometrics either, i.e. finger print scanner. I have the 'face unlock'. I'm not sure of the MTK, but it has 8.1 Oreo, very badly hacked - with malware.. I've removed what I can but I'd rather just flash another ROM..

Anyone have any thoughts for my device? I wouldn't mind Pie if I could get it. And which ROM does this use?? A/B or A or B?

Also - without root how would I go about backing up all the partitions without twrp? If I flash twrp without knowing my version - that could be bad not having the stock recovery - no? My security patch is also WAY out of date - Jul. 5th 2017

Kernel version:
3.18.19+ [email protected] #1 Tue Oct 29 17:37:39 CST 2019

Baseband version:
MOLY.WR8.W1449.MD.WG.MP.V59.PA,2019/03/15 14:53

Build number:
H06_Anica_i9_M8128_V.10?_20191029

Update: Found an image for the 2GB/16GB i10 - https://www.getdroidtips.com/stock-rom-k-touch-i10/
Seems to be legit - I'm scared to flash it though lol Which version of SP Flash Tool works with MT6739? Scatter text shows this is an MT6739 - definitely want to make sure this is correct!

My Anica i10 is an MT6580 series with 2GB RAM / 16GB ROM. I cannot find a flash file for this phone!! I have found an older version but it is setup for a different ROM size and RAM size. I cannot even boot into recovery at this point. I need something!!
 
Last edited: