[ROM][UNOFFICIAL][10] LineageOS 17.1 for Samsung Galaxy Tab S (SM-T700, SM-T705, SM-T800, SM-T800, SM-P600)

Search This thread

8224Freak

Senior Member
May 6, 2017
712
3,113
Berlin
Hello friends,

I tried to update my old Samsung Galaxy Tab S devices with the latest Android 10 (Lineage 17.1). I would like to make the build available for you guys as well.

Special thanks to the teams at Exynos5420 and LineageOS for the sources.

Devices:
  1. Samsung Galaxy Tab S 8.4 WiFi (klimtwifi) SM-T700
  2. Samsung Galaxy Tab S 8.4 LTE (klimtlte) SM-T705
  3. Samsung Galaxy Tab S 10.5 LTE (chagalllte) SM-T805
  4. Samsung Galaxy Tab S 10.5 WiFI (chagallwifi) SM-800
  5. Samsung Galaxy Note 10.1 Edition 2014 (n1awifi) SM-P600

I will create new builds from time to time.

Installation:
1. Flash latest official Samsung Firmware with ODIN
2. Flash latest TWRP Recovery https://twrp.me/Devices/Samsung/
3. Wipe Data
4. Install ROM.ZIP with TWRP https://luis-builds.de/downloads/lineageos/misc/
5. Install latest GApps with TWRP (ARM/Android10) https://opengapps.org/
6. Reboot and Enjoy
7. Optional: Install Magisk

Download the file:
https://luis-builds.de/downloads/lineageos/misc/

Sources:
https://github.com/LineageOS (LineageOS 17.1)
https://github.com/exynos5420/ (Kernel, Device, Vendor)

Greetings Frank
 

flhthemi

Senior Member
Feb 8, 2012
550
94
Statesville, NC
If I'm already on 14.1 do I need flash latest official Samsung Firmware or can I just wipe data with TWRP, flash rom and open gapps? (SM-T800)
 

8224Freak

Senior Member
May 6, 2017
712
3,113
Berlin
If I'm already on 14.1 do I need flash latest official Samsung Firmware or can I just wipe data with TWRP, flash rom and open gapps? (SM-T800)
When you have the latest firmware from Samsung and running 14.1 then you can flash lineage 17.1 with full wipe before (data).

In few hours I am uploading crdroid 6.17 builds based on android 10 for the same devices.

Cu Frank
 

headzy

Senior Member
Dec 9, 2009
106
60
Been checking these forums every week for android 10/11 for our old but much loved Tab S, to my literal delight I see this thread.

Just installed and everything went perfectly and easily, just had a play for a few mins, everything working so far although not tried putting a sim card in, and tab runs smoother than stock Android 6 that I was using.

Thank you very much for your hard work and kindness to share Frank, top bloke.

Gave me something to do while watching the snooker final :)

Tab S android 10 lineage.jpg
 
  • Like
Reactions: saoudien07

kodiak799

Senior Member
Jan 17, 2012
219
49
Wow. I've used this tablet very little in recent years, but thrilled to see this update!

I was able to flash LOS 14.1. Still struggling to flash this or figure out what I'm missing, but when I do I will buy you a coffee!

Amazing that you did this for a device that came out nearly 7 years ago!
 
  • Like
Reactions: saoudien07
Send me the right commits for the kernel. I can merge this.
Sorry, I'm out of my depth with this stuff! It comes from here for LOS 14.1

I have only just got my sm-t805. I install Lineage 14.1 with Deathly kernel. Then I was messing with the kernel settings from here...


I'd prefer to use your 17.1 rom 😁
 

pocepoke

Senior Member
Jul 27, 2011
75
19
jakarta
I was trying it, when playing free fire there were glitches, sometimes the player's body was transparent.
in the world of tank sometimes the game exits. in blockmango sometimes hank
for normal frame rate results tend to be better than LOS 14.1
 
May 4, 2021
5
1
Hi, just wondering what version of TWRP (and Odin) and Gapps people used?

I'm on T805 (chagallte) and flashed TWRP 3.5.2 using Odin v3.10.7. All worked well and was able to install LineageOS and Stock Gapps (ARM 10.0 version). However after install finishes and it boots to OS, it gets stuck on the LineageOS splash screen. Have tried restarting and gone back to TWRP to clear Dalvik Cache but no luck and have tried the installation a couple of times now.

Previously had LineageOS 14.1 and TWRP (not sure what version), so not sure what I'm doing wrong this time around. Any tips or guidance would be appreciated!
 
  • Like
Reactions: idocinthebox
May 4, 2021
5
1
Hi, just wondering what version of TWRP (and Odin) and Gapps people used?

I'm on T805 (chagallte) and flashed TWRP 3.5.2 using Odin v3.10.7. All worked well and was able to install LineageOS and Stock Gapps (ARM 10.0 version). However after install finishes and it boots to OS, it gets stuck on the LineageOS splash screen. Have tried restarting and gone back to TWRP to clear Dalvik Cache but no luck and have tried the installation a couple of times now.

Previously had LineageOS 14.1 and TWRP (not sure what version), so not sure what I'm doing wrong this time around. Any tips or guidance would be appreciated!
So I think it must be something about the Gapps package I picked. Just tried it without installing Gapps and it worked really quick
 

acytoo

Member
Jul 28, 2012
28
11
Google Pixel
Google Pixel 3
Thank you for your great work, downloading now.

------------------------- update and bug report --------------------------

20210505-unofficial klimtwifi, 5g wifi works only on low channels, and heavy load apps (e.g. chrome) crash sometimes.


Flash light not working on my t700, no big g deal though.

--------------------------
 
Last edited:
  • Like
Reactions: prodj77

Top Liked Posts