• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[ROM][UNOFFICIAL][10] LineageOS 17.1 for Samsung Galaxy Tab S (SM-T700, SM-T705, SM-T800, SM-T800, SM-P600)

Search This thread

H421

Member
Jun 15, 2021
5
0
I am sm-t750, now using crdroid, everything seems to be working normally, boot image patch has been installed,, the chrome I installed is still shutting down frequently, force close, does anyone know the problem?

one more thing, cellular data can't be connected
 
Last edited:

MZWiZard

Senior Member
Jan 7, 2010
111
10
Is Camera working on this ROM
It works on my SM-T805 :) a BIG THANKS TO THE DEVELOPER FOR PORTING LINEAGE TO TAB S!! - And I really hope this will be maintained over time or even result in LinageOS 18.1 and higher becoming available in the future.
 
Last edited:
I will try to patch RAM, LMK and ZRAM, anyway please try this first update for klimtlte temporaly with GPU and CPU patched
thank you so much for this! using it now on my T700 and it's so much smoother than stock kernel (not a knock on the dev, of course ✌️). first boot after install (prior to magisk) bootlooped on me. took out my sd card (previously partitioned 80% for ext and the rest for int storage), rebooted and all good! sd card works too as before 👍
 

kamelot1966

New member
Mar 28, 2018
2
0
My tablet is finally working properly again! Thanks for your work, really great! Thank you for the rom!
Endlich läuft mein Tablet wieder vernünftig! Danke für Deine Arbeit, echt super! Vielen Dank für die rom!
 
something went wrong on my machine I can't build my boot image I don't know what happen too, so I will investigate and try to fix it asap
Thanks for your modified boot.img, I get fewer forced shutdowns now. If you plan on updating it may I suggest changing the max charging current to be higher? As we have been using 2000-3000mA on LOS14.1 for years with no issues
 
I found that sporadic Chrome crashes, Gallery and other apps were due to a well-known Android Webview.apk bug.
Following the web's recommendations to resolve, I deleted data and cache and then turned off the system app "Android Webview.apk".
Then from Google Play I installed the latest version of "Android Webview.apk" and "Android Webview Dev.apk".
For the time being (two days) all crasches have disappeared
 
  • Like
Reactions: runekock

Samtab800

Member
Jun 24, 2021
5
0
Hello,

thanks everyone for android 10 on SM-T800.
After many crashes I installed magisk via trwp (the latest one).
I used easy dpi changer to change the resolution to
1920 width x 1200 height.
To use netflix on a rooted tablet you must via
magisk install the liboemcrypto module first otherwise netflix will hang while playing .... Restart and install netflix.
I invite the creators of this rom to continue their efforts so that we can again use the initial resolution 320 dpi
2560 x 1600 if it is physically possible.
Greetings
 

Samtab800

Member
Jun 24, 2021
5
0
thanks cicisbeus,

I m come back on resolution 320 dpi 2560 x 1600

i'm testing on SM-T800.

it seems to be working.
I tried with chrome and then
dolphin navigator.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 7
    I've successfully ported ISoreo's modifications to the SM-T805 chagalllte. My device is booting up fine and the system runs snappier. Apps are loading 'fast' and the animations are smoother (no stuttering). Thank you very much @ISoreo!!

    The only modifications I didn't apply are all the governors ISoreo added. At the moment the default is ondemand which is the same as the default one of ISoreo's boot.img. If someone is missing them, I will add them in the future.

    Here is the link for downloading:
    4
    update for klimtlte : patched gpu up to 600 MHz from 533 MHz should be more smooth, add more cpu governors, i am trying to figure out about our ZRAM and lowmemorykiller how i can fix this problem
    3
    Update for Klimtlte : update some cpu governor (wheatley, conservativex, darkness, intellimm, lionheart) sorry for a long time i'm quite busy on kernel branch and other stuff
    3
    Is there anyone who can port ISoreo's custom kernel over to the T805? I would love to be able to upgrade to a reliable LineageOS 17.1
    here you are please try it, and give the result back also backup stock boot image first before try it, if the performance get worse please revert to stock
    2
    Update for klimtwifi : everything should be fine on this patched, please try it
  • 56
    Hello friends,

    I tried to update my old Samsung Galaxy Tab S devices with the latest Android 10 (Lineage 17.1). I would like to make the build available for you guys as well.

    Special thanks to the teams at Exynos5420 and LineageOS for the sources.

    Devices:
    1. Samsung Galaxy Tab S 8.4 WiFi (klimtwifi) SM-T700
    2. Samsung Galaxy Tab S 8.4 LTE (klimtlte) SM-T705
    3. Samsung Galaxy Tab S 10.5 LTE (chagalllte) SM-T805
    4. Samsung Galaxy Tab S 10.5 WiFI (chagallwifi) SM-800
    5. Samsung Galaxy Note 10.1 Edition 2014 (n1awifi) SM-P600

    I will create new builds from time to time.

    Installation:
    1. Flash latest official Samsung Firmware with ODIN
    2. Flash latest TWRP Recovery https://twrp.me/Devices/Samsung/
    3. Wipe Data
    4. Install ROM.ZIP with TWRP https://luis-builds.de/downloads/lineageos/misc/
    5. Install latest GApps with TWRP (ARM/Android10) https://opengapps.org/
    6. Reboot and Enjoy
    7. Optional: Install Magisk

    Download the file:
    https://luis-builds.de/downloads/lineageos/misc/

    Sources:
    https://github.com/LineageOS (LineageOS 17.1)
    https://github.com/exynos5420/ (Kernel, Device, Vendor)

    Greetings Frank
    7
    I've successfully ported ISoreo's modifications to the SM-T805 chagalllte. My device is booting up fine and the system runs snappier. Apps are loading 'fast' and the animations are smoother (no stuttering). Thank you very much @ISoreo!!

    The only modifications I didn't apply are all the governors ISoreo added. At the moment the default is ondemand which is the same as the default one of ISoreo's boot.img. If someone is missing them, I will add them in the future.

    Here is the link for downloading:
    6
    I'm finding the config since zram doesn't work also the can't keep it in ram. moreover, those apps were kill by the LMK when I have try to open a lot of apps but it's always killed it

    Edited : I got these value from LOS 14.1 might be useful a lot
    Markdown (GitHub flavored):
    echo 1262 1212 1162 1112 1075 1037 1000 975 950 925 900 875 850 850 1150 1087 1037 987 950 912 875 850 850 850 850 850 > /sys/devices/system/cpu/cpu0/cpufreq/UV_mV_table
    echo 177 > /sys/devices/platform/mali.0/minclock
    echo 1 > /sys/devices/platform/mali.0/dvfs
    echo 600 962500 > /sys/devices/platform/mali.0/volt_table
    echo 533 937500 > /sys/devices/platform/mali.0/volt_table
    echo 480 900000 > /sys/devices/platform/mali.0/volt_table
    echo 420 862500 > /sys/devices/platform/mali.0/volt_table
    echo 350 812500 > /sys/devices/platform/mali.0/volt_table
    echo 266 762500 > /sys/devices/platform/mali.0/volt_table
    echo 177 725000 > /sys/devices/platform/mali.0/volt_table
    echo 100 725000 > /sys/devices/platform/mali.0/volt_table
    echo 1000 > /sys/devices/platform/sec-battery/ac_input_curr
    echo 1000 > /sys/devices/platform/sec-battery/ac_chrg_curr
    echo 2048 > /sys/block/mmcblk0/queue/read_ahead_kb
    echo 1024 > /sys/block/mmcblk1/queue/read_ahead_kb
    echo 0 > /sys/block/mmcblk0/queue/iostats
    echo 0 > /sys/block/mmcblk0/queue/add_random
    echo 1 > /sys/kernel/mm/uskm/deferred_timer
    echo 400000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    
    LMK Fore 72 Vis 90 Sec 108 Hidd 126 Content 144 Empty 180 MB unit
    VM Dirty Ratio 20 % Dirty Background Ratio 5% Dirty Expire Centisecs 200 cs
    Overcommit Ratio 50% Dirty Writeback Centisecs 5000cs Swappiness 100%
    VFS Cache Pressure 99
    Min free Kilobytes 2839


    Okay so I played around with stuff a bit, the tablet is running smoother and snappier now. And much much cooler. Hope this helps everyone.

    I am using smartpack kernel manager
    Here are the settings I am using
    1. CPU max frequency 1700 (1800 makes it run too hot, might go down to 1600 if 1700 still runs hot). Min 100hz (apply on boot)
    2. Governor at interactive
    3. Target loads at 75 600000:75 800000:85 1500000:90 1700000:95
    4. Multi-core power saving enabled
    5. CPU boost enabled
    6. Kernal samepage off and disabled on boot
    7. Low memory killer off and disabled on boot (Low memory killer has to be disabled on every device reboot from the app)
    8. Z-ram 4096 and lz4 compression. Might try lzo later. (apply on boot)
    9. Virtual memory turntable on
    10. Entroy enabled on boot and read 256 and write 512
    11. Battery enabled on boot and charging option on
    12. IO scheduled disabled on boot

    if anyone improves on these settings please update on this thread. We would all appreciate it.
    4
    Could you tell where I can change it? I can't see it in display settings.
    In the other hand, Does anyone has impression that the device is running very slowly? What can help to change it? Kernel change?

    I did complete wipe from TRWP all settings, cache, internal storage and other stuff.
    I've got SM-T800

    Cheers
    you can use ADB


    Bash:
    adb shell wm size 1200x1920
    
    adb shell wm density 240

    reference: https://nerdschalk.com/change-screen-resolution-adb-android/
    4
    update for klimtlte : patched gpu up to 600 MHz from 533 MHz should be more smooth, add more cpu governors, i am trying to figure out about our ZRAM and lowmemorykiller how i can fix this problem