[ROM][UNOFFICIAL][10] LineageOS 17.1 for Samsung Galaxy Tab S (SM-T700, SM-T705, SM-T800, SM-T800, SM-P600)

Search This thread
Hopefully someone can help with a custom kernel. This tablet gets too hot and throttles itself. By playing with the CPU frequencies this can be prevented and tablet will run quickly and smoothly.

I am a "hardware guy" otherwise I would try to do it myself!


Note: putting the extra thermal pads in is helpful too but just adjusting the kernel makes a big difference!

You can check your own device to see if it's throttling...

 

prodj77

Member
Mar 6, 2013
47
17
43
Thank you so much @8224Freak my Tab S Wi-Fi 10" is backing to life!!, there is some bugs (Wi-Fi 5 Hz it's not visible, only 2.4 Hz, the screen brightness its no so bright at max., I cant find the pixel protection for OLED display), but at least I have Android 10 in my tablet. Greetings from Mexico City 👍.
 

Danistics1

New member
May 7, 2021
2
0
Brussels
Hi, just wondering what version of TWRP (and Odin) and Gapps people used?

I'm on T805 (chagallte) and flashed TWRP 3.5.2 using Odin v3.10.7. All worked well and was able to install LineageOS and Stock Gapps (ARM 10.0 version). However after install finishes and it boots to OS, it gets stuck on the LineageOS splash screen. Have tried restarting and gone back to TWRP to clear Dalvik Cache but no luck and have tried the installation a couple of times now.

Previously had LineageOS 14.1 and TWRP (not sure what version), so not sure what I'm doing wrong this time around. Any tips or guidance would be appreciated!

Hi, I'm having the exact same behavior. stuck on the LOS splash screen.
Did you found a way to resolve this?
 

clavead

New member
Sep 19, 2010
4
1
Project Treble
Hi, I'm having the exact same behavior. stuck on LOS splash screen.
Did you found a way to resolve this?
Try flashing pico or nano Gapp insteads, there is not enough system memory available to allow for installation of stock Gapps. You can always install the remaining Google apps normally from the Play store and they will work just fine.
 
May 4, 2021
5
0
Hi, I'm having the exact same behavior. stuck on the LOS splash screen.
Did you found a way to resolve this?
I used the Aroma GUI installer, but was VERY selective with the apps I chose to install, i.e. I only picked the ones that I think are necessary (those that are part of Pico / Nano), and then those where the Gapps app replaces stock. Worked like a charm first time around.
 
May 4, 2021
5
0
Chrome keeps crashing on me, even when I've only got a single tab open (e.g. it closed after I hit reply on my message above). Not running any other apps and only have bluetooth keyboard connected so that I can type. Anyone else having issues with apps closing / system crashing?
 

theastroboy

Member
Aug 4, 2016
9
1
Does this work on a Canadian SM-T705W (klimtltecan)? It is currently on Lollipop and there is no newer stock ROM. It would be nice to keep the SIM capability. However, I would pick performance over SIM capability any day as I rarely use this tablet with a SIM card.

Anyone?

Thanks in advance.
 
Last edited:

Amoosajjad

New member
May 8, 2021
2
0
I tried klimtlte .everything is OK .but my mobile network didn't work . actually Sim card detected but LTE or 3G or 2G for internet not working ...
 

ymlik

Senior Member
Nov 19, 2008
164
36
Rennes
Hello,

I installed your Rom (T800) it works except:
-camera
- fingerprint reader
-torch

Is this normal, or does it work for you?

Thanks in advance
 

welton

Member
Sep 15, 2010
16
6
Thank you so much for this! Installed using instructions provided and it works. It's like buying a new device :) .

As someone already highlighted the only issue I found so far is not being able to use 5 ghz wifi on chagallwifi, but I can live with that.

My process was: upgraded TWRP, wiped everything, installed rom and pico gapps.
 

tvict

New member
May 9, 2021
3
0
Hello friends,

I tried to update my old Samsung Galaxy Tab S devices with the latest Android 10 (Lineage 17.1). I would like to make the build available for you guys as well.

Special thanks to the teams at Exynos5420 and LineageOS for the sources.

Devices:
  1. Samsung Galaxy Tab S 8.4 WiFi (klimtwifi) SM-T700
  2. Samsung Galaxy Tab S 8.4 LTE (klimtlte) SM-T705
  3. Samsung Galaxy Tab S 10.5 LTE (chagalllte) SM-T805
  4. Samsung Galaxy Tab S 10.5 WiFI (chagallwifi) SM-800
  5. Samsung Galaxy Note 10.1 Edition 2014 (n1awifi) SM-P600

I will create new builds from time to time.

Installation:
1. Flash latest official Samsung Firmware with ODIN
2. Flash latest TWRP Recovery https://twrp.me/Devices/Samsung/
3. Wipe Data
4. Install ROM.ZIP with TWRP https://luis-builds.de/downloads/lineageos/misc/
5. Install latest GApps with TWRP (ARM/Android10) https://opengapps.org/
6. Reboot and Enjoy
7. Optional: Install Magisk

Download the file:
https://luis-builds.de/downloads/lineageos/misc/

Sources:
https://github.com/LineageOS (LineageOS 17.1)
https://github.com/exynos5420/ (Kernel, Device, Vendor)

Greetings Frank
Hi Frank,

Let me just say that i value this post as very wonderfull.
I was on the lineage OS android 7 from 2019 and never expected that would be another update again for the SM-T800 .
Installed your rom and everthing runs very smooth. Feels i am having a brand new tablet.
As for now i have no issues found. Even my 5ghz wifi is much faster then before.
I hope you will maintain this development and will follow this thread closly.

Again my thanks and regards!
Tjerk
 

welton

Member
Sep 15, 2010
16
6
ok, merci welton, par contre pour moi le wifi 5Ghz fonctionne sur mon chagallwifi.
I got additional clues about why 5ghz wifi is not working. The device can only see see up to channel 112, so if you use channels 149—161 it won't see it. Not a deal breaker, but if anyone knows how to fix it, please let me know.
 
Last edited:
  • Like
Reactions: acytoo

MrMontana3333

New member
May 10, 2021
1
0
First i want to say tanQ for publishing this amazing Release...
Secound i installed Klimtlte. the only bug is Mobile Network. never turned on mobile netwok data
 

tvict

New member
May 9, 2021
3
0
Ok, my initial reaction was a wauw. However i already ran into some problems. I had several browser chrashes. Chrome firefox, it does't matter wich one. Als a spontanious reboot.
But what is really anoying is the fact that the battery is charging slow. On google people talk about putting the fast charging option to off in android 10.
But that option isn't there in this costum rom.

Can anyone help me out here?

Thanks
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    I'm finding the config since zram doesn't work also the can't keep it in ram. moreover, those apps were kill by the LMK when I have try to open a lot of apps but it's always killed it

    Edited : I got these value from LOS 14.1 might be useful a lot
    Markdown (GitHub flavored):
    echo 1262 1212 1162 1112 1075 1037 1000 975 950 925 900 875 850 850 1150 1087 1037 987 950 912 875 850 850 850 850 850 > /sys/devices/system/cpu/cpu0/cpufreq/UV_mV_table
    echo 177 > /sys/devices/platform/mali.0/minclock
    echo 1 > /sys/devices/platform/mali.0/dvfs
    echo 600 962500 > /sys/devices/platform/mali.0/volt_table
    echo 533 937500 > /sys/devices/platform/mali.0/volt_table
    echo 480 900000 > /sys/devices/platform/mali.0/volt_table
    echo 420 862500 > /sys/devices/platform/mali.0/volt_table
    echo 350 812500 > /sys/devices/platform/mali.0/volt_table
    echo 266 762500 > /sys/devices/platform/mali.0/volt_table
    echo 177 725000 > /sys/devices/platform/mali.0/volt_table
    echo 100 725000 > /sys/devices/platform/mali.0/volt_table
    echo 1000 > /sys/devices/platform/sec-battery/ac_input_curr
    echo 1000 > /sys/devices/platform/sec-battery/ac_chrg_curr
    echo 2048 > /sys/block/mmcblk0/queue/read_ahead_kb
    echo 1024 > /sys/block/mmcblk1/queue/read_ahead_kb
    echo 0 > /sys/block/mmcblk0/queue/iostats
    echo 0 > /sys/block/mmcblk0/queue/add_random
    echo 1 > /sys/kernel/mm/uskm/deferred_timer
    echo 400000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    
    LMK Fore 72 Vis 90 Sec 108 Hidd 126 Content 144 Empty 180 MB unit
    VM Dirty Ratio 20 % Dirty Background Ratio 5% Dirty Expire Centisecs 200 cs
    Overcommit Ratio 50% Dirty Writeback Centisecs 5000cs Swappiness 100%
    VFS Cache Pressure 99
    Min free Kilobytes 2839


    Okay so I played around with stuff a bit, the tablet is running smoother and snappier now. And much much cooler. Hope this helps everyone.

    I am using smartpack kernel manager
    Here are the settings I am using
    1. CPU max frequency 1700 (1800 makes it run too hot, might go down to 1600 if 1700 still runs hot). Min 100hz (apply on boot)
    2. Governor at interactive
    3. Target loads at 75 600000:75 800000:85 1500000:90 1700000:95
    4. Multi-core power saving enabled
    5. CPU boost enabled
    6. Kernal samepage off and disabled on boot
    7. Low memory killer off and disabled on boot (Low memory killer has to be disabled on every device reboot from the app)
    8. Z-ram 4096 and lz4 compression. Might try lzo later. (apply on boot)
    9. Virtual memory turntable on
    10. Entroy enabled on boot and read 256 and write 512
    11. Battery enabled on boot and charging option on
    12. IO scheduled disabled on boot

    if anyone improves on these settings please update on this thread. We would all appreciate it.
    3
    Update for klimtlte : update GPU value should be more smooth, undervoltage the CPU should be help about reduce the high temperature
    3
    Great work been away. Will give it a full try tonight. So far causes the tablet to slow down significantly also the display flickers.
    I will try to patch RAM, LMK and ZRAM, anyway please try this first update for klimtlte temporaly with GPU and CPU patched
    2
    Okay so I played around with stuff a bit, the tablet is running smoother and snappier now. And much much cooler. Hope this helps everyone.

    I am using smartpack kernel manager
    Here are the settings I am using
    1. CPU max frequency 1700 (1800 makes it run too hot, might go down to 1600 if 1700 still runs hot). Min 100hz (apply on boot)
    2. Governor at interactive
    3. Target loads at 75 600000:75 800000:85 1500000:90 1700000:95
    4. Multi-core power saving enabled
    5. CPU boost enabled
    6. Kernal samepage off and disabled on boot
    7. Low memory killer off and disabled on boot (Low memory killer has to be disabled on every device reboot from the app)
    8. Z-ram 4096 and lz4 compression. Might try lzo later. (apply on boot)
    9. Virtual memory turntable on
    10. Entroy enabled on boot and read 256 and write 512
    11. Battery enabled on boot and charging option on
    12. IO scheduled disabled on boot

    if anyone improves on these settings please update on this thread. We would all appreciate it.
    LZO doesn't stick on boot or whatever I've tested it, Z-RAM 4 GB can you switch apps from background process? Something wrong in RAM management, it can't keep apps in SWAP (Z-RAM) also, it's always kill many background apps from heavy loads I can't figure out is it occur from LMK or not (from I've tested it by open 2-3 apps before LMK kill those app and bring me back to home screen)
    No.1-5 is perfect settings, I have using it (you can disassemble back plate and applied some thermal paste to reduce cpu heat)
    No. 6-9 I can't confirm the problem come from swappiness or LMK, We should wait until next patch release. If we can patch swappiness from default to 160 which mean we can more aggressive put all apps in SWAP and switch previous app easier
    2
    How did you get netflix to work? :O

    I installed magisk v23 via twrp (renamed apk to zip first),
    rebooted, used magisk modules liboemcrypto disabler and magiskhide props config and rebooted, enabled magisk hide
    installed netflix app via sideload and tick box in magisk to hide this app
    went to netflix account to enable HD streaming for the device
  • 45
    Hello friends,

    I tried to update my old Samsung Galaxy Tab S devices with the latest Android 10 (Lineage 17.1). I would like to make the build available for you guys as well.

    Special thanks to the teams at Exynos5420 and LineageOS for the sources.

    Devices:
    1. Samsung Galaxy Tab S 8.4 WiFi (klimtwifi) SM-T700
    2. Samsung Galaxy Tab S 8.4 LTE (klimtlte) SM-T705
    3. Samsung Galaxy Tab S 10.5 LTE (chagalllte) SM-T805
    4. Samsung Galaxy Tab S 10.5 WiFI (chagallwifi) SM-800
    5. Samsung Galaxy Note 10.1 Edition 2014 (n1awifi) SM-P600

    I will create new builds from time to time.

    Installation:
    1. Flash latest official Samsung Firmware with ODIN
    2. Flash latest TWRP Recovery https://twrp.me/Devices/Samsung/
    3. Wipe Data
    4. Install ROM.ZIP with TWRP https://luis-builds.de/downloads/lineageos/misc/
    5. Install latest GApps with TWRP (ARM/Android10) https://opengapps.org/
    6. Reboot and Enjoy
    7. Optional: Install Magisk

    Download the file:
    https://luis-builds.de/downloads/lineageos/misc/

    Sources:
    https://github.com/LineageOS (LineageOS 17.1)
    https://github.com/exynos5420/ (Kernel, Device, Vendor)

    Greetings Frank
    6
    I'm finding the config since zram doesn't work also the can't keep it in ram. moreover, those apps were kill by the LMK when I have try to open a lot of apps but it's always killed it

    Edited : I got these value from LOS 14.1 might be useful a lot
    Markdown (GitHub flavored):
    echo 1262 1212 1162 1112 1075 1037 1000 975 950 925 900 875 850 850 1150 1087 1037 987 950 912 875 850 850 850 850 850 > /sys/devices/system/cpu/cpu0/cpufreq/UV_mV_table
    echo 177 > /sys/devices/platform/mali.0/minclock
    echo 1 > /sys/devices/platform/mali.0/dvfs
    echo 600 962500 > /sys/devices/platform/mali.0/volt_table
    echo 533 937500 > /sys/devices/platform/mali.0/volt_table
    echo 480 900000 > /sys/devices/platform/mali.0/volt_table
    echo 420 862500 > /sys/devices/platform/mali.0/volt_table
    echo 350 812500 > /sys/devices/platform/mali.0/volt_table
    echo 266 762500 > /sys/devices/platform/mali.0/volt_table
    echo 177 725000 > /sys/devices/platform/mali.0/volt_table
    echo 100 725000 > /sys/devices/platform/mali.0/volt_table
    echo 1000 > /sys/devices/platform/sec-battery/ac_input_curr
    echo 1000 > /sys/devices/platform/sec-battery/ac_chrg_curr
    echo 2048 > /sys/block/mmcblk0/queue/read_ahead_kb
    echo 1024 > /sys/block/mmcblk1/queue/read_ahead_kb
    echo 0 > /sys/block/mmcblk0/queue/iostats
    echo 0 > /sys/block/mmcblk0/queue/add_random
    echo 1 > /sys/kernel/mm/uskm/deferred_timer
    echo 400000 > /sys/devices/system/cpu/cpu0/cpufreq/scaling_min_freq
    
    LMK Fore 72 Vis 90 Sec 108 Hidd 126 Content 144 Empty 180 MB unit
    VM Dirty Ratio 20 % Dirty Background Ratio 5% Dirty Expire Centisecs 200 cs
    Overcommit Ratio 50% Dirty Writeback Centisecs 5000cs Swappiness 100%
    VFS Cache Pressure 99
    Min free Kilobytes 2839


    Okay so I played around with stuff a bit, the tablet is running smoother and snappier now. And much much cooler. Hope this helps everyone.

    I am using smartpack kernel manager
    Here are the settings I am using
    1. CPU max frequency 1700 (1800 makes it run too hot, might go down to 1600 if 1700 still runs hot). Min 100hz (apply on boot)
    2. Governor at interactive
    3. Target loads at 75 600000:75 800000:85 1500000:90 1700000:95
    4. Multi-core power saving enabled
    5. CPU boost enabled
    6. Kernal samepage off and disabled on boot
    7. Low memory killer off and disabled on boot (Low memory killer has to be disabled on every device reboot from the app)
    8. Z-ram 4096 and lz4 compression. Might try lzo later. (apply on boot)
    9. Virtual memory turntable on
    10. Entroy enabled on boot and read 256 and write 512
    11. Battery enabled on boot and charging option on
    12. IO scheduled disabled on boot

    if anyone improves on these settings please update on this thread. We would all appreciate it.
    4
    Could you tell where I can change it? I can't see it in display settings.
    In the other hand, Does anyone has impression that the device is running very slowly? What can help to change it? Kernel change?

    I did complete wipe from TRWP all settings, cache, internal storage and other stuff.
    I've got SM-T800

    Cheers
    you can use ADB


    Bash:
    adb shell wm size 1200x1920
    
    adb shell wm density 240

    reference: https://nerdschalk.com/change-screen-resolution-adb-android/
    3
    If I'm already on 14.1 do I need flash latest official Samsung Firmware or can I just wipe data with TWRP, flash rom and open gapps? (SM-T800)
    When you have the latest firmware from Samsung and running 14.1 then you can flash lineage 17.1 with full wipe before (data).

    In few hours I am uploading crdroid 6.17 builds based on android 10 for the same devices.

    Cu Frank
    3
    Update for klimtlte : update GPU value should be more smooth, undervoltage the CPU should be help about reduce the high temperature