• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][10] LineageOS 17.1 for Samsung Galaxy Tab S (SM-T700, SM-T705, SM-T800, SM-T800, SM-P600)

Search This thread

pinsb

Senior Member
Sep 9, 2011
595
91
London, UK
Guys, firstly I clearly understand the "never ask for a time to fix" rule on these forums, as all work is best endeavours and real life takes priority.

I'm tempted to install this ROM but the lack of working data is a show stopper for me, so while I'm in no way asking about timescales, I would like to know is the problem even being looked at, either upstream or specifically in this thread.

Simplistically, if it's not being even looked at I can just stay with the LOS 14.1 I'm using right now and use later tablets I've got for the functionality that's not supported in LOS 14.1.
 

jays note 2

Senior Member
Mar 10, 2015
257
86
43
Silverdale, Auckland, New Zealand
Guys, firstly I clearly understand the "never ask for a time to fix" rule on these forums, as all work is best endeavours and real life takes priority.

I'm tempted to install this ROM but the lack of working data is a show stopper for me, so while I'm in no way asking about timescales, I would like to know is the problem even being looked at, either upstream or specifically in this thread.

Simplistically, if it's not being even looked at I can just stay with the LOS 14.1 I'm using right now and use later tablets I've got for the functionality that's not supported in LOS 14.1.
Being a Unofficial build there is NO real support unless they make it Official. there have been multiple accounts about Mobile Data not working, yet I don't think anything has been addressed cos like I sed it's a Unofficial Build. Your better off staying on what you have now, but keep you eyes open for any Official builds for your device
 

pinsb

Senior Member
Sep 9, 2011
595
91
London, UK
Being a Unofficial build there is NO real support unless they make it Official. there have been multiple accounts about Mobile Data not working, yet I don't think anything has been addressed cos like I sed it's a Unofficial Build. Your better off staying on what you have now, but keep you eyes open for any Official builds for your device
Except that in a number of occasions previously 'fixes' have been provided by developers in threads that have then been upstreamed, so there exists the possibility that devs working in this thread (and other similar chipset devices) could come up with a solution. I'm just trying to get any sense that it is even being looked at at all, after all, people stating in a build thread that xxx isn't working does not mean the LoS 17.1 maintainer is even aware there's an issue.

Sorry, just as an afterthought, I seem to remember (perhaps incorrectly) that the Tab S series used the same internals as one or two of the Samsung phones and 'fixes' were transportable between devices, I'll have to do some research and see if my memory is right or too fuzzy from many whiskeys.
 
  • Like
Reactions: jays note 2

jays note 2

Senior Member
Mar 10, 2015
257
86
43
Silverdale, Auckland, New Zealand
Except that in a number of occasions previously 'fixes' have been provided by developers in threads that have then been upstreamed, so there exists the possibility that devs working in this thread (and other similar chipset devices) could come up with a solution. I'm just trying to get any sense that it is even being looked at at all, after all, people stating in a build thread that xxx isn't working does not mean the LoS 17.1 maintainer is even aware there's an issue.

Sorry, just as an afterthought, I seem to remember (perhaps incorrectly) that the Tab S series used the same internals as one or two of the Samsung phones and 'fixes' were transportable between devices, I'll have to do some research and see if my memory is right or too fuzzy from many whiskeys.
lets us know what you find, I have a t705y running CRdroid & it'll be good too get mobile data going.
 

korayesque

Member
Oct 25, 2020
7
2
Hi there,

I am tempted to install LineageOS 17.1 on my SM-P600, but I am stuck at step one, I cannot unlock the bootloader.

I have experience of installing LineageOS on Google Nexus 4 and 7. However I cannot unlock the bootloader on this Samsung tablet. I tried looking for information everywhere, but nothing really works.

I can see the tablet using adb devices command when it is on and connected to my PC. When I use power & vol+ combination I cannot see the device with adb command. Therefore I cannot run fastboot flashing unlock or fastboot oem unlock commands.

I tried installing TWRP using ODIN3 and the device boots back to normal when it restarts.

Could someone please lead me to the correct procedure? What am I missing here?

Thank you in advance.

Koray
 

Trlef

New member
Nov 24, 2021
2
0
Hello,
Does anyone has the previous crdroid build (v 6.23) for t705? The latest doesn't boot for me.. thanks!
 

korayesque

Member
Oct 25, 2020
7
2
This thread is not about the P600, but it is possible that the same guide works (but not the same roms!):
Unfortunately it didn't work. I can get to the point where I can put heimdall print-pit command on my Win10 PC, it starts working but gives an error on downloading device's PIT file. As follows:




Initialising connection...
Detecting device...
libusb: error [init_device] device '\\.\USB#VID_0BDB&PID_193E&CDC_0D&MI_06#6&1D9D7D7B&0&0006' is no longer connected!
libusb: error [init_device] device '\\.\USB#VID_046D&PID_C52B&MI_02#6&2C82025E&0&0002' is no longer connected!
Claiming interface...
Setting up interface...

Initialising protocol...
Protocol initialisation successful.

Beginning session...

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device's PIT file...
ERROR: Failed to receive end PIT file transfer verification!
ERROR: Failed to download PIT file!
Ending session...
ERROR: Failed to receive session end confirmation!
Releasing device interface...


Some people suggested to use ODIN3 for this error, but I cannot get TWRP to work when I install it with ODIN3? By the way, I cannot unlock the bootloader and the device is not rooted as I mentioned earlier.

Any help would be appreciated...

K.
 
Last edited:

Hazou

Senior Member
Feb 5, 2012
1,554
2,114
Unfortunately it didn't work. I can get to the point where I can put heimdall print-pit command on my Win10 PC, it starts working but gives an error on downloading device's PIT file. As follows:




Initialising connection...
Detecting device...
libusb: error [init_device] device '\\.\USB#VID_0BDB&PID_193E&CDC_0D&MI_06#6&1D9D7D7B&0&0006' is no longer connected!
libusb: error [init_device] device '\\.\USB#VID_046D&PID_C52B&MI_02#6&2C82025E&0&0002' is no longer connected!
Claiming interface...
Setting up interface...

Initialising protocol...
Protocol initialisation successful.

Beginning session...

Some devices may take up to 2 minutes to respond.
Please be patient!

Session begun.

Downloading device's PIT file...
ERROR: Failed to receive end PIT file transfer verification!
ERROR: Failed to download PIT file!
Ending session...
ERROR: Failed to receive session end confirmation!
Releasing device interface...


Some people suggested to use ODIN3 for this error, but I cannot get TWRP to work when I install it with ODIN3? By the way, I cannot unlock the bootloader and the device is not rooted as I mentioned earlier.

Any help would be appreciated...

K.
Some thing on my mind:
- Remove all unneccesary USB devices
- Try another cable? Looks like tranfer problems to me.
 

paparazzo79

Senior Member
Nov 27, 2012
272
13
I have SM-T800(Tab S) and want to try this version
I'm on Android 5.
Can I flash Lineage without flashing latest Samsung firmware?
 
Last edited:

pinsb

Senior Member
Sep 9, 2011
595
91
London, UK
Could someone who has installed the latest LOS 17.1 and is willing to act as a guinea pig please try to now install the original RIL from the last official Samsung firmware and then report back if data now works?

Please, don't try this if you're even a little unsure what you're doing as I'm not taking the blame if your Tab catches fire and burns down your house as a result. I can't try this myself as my Tab S is currently configured for some specific stuff that is a PITA to reinstall due to two factor auth being required, so if we get reports it's now working OK I'll then bite the bullet and put aside a weekend for the upgrade.
 

golagha11

Senior Member
Nov 23, 2009
264
64
Oslo
I have SM-T700: Warning: No file_contexts. E3004: This package is for device : klimtwifi; This device is . E:unknown command [log], Updater process ended with error: 7, Error installing zip file.-..........................klimtwifi. Downloaded the corresponding file. Any suggestions? Installing from SD-card(tried different SD-cards, so it can't be SD-card issue(I think). Can't mount the device for transfer, so I haven't tried that. Kind of newbie, so please bear with me.
 
Last edited:

Top Liked Posts