[ROM][UNOFFICIAL][10] LineageOS 17.1 for Samsung Galaxy Tab S (SM-T700, SM-T705, SM-T800, SM-T800, SM-P600)

Search This thread

djtallman

New member
Jul 30, 2022
1
0
Running it on my smt700 for a week now, awesome, only aroma variant of gapps worked for me! Thank you very much!
 

CrackPL

New member
May 11, 2016
1
0
I just installed lineage-17.1-20220619-UNOFFICIAL-klimtwifi on SM-T700, with BiTGApps, so this also works.
 

porcino

Senior Member
Feb 18, 2011
307
88
@porcino Can you share a picture of your taping? thanks.
It's about spreading heat from the CPU to the battery, frame and rear lid...

Sorry, I would rather not open the device now, because I also put some thermal paste under the rear lid... It is simple to explain without pictures. I used adhesive aluminium tape, about 5cm width. It is thin, so multiple layers are needed, say 5. You can't miss the processor - it's the hot metal plate to the North of the battery (near the camera). Lay the strips of the tape from the processor across the whole battery. Removing the lid is a bit fiddly - start from the USB port and use a couple of thin plastic implements (cards, guitar picks or collar tabs).

I've noticed that the kernel does not support HMP (8 cores simultaneously), although EXYNOS5420 is able to do that, and Linux for Odroid XU3 (EXYNOS5422) supports it beautifully. Sadly, one can't have it all...
 

Jed D`Lagged

Senior Member
Jan 4, 2006
124
3
Sydney
Jed.delagged.net
Just bumping because I, too, have noticed that Mobile Data does not work with Luis's Lineage 17.1 or crDroid release. klimtlte, SM-T705

It can read the SIM (AP info pulled from SIM and displayed), but it does not seem to be able to communicate over the mobile broadband. Searching for other networks produces no results. I can force 3g over LTE, and my Mobile indicator shows a signal over no signal, but I still cannot connect to any AP, and searching for other networks is still blank.

SMS and Phonecalls work fine.
Wifi is fine
Bluetooth is... working, with some tweaking but I think those issues are unrelated.

I restored the Modem from my Lineage 14.1 backup, but the problem persisted.

It seems like a Logcat has already been produced, but if there's anything else anyone needs to help fix this I'm more than happy to help.
 

Jed D`Lagged

Senior Member
Jan 4, 2006
124
3
Sydney
Jed.delagged.net
Ok, I rebooted the phone, did a manual selection of network, had that fail and grabbed a logcat.

I'm not familiar with android logcat but here are some entries that might be pertinent:

Code:
08-06 09:01:52.035  3088  3088 E RILClient: Connect_RILD: Connecting failed. Connection refused(111)

08-06 09:01:55.751  3040  3040 D TelephonyManager: No /proc/cmdline exception=java.io.FileNotFoundException: /proc/cmdline: open failed: EACCES (Permission denied)

08-06 09:02:05.912  3527  3527 W CarrierConfigManager: Error getting config for subId -1 ICarrierConfigLoader is null

08-06 09:04:17.668  3817  3932 D DC-C-1  : EVENT_SETUP_DATA_CONNECTION_DONE, result: ERROR_DATA_SERVICE_SPECIFIC_ERROR  SetupResult.mFailCause=14, mFailCause: 14

08-06 09:04:55.349  3116  3194 E RILD    : LDC-MGR(9): evt(10002)
08-06 09:04:55.349  3116  3194 E RILD    : RefreshAttachApn: reason 5
08-06 09:04:55.349  3116  3194 E RILD    : IsEsmFlagZeroNetwork: 505025 operator ESM flag 1
08-06 09:04:55.349  3116  3194 E RILD    : LoadApnProfile(): db doesn't exist
08-06 09:04:55.349  3116  3194 E RILD    : IsAttachApnChanged: Failed to load attach apn
08-06 09:04:55.349  3116  3194 E RILD    : RefreshAttachApn: read Attach Apn from DB failed
08-06 09:04:55.349  3116  3194 E RILD    : RefreshAttachApn: delete prev retry event and set retry after 500ms

08-06 09:15:41.147  3122  3477 E RILD    : [G] RX: (M)NET_CMD (S)NET_PLMN_LIST (T)RESP l:44 m:a1 a:a1 [ 06 02 35 30 35 30 32 23 21 23 CB 02 35 30 35 30 32 23 04 00 00 04 35 30 35 30 31 23 21 4E 20 04 35 30 35 30 31 23 04 00 00 04 35 30 35 30 33 23 04 00 00 04 35 30 35 30 33 23 21 15 4F ]
08-06 09:15:41.148  3122  3207 E RILD    : GLNET-MGR(3): evt(105)
08-06 09:15:41.148  3122  3207 E RILD    : NET-MGR: EVENT_AVAILABLE_NETWORKS_DONE
08-06 09:15:41.151  3122  3207 E RILC    : getAvailableNetworksResponse Invalid response: NULL
08-06 09:15:41.152  3122  3207 E RILD    : DoGetAcqOrder():
08-06 09:15:41.152  3122  3207 E RILD    : IpcProtocol41::IpcTxNetGetAcquisitionOrder()
08-06 09:15:41.152  3122  3207 E RILD    : [G] TX: (M)NET_CMD (S)NET_ACQ_ORDER (T)GET l:7 m:a2 a:00 [ ]
08-06 09:15:41.155  3122  3477 E RILD    : [G] RX: (M)NET_CMD (S)NET_ACQ_ORDER (T)RESP l:8 m:00 a:a2 [ 04 ]
08-06 09:15:41.155  3122  3207 E RILD    : GLNET-MGR(3): evt(133)
08-06 09:15:41.155  3122  3207 E RILD    : NET-MGR: EVENT_GET_ACQ_ORDER_DONE
08-06 09:15:41.155  3122  3207 E RILD    : OnGetAcqOrderDone(): AcqOrder=4
08-06 09:15:41.156  3822  3913 D RILJ    : [0230]< QUERY_AVAILABLE_NETWORKS  error 66 [SUB0]
08-06 09:15:41.157  3822  3913 D RilRequest: [0230]< QUERY_AVAILABLE_NETWORKS  error: com.android.internal.telephony.CommandException: INVALID_RESPONSE ret=[]
08-06 09:15:41.201  3122  3207 E RILD    : LDC-MGR(9): evt(10002)

I know it talks about APN information, and I know the information it's showing in the log is legitimate. Hopefully this helps.

EDIT: I'm attaching the logcat but it's not showing on the post?
EDIT: Is there some kind of anti-logcat upload thing going on? I can upload basically anything EXCEPT this particular logcat file
EDIT: I put it in a RAR
 

Attachments

  • logcat-radio.rar
    31.8 KB · Views: 5
Last edited:

bluess57

Senior Member
EDIT: Is there some kind of anti-logcat upload thing going on? I can upload basically anything EXCEPT this particular logcat file
probably a file size limit. Host it somewhere, pm the link and I can take a look.

Unfortunately I'm awaiting tablet parts in the mail to get my SM-T805 back up and working (Prob a week or 2 away).
RILD logs everything as error category, so it's not easy to figure out if messages are real errors or not.
 

Bigdrago

Senior Member
Jun 28, 2010
138
6
It's about spreading heat from the CPU to the battery, frame and rear lid...

Sorry, I would rather not open the device now, because I also put some thermal paste under the rear lid... It is simple to explain without pictures. I used adhesive aluminium tape, about 5cm width. It is thin, so multiple layers are needed, say 5. You can't miss the processor - it's the hot metal plate to the North of the battery (near the camera). Lay the strips of the tape from the processor across the whole battery. Removing the lid is a bit fiddly - start from the USB port and use a couple of thin plastic implements (cards, guitar picks or collar tabs).

I've noticed that the kernel does not support HMP (8 cores simultaneously), although EXYNOS5420 is able to do that, and Linux for Odroid XU3 (EXYNOS5422) supports it beautifully. Sadly, one can't have it all...

Like I did
 

emad-tvk

Member
Apr 6, 2017
12
1
is everything fine with chagalllte version? internet data, network operators, sms, phone calls and ...
I'm still using android 6 on sm-t805 chagalllte, if someone is using this rom please report if everything is working properly about simcard, data and lte
 

Jed D`Lagged

Senior Member
Jan 4, 2006
124
3
Sydney
Jed.delagged.net
is everything fine with chagalllte version? internet data, network operators, sms, phone calls and ...
I'm still using android 6 on sm-t805 chagalllte, if someone is using this rom please report if everything is working properly about simcard, data and lte
With the testing that I did, it seems like everything works except mobile data. Phonecalls, SMS, bluetooth with some fiddling. But mobile data does not seem to work, and we could not change network operators.

Hopefully bluess57 is able to fix the Mobile Data issue.
 
  • Like
Reactions: emad-tvk

Maltoo7497

Member
Aug 19, 2022
10
0
With the testing that I did, it seems like everything works except mobile data. Phonecalls, SMS, bluetooth with some fiddling. But mobile data does not seem to work, and we could not change network operators.

Hopefully bluess57 is able to fix the Mobile Data issue.
I confirm, only mobile data doesn't work. Is there a fix for this problem??
SM-T805
 

bluess57

Senior Member
Ok, my build can be downloaded here :- SM-T805
All the usual disclaimers ... Use at your own risk, I'm not responsibile if you brick your device.
Mobile data LTE works for me.

Video recording is broken still.
I don't know if anything else is broken.

Do a backup (if wanted) & WIPE FIRST.

This is a Selinux enforcing build.
The .apks are signed.
I don't use Magisk so don't ask me.

I will/can provide OTA updates for short period (whilst the Azure subscription lasts)
 

Top Liked Posts