[ROM][UNOFFICIAL][10] LineageOS 17.1 for Samsung Galaxy Tab S (SM-T700, SM-T705, SM-T800, SM-T800, SM-P600)

Search This thread

Maltoo7497

Member
Aug 19, 2022
10
0
Mobile data LTE works for me.

Video recording is broken still.
Mobile data working, but the icon LTE didn't work for me. 3G and 2G icon working normally.
Video recording not working. But it's important that LTE works big thx bluess57!

GridArt_20220824_111005726.jpg
 

bluess57

Senior Member
Yep I don't get LTE signal strength bars in the icon ,not all that important I guess.
I've found a lead on why video recording is broken, so I may be able to fix.
BTW the ondemand kernel governor seems a little laggy, so I'm trying the interactive governor instead, and I'll look at a deathly kernel build.
 

Angeloftheafterlife

Senior Member
Jan 21, 2012
52
13
Samsung Galaxy Tab S
hey there!

I am having a strange issue with wifi on the latest builds for my SM-T800, both lineage and crdroid (lineage-17.1-20220619-UNOFFICIAL-chagallwifi). On stock android 6.0.1, everything works fine.

When I flash the lineage build, it boots properly, but is unable to connect to my mesh wifi network (saying to check the password and try again).

I have tried disabling the 5Ghz band to see if that was the cause, but I'm still getting the same issue. I know I have the password correct. Has anyone else seen this?

edit: after some more testing, this appears to be happening on minashokry's Lineage 17.1 builds as well, which makes me think this is a lineage issue. Lineage 15.1 and below works fine.

edit2: after even more testing, it looks like it has something to do with the security algo the network uses. I've tried "WPA2-PSK [AES]" and "WPA2-PSK + WPA-PSK[TKIP]" with no luck. If the network is unsecured, it works fine.
 
Last edited:

pacc

Senior Member
Jul 16, 2008
426
109
hey there!

I am having a strange issue with wifi on the latest builds for my SM-T800, both lineage and crdroid (lineage-17.1-20220619-UNOFFICIAL-chagallwifi). On stock android 6.0.1, everything works fine.

When I flash the lineage build, it boots properly, but is unable to connect to my mesh wifi network (saying to check the password and try again).

I have tried disabling the 5Ghz band to see if that was the cause, but I'm still getting the same issue. I know I have the password correct. Has anyone else seen this?

edit: after some more testing, this appears to be happening on minashokry's Lineage 17.1 builds as well, which makes me think this is a lineage issue. Lineage 15.1 and below works fine.
Many bugs are from component drivers, some are broken (ex. Mic on T700), some unstable and some work, unfortunately it seems to me this won't change any time soon.
 

hit321

Member
Mar 28, 2012
13
2
PoA
Xiaomi Mi 9 SE
Hello friends,

I tried to update my old Samsung Galaxy Tab S devices with the latest Android 10 (Lineage 17.1). I would like to make the build available for you guys as well.

Special thanks to the teams at Exynos5420 and LineageOS for the sources.

Devices:
  1. Samsung Galaxy Tab S 8.4 WiFi (klimtwifi) SM-T700
  2. Samsung Galaxy Tab S 8.4 LTE (klimtlte) SM-T705
  3. Samsung Galaxy Tab S 10.5 LTE (chagalllte) SM-T805
  4. Samsung Galaxy Tab S 10.5 WiFI (chagallwifi) SM-800
  5. Samsung Galaxy Note 10.1 Edition 2014 (n1awifi) SM-P600

I will create new builds from time to time.

Installation:
1. Flash latest official Samsung Firmware with ODIN
2. Flash latest TWRP Recovery https://twrp.me/Devices/Samsung/
3. Wipe Data
4. Install ROM.ZIP with TWRP https://luis-builds.de/downloads/lineageos/misc/
5. Install latest GApps with TWRP (ARM/Android10) https://opengapps.org/
6. Reboot and Enjoy
7. Optional: Install Magisk

Download the file:
https://luis-builds.de/downloads/lineageos/misc/

Sources:
https://github.com/LineageOS (LineageOS 17.1)
https://github.com/exynos5420/ (Kernel, Device, Vendor)

Greetings Frank
First of all thank you all to help revive this device. I was using LOS 14.1. But now I’m confused. Can you give me a tip or something to install the "1. Flash latest official Samsung Firmware with ODIN"?
I tried search but I didn’t found many things. 1) How can I check/how can I know if I have the last Firmware? 2) In this site [https://sfirmware.com/samsung-sm-t800/] I found 2 files, one with the signal BIN (whats mean)? T800XXS1CSA1 (SM-T800_1_20190220102753_6o8ddzq9r1_fac.zip) (BIN one) and T800XXS1CSA1 (SM-T800_1_20190207222540_qevr4ncexn.zip)
Which one should I use?
I’m using now the "crDroidAndroid-10.0-20220618-chagallwifi-v6.27-LuisROM" with "the open_gapps-arm-10.0-pico-20220215" and it seems running very well.

EDIT:
I correct the name of the files. The both zip files are from 2019.
 
Last edited:

runekock

Senior Member
Apr 24, 2012
971
536
Samsung Galaxy Tab S
Nexus 6
1) How can I check/how can I know if I have the last Firmware? 2) In this site [https://sfirmware.com/samsung-sm-t800/] I found 2 files, one with the signal BIN (whats mean)? T800XXS1CSA1 (SM-T800_1_20161024215254_nwah9je03t_fac.zip) (BIN one) and T800XXU1CPHD (SM-T800_1_20190207222540_qevr4ncexn.zip)
Which one should I use?
1) If your Tab has been running Samsung firmware, then you're probably already at the latest version. Generally, any Samsung marshmallow version is okay. This is just a precaution for those that haven't kept up with Samsung's updates, or have flashed weird stuff previously.

2) https://www.sammobile.com/firmwares/ has a good list of what Samsung has published for the different countries (not that the country really matters for a T800). Normally, I'd expect a CS version to be later than a CP one, so maybe your site has the dates wrong.
 

hit321

Member
Mar 28, 2012
13
2
PoA
Xiaomi Mi 9 SE
1) If your Tab has been running Samsung firmware, then you're probably already at the latest version. Generally, any Samsung marshmallow version is okay. This is just a precaution for those that haven't kept up with Samsung's updates, or have flashed weird stuff previously.

2) https://www.sammobile.com/firmwares/ has a good list of what Samsung has published for the different countries (not that the country really matters for a T800). Normally, I'd expect a CS version to be later than a CP one, so maybe your site has the dates wrong.
In the same files BIN and Normal theres files with name CS.
In the BIN file (T800XXS1CSA1 (SM-T800_1_20190220102753_6o8ddzq9r1_fac) there’s:
1. AP_T800XXS1CSA1_CL9407408_QB21693310_REV00_user_low_ship.tar.md5
2. BL_T800XXS1CSA1_CL9407408_QB21693310_REV00_user_low_ship.tar.md5
3. CSC_ZTO_T800ZTO1CSA1_CL9407408_QB21731972_REV00_user_low_noship.tar.md5
In the "normal" file (T800XXU1CPHD (SM-T800_1_20190207222540_qevr4ncexn.zip)) there’s a single file:
1. T800XXS1CSA1_T800ZTO1CSA1_HOME.tar.md5

So which one should I use and how to install it?
 

Hakosuka11

Senior Member
Aug 17, 2012
124
27
Buenos Aires
Hello, I have flashed T700 CRrom in my brothers Tab S like two months ago. He is having heating issues. He don't uses social media and don't games neither, just some web browsing and YouTube. Anyone had overheating and poor battery issue? Any recommendations? If some kind folk can gimme advice I will thank you.

PS: The ROM was flashed with minimal Gapps. And like I said is only using Kiwi Browser and YouTube.
 

bluess57

Senior Member
Hello, I have flashed T700 CRrom in my brothers Tab S like two months ago. He is having heating issues. He don't uses social media and don't games neither, just some web browsing and YouTube. Anyone had overheating and poor battery issue? Any recommendations? If some kind folk can gimme advice I will thank you.

PS: The ROM was flashed with minimal Gapps. And like I said is only using Kiwi Browser and YouTube.
read:-> https://forum.xda-developers.com/t/mod-thermal-mod-of-t805-t800-boost-performance-by-150.3993917/
 

Paul1235

Member
Sep 7, 2022
7
0
First of all thank you for the ROM.
I wanted to ask you to consider the charging time in the next build,it takes so long to charge the tablet.
And there is no sync between real charging time and the text that shows the remain hours of that.
When I use the tablet while charging even in little use (looking to my SMS), percentage remains the same and extends charging time.
Dear bluess57, I think it's better you modify the luis ROM because it seems to be stronger and stabler than the lineageOS,it consumes less battery and it's more powerful,but mobile data and video recording are not working and battery charging time takes so long.
I hope your next ROM becomes the best build ever that has no bugs for this lovely tablet.
And again thank you for your efforts and good luck genius bluess57.
👏👍🤗
 
Last edited:

bluess57

Senior Member
Would this build work for the 705 also? I think they are interchangeable... Pls confirm.

And thank you!
 

SpiderKen

Member
Sep 8, 2022
13
0
I am using Samsung Tab S 10.5 version T805C, after running the rom lineage-17.1-20220619-UNOFFICIAL-chagallllte.zip , mobile data does not work (in the original rom it works normally), video recording not work.

T805C is the China region, when I install the original rom, it can't install gapps (error 70 even when I use opengapp 6.0 pico). Is there any way to fix this problem?

I just want orginal rom with gapps (because I need mobile data work)
 

bluess57

Senior Member
I am using Samsung Tab S 10.5 version T805C, after running the rom lineage-17.1-20220619-UNOFFICIAL-chagallllte.zip , mobile data does not work (in the original rom it works normally), video recording not work.

T805C is the China region, when I install the original rom, it can't install gapps (error 70 even when I use opengapp 6.0 pico). Is there any way to fix this problem?

I just want orginal rom with gapps (because I need mobile data work)
Are you using twrp to install opengapps?
Its not something I can fix

Did you try ?
SM-T805 Chagallte :-
lineage-17.1-20220821-UNOFFICIAL-chagalllte.zip

Need a logcat of radio to see if there is something obvious going wrong with LTE
 

SpiderKen

Member
Sep 8, 2022
13
0
Of course, i tried SM-T805 Chagallte : lineage-17.1-20220821-UNOFFICIAL-chagallllte.zip.
But LTE and video recording still not working.
 

Top Liked Posts