[ROM][UNOFFICIAL][10][Q]LineageOS 17.1 for z5c (suzuran)

Search This thread

tarukanav

Member
Jan 9, 2021
14
0
I have the same issue, wiped everything and formatted data in TWRP, still gets stuck on animation after bootloop. After first boot it goes as far as to Android setup Welcome sign, I press Start, then the circle starts going saying "Just a sec", then reboots and gets stuck on Lineage animation. Also tried with no GAPPS, no Magisk, still the same. Did anyone find a solution?

P.S. Model is E5823.
by the way flashing this https://forum.xda-developers.com/t/rom-11-x-havoc-os-4-2-unofficial-suzuran.4249577/ using the same method boots fine but fingerprint sensor and SafetyNet do not work there so this thread's ROM would be much better
that happens to me too but its not related to rom , just press back and try again , my problem propably was maybe new magisk , not sure.
 

tarukanav

Member
Jan 9, 2021
14
0
Also without gaps i cant seem to add my google account always keep saing acc name or pass is wrong , strangely tho google security keeps telling that somebody (me ) is trung to login. when i install gaps all works perfect.
 

plusminus_

Senior Member
  • The tracks in albums in the default Music app and the third-party app I use are in a strange order, when sorted by track number, like this, which is annoying.
Tiny update! From these comments it appears that this is caused by a bug in MediaStore in Android 10 (it is also happening to me on a different phone running LOS 17.1 and in different music players), which is fixed in Android 11.

(I personally worked around it by sorting by file name instead of track number.)
 
  • Like
Reactions: Berni-0815

Berni-0815

Senior Member
Sep 22, 2016
1,922
1,631
Germany
From other device trees: "Our device doesn't simply support sae."
For los18 I had to set a variable in the WifiOverlay configuration that prevents the device from automatically try to upgrade to WPA3 and stays in WPA2 mode: Klick
Los17 doesn't have this configuration at all.
 

Ermann123

Member
Apr 30, 2020
45
4
Since the one update before the recent one, after updating (ok, without immediataly reinstalling Magisk) the Microg configuration gets smashed, so it is necessary to re-register each app manually.
 

Berni-0815

Senior Member
Sep 22, 2016
1,922
1,631
Germany
I don't maintain third party apps like microG at all. I'm not responsible for any issues when someone is using microG.
USB-OTG is indeed only working when plugged in at boot time. I can't change this behaviour.
I'm sorry.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    New version out; see 1st post.
    • Android security patch level: 5 April 2021
    1
    But with that you're setting SELinux to permissive and to my understanding this is a security leak!
    Or do I misunderstand you?
    1
    Yes. i suggested 2 options; second option is for fix that issue without setting selinux to permissive.
    That's the best way.
    why do you need any "selinux permissiver zip" ?
    last build / 22,1 magisk.,. ,,. no problem
    Because some users reported not working sensors. And that can be fixed by two ways:
    1. Flash latest stock ROM before flashing LineageOS ROM
    2. Set SELinux to permissive.
    The first way is the best.
    1
    New version out; see 1st post.
    • Minor bug fixes
    1
    You don't need to update at all if your installed ROM is working without any problems.
    The new version contains only minor fixes; nothing serious.
  • 45
    Hi all:

    Here is a LineageOS 17.1 ROM for Z5 compact (suzuran).

    Download 2021-04-21

    This is a 7z archive with the zip'ed rom and the md5 file in it. Please unpack this archive, copy the included two files somewhere to your device, reboot into twrp and flash this zip file. Enable zip verification and md5sum checking.

    Kernel sources
    Tree sources

    Features:

    • OS Version: 10.0 (Q)
    • Kernel: Linux 3.10
    • Kernel 3.10.108
    • New: Android security patch level: 5 April 2021
    • Using sony blob's from stock version 32.4.A.1.54
    • Memory issues finally fixed!
    • Battery consumption significantly reduced! For further reduction, please follow these instructions.
    • Google Pay does not give an error when starting the app. This does not mean, that payment is working. I can't test it, because I don't use this feature at all. Please report if it's working or not.
    • Updated aptX encoder blobs.
    • P2P-Crashes fixed.

    Important informations:
    • You should be familiar with general installation of custom ROMs.
    • Required for installation: TWRP 3.2.1 (pick the version from 2018-02-23!!!) There is a version 3.2.3 out there, but with that version I had problems to restore my backups. 3.2.1 is just working perfect for me!
      OR use my self built TWRP-version 3.5.2!
    • This ROM needs a clean install, old /data may cause problems!
    • This ROM is NOT pre-rooted.

    Working:
    • Phone calls (see attached screenshot)
    • SMS
    • WiFi
    • Bluetooth
    • Fingerprint
    • GPS
    • Location services
    • Headset
    • LiveDisplay (see attached screenshots)
    • Enforced SELinux support (see attached screenshot)
    • Torch
    • German app AusweisApp2 working (see this post)
    • Offline charging
    • Notification LED
    • GApps (pick this version: ARM64, 10.0, pico [tested])
    • Camera; both built-in camera (Snap) and 3-rd party camera apps.
      Snap may be a little bit laggy, please use 3-rd party camera app instead; for example OpenCamera. If you're running into errors, please report.
    • FM-Radio
    • SafetyNet test passed successfully
    These things are NOT working (or badly working):
    • Encryption
    • Camera focus at low distances.
    • Streaming (mirroring)
    • Payment
    Maybe some more things are not working.

    If you have problems with GApps:
    Sometimes the SetupWizard of GApps crashes on and on. Then you have to boot into TWRP, mount system, and go into terminal, where you have to delete SetupWizard (see screenshots):
    Code:
    cd /system/system/priv-app
    rm -rf SetupWizard
    Reboot.


    Use this rom at your own risk! It comes without any warranty! I'm not responsible for any damage! If you don't agree with that, don't try to flash this rom in any way.

    Benefits:

    • Added F-Droid and UnifiedNLP! If you don't want this, simply de-install it.
    • I've set maximum speaker volume to a higher value.
    • I've increased microphone gain.
    • I've changed the microfone gain to avoid echo in phone calls.
    Changelog

    Troubleshooting:


    • If you're running into an error, please search in this thread if this error is already posted, before you post it again!
      If not, I need a LOG to see what went wrong. Without a LOG I can't help you!
      A LOG can be fetched by connecting the device with an USB cable to your PC and then by typing these commands line by line:
      Code:
      adb root
      adb shell logcat -b all -d > logcat
      Send my this LOG file via PM.
    • If you stuck in a bootloop you can fetch a LOG with this trick:
      • Press the power button and the volume up button together until the device shuts down.
      • HOLD the power button.
      • Release the volume up button and press the volume down button immediately after releasing the volmue up button.
      • The device should start into TWRP recovery.
      • Tap on "Advanced", then on "Terminal" and enter these commands line by line:
        Code:
        cd sys/fs/pstore
        cp * /sdcard
      • Send me the copied file(s), if any, via PM.
    10
    New version out; see 1st post.
    New: Phone calls and SMS fully working! :good:
    9
    New version out; see 1st post.
    • Android security patch level: 5 August 2020
    • Offline charging working
    • Notification LED working
    8
    New version out; see 1st post. Some memory improvements. Device runs smooth without GApps and keeps quite cool and battery loss is low.
    But with GApps the device becomes unusable after quite short time.
    7
    New version out; see 1st post.
    • Battery consumption significantly reduced! For further reduction, please follow these instructions.
    • Google Pay does not give an error when starting the app. This does not mean, that payment is working. I can't test it, because I don't use this feature at all. Please report if it's working or not.
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone