• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][11.0][ I9300 ][ LineageOS 18.1 ][BETA][TREBLELIZED]

Search This thread
Mar 20, 2021
28
25
Samsung Galaxy S III I9300
Hi, I tested out the ROM, and it was very smooth, smooth meaning it was the smoothest Alpha stage ROM I've ever tested out. Not sure if this can be counted as a bug, but I'll still write it below. I can select the ringtone and hear the preview for the first 2 times or so, but when I try to select again, the pop-up freezes and then shows the message, "Sounds isn't responding". This gets fixed when restarting, so I'm fine with that. And another thing, did you remove the touchscreen gestures for compatibility issues or are you still working on it? Or is it not working just for me? I have posted a screen record below. Other than all this, this is one of the best ROMs I've ever tried. I really appreciate you for your hardwork :) .

 
  • Like
Reactions: rodrotterdam

html6405

Recognized Developer
Jan 15, 2016
1,381
1,253
Hi, I tested out the ROM, and it was very smooth, smooth meaning it was the smoothest Alpha stage ROM I've ever tested out. Not sure if this can be counted as a bug, but I'll still write it below. I can select the ringtone and hear the preview for the first 2 times or so, but when I try to select again, the pop-up freezes and then shows the message, "Sounds isn't responding"
Hi,
really strange, I've tested this and it does not happen on my device, I can select the ringtone as many times as I want.
And another thing, did you remove the touchscreen gestures for compatibility issues or are you still working on it? Or is it not working just for me?
This happens because this device does not has an stylus.
The touchscreen gestures are explicit for the note models.
 
  • Like
Reactions: rodrotterdam

event_horizontal

New member
Sep 12, 2021
1
0
(Long time visitor, first time poster)

Hey, sorry to butt in...but I think this is really cool.

I have an I9300. I replaced the battery a while back, but there's absolutely nothing wrong with the phone: it's still going strong.

To be able to use it as a daily driver with L18.1 would be pretty awesome!

@html6405 Thank you for all your work!
 

rootlessuser

Member
Sep 12, 2021
7
1
New user here. First, thanks to the developer for his work. I tried this ROM both on my tablet Note 10.1 GT-N8010 and my Galaxy S3. On my N8010, it works flawlessly. I could even believe that I have a device made for Android 11.

On my Galaxy S3, there is no way to use it. Apps will crash, Trebuchet will crash, and system UI will crash.

I have no idea why such differences between the two devices as they are both from 2012. I tried several times on the Galaxy S3. Even reinstalled the stock ROM to be sure that no other leftovers from other ROMs would interfere and flashed Lineage 18 again.

I thought that maybe the problem came from the launcher as Trebuchet crashed, so I tried a few launchers. At first, it seemed to work, but after a short while, maybe an hour, the problem came back. Apps stopped to work, launcher too and I was unable to do anything with my phone as it was just hanging.

I even suspected a hardware problem as I recently changed the motherboard (the motherboard was bought second hand and got changed in a repair shop), but after having installed again an Android 7.1 ROM, the phone works more or less normally. It slows down from time to time but no error like apps, launcher or UI system stopped.

If anyone has an idea why my phone behaves so poorly with Lineage 18 and have some idea of what I could try to fix that, it would be welcomed.
 
Last edited:

adfree

Senior Member
Jun 14, 2008
9,279
5,476
Thanx for this ROM.

So I can play around with Android 11...


Seems harder as my Android 4 skills... o_O

Code:
[ril.product_code]: [GT-I9300RWXDBT]

[ro.product.model]: [GT-I9300]

[ro.product.odm.model]: [GT-I9300]


[ro.product.product.model]: [GT-I9300]

[ro.product.system.model]: [GT-I9300]

[ro.product.system_ext.model]: [GT-I9300]

[ro.product.vendor.model]: [GT-I9300]


[ro.vendor.product.model]: [GT-I9300]


Please need help to change Model Name... for some stupid tests...


Thanx in advance.

Best Regards

Edit 1.

Maybe I do many things wrong...

Code:
settings get global device_name


settings put global device_name SM-R860

But still under About... Model shows GT-I9300...

Edit 2.

Maybe Magisk and Modules could help me...


Edit 3.

Cool. This work for me.

MagiskHide Props Config
 
Last edited:
  • Like
Reactions: html6405

HANA.BICO

Member
Aug 29, 2019
10
2
These rom consume a lot of ram , Is there a way to remove some programs or stop of the programs working in background or make it more intelligent to reduce the consumption of ram and battery !!??
please help in next update
thanks
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Great news, after a long time creating hack's to boot up the modem on the exynos4 LTE devices (also the i9305),
    I've finally managed to get the RIL working, this mean's that I will create an own I9305 build soon.
    2
    Thanks for reporting this, @wilk.gr76! That encouraged me to try it on an i9305.

    It's working pretty well on the i9305. I had expected more glitches. Installation (clean flash) of build 20210922 went smoothly - just modified updater-script to add i9305 to the assert command (could also just delete the assert command). My observations:
    • Performance: seems OK - isn't noticeably different from same device with 16.0. [this device has 2G memory, and I haven't installed Gapps or MicroG]
    • Random reboots: I haven't seen any yet (two days since install).
    • Wifi is working, but can't establish a connection to a dual-band 2.4GHz+5GHz network, even with random MAC addressing turned on. It connects to single-band 2.4GHz or 5GHz networks, and the connection is stable with either. Note: with LOS 16.0, it could connect to the dual-band network.
    • Hardware navbar (including Home) not working. On-screen navbar works.
    • Sensors: DevCheck app can see all sensors, and they all seem active.
    • GPS isn't working.
    • Screen rotation isn't working properly - the angle of rotation is 180 degrees out (display is upside-down) if allowed to rotate.
    • Camera works with the camera app that came with this build, except that the image orientation is 180 degrees out.
    • Audio: speaker works, but max volume is low.
    • Bluetooth is working with a BT headset and BT speaker. Volume range is reasonable.
    • Telephony: I haven't tested yet.
    Hi,
    thx for your testing's, but I wan't to mention that this build is not meant to be installed on an i9305.
    There are some hardware specific differences, this is why GPS, RIL couldn't work on this device.
    The screen rotation is normal on my i9300, so I'm not sure if this is also a hardware specific aspect.

    But I'm working on the LTE devices, it's not really easy to fix the RIL on Android 11, but I've already made some progress and hope to fix it completely soon.
    Than I could publish an own build for the i9305.
    2
    Hi,
    thx for your testing's, but I wan't to mention that this build is not meant to be installed on an i9305.
    There are some hardware specific differences, this is why GPS, RIL couldn't work on this device.
    The screen rotation is normal on my i9300, so I'm not sure if this is also a hardware specific aspect.

    But I'm working on the LTE devices, it's not really easy to fix the RIL on Android 11, but I've already made some progress and hope to fix it completely soon.
    Than I could publish an own build for the i9305.
    Thanks @html6405. I tried it just to see what would happen. I'm not depending on the device as a daily drive, so if it had not worked at all it wouldn't have mattered. I am surprised at what does work, and not at all surprised by the bits that don't.

    And thank you for working on a build for the LTE devices! If you need testers for the i9305, I'd be willing to volunteer. ;)
    2

    I9305 users, have fun :)
    1
    I flashed this to my SHV-E210S, which is identical to the i9305, with the addition of the digital TV tuner. I'm very impressed to see this running, here's what I found:

    • I did have to modify the install script to get it to install on this model. If you do want to add 'official' support in the installer, the model code is `m3`.
    • It wouldn't connect to a WiFi network, and it showed up as having the MAC address of 00:00:00:00:00:00. Setting it to use randomised MAC addresses allows it to connect. I did upgrade from an Android 9 rom (clean install), so I'm guessing something happened with that and that it would be fine if I had installed stock ROM first.
    • Camera doesn't seem to work. OpenCamera does recognise the camera, but doesn't seem to be able to open it or use the flash. Not a big deal, as it is an S3.
    • Adaptive brightness works fine
    • No random restarts yet.
    It is a little on the slow side, but it is like a decade old now, so I really can't fault it for that. Haven't run into any other issues and I'm very impressed that this is running on the S3.
    Thanks for reporting this, @wilk.gr76! That encouraged me to try it on an i9305.

    It's working pretty well on the i9305. I had expected more glitches. Installation (clean flash) of build 20210922 went smoothly - just modified updater-script to add i9305 to the assert command (could also just delete the assert command). My observations:
    • Performance: seems OK - isn't noticeably different from same device with 16.0. [this device has 2G memory, and I haven't installed Gapps or MicroG]
    • Random reboots: I haven't seen any yet (two days since install).
    • Wifi is working, but can't establish a connection to a dual-band 2.4GHz+5GHz network, even with random MAC addressing turned on. It connects to single-band 2.4GHz or 5GHz networks, and the connection is stable with either. Note: with LOS 16.0, it could connect to the dual-band network.
    • Hardware navbar (including Home) not working. On-screen navbar works.
    • Sensors: DevCheck app can see all sensors, and they all seem active.
    • GPS isn't working.
    • Screen rotation isn't working properly - the angle of rotation is 180 degrees out (display is upside-down) if allowed to rotate.
    • Camera works with the camera app that came with this build, except that the image orientation is 180 degrees out.
    • Audio: speaker works, but max volume is low.
    • Bluetooth is working with a BT headset and BT speaker. Volume range is reasonable.
    • Telephony: I haven't tested yet.
  • 27
    Code:
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    *
    */

    Hi,

    here you can find my version of LineageOS 18.1 for our Samsung Galaxy S3 (I9300).
    At first I want to thank @rINanDO, @ChronoMonochrome for all your work.
    This Rom is based on https://forum.xda-developers.com/t/rom-unofficial-11-0-0-lineageos-18-0-alpha-20-10-2020.4179303/ .

    This is a early beta build, so don't install it if you want a stable rom and don't report my already listed bugs!


    Here you can see how far everything is working for now.

    • Boot
    • Audio
    • Bluetooth
    • Graphics
    • Cameras
    • Sensors
    • Wifi
    • GPS
    • USB
    • Video playback (HW/SW)
    • Tethering via USB
    • RIL
    • OTA-Updates
    • GSI flash
    • NFC
    • much more...
    • Tethering via WIFI and Bluetooth
    • BT headset call
    • Screen Cast, Chromecast did work, Samsung TV not
    • Random reboots
    • SD-Card can't be formatted as a storage expansion, your device will crash
    • Maybe more
    You could use a gps.conf from https://app.box.com/s/w57s1v1n3hie7l5lk28i for your location and replace /vendor/etc/gps.conf.
    Or you try GPS Server Optimizer app for a faster 3D fix.
    For both methods you need root rights.
    If you are going to use Gapps,
    here you can download them:
    Open Gapps
    For the others, you can use microG in future.

    Do you like my work?
    Than you can simply hit the thanks button and consider to spend me a coffee or a beer,
    I'm doing this in my free time and it also costs a lot of money to buy hardware.

    donate

    XDA:DevDB Information
    [ROM][11.x][I9300][BETA] LineageOS 18.1, ROM for the Samsung Galaxy S3

    Contributors

    html6405
    Source Code: https://github.com/html6405

    ROM OS Version: 11.x R
    ROM Kernel: Linux 3.x
    ROM Firmware Required: TWRP 3.5.2
    Based On: LineageOS
    Selinux: permissive, this only makes sense as soon the ROM is stable.

    Version Information
    Status:
    Beta

    Created 2021-07-05
    Last Updated 2021-09-22
    7
    Update 06.07.2021:
    • Changed menu button behavior to better support AOSP
    • WIFI and RIL fixes for AOSP
    Now you can flash your first GSI on your Samsung Galaxy SIII.

    This update will be available via AFH and OTA.
    7
    Update 24.07.2021:
    Via OTA and AFH.
    6
    Update 15.07.2021:
    • Included permissions for signature spoofing
    • Disabled wallpaper zoom ( lowered max scale for the wallpaper when it's zoomed in )
    • Inserted parted for repartitioning, this will be necessary for most GSI's in future (just a single process, it will persist).
    • Inserted a fixgsi script, with this we are able to boot up most android 11 GSI's (but most of them will not be stable without my patches).
    Via OTA and AFH.
    5
    Great news, after a long time creating hack's to boot up the modem on the exynos4 LTE devices (also the i9305),
    I've finally managed to get the RIL working, this mean's that I will create an own I9305 build soon.