• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][11] Havoc-OS 4.x [tblte][trlte][trlteduos]

Search This thread

t5ghc5k97qc7

New member
Oct 9, 2017
4
1
This isn't going to be much help but I had this exact issue and can't for the life of me remember what eventually fixed it...

As you say, there was definitely no 'revoke' option and I remember trying every solution I could find until something eventually worked. I'll try wracking my brains to remember what it was because there definitely was a fix.

The solution was to manually generate private und public keys with older windows version of adb (1.0.39) and then copy public key to /data/misc/adb . The latest adb version 1.0.41 (I don't know if there is a newer one) won't generate public keys, and ssh-keygen didn't generate correct public key. Maybe this could be helpful to someone.
I hope devs will fix this and enable usual popup dialog which asks for authorization, and put revoke option as well. Thanks.
 
  • Like
Reactions: tbmmbt

maxed4901

Senior Member
Aug 11, 2013
1,001
380
Male'
www.blogger.com
Hey guys. My daughters phone broke during covid 😥 and gave her my old N910G. Funny thing happened though. OOT I forgot the model. On the back cover it said N910C and I flashed TWRP latest for the that version and bricked it. Then kept it and she was 😔 😢 for 3 days laugh 😆 I revived it. Found out the version was N910G and the "G" was kinda faded off to a "C". 😄 😭

But the thing was, I gave life to the note 4!and its awesome! This ROM is great so far.thanks @ripee

Any telegram group for this device group? I think it deserves one.

I've got a small problem too. I am trying to setup Google parental controls on it but the digital well being opens and says 'something went wrong try again later' all apps are updated to latest version as well.. and also, can't enable app installation from unknown sources. Can't click it. I've disabled Google play protect but nothing.
 
how do you update security patch?
and is there option to migrate data new flashing new version
I use three different possibilities for updates:
1. very dirty flash (new version on top of old)
2. normal dirty (just wiping "system" prior to flashing)
3. clean (wiping everything + "data format")
Just try one after another.
Obviously always make a backup with TWRP to SD.
On a clean flash it mostly workes restoring "data" afterwards.
 

3v3rdim

Senior Member
Jun 18, 2018
163
38
Suva
with clean install after a while i allways get when opening phone ringtone
settings keep stopping?

This happened to me the first time i flashed as well..to me it seems the rom doesn't have the in-built sound/ringtone picker app....but that's fine, there's a way around that...

Edit:
It turns out I was wrong on that account as the ROM does contain the soundpicker app in it....the problem lies with Gapps...Google made some changes with their pico gapps package..My sincere apology to everybody here for my mistake....

1. if you flashed pico gapps then use an app eg Zedge app to change ringtone & notification sound (Please Note: also google removed "sound picker" app from the pico gapps package...I think....coz it seems its not there anymore. hmmm)

2. flash nano gapps package (the first time)...it has the sound picker app by google.....this assumes,of course you are okay with having extra google apps and stuff. You have more options regarding ringtones and notification (as in individual contacts will have their own ringtones/notifications sounds)

Edit:
There is also 3rd way ...via contribution from Senior Dev @TheHitMan its called "Bitgapps"
( google it plz).

hope this helps....there might be other solutions Im not aware of...good luck
 
Last edited:
  • Like
Reactions: MusTangAu
not possible export everything apps data etc and when flashing new clean image import again?
Didn't say export but backup.
That meant using the backup option for "Data" partiton in TWRP.
Obviously that can't be done before it's installed.
 
Last edited:
  • Like
Reactions: whynot2018

speedspeed1

Member
Jan 2, 2021
24
0
Didn't say export but backup.
That meant using the backup option for "Data" partiton in TWRP.
Obviously that can't be done before it's installed.

i still dont understand
lets say i am on other image
and i wanna export my data and then import in this version

ps. i tried titanium works good but then i cannot get multiple spaces imported
they get imported but the multiple spaces inside are not there after import

so what other options i have to restore all my data?
 
@speedspeed1 what's the state of your N910? anyhow?
In my #144 I referred to your question about updating patches and new versions of the same ROM.
That might work with apps like Migrate, Titanium and in some cases with restoring TWRP Data backup.
I only test/use the latter.
Hopping from LOS to Havoc, crDroid or......? I always do by clean flashing and only use app-internal storing of settings.
 

tbmmbt

Senior Member
Aug 2, 2017
51
20
Just a curious enquiry but is this ROM likely to get further updates? I really appreciate the work that's gone into it and although it's working quite well there's just a few too many issues for me to use it as my main ROM so I've gone back to Havoc 2 (Android 9) for now.

I know we're lucky to have a working Android 10 on this old device but just wondering about possibility of future updates - thank you!
 

badboyblue

Senior Member
Mar 25, 2012
406
59
I freshly installed the latest Havoc v3.12, but USB debugging doesn't work. My PC won't get authorised as ADB device (it works with other ROMs). There is also no "Revoke USB debugging authorizations" option in "Developer Options" available at all. I checked /data/misc/adb folder, it stays empty. Any idea ? Thanks!
I also tried to manually generate public key from private key and copy it to /data/misc/adb but that didn't work either.
I got the same problem with all the Android 10, the problem rose after flashing Magisk, and I found this solution: Flash Magisk 20.3 insteal of 20.4. For some reason Magisk 20.4 will make the phone not showing Android debugging options when connect to PC.
 

Akramadel

New member
Dec 23, 2017
4
0
30
Please anyone help me 😥
I cannot sign into google account .. i tried before to wipe and clear cache both of ( google play google play services and google account manager ) without advantage .... Anyone tell me how to fix this solution please .. I cannot use my phone after install this awesome rom 😥😥😥
Screenshot_20210119-213340.jpg
 

jhford

Senior Member
I have an N910T (T-Mobile) running this ROM. Everything works fine except when I reboot the OS can't seem to connect to the SIM and not only does.is the LTE/4G icon absent from the status bar but also there is no dial tone. My solution has been to reboot, sometimes several times. until the OS recognizes the SIM. My wife wants my phone as a backup, but she will go nuts if she has no dial tone after rebooting. Is there a solution within this ROM, or do I have to switch ROMs and which ROM would you guys suggest?
Thanks
 

Top Liked Posts

  • There are no posts matching your filters.
  • 17
    Havoc_Logo.png

    About.png

    Havoc-OS 4.x is based on AOSP, inspired by Google Pixel.
    Has a refined Material Design 2 UI crafted by @SKULSHADY.
    Many useful features that provide a smooth premium experience.
    Just flash and enjoy...

    Screenshots.png


    Team.png

    Founder & Lead Developer:
    SKULSHADY (Anushek Prasal)

    DevOPS & Scaling:
    Irongfly (Sukeerat Singh Goindi)

    Support Team:
    theo.j22 (Tushar Jain)

    Donate.png

    If you like my work and would like to support this project then please consider donating.

    Links.png

    SM-N910F/G/P/R4/T/T3/V/W8: trlte
    SM-N9100ZC/ZH/6W/9W: trlteduos
    SM-N915F/G/P/R4/T/W8: tblte
    About Us: https://havoc-os.com
    Recovery: https://twrp.me
    Magisk: https://github.com/topjohnwu/Magisk/releases
    Telegram Support Group: https://t.me/havocofficial
    Telegram Announcements Channel: https://t.me/Havoc_OS
    Code Review: https://review.havoc-os.com

    Installation.png

    1. Download the ROM, GApps (Optional), Magisk (Optional) from the links above.
    2. Wipe System, Data, Dalvik, Cache.
    3. Flash the ROM, GApps (Optional), Magisk (Optional).
    4. Reboot and Enjoy.

    Credits.png

    LineageOS (https://github.com/LineageOS)
    Crdroid (https://github.com/crdroidandroid)
    Pixel Experience (https://github.com/PixelExperience)
    And all the other Developers, Testers, Donators and Users.

    Source.png


    XDA:DevDB Information
    Havoc-OS 4.x, ROM for the Samsung Galaxy Note 4

    Contributors
    ripee, ghostwheel, logosA, khalvat, afaneh92, ananjaser1211, tripLr
    ROM OS Version: Android 11
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: Stock Marshmallow for your variant.

    Version Information
    Status:
    Stable
    Current Stable Version: 11
    Stable Release Date: 2021-07-27

    Created 2020-06-07
    Last Updated 2021-07-27​
    7
    Reserved

    Bugs

    - 5GHz hotspot gives an error message when attempting to turn it on.
    - If NFC is turned off when the phone is booted up, the NFC toggle will freeze in the "off" position and remain off until the phone is rebooted. If NFC is turned on when the phone is booted up, the NFC toggle will function properly to turn NFC both on and off. However, if NFC is turned off and the phone is rebooted, this bug will reappear.
    - The 2nd SIM slot does not work in any trlteduos variant.
    - VoLTE is not supported, and will not be supported for the foreseeable future.
    - You tell us!​
    5
    New builds running now, as per feedback regarding problems with media playback in a couple apps. Havoc has merged some stuff that may be related to this, since the last builds only a couple days ago.
    4
    For some reason I ain't able to Download. It's Says I have exceeded download quota.
    Can someone upload the latest to 'MediaFire" thx

    If i had a dollar for everytime some posted about the google download quota.....

    Fix (requires a google account):

    1) Make sure youre signe dnto your google account
    2) Select ROM file
    3) Make copy
    5) Download copy

    In more depth:

    https://www.ghacks.net/2017/04/14/fix-google-drive-sorry-you-cant-view-or-download-this-file-error/

    Not A ROM issue folks.....
    3
    For some reason I ain't able to Download. It's Says I have exceeded download quota.
    Can someone upload the latest to 'MediaFire" thx

    Either log into your google account, or add the folder for your variant to your own account and all future builds will appear in it without using up your account's space.

    This is how Google Drive functions, nothing to do with the rom, XDA, or user error on my part or yours. The reason why I use Google Drive is because it is relatively easy to automate the upload process in my build scripts, and premium storage is quite cheap. Not to mention that, having added the variant folder to your account, you can very easily see new builds right in the app on your phone and download them as if they were OTA updates.