[ROM][UNOFFICIAL][11] LineageOS 18.1 for Fire TV Stick Lite/3rd gen (sheldon/p)

Search This thread

Chazy12

Senior Member
Nov 6, 2013
177
45
Last edited:
  • Like
Reactions: ChriMo

ChriMo

Senior Member
Oct 13, 2014
473
124
May I ask if and which games work well when having only the Fire remote as controller?
I tried to install 5-6 but all failed.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    I have a 4k(mantis), will I brick it if I flash LineageOS? Problem I have is, Amazon told me not to return the 4k and I cannot register. I am not sure if e-fuse tripped by Amazon yet. Kamakiri worked, have access to TWRP through adb (no OTG)

    I just want to know if I twrp install Lineage, will I brick it forever? Ubuntu maybe? Anything I can do without Amazon registration?

    Edit: looking at the mantis info from this thread github, mantis is also a mt8695. So it might not work, but it should not brick it, right? Meaning if it doesn't flash, I can flash pre-root stock ROM back? I am feeling brave. Wish me luck.

    Thanks
    1
    Hi everyone. So im new in this. I did all the steps and it worked. If someone can help me with my next questions.
    1--- I installed some apk files and some don't show up, any way to fix this?
    2--- Can i change the theme or launcher and how?
    3--- Im using a remote with a dongle, the back button dont work, is that normal? It works on other devices.
    Thx 😉
    1- wierd, I did you check the apps instead of just the home drawer? Also sound alike a problem which was in the first release of this rom. Have you updated to the latest version?
    2.search this thread
    3.use the standard one... Lol
    1
    Hi thx for ur answers.
    1- i can see the installed apps in the settings or with a other app. Its just inconvenient, i tought because this a lineage rom this wouldn't happen.
    2- i looked allot of pages and didn't find it. I will look again.
    3- i dont have the standard remote but i just bought one. 🥳
    Using latest release and the same problem with apps I sideloaded. Apps installed through google Play show up.
    1
    Start your fire stick with a pc with fireISO. In Lineage OS under setting select buttons and check if advanced reboot is activate. Then go to reboot and select recovery. It will reboot in TWRP. Mount the memory, copy the zip rom file into the fire stick and flash it with twrp ( 1- adb devices 2- adb shell 3- twrp install rom.zip 4- exit 5- adb reboot)
    I did it, thanks for your availability.
  • 38
    1607247455067-png.5435845

    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.
    Instructions:
    • Reboot to TWRP
    • Wipe data, system (/system_root) and cache
    • Flash the ROM and the GApps
    • Reboot and enjoy!
    Downloads:
    Reporting Bugs:
    • DO NOT Report bugs if you're running a custom kernel, you installed Xposed or you installed Magisk
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    Known issues:
    • Dolby Digital Plus™ E-AC-3
    • Netflix
    Notes:
    • SELinux is in Permissive mode
    • The ROM supports both sheldon (Fire TV Stick Lite) and sheldonp (Fire TV Stick 3rd gen)
    • Do not ask for ETAs
    How do i...
    • Unlock and install TWRP?
    • Go back to the original/stock ROM?
      • Download the stock update.bin (sheldon | sheldonp) and flash it using TWRP
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Contributors
    R0rt1z2, k4y0z, t0x1cSH, diegocr
    Source Code: https://github.com/mt8695
    Kernel source: https://github.com/mt8695/android_kernel_amazon_mt8695
    16
    🕑 New build is up: 2022-05-05
    • Fixed the advanced audio distribution profile (A2DP)​
    • Fixed the remote disconnecting after rebooting​
    • Fixed the 3rd gen remote app-button(s)​
    • Fixed the microphone (assistant works now)​
    • Fixed Netflix not showing up in the Play Store​
    • Added support for newer remote revisions​
    • Enabled memory optimizations for low-RAM devices​
    • Enabled the XPAD kernel driver (xbox gamepads)​
    • Enabled exFAT/NTFS support in the kernel​
    • Switched to sheldonp blobs​
    NOTE: Netflix still has memory management issues (video playback), I'm still trying to figure out a way to fix this.

    NOTE: As for the assistant button, it works but in a bit weird way; do not release the button when you stop talking, keep it pressed even if you have finished (the assistant will notice once you stop talking).
    13
    New build is up: 2022-09-25
    • Fixed the low-volume issue.
    • Switched to SMLK (Simple Low Memory Killer).
    • Added support for UKSM (Ultra Kernel Samepage Merging)
    • Fixed support for NTFS external devices.
    • Fixed (minor) YouTube video flickering(s).
    • Fixed crashes when trying to use (some) streaming TV apps.
    • Disabled some non-ATV features (leftovers).
    12
    Just a reminder to make clear that development for this device is not dead. As soon as I can, I will resume development.​
    12
    when will the next compilation be ready approximately?

    Thanks for the work you do!
    I don't know. I'm currently on vacation so I'm away from the PC for some days, but I guess it'll be released during the next week.