[ROM][UNOFFICIAL][11][R]LineageOS 18.1 for z5c (suzuran)

Search This thread

Pantoffel_Cruise

New member
Jun 10, 2022
1
1
Hi, first of all great job Bernie, this is an awesome ROM as it made the z5c of my gf pretty smooth.
I just upgraded it to the newest version with the hope that microphone gain would finally be on an adequate level.
Sadly, it is still very low gain, so that you really have to shout into the mic in order to get heard by the person on the other side on speach recordings on whatsapp.
Is there a way to fix that issue? Maybe I can also try to fix it if you can give me a little bit of advise on how to do it.
Best Greetings from Hanover!
 
  • Like
Reactions: 1ggn3

groggog

Member
Jun 16, 2016
6
4
Sadly, it is still very low gain, so that you really have to shout into the mic in order to get heard by the person on the other side on speach recordings on whatsapp.
Is this using bluetooth? I get good volumes through the phone mic and wired headsets but whenever I use a bluetooth headset (I've tried several) the people on the other end complain that they can't hear me. I've thought it was maybe a problem with the bluetooth devices but maybe it's not...

I'm on the 20210810.211238 update though if that makes any difference.
 

1ggn3

Senior Member
Oct 26, 2020
61
12
Has anyone had issues with using the lineageOS calendar app?

org.lineageos.etar (version 11)

When I try to create an event, there's a lag of up to 20 seconds with any action (keyboard popping up, activating a different text field, entering event name, modifying time/date, ...).

Message pops up "Calendar isn't responding .. Close app / Wait"

I'm using DAVx5 and have a calendar account synced.

I'm still on the los 20220413 build.

logcat doesn't look like there's anything interesting/useful.
Same here. I installed the regular Etar from F-Droid, and that one works fine. Also disabled the LOS Etar, so it won't be in the way.
 
Last edited:
  • Like
Reactions: bvlgvr

Berni-0815

Senior Member
Sep 22, 2016
2,269
2,049
Germany
Sony Xperia Z5 Compact
New version out; see 1st post.
  • Android security patch level: 5 June 2022
 

Attachments

  • Screenshot_20220624-110726_Package_installer.png
    Screenshot_20220624-110726_Package_installer.png
    75.4 KB · Views: 14

petefoth

Senior Member
Last edited:

laakssim

Member
Jul 22, 2022
14
1
Tried the 20220715.142108 ROM and found two things not working; microphone volume level on Whatsapp and FB messenger calls is way too low, and video recording on any camera app was very laggy at first and then stopped working completely (this I noticed on the default camera app, Open Camera and Instagram app). The default camera app gives an error "Could not start media recorder", the others just won't record video.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    New version out; see 1st post.
    • Android security patch level: 5 August 2022
  • 36
    Hi all:

    Here is a LineageOS 18.1 ROM for Z5 compact (suzuran).

    Download 2022-08-15

    This is a 7z archive with the zip'ed ROM and the md5 file in it. Please unpack this archive, copy the included two files somewhere to your device, reboot into TWRP and flash this zip file. Enable md5sum checking. The zip file itself is not signed, so you have to disable zip verification.

    Kernel sources
    Tree sources

    Features:

    • OS Version: 11 (R)
    • Kernel: Linux 3.10
    • Kernel 3.10.108
    • New: Android security patch level: 5 August 2022
    • Using Sony blob's from stock version 32.4.A.1.54

    Important informations:
    • You should be familiar with general installation of custom ROMs.
    • Required for installation: TWRP 3.2.1 (pick the version from 2018-02-23!!!)
      OR use my self built TWRP-version 3.6.2!
    • This ROM needs a clean install, old /data may cause problems!
    • This ROM is NOT pre-rooted. For rooting you can use Magisk.
    • It is highly recommended that your device is running (or HAS RUN in the past!) the latest stock ROM from Sony (32.4.A.1.54) before flashing this ROM.
      Otherwise the baseband files may not match.
    Working:
    • Audio
    • Bluetooth
    • Camera; both built-in camera (Snap) and 3-rd party camera apps.
      Camera2 may be a little bit laggy, please use 3-rd party camera app instead; for example OpenCamera. If you're running into errors, please report.
    • Enforced SELinux support
    • Fingerprint
    • FM-Radio (maybe it needs a few restarts before it's working)
    • GApps (MindTheGApps 11 arm64)
    • German app AusweisApp2
    • GPS
    • Headset
    • Hotspot
    • LiveDisplay
    • Location services
    • Notifications
    • Notification LED
    • Offline charging
    • Phone calls
    • Reboot into recovery and bootloader
    • SafetyNet test passed successfully
    • Signed build
    • SMS
    • Sounds
    • Torch
    • WiFi
    • ...please tell me...
    These things are NOT working (or badly working):
    • Encryption
    • Camera focus at low distances.
    • Payment
    • Streaming (mirroring)
    • VoLTE
    Maybe some more things are not working.Please tell me...

    Use this ROM at your own risk! It comes without any warranty! I'm not responsible for any damage! If you don't agree with that, don't try to flash this ROM in any way.

    Benefits:

    • Added Aurora-Store, F-Droid and UnifiedNLP! If you don't want this, simply de-install it.
    • I've set maximum speaker volume to a higher value.
    • I've increased microphone gain.
    • I've changed the microfone gain to avoid echo in phone calls.
    Changelog

    Troubleshooting:


    • If you're running into an error, please search in this thread if this error is already posted, before you post it again!
      If not, I need a LOG to see what went wrong. Without a LOG I can't help you!
      A LOG can be fetched by connecting the device with an USB cable to your PC and then by typing these commands line by line:
      Code:
      adb root
      adb shell logcat -b all -d > logcat
      Send my this LOG file via PM.
    • If you think this could be a SELinux related issue, please try to set the device to permissive mode first.
      If the issue is gone, I need the policy file too (plus LOG). Fetch it by typing this line in a terminal:
      Code:
      adb pull /sys/fs/selinux/policy
    • If you stuck in a bootloop you can fetch a LOG with this trick:
      • Press the power button and the volume up button together until the device shuts down.
      • HOLD the power button.
      • Release the volume up button and press the volume down button immediately after releasing the volmue up button.
      • The device should start into TWRP recovery.
      • Tap on "Advanced", then on "Terminal" and enter these commands line by line:
        Code:
        cd sys/fs/pstore
        cp * /sdcard
      • Send me the copied file(s), if any, via PM.


    One last request:

    Please, do not ask about problems for which my ROM is not responsible.
    From now on I will only react to problems that I can reproduce and that are caused by my ROM.


    I'm sorry for that, but I'm developing this ROM in my spare time and I still have a normal life.
    12
    New version out; see 1st post.
    • Kernel improvements
    12
    New version out; see 1st post.
    • Android security patch level: 1 October 2021
    • DynamicsProcessing library implemented
    12
    I finally managed to increase the write speed on /sdcard partition dramatically:
    Code:
    suzuran:/ $ dd if=/dev/zero of=/sdcard/output count=65536
    65536+0 records in
    65536+0 records out
    33554432 bytes (32 M) copied, 0.706444 s, 45 M/s
    suzuran:/ $
    New version out; see 1st post.
    10
    New version out; see 1st post.
    • Android security patch level: 5 May 2021