[ROM][UNOFFICIAL][11][R]LineageOS 18.1 for z5c (suzuran)

Search This thread


New member
Feb 11, 2023
so, i flashed this rom onto my phone (in hopes to main it again) but the phone does not read my sim card. can i fix that somehow? the last time i tried it on another rom the card worked.


New member
Feb 11, 2023
idk why but i don't have that one available in flash tool, do i have to try another tool or am i screwed


  • Unbenannt.png
    89.5 KB · Views: 38


New member
Feb 11, 2023
And then click on the XPeriFirm Button. Then select E5832, choose your region and download the firmware. The FlashTool then creates the flashable ROM.
so how would i flash this then, flashing with flash mode doesn't see it (and the button inside the app does nothing for me, had to download xperifirm manualy to get it)


Senior Member
Sep 22, 2016
Sony Xperia Z5 Compact
and the button inside the app does nothing for me
I understand! That's a bug in newer versions of the FlashTool. The XperiFirm execution file is missing! Dunno why...
You have to copy XperiFirm(32/64).exe from your downloaded XperiFirm archive (depending on your Windows Version) as XperiFirm.exe (without 32 or 64) to:
or the equivalent in microsoft naming conventions:
  • Like
Reactions: Scalpos

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    New version out; see 1st post.
    • Android security patch level: 5 May 2023
  • 36
    Hi all:

    Here is a LineageOS 18.1 ROM for Z5 compact (suzuran).

    New: ROM with microG apk's included in priv-app:
    Download 2023-05-15

    Please pay attention: microG can't coexist with GApps! So decide whether to install microG OR GApps!

    If you want to remove microG, enter these command line by line in a terminal:
    adb root
    adb shell
    mount -o remount,rw /
    rm /system/priv-app/DroidGuard/DroidGuard.apk
    rm /system/priv-app/FakeStore/FakeStore.apk
    rm /system/priv-app/GmsCore/GmsCore.apk
    rm /system/priv-app/GsfProxy/GsfProxy.apk


    Or flash this microG-remover.

    This is a 7z archive with the zip'ed ROM and the md5 file in it. Please unpack this archive, copy the included two files somewhere to your device, reboot into TWRP and flash this zip file. Enable md5sum checking. The zip file itself is not signed, so you have to disable zip verification.

    Kernel sources
    Tree sources


    • OS Version: 11 (R)
    • Kernel: Linux 3.10
    • Kernel 3.10.108
    • New: Android security patch level: 5 May 2023
    • Using Sony blob's from stock version 32.4.A.1.54

    Important informations:
    • You should be familiar with general installation of custom ROMs.
    • Required for installation: TWRP 3.2.1 (pick the version from 2018-02-23!!!)
      OR use my self built TWRP-version 3.6.2!
    • This ROM needs a clean install, old /data may cause problems!
    • This ROM is NOT pre-rooted. For rooting you can use Magisk.
    • It is highly recommended that your device is running (or HAS RUN in the past!) the latest stock ROM from Sony (32.4.A.1.54) before flashing this ROM.
      Otherwise the baseband files may not match.
    • Audio
    • Bluetooth
    • Camera (with the restriction to 8 MP); both built-in camera (Snap) and 3-rd party camera apps.
      Camera2 may be a little bit laggy, please use 3-rd party camera app instead; for example OpenCamera. If you're running into errors, please report.
    • Enforced SELinux support
    • Fingerprint
    • FM-Radio (maybe it needs a few restarts before it's working)
    • GApps (MindTheGApps 11 arm64)
    • German app AusweisApp2
    • GPS
    • Headset
    • Hotspot
    • LiveDisplay
    • Location services
    • Notifications
    • Notification LED
    • Offline charging
    • Phone calls
    • Reboot into recovery and bootloader
    • SafetyNet test passed successfully
    • Signed build
    • SMS
    • Sounds
    • Torch
    • WiFi
    • ...please tell me...
    These things are NOT (or badly) working:
    • Encryption
    • Camera focus at low distances.
    • Payment
    • Streaming (mirroring)
    • VoLTE
    Maybe some more things are not working.Please tell me...

    Use this ROM at your own risk! It comes without any warranty! I'm not responsible for any damage! If you don't agree with that, don't try to flash this ROM in any way.


    • Added Aurora-Store, F-Droid and UnifiedNLP! If you don't want this, simply de-install it.
    • I've set maximum speaker volume to a higher value.
    • I've increased microphone gain.
    • I've changed the microfone gain to avoid echo in phone calls.


    • If you're running into an error, please search in this thread if this error is already posted, before you post it again!
      If not, I need a LOG to see what went wrong. Without a LOG I can't help you!
      A LOG can be fetched by connecting the device with an USB cable to your PC and then by typing these commands line by line:
      adb root
      adb shell logcat -b all -d > logcat
      Send my this LOG file via PM.
    • If you think this could be a SELinux related issue, please try to set the device to permissive mode first.
      If the issue is gone, I need the policy file too (plus LOG). Fetch it by typing this line in a terminal:
      adb pull /sys/fs/selinux/policy
    • If you stuck in a bootloop you can fetch a LOG with this trick:
      • Press the power button and the volume up button together until the device shuts down.
      • HOLD the power button.
      • Release the volume up button and press the volume down button immediately after releasing the volmue up button.
      • The device should start into TWRP recovery.
      • Tap on "Advanced", then on "Terminal" and enter these commands line by line:
        cd sys/fs/pstore
        cp * /sdcard
      • Send me the copied file(s), if any, via PM.

    One last request:

    Please, do not ask about problems for which my ROM is not responsible.
    From now on I will only react to problems that I can reproduce and that are caused by my ROM.

    I'm sorry for that, but I'm developing this ROM in my spare time and I still have a normal life.
    New version out; see 1st post.
    • Kernel improvements
    New version out; see 1st post.
    • Android security patch level: 1 October 2021
    • DynamicsProcessing library implemented
    I finally managed to increase the write speed on /sdcard partition dramatically:
    suzuran:/ $ dd if=/dev/zero of=/sdcard/output count=65536
    65536+0 records in
    65536+0 records out
    33554432 bytes (32 M) copied, 0.706444 s, 45 M/s
    suzuran:/ $
    New version out; see 1st post.
    New version out; see 1st post.
    • Android security patch level: 5 May 2021