[ROM][UNOFFICIAL][11][R]LineageOS 18 for z5c (suzuran)[BETA]

Search This thread

TheVan28

Senior Member
some 3p camera apps i tried didn't work (nokia camera); in the ones that did, quality, focus and response were all problematic.

I found any camera app that supports the full 23 mpx resolutions to have no problems with focus and quality, they behave just like they did on lineage 14.
But the viewfinder doesen't work, you can still take pictures though.
 

da_julez

Member
May 9, 2016
7
0
Aachen
Hi Bernie, flashed your rom yesterday, of course clean install, during night time it went out of Power and shuted itself down, then i tried to charge it, but it won't. Plugged it into my pc, but still no sign of live. Also its not shown in device manager. Absolutely unresponsive. Will try to boot it up in fastboot mode now.
 

Berni-0815

Senior Member
Sep 22, 2016
1,968
1,680
Germany
Hi Bernie, flashed your rom yesterday, of course clean install, during night time it went out of Power and shuted itself down
As I wrote, the battery consumption is very high and the ROM is not intended to be a daily driver!
then i tried to charge it, but it won't. Plugged it into my pc, but still no sign of live.
Try to press power and volume up buttons at the same time. That normally powers down the device.
After that it should be rechargable.
 

da_julez

Member
May 9, 2016
7
0
Aachen
Hi, I tried this as well, but still no sign of life. No Fastboot mode, no flash mode. Nothing. Don't know, what to do now, my pc and my laptop also won't recognize the device. No LED when connected to the charger.No reaction when trying to reboot, nether with PWR+VOL UP nor when i press the reboot button beneath the microsd slot. Seems to me that it's bricked. That Doesn't mean that I blame your Rom for this, but maybe you know an solution to this behavior.
 

DevelLevel

Senior Member
  • Hi, I tried this as well, but still no sign of life. No Fastboot mode, no flash mode. Nothing. Don't know, what to do now, my pc and my laptop also won't recognize the device. No LED when connected to the charger.No reaction when trying to reboot, nether with PWR+VOL UP nor when i press the reboot button beneath the microsd slot. Seems to me that it's bricked. That Doesn't mean that I blame your Rom for this, but maybe you know an solution to this behavior.
    Have you tried leaving it charging overnight?
     

    DevelLevel

    Senior Member
  • It looks like the battery is deeply discharged.
    I really don't know how you can reanimate such a battery, because I don't know enough of the inner mechanisms of Li-Ion accumulators.
    Maybe you have to replace it.
    Sometimes leaving a Li-po battery charging for an extended period of time may be able to get it to work. (That's what I know about Li-po not Li-Ion)
    But it may have gotten some damage by having it at such an low voltage for so long. The battery may have worn a bit.
     

    1ggn3

    Member
    Oct 26, 2020
    49
    10
    I had that a couple of times, I could always fix it by just letting the phone charge for some time (maybe around 15-20 minutes). If it doesn't work, maybe try different chargers, I've had good results with the usb3 port of my notebook.

    I think the battery has an over-discharge protection, which shuts the phone down and prevents it from starting again. The battery needs to go above a certain voltage to allow the phone to start again.

    If that doesn't work, well.. I somehow fried the charging functionality of my first Z5C back in 2016, but I got another one under warranty. I believe it was because of a faulty charger, though.
     

    YamiYukiSenpai

    Senior Member
    Oct 7, 2014
    305
    35
    Couple of weird things I noticed:
    * F-Droid wouldn't install apps automatically, even if I try to install F-Droid Privileged Extension
    * I installed YouTube Vanced via root using Vanced Manager, and the app keeps uninstalling every reboot.

    Anyone experienced the same thing?

    Sent from my Xperia Z5 Compact using XDA Labs
     

    Berni-0815

    Senior Member
    Sep 22, 2016
    1,968
    1,680
    Germany
    New version out; see 1st post.
    • Some fixes.
    • If you have problems with something that's working on my device, you have to present LOGs. Otherwise I can't help you!
     

    Berni-0815

    Senior Member
    Sep 22, 2016
    1,968
    1,680
    Germany
    This new version is running very stable and the battery lasts quite long, if you are NOT using bluetooth! Using bluetooth consumes a lot of battery and the device is getting quite warm.
     

    darkangel32

    Member
    Mar 26, 2020
    49
    5
    I have a unlocked Z5 compact running stock 7.1.1. Any good guide for installing this rom?
    Also, should i go for this one or lineageOS 17 (android11), that you also made?

    I have rooted and unlocked bootloader on a Z ultra, using twrp before. For this Z5c i dont need it rooted, just install this rom.

    Thanks in advance.
     

    Berni-0815

    Senior Member
    Sep 22, 2016
    1,968
    1,680
    Germany
    I have a unlocked Z5 compact running stock 7.1.1. Any good guide for installing this rom?
    I don't know one. In short:
    1. Flash the latest stock firmware (32.4.A.1.54) and start it once; very important
    2. Flash TWRP (see 1st post)
    3. Wipe /data, dalvik and cache
    4. Install the ROM
    Also, should i go for this one or lineageOS 17 (android11), that you also made?
    Los17 (Android 10) is a little bit more stable.

    For this Z5c i dont need it rooted, just install this rom.
    Both are not pre-rooted.
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 3
      Hi all:

      Here is a LineageOS 18.0 BETA ROM for Z5 compact (suzuran).

      Download 2020-12-11

      This is a 7z archive with the zip'ed ROM and the md5 file in it. Please unpack this archive, copy the included two files somewhere to your device, reboot into TWRP and flash this zip file. Enable zip verification and md5sum checking.

      Kernel sources
      Tree sources

      Features:

      • OS Version: 11 (R)
      • Kernel: Linux 3.10
      • Kernel 3.10.108
      • New: Android security patch level: 5 November 2020 (see attached screenshot)
      • Using Sony blob's from stock version 32.4.A.1.54

      Important informations:
      • You should be familiar with general installation of custom ROMs.
      • Required for installation: TWRP 3.2.1 (pick the version from 2018-02-23!!!) There is a version 3.2.3 out there, but with that version I had problems to restore my backups. 3.2.1 is just working perfect for me!
      • This ROM needs a clean install, old /data may cause problems!
      • This ROM is NOT pre-rooted. For rooting you can use Magisk.

      Working:
      • Phone calls
      • SMS
      • WiFi
      • Bluetooth
      • Fingerprint
      • GPS
      • Location services
      • Headset
      • LiveDisplay
      • Enforced SELinux support
      • Torch
      • German app AusweisApp2
      • Offline charging
      • Notification LED
      • NikGapps (pick this version: ARM64, 11.0, core [tested]).
      • New: Camera; both built-in camera (Camera2) and 3-rd party camera apps.
        Camera2 may be a little bit laggy, please use 3-rd party camera app instead; for example OpenCamera. If you're running into errors, please report.
      • New: FM-Radio (maybe it needs a few restarts before it's working)

      These things are NOT working:
      • Restart into recovery
      Maybe some more things are not working.

      Use this ROM at your own risk! It comes without any warranty! I'm not responsible for any damage! If you don't agree with that, don't try to flash this ROM in any way.

      Benefits:

      • Added F-Droid and UnifiedNLP! If you don't want this, simply de-install it.
      • I've set maximum speaker volume to a higher value.
      • I've increased microphone gain.
      • I've changed the microfone gain to avoid echo in phone calls.
      2
      LineageOS 18.1 is out! ---> Klick
      1
      I was just gonna ask if you're planning on jumping on it after seeing the post from XDA. Am I assuming that whatever you did to make the camera work on LineageOS 17 didn't work with 18?