[ROM][UNOFFICIAL][12.1][DISCONTINUED] LineageOS 19.1 for Galaxy Tab S6 Lite Exynos

Search This thread

lol69 96

May 14, 2022
Can anybody tell how to flash recovery using odin?
Heimdall doesn't seem to work..throwing error 12

Please anybody reply asap....do we need to change recovery.img to .yar and apply it to AP or what?

Guys I am moving to college tomorrow and will not come back for atleast 3 months
Last edited by a moderator:
Can anybody tell how to flash recovery using odin?
Heimdall doesn't seem to work..throwing error 12

Please anybody reply asap....do we need to change recovery.img to .yar and apply it to AP or what?

Guys I am moving to college tomorrow and will not come back for atleast 3 months
Rename the image to recovery.img and using 7zip save it as recovery.tar
Then flash with Odin under AP. Make sure to disable auto reboot 1st.

lol69 96

May 14, 2022
No worries....flashed it using odin and the rom is almost perfect except some ui problem.
But I loved it so much


May 29, 2009
No worries....flashed it using odin and the rom is almost perfect except some ui problem.
But I loved it so much
Can you please post each and every step you followed? I am getting the same error 12 with heimdall

Update: got it working. For anyone like me who's stuck, here's what you need to do-
Use Hemidall 1.4.2. Interestingly it is not available for windows. So I used Ubuntu. And that's it. Installed the lineage recovery. Then it was just about following the instructions in OP. One more thing, while side loading it will ask if you want to continue on phone at 47%. Remember to click yes.
Last edited:


Senior Member
May 25, 2017

I made the dirty upgrade from 18.1 to 19.1, and everything works without trouble. :)

At first did install LOS19.1-Recovery using "heimdall".

Reboot into new LOS-Recovery, did sideload LOS19.1, reboot again into Recovery(!) and did install OpenGapps-12.1-nano-UNOFFICIAL, reboot into system.

No Dalvik/Cache clean was necessary. Just only root was lost.

So reboot from the running system again into Recovery, and sideloaded Lygisk(Magisk)-23.015.

Reboot again, and even all previous Magisk-Modules are working.

Just only the Trebuchet-configuration was lost.

And I found one issue:
When in lock screen, there is just only a gray area at the bottom instead of the charging info. Maybe that is fixable in one of the next builds?


  • Like
Reactions: dagustl
Thanks for sharing your steps and experiences.
Can you report something about if the s-pen works properly ?
I´m going to flash LOS on my S6 lite which i bought some months ago,
because i also use Lineage and CyanogenMod since 10 years on my other devices.
Oh, and btw maybe it´s better to switch from this unofficial to the other thread for the official LOS19.1 since it´s released since some weeks. ;)
And ofcourse big thanks to all the dev´s ! 🙇‍♂️
Last edited:


Jan 2, 2018
I did a dirty flash from 18.1 to 19.1. Had to configure my widgets new and had to install another keyboard, because keyboard AOSP does only show one row at the top of the screen and I was not able to use it.

What I did in short:

boot it into download mode
  • heimdall flash AD12 firmware (without --UP_PARAM)
  • heimdall flash los19.1 recovery
reboot into recovery
  • adb sideload los19.1


Senior Member
Sep 17, 2008
São Paulo
Please don't take me wrongly, I'm not demanding updates. Just curious regarding the August update, over the last months we got bad used to having multiple releases per month with always synced source code, secure updates, and kernel updates, and this month passed away without anything. Did something change @Linux4? people on this unofficial should move to the official release channel?


Senior Member
Apr 30, 2011
I just installed this on my tablet and everything seems to work fine except for the Home, Back and Current Apps buttons. How to get them on the screen? I'm old and grouchy and want to do things the old fashioned way. ;) It would be fine if they only appeared when swiping up from the bottom.

edit: Never mind. I found how to switch from gesture to 3 button navigation.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 15

    LineageOS is a free, community built, aftermarket firmware distribution of Android 12, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    • Follow the instructions here


    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • DO NOT Report bugs if you're using TWRP
    • DO NOT Report bugs while having Magisk installed (especially with Zygisk enabled)
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Telegram group

    Linux4, programminghoch10
    Source Code: https://github.com/LineageOS
    Kernel source: https://github.com/LineageOS/android_kernel_samsung_gta4xl/tree/lineage-19.1
    • Any R based firmware installed on your device.

    Pre-Install Instructions

    Warning: The following instructions will unlock the bootloader and wipe all userdata on the device.

    1. Connect the device to a Wi-Fi network.
    2. Enable Developer Options by pressing the “Build Number” option in the “Settings” app within the “About” menu
      • From within the Developer options menu, enable OEM unlock.
    3. Power off the device, and boot it into download mode:
      • With the device powered off, hold Volume Down + Volume Up and connect USB cable to PC.
      • Now, click the button that the onscren instructions coorelate to “Continue” and/or “Unlock Bootloader”.
    4. Your device will reboot, you may now unplug the USB cable from your device.
    5. The device will demand you format userdata, please follow the onscreen instructions to do so.
    6. Run through Android Setup skipping everything you can, then connect the device to a Wi-Fi network.
    7. Re-enable Development settings by clicking the “Build Number” option 10 times, in the “Settings” app within the “About” menu, and verify that “OEM Unlock” is still enabled in the “Developer options” menu.

    Installing LineageOS for the first time
    1. Flash lineage recovery
      Only the provided lineage recovery will be supported,
      using TWRP might result in a possible data loss!!

      If using Odin rename the lineage recovery image for your model to recovery.img and add it to a .tar archive using e.g 7zip.
      If using Heimdall use: heimdall flash --RECOVERY recovery.img --no-reboot
    2. Boot lineage recovery
      IMPORTANT: Do not boot into system again before booting recovery, or system will restore stock recovery!
      If using Odin untick auto-reboot before flashing.
      After flashing reboot by pressing Volume Down and Power for approximately 7 seconds,
      immediately hold Volume Up and Power to boot recovery
      IMPORTANT: As of OneUI 3 your device needs to be connected to a PC via USB cable in order to be able to
      boot recovery via Volume Up, Bixby and Power.
    3. Factory reset using Factory reset -> Format data/factory reset
      Warning: Unlike TWRP this will also erase internal storage!
    4. Sideload LineageOS by enabling sideload via Apply Update -> Apply from ADB
      Then run adb sideload <path to your lineage.zip> on your PC
    5. Sideload GApps and magisk by repeating above step
      with their zip/apk

    I strongly recommend to use Lygisk instead,
    which is a fork of Magisk that aims to improve support for devices with FBE that can't (and shouldn't anyways!) decrypt userdata in recovery,
    this will also fix OTAs getting stuck while having installed Magisk.

    • SELinux enforcing
    • AES-256-XTS FBE encryption
    • Latest Linux 4.14.x kernel

    Known issues
    • LineageOS specific features like livedisplay (for now)
    • You tell me
    https://lineage.linux4.de/fw_update/gta4xlwifi.html doesn't require you to go back to full stock (the firmware is downloaded automatically using samloader in gh actions in my repo here: https://github.com/Linux4/firmware-update)