[ROM][UNOFFICIAL][12 L][ I9305 ][ LineageOS 19.1 ][BETA]

Search This thread

lpedia

Senior Member
Sep 18, 2020
313
156
Samsung Galaxy Tab S2
HTC 10
@html6405, this ROM is amazing! I've just re-installed using the latest version (I had gone back to 18.1 after trying out the first 19.0 for a while), gappsless and not rooted, and it's very smooth.

SIM was detected during LOS setup and is working. The only issue I've seen so far is that on-screen navigation doesn't seem to be working. If I select that, there are no nav buttons visible. 😕 But hardware nav is working fine, so that's not a show-stopper.

I particularly like that LOS setup automatically selected the correct timezone! 👍
 

EeeK

Senior Member
Nov 30, 2011
132
7
Update 04.04.2022:
  • Re-Implemented and enabled boeffla sound
Just use the Updator to upgrade to this version and installed MindTheGapps but playstore kinda stuck with a "You're offline" message.

Want to reflash again, does the Updator export update works?
 

djyahoo

Member
Jul 10, 2021
26
7
Hi and thank you again for your work, @html6405 !
I am testing this ROM on my second i9305 (yes, I own two S3 LTE :) ).
Yet it seems to be quite good but... I have got some problems with Play Store. Any attempt to install an app stucks on "pending" message. Tried to wipe app cache, to wipe "cache / dalvik cache" from twrp, but it is a fail.
Of course my network connection is OK - browser is functional.

I installed MindTheGapps (MindTheGapps-12.1.0-arm-20220416_173154), should I try a previous version (e.g. the one quoted by @Captain Kangaroo ?).

I read you quote "MicroG", I don't know it but is it a "OpenGapps / MindTheGapp-like app" ? It doesn't seem to use PlayStore isn't there any hazard to use this kind of store app (and yes, I know you gonna to reply "not much more than installing the rom provided by @html6405... :) )?

Thank you for your advices,
 
  • Like
Reactions: Captain Kangaroo

djyahoo

Member
Jul 10, 2021
26
7
Hi and thank you again for your work, @html6405 !
I am testing this ROM on my second i9305 (yes, I own two S3 LTE :) ).
Yet it seems to be quite good but... I have got some problems with Play Store. Any attempt to install an app stucks on "pending" message. Tried to wipe app cache, to wipe "cache / dalvik cache" from twrp, but it is a fail.
Of course my network connection is OK - browser is functional.

I installed MindTheGapps (MindTheGapps-12.1.0-arm-20220416_173154), should I try a previous version (e.g. the one quoted by @Captain Kangaroo ?).

I read you quote "MicroG", I don't know it but is it a "OpenGapps / MindTheGapp-like app" ? It doesn't seem to use PlayStore isn't there any hazard to use this kind of store app (and yes, I know you gonna to reply "not much more than installing the rom provided by @html6405... :) )?

Thank you for your advices,

I "self reply" :)

Eyyykh.... a strange thing : actually, if I disable WI-FI and just rely on my "mobile data", Play store then begins to download and install the app !

So here is the situation for me : at the moment, everything seems to be cool (with MindtheGap). App download from Playstore DO require to disable WI-FI and rely only on mobile data. However, there are some "lags", very noticeable, that does not exist with Lineage 18 from @html6405 . I am going on with testing this rom...
 
  • Like
Reactions: Captain Kangaroo

Captain Kangaroo

Senior Member
Aug 4, 2018
186
203
Paris
I "self reply" :)

Eyyykh.... a strange thing : actually, if I disable WI-FI and just rely on my "mobile data", Play store then begins to download and install the app !

So here is the situation for me : at the moment, everything seems to be cool (with MindtheGap). App download from Playstore DO require to disable WI-FI and rely only on mobile data. However, there are some "lags", very noticeable, that does not exist with Lineage 18 from @html6405 . I am going on with testing this rom...
I have a very limited use of this device (no radio Sim, no or very few internet traffic via wifi) and as I experienced problems when installing any Gapps – device became laggy and did,t update via wifi - I use it gappless and installed very few apps via *.apk.

Also, I succeded rooting with Magisk; but device became very laggy with no response of some apps. Now, I'm happy to use my device as a PDA.

Good luck to @djyahoo for his/her experiments and thank you again to @html6405 for the great work.

Last Update 19.04.2022 via OTA went very well.
 
  • Like
Reactions: html6405

djyahoo

Member
Jul 10, 2021
26
7
I confirm : the phone became very laggy for the second time, after a few hours of "passive use".

Here is a "htop" screenshot :

1650557839395.png


There are duplicate processes (com.android.phone, com.android.systemui, com.android.messaging...), sometimes for different users, sometimes with the same user.

And moreover : only two cores over the four are "online" ! (update : same situation for lineage 18, though... on lineage 14 there were 4 CPUs online).

For this session, I have only done a "sms backup and restore" restoration of my sms, nothing else for this session. And now it's over but phone is still unusable as it....is.....verrryyyyy.... slow :)

After a reboot, note that I still have duplicate processes and only two cores online, but there is no more lag at this time.
New info after reboot : the nofication bar showed a pending task "Google Speech services - waiting for a network connection"... but I had a network connection (mobile data without wifi). And this time... as soon as i set the wi-fi on, the download began. Very difficult to understand :
- Play store is only OK with WI-FI off / mobile data on
- Updates are only OK with WI-FI on
This time, after only 30 minutes after reboot, doing nothing, I can see that the device lags again.
 
Last edited:

djyahoo

Member
Jul 10, 2021
26
7
Hi guys, here are some news from this rom on my device.

Some CPUs are switching between offline and online. At boot time, the four CPUs are online :
1650617594663.png

and after a while, some CPU become offline... but then can recover (see CPU 2)
1650617662706.png

and there is a possibility that they become all online after that :
1650617766830.png


It may be the expected behaviour... but the fact that two CPUs were offline while the phone was heavy lagging is surprising.
 
Last edited:

djyahoo

Member
Jul 10, 2021
26
7
So far are the results of my tests...

What I have tested and is working :
  • Audio calls
  • SMS / MMS
  • Camera
  • Speakers and microphone (tried with voice recorder at this time)
  • Wifi and mobile data (but there are some problems - see below)
  • USB connection with PC (ADB + MTP)
  • Nearby share
  • Screenshots
  • Sound and micro are good under most of use cases (headset, handset, speakers etc...) : I used to deal with sound and mic problems with previous version of Lineage (14 then 18), but now it seems to be better in this rom, congratulations :)
  • Screen split mode works only by swiping up (to view running apps) then clicking on an app logo / "display at top".

What is not working :
  • Device become laggy after a while (until it become unusable at all)
  • Strange behaviour with network connection at the first days of use : sometimes I have to disable wifi and rely only on mobile data, sometimes I have to enable WI-FI to make an app working with internet... and sometimes, for a given use case at two different times, the solution can differ (either enable o disable WI-FI)... EDIT 28/04/2022 : now this problem doesn't seem to exist anyore, very weird because I changed nothing...
  • Settings in the gallery app (blank screen)
  • Adding contacts to the emergency settings (yes I know, it is not a high priority bug...)
  • Screen split mode by tile shortcut (via swipe down)
  • Bluetooth with car : pairing is OK but no sound and no microphone... and after that there is no sound anymore for any call even without bluetooth : no other way than rebooting :( After some minutes of bluetooth pairing, phone begins to be very laggy, too.
  • Bluetooth with headset : pairing ok but sound/microphone sound is very very low.
  • The "type your sim code" screen is VERY slow to come. You sometimes have to wait for one or two minutes after unlocking before this screen is shown. At the beginning, I thought it was a problem with sim recognition.
  • GPS fix is pretty bad - much more than my other i9305 with LOS 18.1. Tried with some other gps.conf, just a little better but still not as good as my other i9305. Didn't tried yet with the app pointed by @html6405 in this post.

I haven't experienced random reboot, afaic

Some problem above make this rom unsable in real life, for me. Lineage 18.1 is much much more usable at this time.
I am going to test the new Lineage 18.1, update 20.04.2022. EDIT 28/04/2022 : I resumed trying yesterday to test this device with this rom, and it is weird because now the phone is nearly usable in real ife : no connection problem and the phone become laggy after hours (less than a day, though) - except if I make a bluetooth pairing (lags come quickly in this case and blutooth is not functional anyway).

Here is a last_kmsg file, after a reboot I had to do because of heavy slowdown... but there were NO crash, so I don't know if this file will worth an analysis. Moreover, for this session, I removed the sim and sd card to check if it could be related to the lags (and it is not, at last).
I tried with different batteries (I tried the one used for my other device with Lineage 18, which works fine), for no change.

Please note that I haven't installed Magisk (device is not rooted).

Have a good day !
 

Attachments

  • last_kmsg.zip
    157 KB · Views: 4
Last edited:

2uPGodCnrwa

Senior Member
Feb 13, 2019
71
156
I fixed the slowdown problem by editing the file /vendor/etc/init/tweaks.rc :
setprop sys.power.cpufreq_max_limit 1600000
setprop sys.power.cpufreq_min_limit 800000

the cpuinfo app gives frequencies from 200 to 1700 anyway…

I have tested cpufreq_min_limit 200000 but phone become lag as well, no other test

This work on i9300 but made the battery drain very quickly for me.

Devices with magisk and no gapp
 
  • Like
Reactions: Captain Kangaroo

djyahoo

Member
Jul 10, 2021
26
7
I fixed the slowdown problem by editing the file /vendor/etc/init/tweaks.rc :
setprop sys.power.cpufreq_max_limit 1600000
setprop sys.power.cpufreq_min_limit 800000

the cpuinfo app gives frequencies from 200 to 1700 anyway…

I have tested cpufreq_min_limit 200000 but phone become lag as well, no other test

This work on i9300 but made the battery drain very quickly for me.

Devices with magisk and no gapp
Thank you for sharing, I'm gonna give it a try on my i9305 (and I was ready to uninstall this 19.1 ROM today, so you just changed my plan :) ) ?
 

djyahoo

Member
Jul 10, 2021
26
7
I fixed the slowdown problem by editing the file /vendor/etc/init/tweaks.rc :
setprop sys.power.cpufreq_max_limit 1600000
setprop sys.power.cpufreq_min_limit 800000

the cpuinfo app gives frequencies from 200 to 1700 anyway…

I have tested cpufreq_min_limit 200000 but phone become lag as well, no other test

This work on i9300 but made the battery drain very quickly for me.

Devices with magisk and no gapp

So.... unfortunately, no so good news for me.

First, in case it could help further readers : these settings does not survive across reboot.

Now the results : what is good with these settings is that shutting off or restarting process is much quicker than with the standard configuration (I noticed that the process of boot and shut down is, by default, much more slower whith ROM 19 than with Lineage 18.1).


The primary use case for me, in order to make the device severely lagging quickly, is to bluetooth pairing it with my car : the lag comes neary instantely after first attempt to call anybody. Well, with the two settings max_limit and min_limit, the lag come gain.
Note that by forcing cpu_governor to "performance", the lags stops immediately. But as I am not rooted, it is not very easy for me to force performance governor (and I found no way to set it at startup).

Though I forced cpu governor to "performance" and the two settings for cpu frequencies, I just had again the problem with the "black locked screen with light yellow notification led on (not binking)" : no way to wake up from this state, and adb connection is down.


And I noticed again some problems with sim card :
  • Several mobile connection losses during the day (at the same location, where I have a good signal). Generally it recovers by itself. I thought my sim card was involved in this problem, but I just received a new replacement for my Sim card and the problem is still there.
  • sometimes it requires to try several reboot before getting the "type your pin code" screen (@html6405 already warned us about this problem)


For me the ROM would be useable as a "everyday phone" :
  • with cpu_governor set to performance by default (or at least with a fix for the slowdown problems)
  • with a fix for bluetooth sound and microphone problem
  • with a fix for the "black locked screen with light yellow notification led on (not binking)" with no way to make the device "displaying something again"
  • with a fix for the GPS (with the same gps.conf than my other device i9305 with LOS18.1 that can find a 3d fix quite easily, the gps reception is very bad for this LOS19.1 - very hard to have 3d fix)
  • with the fix for the "swipe up to unlock

As a remind, I am under LOS19.1 last version / Gapps pico.

Have a good day !
 
Last edited:

2uPGodCnrwa

Senior Member
Feb 13, 2019
71
156
So.... unfortunately, no so good news for me.

First, in case it could help further readers : these settings does not survive across reboot.

Now the results : what is good with these settings is that shutting off or restarting process is much quicker than with the standard configuration (I noticed that the process of boot and shut down is, by default, much more slower whith ROM 19 than with Lineage 18.1).


The primary use case for me, in order to make the device severely lagging quickly, is to bluetooth pairing it with my car : the lag comes neary instantely after first attempt to call anybody. Well, with the two settings max_limit and min_limit, the lag come gain.
Note that by forcing cpu_governor to "performance", the lags stops immediately. But as I am not rooted, it is not very easy for me to force performance governor (and I found no way to set it at startup).

Though I forced cpu governor to "performance" and the two settings for cpu frequencies, I just had again the problem with the "black locked screen with light yellow notification led on (not binking)" : no way to wake up from this state, and adb connection is down.


And I noticed again some problems with sim card :
  • Several mobile connection losses during the day (at the same location, where I have a good signal). Generally it recovers by itself. I thought my sim card was involved in this problem, but I just received a new replacement for my Sim card and the problem is still there.
  • sometimes it requires to try several reboot before getting the "type your pin code" screen (@html6405 already warned us about this problem)


For me the ROM would be useable as a "everyday phone" :
  • with cpu_governor set to performance by default (or at least with a fix for the slowdown problems)
  • with a fix for bluetooth sound and microphone problem
  • with a fix for the "black locked screen with light yellow notification led on (not binking)" with no way to make the device "displaying something again"
  • with a fix for the GPS (with the same gps.conf than my other device i9305 with LOS18.1 that can find a 3d fix quite easily, the gps reception is very bad for this LOS19.1 - very hard to have 3d fix)
  • with the fix for the "swipe up to unlock

As a remind, I am under LOS19.1 last version / Gapps pico.

Have a good day !
did you modify the file /vendor/etc/init/tweaks.rc and delete the line setprop sys.power.cpufreq_max_limit 1200000 ?
I also deactivated boeffla after a sound problem…

I also have disconnections or loss of network (restart required) and the "swipe to unlock" problem, the gps is correct (by modifying the gps.conf), and no black screen problem.
 

html6405

Recognized Developer
@html6405 In this ROM there is another small problem : the length needed in order to swipe up the "unlock screen" is way way to long to drag. We have to swype from the bottom of the screen to the nearly top of the screen, otherwise it is a "swipe up fail".
This problem seems to be known :
https://www.reddit.com/r/LineageOS/comments/6wk0nb/_/dm8oth6
And the fix worked for me :
  1. settings put global HIC_enable 0
  2. reboot
  3. enjoy
I could disable HIC by default, I will give it a try how it works disabled, If I can see a improvement, I will publish it with the next update.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Update 23.01.2023:
    • Synced with latest LineageOS sources
    • Set swappiness back to 100
  • 11
    Code:
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    *
    */

    Hi,

    here you can find my version of LineageOS 19.1 for our Samsung Galaxy S3 (I9305).

    This is a beta build, also from the LineageOS side, there are typical functions still missing, so don't install it if you want a completely stable and completed ROM and don't report my already listet bugs!

    Attention:

    Sometimes it needs another reboot to find the sim card.

    When you have BitGapps installed, you have to reflash them after every update!

    Here you can see how far everything is working for now.

    • Boot
    • Audio
    • Bluetooth
    • Graphics
    • Cameras
    • Sensors
    • Wifi
    • GPS
    • USB
    • Video playback (HW/SW)
    • Tethering via USB
    • RIL
    • OTA-Updates
    • Tethering via WIFI and Bluetooth
    • much more...
    • Random reboots
    • NFC
    • SD-Card can't be formatted as internal storage, this will cause a bootloop
    You could use a gps.conf from https://app.box.com/s/w57s1v1n3hie7l5lk28i for your location and replace /vendor/etc/gps.conf.
    Or you try GPS Server Optimizer app for a faster 3D fix.
    For both methods you need root rights.
    I would recommend to use microG instead of BitGapps,
    here you can find the installation instructions:
    1. Download Magisk 24.1 and flash it via TWRP (yes, flash the APK file), reboot
    2. Open Magisk and update the App (and do a reboot if it's asking)
    3. Enable Zygisk in Magisk
    4. Download and install microG installer in the Magisk manager, reboot
    5. Download and install safetynet-fix in the Magisk manager, reboot
    6. Check with a safetynet checker app and you should pass :)

    Do you like my work?
    Than you can simply hit the thanks button and consider to spend me a coffee or a beer,
    I'm doing this in my free time and it also costs a lot of money to buy hardware.

    donate

    Wanna improve your sound configs, control your charging current and more?
    Now you can use my app to access all boeffla configurations, there will follow more functions.


    XDA:DevDB Information
    [ROM][12.x][I9305][BETA] LineageOS 19.1, ROM for the Samsung Galaxy S3 LTE

    Contributors

    html6405
    Source Code: https://github.com/html6405

    ROM OS Version: 12.x S
    ROM Kernel: Linux 3.x
    ROM Firmware Required: TWRP 3.5.2
    Based On: LineageOS
    Selinux: permissive, this only makes sense as soon the ROM is stable.

    Version Information
    Status:
    Beta

    Created 2022-02-10
    Last Updated 2023-01-23
    5
    Update 04.04.2022:
    • Re-Implemented and enabled boeffla sound
    4
    So far are the results of my tests...

    What I have tested and is working :
    • Audio calls
    • SMS / MMS
    • Camera
    • Speakers and microphone (tried with voice recorder at this time)
    • Wifi and mobile data (but there are some problems - see below)
    • USB connection with PC (ADB + MTP)
    • Nearby share
    • Screenshots
    • Sound and micro are good under most of use cases (headset, handset, speakers etc...) : I used to deal with sound and mic problems with previous version of Lineage (14 then 18), but now it seems to be better in this rom, congratulations :)
    • Screen split mode works only by swiping up (to view running apps) then clicking on an app logo / "display at top".

    What is not working :
    • Device become laggy after a while (until it become unusable at all)
    • Strange behaviour with network connection at the first days of use : sometimes I have to disable wifi and rely only on mobile data, sometimes I have to enable WI-FI to make an app working with internet... and sometimes, for a given use case at two different times, the solution can differ (either enable o disable WI-FI)... EDIT 28/04/2022 : now this problem doesn't seem to exist anyore, very weird because I changed nothing...
    • Settings in the gallery app (blank screen)
    • Adding contacts to the emergency settings (yes I know, it is not a high priority bug...)
    • Screen split mode by tile shortcut (via swipe down)
    • Bluetooth with car : pairing is OK but no sound and no microphone... and after that there is no sound anymore for any call even without bluetooth : no other way than rebooting :( After some minutes of bluetooth pairing, phone begins to be very laggy, too.
    • Bluetooth with headset : pairing ok but sound/microphone sound is very very low.
    • The "type your sim code" screen is VERY slow to come. You sometimes have to wait for one or two minutes after unlocking before this screen is shown. At the beginning, I thought it was a problem with sim recognition.
    • GPS fix is pretty bad - much more than my other i9305 with LOS 18.1. Tried with some other gps.conf, just a little better but still not as good as my other i9305. Didn't tried yet with the app pointed by @html6405 in this post.

    I haven't experienced random reboot, afaic

    Some problem above make this rom unsable in real life, for me. Lineage 18.1 is much much more usable at this time.
    I am going to test the new Lineage 18.1, update 20.04.2022. EDIT 28/04/2022 : I resumed trying yesterday to test this device with this rom, and it is weird because now the phone is nearly usable in real ife : no connection problem and the phone become laggy after hours (less than a day, though) - except if I make a bluetooth pairing (lags come quickly in this case and blutooth is not functional anyway).

    Here is a last_kmsg file, after a reboot I had to do because of heavy slowdown... but there were NO crash, so I don't know if this file will worth an analysis. Moreover, for this session, I removed the sim and sd card to check if it could be related to the lags (and it is not, at last).
    I tried with different batteries (I tried the one used for my other device with Lineage 18, which works fine), for no change.

    Please note that I haven't installed Magisk (device is not rooted).

    Have a good day !
    4
    Update 19.04.2022:
    • Synced with LineageOS sources
    3
    Maybe interesting!? ;)

    ComputerBase: Samsung Galaxy S III: Android-Updates für bis zu 10 Jahre alte Smartphones.