[ROM][UNOFFICIAL][12 L][ I9305 ][ LineageOS 19.1 ][BETA]

Search This thread

djyahoo

Member
Jul 10, 2021
26
7
did you modify the file /vendor/etc/init/tweaks.rc and delete the line setprop sys.power.cpufreq_max_limit 1200000 ?
I also deactivated boeffla after a sound problem…

I also have disconnections or loss of network (restart required) and the "swipe to unlock" problem, the gps is correct (by modifying the gps.conf), and no black screen problem.
Damned you're right, I missed your first line, sorry :( So I assume this is the reason why it didn't persists accross reboot. Sorry, and thank you.
Could you tell me how you deactivated boeffla ? Edit 01/05/2022 : OK I think it is also in the same file tweaks.rc...
 
Last edited:

korgot123

New member
Aug 14, 2021
2
0
Update 19.04.2022:
  • Synced with LineageOS sources
Hellow. Please fix ( Mobile Internet{Network} ) this bug:

SIM card added

Restart your device to access the mobile network.

I rebooted my smartphone 5 times and this error appears again and again

Sim card (no GSM) : UMTS
Screenshot_20220515-205952_Trebuchet.png
 

korgot123

New member
Aug 14, 2021
2
0
Hi,
try to ignore this message (just don't press restart).
yes it definitely works.

(1)the first problem is that Wi-Fi turns off during games, and it just accidentally turns off - and basically you have to reconnect yourself manually

(2) the second problem in Tik Tok (lite) blue + green + red + purple artifacts appear - and some videos cannot be watched - the image blinks and glitches of different colors appear -but most of the videos work fine

(3) the third problem is not always a screenshot is taken and writes failed to take a screenshot..... but mostly it works fine

(4)the fourth problem with the game mobile legends bang bang - it is necessary to accidentally turn off the screen with a button or collapse then expand the game, a black screen appears - it is during the game and it is impossible to share the game - a black screen also appears from the game menu - and until you close the game, the game does not go back into the game

(5) the fifth problem with root with Magisk (stable version):writes the following - Requires Additional Setup : Your device needs additional setup for Magisk to work properly . Do you want to proceed and reboot? when the ok button is pressed, it gives out an error and does not reboot - as Magisk itself requires

translated through Yandex translator - because I know English very badly at the level of a small child, I will add some screenshots:
 

Attachments

  • Screenshot_20220522-112648_Trebuchet.png
    Screenshot_20220522-112648_Trebuchet.png
    89.1 KB · Views: 33
  • Screenshot_20220526-211323_Trebuchet.png
    Screenshot_20220526-211323_Trebuchet.png
    327 KB · Views: 34
  • Screenshot_20220527-203706_Trebuchet.png
    Screenshot_20220527-203706_Trebuchet.png
    157.2 KB · Views: 35
  • Screenshot_20220527-203755_Trebuchet.png
    Screenshot_20220527-203755_Trebuchet.png
    333.9 KB · Views: 30
  • Screenshot_20220527-205739_Trebuchet.png
    Screenshot_20220527-205739_Trebuchet.png
    345.7 KB · Views: 32
  • Screenshot_20220527-210112_Trebuchet.png
    Screenshot_20220527-210112_Trebuchet.png
    667.5 KB · Views: 31
  • Screenshot_20220527-212421_Trebuchet.png
    Screenshot_20220527-212421_Trebuchet.png
    531.5 KB · Views: 30
  • Screenshot_20220527-212429_Trebuchet.png
    Screenshot_20220527-212429_Trebuchet.png
    546.6 KB · Views: 30
Last edited:

Bleifuss2000

Member
Mar 10, 2021
5
2
Google Speech to Text does not work propery.
Any idea how i can fix this?
photo_2022-06-07_20-30-03.jpg

I installed the latest version.
In my Navi App Calimoto is unfortunately also no voice announcements available.
 
Last edited:

html6405

Recognized Developer
(1)the first problem is that Wi-Fi turns off during games, and it just accidentally turns off - and basically you have to reconnect yourself manually
Ok I'm not facing this.
(2) the second problem in Tik Tok (lite) blue + green + red + purple artifacts appear - and some videos cannot be watched - the image blinks and glitches of different colors appear -but most of the videos work fine
Well this can happen because of a wrongly configured AVC hardware decoder,
I know this problem since we have custom ROM's for the exynos4 devices (or since we have to use the open source implementation for them).
I've removed this decoder for bigger devices, because it happens much more on them, but if you wanna try,
here's a vendor image with the removed avc hardware decoder (software decoding will be forced).
(3) the third problem is not always a screenshot is taken and writes failed to take a screenshot..... but mostly it works fine
We have a limited heap, I see no solution for this rn.
(4)the fourth problem with the game mobile legends bang bang - it is necessary to accidentally turn off the screen with a button or collapse then expand the game, a black screen appears - it is during the game and it is impossible to share the game - a black screen also appears from the game menu - and until you close the game, the game does not go back into the game
Ok
(5) the fifth problem with root with Magisk (stable version):writes the following - Requires Additional Setup : Your device needs additional setup for Magisk to work properly . Do you want to proceed and reboot? when the ok button is pressed, it gives out an error and does not reboot - as Magisk itself requires
Try to use v23 or 24.1, higher versions could cause problems.
does mhl works on this rom?
Nope, MHL support is dropped since A7.
Google Speech to Text does not work propery.
Any idea how i can fix this?
I'm sorry, but I don't use gapps, maybe a different package could fix this.
 

BeeJ1109

Senior Member
Sep 26, 2015
197
52
Adelaide
Hi @html6405,
I read some comments back awhile, that you are now only working on LOS 19.1 ROM. But this ROM is in it's infancy stage, requiring lots of work to be stable.
Whereas LOS 18.1 ROM, has been working perfectly months now.
Why not Update Security patchs for this stable ROM, whilst you develope LOS 19.1, as the future Replacement, when more stable.

Just my thoughts, what do you think of my suggestion.
Cheers BJ
 

html6405

Recognized Developer
Hi @html6405,
I read some comments back awhile, that you are now only working on LOS 19.1 ROM. But this ROM is in it's infancy stage, requiring lots of work to be stable.
Whereas LOS 18.1 ROM, has been working perfectly months now.
Why not Update Security patchs for this stable ROM, whilst you develope LOS 19.1, as the future Replacement, when more stable.

Just my thoughts, what do you think of my suggestion.
Cheers BJ
Hi,
it's because I have less time for Android now,
the only update I maybe will bring for LineageOS 18.1 is another RIL improvement if I manage this on A12.

It takes a lot of time to do the resync with LineageOS and keep my work, so I only can concentrate on one project.
 

Captain Kangaroo

Senior Member
Aug 4, 2018
186
203
Paris
@html6405 no no no don't apologize!
Having Android 12L on an S3 is already a feat and we take the best despite bugs and other inconveniences.
Stay on your goal at your pace, ...
For me it's fine and everything that will come in the future is good
 
  • Like
Reactions: html6405

BeeJ1109

Senior Member
Sep 26, 2015
197
52
Adelaide
Hi,
it's because I have less time for Android now,
the only update I maybe will bring for LineageOS 18.1 is another RIL improvement if I manage this on A12.

It takes a lot of time to do the resync with LineageOS and keep my work, so I only can concentrate on one project.
Hi @html6405,
Thanks for great effort, do what you wish, at your own pace, I totally understand, the effort required to get ROMs working, and to be stable. My 9305 is working perfectly at the moment on LOS 18.1, just surprised a phone from 2012, would work on A12.
I assuming, you are having issues with Sim recognition, therefore requiring RIL fix.

As you mention, if you get it working on LOS 19.1, you will fix up LOS 18.1, if I have understood you correctly.
As my 9305 works on LOS 18.1, only that Sim card is not active, therefore I cannot make test calls on 4G LTE network, but does recognise Telstra network.
ISMI 5050134853393788, Reads IMEI 3539*******9231 on Sim , can make Emergency call only, being 000 in Australia. RSSI -31 dBm 16 asu. GPS provides location & location map. Provides data from Mobile Site for a few secs, just enough time to get screenshot. (See below)
I am using G-Mon Pro
Cheers BJ
 

Attachments

  • Screenshot_20220627-213843_G-MoN_Pro.png
    Screenshot_20220627-213843_G-MoN_Pro.png
    117.3 KB · Views: 24

korgot12345

New member
Jul 6, 2022
1
0
Hi
Update 15.06.2022:
  • Synced with latest LineageOS sources
  • Uploaded a vendor image with disabled avc hardware decoding
HI !

1) I want to write to you: there is a site with erotic content 18+\21+: xnxx.com - so there is a bug with the image of purple and green stripes appear and do not give a normal look and in all directions - please fix it

2) There is a game: Lords of War & Money: Strategy (in Russian it is called :Heroes of war and money) - it turns on but it is impossible to play - I press play - the battle is loading and then silence and written this game does not respond to close or wait - please fix it the game is free - many people play it - and I want to play from work and at home without including a laptop or computer
Update 15.06.2022:
  • Synced with latest LineageOS sources
  • Uploaded a vendor image with disabled avc hardware decoding
 

Attachments

  • Screenshot_20220706-195446_Via.png
    Screenshot_20220706-195446_Via.png
    344.7 KB · Views: 23
  • Screenshot_20220706-201042_Aurora Store.png
    Screenshot_20220706-201042_Aurora Store.png
    381.5 KB · Views: 21
  • Screenshot_20220706-201612_Lords of War and Money.png
    Screenshot_20220706-201612_Lords of War and Money.png
    49.2 KB · Views: 20
  • Screenshot_20220706-201555_Lords of War and Money.png
    Screenshot_20220706-201555_Lords of War and Money.png
    12.7 KB · Views: 21

html6405

Recognized Developer
HI !

1) I want to write to you: there is a site with erotic content 18+\21+: xnxx.com - so there is a bug with the image of purple and green stripes appear and do not give a normal look and in all directions - please fix it
Hi,
thats the background why I've uploaded a vendor image with disabled avc hardware decoding, not for porn, but for many other videos and streaming apps :D.
Did you try this?

I can't fix the hardware decoder yet, I've tried many configurations for the decoder without any luck.
So I'm really sorry, but you have to try it with software decoding, but I'm not sure how well this will work.
2) There is a game: Lords of War & Money: Strategy (in Russian it is called :Heroes of war and money) - it turns on but it is impossible to play - I press play - the battle is loading and then silence and written this game does not respond to close or wait - please fix it the game is free - many people play it - and I want to play from work and at home without including a laptop or computer
I'm sorry but there is no helpful output for me, you could send a bug report to the app developer.
 

Daniel_FR

New member
Jul 19, 2022
1
0
Hi,

First of all, thank you for your great work and make live again this phone !
MicroG is good to be degooglized !
It works well but I have some points to tune :
- low microphone level, for example when you make a video with the camera app, and choppy video in comparaison to the stock rom
- I can't have GPS working (I'm in France)
- network can have time to be up : I have to wait to have SMS and calls up
- sometimes it freeze and reboot

Tell me what log you need if you have any time.

Best regards.
 

BeeJ1109

Senior Member
Sep 26, 2015
197
52
Adelaide
Hi @html6405,
Tried Latest June 2022 build for LOS19.1 on my 9305.
Some issues
1. Installed Magisk 25.2 to Root Phone, sort of works, Updated Magisk Manager 25.2 partially works, some apps have root access added, some apps cannot achieve "Write access to EXT SD Card". Even though Root access has been achieved. X-PLORE file Explorer has root access, but Not Write access. LOS 18.1 ROM WORKS CORRECTLY.
So without SD cards Write access on ROM LOSv19.1. Sadly makes this ROM USELESS.

2. Using TWRP v3.6.0_9.0.
I Found 10 partitions can be Backed up to Restore later.
Extra partitions added compared to LOS18.1 - another extra System (system_image.emmc) (1.5GB) partition & Vendor (vendor_image.emmc) (560MB) partition , meaning there is additional extra partitions to existing System (system.ext4) (1.1GB) & Vendor (vendor.ext4) (60MB) partitions, both being different sizes.

3. Recognition of Sim appears inconsistent, very unstable.

4. Having issues to install BiTGapps-arm-12. ROM rejects using TWRP to flash zip, will not allow system partition to be mounted. Maybe as a result of there being 2 system partitions.
1. system.ext4.win (1.1GB) (normal). 2. system_image.emmc (1.5GB) (additional).

Very Strange. I added the TWRP recovery.log.

So I reverted back to LOS 18.1 ROM, that works.
Cheers BJ.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 2
    Update 23.01.2023:
    • Synced with latest LineageOS sources
    • Set swappiness back to 100
  • 11
    Code:
    /*
    * Your warranty is now void.
    *
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.
    *
    */

    Hi,

    here you can find my version of LineageOS 19.1 for our Samsung Galaxy S3 (I9305).

    This is a beta build, also from the LineageOS side, there are typical functions still missing, so don't install it if you want a completely stable and completed ROM and don't report my already listet bugs!

    Attention:

    Sometimes it needs another reboot to find the sim card.

    When you have BitGapps installed, you have to reflash them after every update!

    Here you can see how far everything is working for now.

    • Boot
    • Audio
    • Bluetooth
    • Graphics
    • Cameras
    • Sensors
    • Wifi
    • GPS
    • USB
    • Video playback (HW/SW)
    • Tethering via USB
    • RIL
    • OTA-Updates
    • Tethering via WIFI and Bluetooth
    • much more...
    • Random reboots
    • NFC
    • SD-Card can't be formatted as internal storage, this will cause a bootloop
    You could use a gps.conf from https://app.box.com/s/w57s1v1n3hie7l5lk28i for your location and replace /vendor/etc/gps.conf.
    Or you try GPS Server Optimizer app for a faster 3D fix.
    For both methods you need root rights.
    I would recommend to use microG instead of BitGapps,
    here you can find the installation instructions:
    1. Download Magisk 24.1 and flash it via TWRP (yes, flash the APK file), reboot
    2. Open Magisk and update the App (and do a reboot if it's asking)
    3. Enable Zygisk in Magisk
    4. Download and install microG installer in the Magisk manager, reboot
    5. Download and install safetynet-fix in the Magisk manager, reboot
    6. Check with a safetynet checker app and you should pass :)

    Do you like my work?
    Than you can simply hit the thanks button and consider to spend me a coffee or a beer,
    I'm doing this in my free time and it also costs a lot of money to buy hardware.

    donate

    Wanna improve your sound configs, control your charging current and more?
    Now you can use my app to access all boeffla configurations, there will follow more functions.


    XDA:DevDB Information
    [ROM][12.x][I9305][BETA] LineageOS 19.1, ROM for the Samsung Galaxy S3 LTE

    Contributors

    html6405
    Source Code: https://github.com/html6405

    ROM OS Version: 12.x S
    ROM Kernel: Linux 3.x
    ROM Firmware Required: TWRP 3.5.2
    Based On: LineageOS
    Selinux: permissive, this only makes sense as soon the ROM is stable.

    Version Information
    Status:
    Beta

    Created 2022-02-10
    Last Updated 2023-01-23
    5
    Update 04.04.2022:
    • Re-Implemented and enabled boeffla sound
    4
    So far are the results of my tests...

    What I have tested and is working :
    • Audio calls
    • SMS / MMS
    • Camera
    • Speakers and microphone (tried with voice recorder at this time)
    • Wifi and mobile data (but there are some problems - see below)
    • USB connection with PC (ADB + MTP)
    • Nearby share
    • Screenshots
    • Sound and micro are good under most of use cases (headset, handset, speakers etc...) : I used to deal with sound and mic problems with previous version of Lineage (14 then 18), but now it seems to be better in this rom, congratulations :)
    • Screen split mode works only by swiping up (to view running apps) then clicking on an app logo / "display at top".

    What is not working :
    • Device become laggy after a while (until it become unusable at all)
    • Strange behaviour with network connection at the first days of use : sometimes I have to disable wifi and rely only on mobile data, sometimes I have to enable WI-FI to make an app working with internet... and sometimes, for a given use case at two different times, the solution can differ (either enable o disable WI-FI)... EDIT 28/04/2022 : now this problem doesn't seem to exist anyore, very weird because I changed nothing...
    • Settings in the gallery app (blank screen)
    • Adding contacts to the emergency settings (yes I know, it is not a high priority bug...)
    • Screen split mode by tile shortcut (via swipe down)
    • Bluetooth with car : pairing is OK but no sound and no microphone... and after that there is no sound anymore for any call even without bluetooth : no other way than rebooting :( After some minutes of bluetooth pairing, phone begins to be very laggy, too.
    • Bluetooth with headset : pairing ok but sound/microphone sound is very very low.
    • The "type your sim code" screen is VERY slow to come. You sometimes have to wait for one or two minutes after unlocking before this screen is shown. At the beginning, I thought it was a problem with sim recognition.
    • GPS fix is pretty bad - much more than my other i9305 with LOS 18.1. Tried with some other gps.conf, just a little better but still not as good as my other i9305. Didn't tried yet with the app pointed by @html6405 in this post.

    I haven't experienced random reboot, afaic

    Some problem above make this rom unsable in real life, for me. Lineage 18.1 is much much more usable at this time.
    I am going to test the new Lineage 18.1, update 20.04.2022. EDIT 28/04/2022 : I resumed trying yesterday to test this device with this rom, and it is weird because now the phone is nearly usable in real ife : no connection problem and the phone become laggy after hours (less than a day, though) - except if I make a bluetooth pairing (lags come quickly in this case and blutooth is not functional anyway).

    Here is a last_kmsg file, after a reboot I had to do because of heavy slowdown... but there were NO crash, so I don't know if this file will worth an analysis. Moreover, for this session, I removed the sim and sd card to check if it could be related to the lags (and it is not, at last).
    I tried with different batteries (I tried the one used for my other device with Lineage 18, which works fine), for no change.

    Please note that I haven't installed Magisk (device is not rooted).

    Have a good day !
    4
    Update 19.04.2022:
    • Synced with LineageOS sources
    3
    Maybe interesting!? ;)

    ComputerBase: Samsung Galaxy S III: Android-Updates für bis zu 10 Jahre alte Smartphones.