[ROM][UNOFFICIAL][12 L][ I9305 ][ LineageOS 19.1 ][BETA]

Search This thread


Feb 17, 2009
I cannot instal gapps, because there are only for android 11 for download.

Do anyone have working pico gapps for this 12L version o android?

Wil Android auto work on this 12L version?

Thank you :)

Captain Kangaroo

Senior Member
Aug 4, 2018
I cannot instal gapps, because there are only for android 11 for download.

Do anyone have working pico gapps for this 12L version o android?

Wil Android auto work on this 12L version?

Thank you :)
Here it is :)
BiTGapps https://www.pling.com/p/1864360/
MindTheGapps https://androidfilehost.com/?w=files&flid=322935
open_gapps https://sourceforge.net/projects/althafvly/files/gapps/
To be honest, I don't recall which one I've installed or even if I installed gapps on my S3 :unsure:
I confirm that i did'nt install gapps on my S3 but did it on my S5 and it works ...
Last edited:
  • Like
Reactions: larswars


Senior Member
Sep 26, 2015


  • Screenshot_20220930-130810_Brave.jpg
    343.2 KB · Views: 27
  • Screenshot_20220930-130922_Brave.jpg
    175 KB · Views: 27


Recognized Developer
  • Like
Reactions: lpedia


Feb 17, 2009
When i connect my phone to car i receive this:


I installed fresh os (wipe data) + BiTGapps. When i turn on my phone, i have google market.

What can i do? You have any suggestion? :) Thank you!


Senior Member
Sep 18, 2020
Samsung Galaxy Tab S2
HTC 10
  • Like
Reactions: html6405

Top Liked Posts

  • There are no posts matching your filters.
  • 3
    Update 23.01.2023:
    • Synced with latest LineageOS sources
    • Set swappiness back to 100
    HI ALL, @html6405,
    The latest ROM release, is very stable, works great, SIM working, as well as WIFI, Bluetooth,
    All 40 apps, all working, as expected, same as previous LOS 18.1 version. Also using now TWRP v3.7. to Full Backup, before any upgrading, to allow easy restore back to previous working ROM with Root, All Apps. Best Practice always, backup before, you experiment with New ROM.
    So great work, keep it up. Rooted with Magisk 25.2 was working, but could not see Rooted apps permissions, or any modules applied, even though they all worked as expected, but hidden in The Magisk Manager. So I did as suggested by @html6405 feedback, I installed earlier v24.1, now working as expected.
    So happy that my old GT-I9195T works on Android 12 as LOS19.1.
    Cheers BJ
  • 11
    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.


    here you can find my version of LineageOS 19.1 for our Samsung Galaxy S3 (I9305).

    This is a beta build, also from the LineageOS side, there are typical functions still missing, so don't install it if you want a completely stable and completed ROM and don't report my already listet bugs!


    Sometimes it needs another reboot to find the sim card.

    When you have BitGapps installed, you have to reflash them after every update!

    Here you can see how far everything is working for now.

    • Boot
    • Audio
    • Bluetooth
    • Graphics
    • Cameras
    • Sensors
    • Wifi
    • GPS
    • USB
    • Video playback (HW/SW)
    • Tethering via USB
    • RIL
    • OTA-Updates
    • Tethering via WIFI and Bluetooth
    • much more...
    • Random reboots
    • NFC
    • SD-Card can't be formatted as internal storage, this will cause a bootloop
    You could use a gps.conf from https://app.box.com/s/w57s1v1n3hie7l5lk28i for your location and replace /vendor/etc/gps.conf.
    Or you try GPS Server Optimizer app for a faster 3D fix.
    For both methods you need root rights.
    I would recommend to use microG instead of BitGapps,
    here you can find the installation instructions:
    1. Download Magisk 24.1 and flash it via TWRP (yes, flash the APK file), reboot
    2. Open Magisk and update the App (and do a reboot if it's asking)
    3. Enable Zygisk in Magisk
    4. Download and install microG installer in the Magisk manager, reboot
    5. Download and install safetynet-fix in the Magisk manager, reboot
    6. Check with a safetynet checker app and you should pass :)

    Do you like my work?
    Than you can simply hit the thanks button and consider to spend me a coffee or a beer,
    I'm doing this in my free time and it also costs a lot of money to buy hardware.


    Wanna improve your sound configs, control your charging current and more?
    Now you can use my app to access all boeffla configurations, there will follow more functions.

    XDA:DevDB Information
    [ROM][12.x][I9305][BETA] LineageOS 19.1, ROM for the Samsung Galaxy S3 LTE


    Source Code: https://github.com/html6405

    ROM OS Version: 12.x S
    ROM Kernel: Linux 3.x
    ROM Firmware Required: TWRP 3.5.2
    Based On: LineageOS
    Selinux: permissive, this only makes sense as soon the ROM is stable.

    Version Information

    Created 2022-02-10
    Last Updated 2023-01-23
    Update 04.04.2022:
    • Re-Implemented and enabled boeffla sound
    So far are the results of my tests...

    What I have tested and is working :
    • Audio calls
    • SMS / MMS
    • Camera
    • Speakers and microphone (tried with voice recorder at this time)
    • Wifi and mobile data (but there are some problems - see below)
    • USB connection with PC (ADB + MTP)
    • Nearby share
    • Screenshots
    • Sound and micro are good under most of use cases (headset, handset, speakers etc...) : I used to deal with sound and mic problems with previous version of Lineage (14 then 18), but now it seems to be better in this rom, congratulations :)
    • Screen split mode works only by swiping up (to view running apps) then clicking on an app logo / "display at top".

    What is not working :
    • Device become laggy after a while (until it become unusable at all)
    • Strange behaviour with network connection at the first days of use : sometimes I have to disable wifi and rely only on mobile data, sometimes I have to enable WI-FI to make an app working with internet... and sometimes, for a given use case at two different times, the solution can differ (either enable o disable WI-FI)... EDIT 28/04/2022 : now this problem doesn't seem to exist anyore, very weird because I changed nothing...
    • Settings in the gallery app (blank screen)
    • Adding contacts to the emergency settings (yes I know, it is not a high priority bug...)
    • Screen split mode by tile shortcut (via swipe down)
    • Bluetooth with car : pairing is OK but no sound and no microphone... and after that there is no sound anymore for any call even without bluetooth : no other way than rebooting :( After some minutes of bluetooth pairing, phone begins to be very laggy, too.
    • Bluetooth with headset : pairing ok but sound/microphone sound is very very low.
    • The "type your sim code" screen is VERY slow to come. You sometimes have to wait for one or two minutes after unlocking before this screen is shown. At the beginning, I thought it was a problem with sim recognition.
    • GPS fix is pretty bad - much more than my other i9305 with LOS 18.1. Tried with some other gps.conf, just a little better but still not as good as my other i9305. Didn't tried yet with the app pointed by @html6405 in this post.

    I haven't experienced random reboot, afaic

    Some problem above make this rom unsable in real life, for me. Lineage 18.1 is much much more usable at this time.
    I am going to test the new Lineage 18.1, update 20.04.2022. EDIT 28/04/2022 : I resumed trying yesterday to test this device with this rom, and it is weird because now the phone is nearly usable in real ife : no connection problem and the phone become laggy after hours (less than a day, though) - except if I make a bluetooth pairing (lags come quickly in this case and blutooth is not functional anyway).

    Here is a last_kmsg file, after a reboot I had to do because of heavy slowdown... but there were NO crash, so I don't know if this file will worth an analysis. Moreover, for this session, I removed the sim and sd card to check if it could be related to the lags (and it is not, at last).
    I tried with different batteries (I tried the one used for my other device with Lineage 18, which works fine), for no change.

    Please note that I haven't installed Magisk (device is not rooted).

    Have a good day !
    Update 19.04.2022:
    • Synced with LineageOS sources
    Maybe interesting!? ;)

    ComputerBase: Samsung Galaxy S III: Android-Updates für bis zu 10 Jahre alte Smartphones.