[ROM][UNOFFICIAL][12][S]LineageOS 19.1 for z5c (suzuran)

Search This thread


Mar 9, 2022
Hello Berni,

thanks for your work at the z5c. I am currently using the /e/ version of it, but it is a little bit laggy. Which rom do you recommend? It would be nice to have also the possibility to build it by myself, especially, if it is not supported anymore. I had nicki (xperia m) before and after lineageos dropped the support, I was able to build it by myself and got the latest security patches. I would use microg for it...

The old kernel has also some issues... is VPN or hotspot working for lineageos >= 19? Thanks!


Senior Member
Dec 12, 2015
Whaley Bridge
Sony Xperia Z3 Compact
I'm not sure how to download any stuff from GitLab (I'm exclusively using GitHub) and make a privileged app from it.
If this service will be available at f-droid.org, it would be way easier!
I use this project to add and remove apps from LOS (and /e/OS) builds): https://github.com/sfX-android/android_vendor_extendrom. I have found it really useful and, once you've got your head round how it works, it's easy to use to add or remove apps (including `priv-apps`) to / from custom ROM builds.

It handles the download of the apps from wherever they are based (F-Droid, GitHub, GitLab, other web sites) and creation of the necessary makefiles.
- the list of available packages/apps is in the file `repo/packages.txt`
- the downloads and makefile creation is done in the file `get_prebuilts.sh`
- the needed environment variables are described in the `README.md`. (I export them, make the necessary change to `/vendor/lineage/config/common.mk`, and call `get_prebuilts.sh` in an init script, rather than in a device-specific `vendorsetup.sh` or makefile)

The following lines in`repo/packages.txt` have all the needed information for Aurora Services
# Aurora Services
# Allow Aurora Store to install updates automatically

The following is what is written to the generated `Android.mk` for Aurora services
include $(CLEAR_VARS)
LOCAL_MODULE := AuroraServices
LOCAL_SRC_FILES := prebuilt/AuroraServices_v1.1.1.apk
LOCAL_REQUIRED_MODULES := permissions_com.aurora.services.xml

And the project owner, is really helpful, and happy to accept changes to add new target packages


Mar 9, 2022
Dear Berni,

I tried your build, but encryption is not working. I got the following error message during encryption:
init : Control message: Could not find '[email protected]::ICryptfsHw/default' for ctl.interface_start from pid: 386 (/system/bin/hwservicemanager)

I know, you mentioned it, but also with your 18.1 build, encryption is working.

I tried also to encrypt with 18.1 and then flash 19.1, but after the password, it will stuck and logcat is not working, yet...


Mar 9, 2022
right, but with 18.1 it is working ... it works also with the /e/ 18.1 version, I have not tried the 17.1

encryption is important for me, since I have some sensitive data (passwords, etc.) on my phone.

Any chance to fix it in 19.1? :) Thanks!


Mar 9, 2022
I have two z5c, one with the latest official /e/ 18.1 and one now with latest Berni's 18.1. Encryption works fine, but I have not make any throughput benchmarks... the /e/ is my daily phone, and I used it since march without any problems with encryption...

I encrypt the data partiition directly after a clean install and then restore the data from backup


Senior Member
Sep 22, 2016
Sony Xperia Z5 Compact
I got the following error message during encryption:
init : Control message: Could not find '[email protected]::ICryptfsHw/default' for ctl.interface_start from pid: 386 (/system/bin/hwservicemanager)
Addition: As you can see in this snippet from the file manifest.xml, cryptfs is present! Why it can't be found is unknown.
    <hal format="hidl">


Senior Member
Sep 22, 2016
Sony Xperia Z5 Compact
I use this project to add and remove apps from LOS
I've decided to use my own way:

Top Liked Posts

  • There are no posts matching your filters.
  • 13
    Hi all:

    Here is a LineageOS 19.1 ROM for Z5 compact (suzuran).

    New: ROM with microG apk's included in priv-app:
    Download 2023-02-19

    Please pay attention: microG can't coexist with GApps! So decide whether to install microG OR GApps!

    If you want to remove microG, enter these commands line by line in a terminal:
    adb root
    adb shell
    mount -o remount,rw /
    rm /system/priv-app/DroidGuard/DroidGuard.apk
    rm /system/priv-app/FakeStore/FakeStore.apk
    rm /system/priv-app/GmsCore/GmsCore.apk
    rm /system/priv-app/GsfProxy/GsfProxy.apk


    Or flash this microG-remover.

    This is a 7z archive with the zip'ed ROM and the md5 file in it. Please unpack this archive, copy the included two files somewhere to your device, reboot into TWRP and flash this zip file. Enable md5sum checking. The zip file itself is not signed, so you have to disable zip verification.

    Kernel sources
    Tree sources


    • OS Version: 12 (S)
    • Kernel: Linux 3.10
    • Kernel 3.10.108
    • New: Android security patch level: 5 February 2023
    • Using Sony blob's from stock version 32.4.A.1.54

    Important informations:
    • You should be familiar with general installation of custom ROMs.
    • Required for installation: TWRP 3.2.1 (pick the version from 2018-02-23!!!)
      OR use my self built TWRP-version 3.7.0!
    • This ROM needs a clean install, old /data may cause problems!
    • This ROM is NOT pre-rooted. For rooting you can use Magisk.
    • It is highly recommended that your device is running (or HAS RUN in the past!) the latest stock ROM from Sony (32.4.A.1.54) before flashing this ROM.
      Otherwise the baseband files may not match.
    • Audio
    • Bluetooth
    • New: Camera fully working!
    • Enforced SELinux support
    • Fingerprint (sometimes crashes)
    • FM-Radio (maybe it needs a few restarts before it's working)
    • GApps
    • German App AusweisApp2
    • GPS
    • Headset
    • LiveDisplay
    • Location services
    • Network Traffic Monitoring
    • NFC
    • Notifications
    • Notification LED
    • Offline charging
    • Phone calls
    • Reboot into recovery and bootloader
    • Sensors
    • Signed build
    • SMS
    • Sounds
    • Torch
    • WiFi
    • ...please tell me...
    These things are NOT (or badly) working:
    • Encryption
    • Payment
    • Streaming (mirroring)
    • VoLTE
    Maybe some more things are not working. Please tell me...

    Use this ROM at your own risk! It comes without any warranty! I'm not responsible for any damage! If you don't agree with that, don't try to flash this ROM in any way.


    • Added Aurora-Store, F-Droid and UnifiedNLP! If you don't want this, simply de-install it.
    • I've set maximum speaker volume to a higher value.
    • I've increased microphone gain.
    • I've changed the microfone gain to avoid echo in phone calls.


    • If you're running into an error, please search in this thread if this error is already posted, before you post it again!
      If not, I need a LOG to see what went wrong. Without a LOG I can't help you!
      A LOG can be fetched by connecting the device with an USB cable to your PC and then by typing these commands line by line:
      adb root
      adb shell logcat -b all -d > logcat
      Send my this LOG file via PM.
    • If you think this could be a SELinux related issue, please try to set the device to permissive mode first.
      If the issue is gone, I need the policy file too (plus LOG). Fetch it by typing this line in a terminal:
      adb pull /sys/fs/selinux/policy
    • If you stuck in a bootloop you can fetch a LOG with this trick:
      • Press the power button and the volume up button together until the device shuts down.
      • HOLD the power button.
      • Release the volume up button and press the volume down button immediately after releasing the volmue up button.
      • The device should start into TWRP recovery.
      • Tap on "Advanced", then on "Terminal" and enter these commands line by line:
        cd sys/fs/pstore
        cp * /sdcard
      • Send me the copied file(s), if any, via PM.

    One last request:

    Please, do not ask about problems for which my ROM is not responsible.
    From now on I will only react to problems that I can reproduce and that are caused by my ROM.

    I'm sorry for that, but I'm developing this ROM in my spare time and I still have a normal life.
    Dear Bernie-0815,

    Your ROM 19.1 works like a charm. Had it installed two weeks ago and tried all kinds of stuff; nothing failed so far. I just wanted to give you a very huge Thank You! for your efforts and your great work.

    I used the old official Lineage 14.1 until now because I was hesitant to try an 'unofficial' version. But your ROM has breathed new life into this smartphone which I attempt to keep for a number of reasons (small size, headphone jack, not interested in fancy new hardware etc.).

    So, I just wanted to reach out and thank you for making it possible to use older, yet absolutely functional smartphones longer. I recommended your ROM to a friend also using a Z5 compact (still with the stock Sony ROM) and think she'll soon go for it as well.

    Keep up the good work, and be assured that there are people out there still using the Z5 Compact on a daily base and in productive mode!
    New version out; see 1st post.
    • New icon set
    • Switched to Enforced SELinux mode
    • Switched to signed builds
    New version out; see 1st post.
    • Android security patch level: 5 May 2022
    New version out; see 1st post.
    • Updated from android-12.1.0_r7 to android-12.1.0_r11
    • Android security patch level: 5 July 2022