[ROM][UNOFFICIAL][12][S]LineageOS 19.1 for z5c (suzuran)

Search This thread


Jul 22, 2022
Here's how I did at first install of this ROM, probably I did something wrong then :D With your self built TWRP-version 3.6.2; clean caches, clean data, format data, install ROM, install NickGApps Omni, clean caches, reboot. Setup the phone with Google account, restore apps, settings etc. from some previous backup. Check through the settings of the phone and set those that did not come from the backup. Start your apps one by one to set them up and test if they work or not.
And on update I just booted to TWRP, installed the newer ROM and rebooted.


Senior Member
Sep 22, 2016
Sony Xperia Z5 Compact
The problem may be the NickGApps package. I don't use any GApps.
I'm always wiping these partitions when doing a clean install:


  • Screenshot_1975-08-22-21-50-11.png
    57.8 KB · Views: 24


Jul 22, 2022
On the first post there is GApps in the list of "working" things.... maybe you could try it?

I have thought that if I wipe the System-partition, I need to re-install TWRP. But probably I'm wrong then.


Senior Member
Sep 22, 2016
Sony Xperia Z5 Compact
I've written in my 1st post, that GApps is working; I've never written, that I'm using it. For sure I've tested it and at the point of my test it worked flawlessly.
TWRP is installed in the so called OTA partition, not in /system.
  • Like
Reactions: laakssim
I've written in my 1st post, that GApps is working; I've never written, that I'm using it. For sure I've tested it and at the point of my test it worked flawlessly.
TWRP is installed in the so called OTA partition, not in /system.
I use your TWRP v3.6.2.0-9, installed in the FOTAKernel partition. Might be related to the gapps package. I'm using Nikgapps.


Jul 22, 2022
Tried without Gapps and with very clean install, and still certain apps crash and reboot the phone. At least Instagram and that local banking app did it. I'm giving up as I need these apps.. well at least the banking app.


Senior Member
Jun 19, 2010
yes, it's great, network traffic is visible now.
reboots when some apps started (banking apps, ProtonVPN,...). i'm giving up for a while with 19.x
security lock with pattern (I tried 4x4) after setup returns to un-setuped
(I'm with 19 + magisk 25.2, no gapps)

Top Liked Posts

  • There are no posts matching your filters.
  • 1

    The thing is, a system webview cannot be installed without its signature being added to the system. Magisk can do that but I dit not want to temper with my boot and recovery images so I chose another solution using an overlay. Overlays install on top of an already installed system and override parts of it. There is a readily made overlay to add Bromite's signature that I installed using ADB and USB debugging (which allows debugging as root in the ROM you provide). After installing the overlay and rebooting, I first had troubles installing bromite webview directly from an APK, so I added their repo for F-Droid and installed it from there. It says it requires root to do so, but it actually does not since Bromite's signature was already added to the system.
    Then I chose Bromite's webview implementation from Android configuration panel (in the options for developpers).

    And tadaaa! It works now.
    If you're really using my sources, you should use my init script too. There you can see two reverts. One of them restores the creation of qti_camera_device_defaults:
    Thanks for that Berni - it gave me enough clues to get my unofficial Lineage for MicroG builds working for 19.1

    I have recently made unofficial and custom builds of LineageOS for microg for this device, based on Professor-Berni's most recent builds.

    The builds are available in this AndroidFileHost directory

    More information at https://codeberg.org/petefoths-projects/unofficial-l4m-builds
    So, I have uploaded 19.1 versions of these files to AndroidFileHost. I have tested them as follows

    UNOFFICIAL build https://www.androidfilehost.com/?fid=14871746926876822023
    - Calls, SMS, WiFi, mobile data, Camera all work
    - proximity sensor is not quite right. Screen goes blank when call is answered. Not restored unless you press e.g the the power button

    CUSTOM-PLUS build https://www.androidfilehost.com/?fid=14871746926876822024
    - as for UNOFFICIAL build PLUS
    - NextCloud and DAVx5 sync both work

    I ran into problems when I dirty flashed these over Berni's `lineage-19.1-20220824-SIGNED-suzuran.zip`. That may have been finger trouble, but I had to re-flash stock firmware with Flashtool, re-flash TWRP, then install my ROMs. They should install fine, if you format data in TWRP before flashing. Any feedback welcome :)
    Please try this version and report. I've changed the webview implementation.

    Sorry, the issue is still the same, and the same solution using Bromite webview still solves it. I have no idea what makes the original webview crash the whole system.
    New version out; see 1st post.
    • Android security patch level: 5 September 2022
    Is there still a problem with focusing in the camera?
    Sometimes yes, sometimes no.
    What is the maximum resolution for video recording?
    4K UHD. But that's very unstable. Sound and video is not synchron. Don't use it. HD 1080p is working better.
  • 10
    Hi all:

    Here is a LineageOS 19.1 ROM for Z5 compact (suzuran).

    Download 2022-09-11

    This is a 7z archive with the zip'ed ROM and the md5 file in it. Please unpack this archive, copy the included two files somewhere to your device, reboot into TWRP and flash this zip file. Enable md5sum checking. The zip file itself is not signed, so you have to disable zip verification.

    Kernel sources
    Tree sources


    • OS Version: 12 (S)
    • Kernel: Linux 3.10
    • Kernel 3.10.108
    • New: Android security patch level: 5 September 2022
    • Using Sony blob's from stock version 32.4.A.1.54

    Important informations:
    • You should be familiar with general installation of custom ROMs.
    • Required for installation: TWRP 3.2.1 (pick the version from 2018-02-23!!!)
      OR use my self built TWRP-version 3.6.2!
    • This ROM needs a clean install, old /data may cause problems!
    • This ROM is NOT pre-rooted. For rooting you can use Magisk.
    • It is highly recommended that your device is running (or HAS RUN in the past!) the latest stock ROM from Sony (32.4.A.1.54) before flashing this ROM.
      Otherwise the baseband files may not match.
    • Audio
    • Bluetooth
    • New: Camera fully working!
    • Enforced SELinux support
    • Fingerprint (sometimes crashes)
    • FM-Radio (maybe it needs a few restarts before it's working)
    • GApps
    • German App AusweisApp2
    • GPS
    • Headset
    • LiveDisplay
    • Location services
    • Network Traffic Monitoring
    • NFC
    • Notifications
    • Notification LED
    • Offline charging
    • Phone calls
    • Reboot into recovery and bootloader
    • Sensors
    • Signed build
    • SMS
    • Sounds
    • Torch
    • WiFi
    • ...please tell me...
    These things are NOT working (or badly working):
    • Encryption
    • Payment
    • Streaming (mirroring)
    • VoLTE
    Maybe some more things are not working. Please tell me...

    Use this ROM at your own risk! It comes without any warranty! I'm not responsible for any damage! If you don't agree with that, don't try to flash this ROM in any way.


    • Added Aurora-Store, F-Droid and UnifiedNLP! If you don't want this, simply de-install it.
    • I've set maximum speaker volume to a higher value.
    • I've increased microphone gain.
    • I've changed the microfone gain to avoid echo in phone calls.


    • If you're running into an error, please search in this thread if this error is already posted, before you post it again!
      If not, I need a LOG to see what went wrong. Without a LOG I can't help you!
      A LOG can be fetched by connecting the device with an USB cable to your PC and then by typing these commands line by line:
      adb root
      adb shell logcat -b all -d > logcat
      Send my this LOG file via PM.
    • If you think this could be a SELinux related issue, please try to set the device to permissive mode first.
      If the issue is gone, I need the policy file too (plus LOG). Fetch it by typing this line in a terminal:
      adb pull /sys/fs/selinux/policy
    • If you stuck in a bootloop you can fetch a LOG with this trick:
      • Press the power button and the volume up button together until the device shuts down.
      • HOLD the power button.
      • Release the volume up button and press the volume down button immediately after releasing the volmue up button.
      • The device should start into TWRP recovery.
      • Tap on "Advanced", then on "Terminal" and enter these commands line by line:
        cd sys/fs/pstore
        cp * /sdcard
      • Send me the copied file(s), if any, via PM.

    One last request:

    Please, do not ask about problems for which my ROM is not responsible.
    From now on I will only react to problems that I can reproduce and that are caused by my ROM.

    I'm sorry for that, but I'm developing this ROM in my spare time and I still have a normal life.
    New version out; see 1st post.
    • New icon set
    • Switched to Enforced SELinux mode
    • Switched to signed builds
    New version out; see 1st post.
    • LiveDisplay - Picture adjustment re-implemented (hopefully it works now!)
    New version out; see 1st post.
    • Android security patch level: 5 May 2022
    New version out; see 1st post.
    • Updated from android-12.1.0_r7 to android-12.1.0_r11
    • Android security patch level: 5 July 2022