[ROM][UNOFFICIAL][12L][EAS][OTA][SM-T820][SM-T825][2023-09-20] LineageOS 19.1 for Galaxy Tab S3

Search This thread
Jun 29, 2010
Hi everybody,

On my S3 I am getting from time to time a lethargic moment where apps no longer launch and buttons stop responding. Then it starts blinking with color bands across the screen until it naturally soft (?) restarts.
Annoying for the blinking part but no big deal if nothing suffers from it. Just not sure if it is solved in the newer LOS version or newer kernel ? (and not sure if @masdaster's newer build is sm-t825 only or if it would be okay on sm-t820).

Any idea/pointer welcomed :)


Senior Member
Jan 30, 2013
Thanks for the heads up. I may have to switch back to an earlier build then. Not having realiable wifi is a not good enough for me.

Hmmm. OK will look into that. I have my router set up so 5 and 2.4 are on the same channel, then the device selects which frequency to connect to. But to be fair ive not experienced this problem with other lineage builds. Ive had a bout 8 Samsung S5`s, currently 6 Galaxy tab S3`s, i have a oneplus 7 pro on lineage, and A galaxy S3 and a samsungs A54. I will try it out, if it doesnt resolve will have to shift to earlier build of Lineage..Ive never been bothered about latest or greatest just as long as it works. wifi drops aint good enough.
Have you get an version that the wifi works well?
For me the wifi plague is a constant in all versions.
Dec 26, 2017
HI onolox,
Sorry i never got round to changing to a different build. I have more pressing RL issues. im kind of relying on the coders to fix this. Not something i can do. Im patient.
Last edited:


Jan 14, 2022
I had zero problems installing this rom along with NikGapps-omni-arm64-12.1-20220413. I also installed Magisk 26.1 by patching the boot.img. The rom is stable and fast. My only problem is with the microphone/speakers not working during voice calls (and the video being messed up). Hopefully these will be getting fixed at some point. Is it possible that the microphone is simply somehow muted in the code?
Last edited:

Sonic Boom

Apr 21, 2009
Tampa, FL
Has anyone actually been able to return a Tab S3 back to stock? Sadly i tried this ROM on my soft bricked Galaxy tab S3 T820 and it seems to have had no effect, I can still reach it via odin3 though...since there are minimal directions other than "flash the rom" i put the files on the external SD and restored the recovery and then the boot but on reboot nothing happens and TWRP no longer launches when selecting recovery.
Last edited:
Has anyone actually been able to return a Tab S3 back to stock?
Yes, several times on T825.
Done it like @UweRammelt wrote.
..... "flash the rom" i put the files on the external SD
Best to do is store them in the same PC folder where you started Odin from.
and restored the recovery and then the boot but on reboot nothing happens and TWRP no longer launches when selecting recovery.
BUT why do you expect a working TWRP when you deleted it by flashing stock ROM??

Sonic Boom

Apr 21, 2009
Tampa, FL
Go to Download Mode (press and hold Power and Vol Down), then flash all four parts of the Original Samsung firmware.
Thank you, I've done that countless times. Not sure what i could be doing wrong. I'm selecting the below for my order. I've also done it with CSC and CP swapped and without CSC. I see it downloading, then PASS! in Odin and then reboot and it back to the download screen. IF I wipe to factory reset, it wipes, asks me if i want to enable read write or read only, I select leave as is. and I am back at TWRP.
AP SM-T820_1_20200501145641_h0dxr2w1l3_fac\AP_T820XXU3CTD5_CL17010817_QB30464690_REV00_user_low_ship_MULTI_CERT_meta_OS9.tar.md5
BL SM-T820_1_20200501145641_h0dxr2w1l3_fac\BL_T820XXU3CTD5_CL17010817_QB30464690_REV00_user_low_ship_MULTI_CERT.tar.md5
CP SM-T820_1_20200501145641_h0dxr2w1l3_fac\HOME_CSC_XAR_T820XAR3CTB1_CL16421493_QB29053944_REV00_user_low_ship_MULTI_CERT.tar.md5
CSC SM-T820_1_20200501145641_h0dxr2w1l3_fac\CSC_XAR_T820XAR3CTB1_CL16421493_QB29053944_REV00_user_low_ship_MULTI_CERT.tar.md5

Looks like I am using the wrong original Samsung firmware. If I recall , the tablet was purchased either directly from Samsung or as a package from Verizon. I am using SM-T820 for XAR which is Cellular South but should be using either XAA or VZW.. I cannot find either.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 30
    * Your warranty will be VOID after installing a custom ROM.
    * Get notified yourself that I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed.
    * Please do some research if you have any concerns about features included in this ROM
    * before flashing it!
    * YOU are choosing to make these modifications,
    * and if you point the finger at me for messing up your device,
    * I will laugh at you.

    # LineageOS

    LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    # What's working
    • Display/Touchscreen
      • LiveDisplay
    • Audio playback
      • Dolby Atmos
      • Headphone/Headset
      • Quad speakers
    • Video playback
      • HDR
    • Camera
    • Microphone
    • Sensors
    • Fingerprint sensor
    • GPS
    • LTE (SM-T825)
    • Hotspot
    • WiFi
    • WiFi display
    • Bluetooth
    • DRM
      • Widevine L1
    • Samsung Doze
    • S-Pen
      • Palm rejection
    • Hardware Encryption
      • MDFPP
    • SD Card
    • Power-off mode charging
    # Untested
    • FBE for userdata
    # What's not working
    • USB OTG
    • SELinux permissive
    • Please see the "Known issues" part of this post

    # Downloads

    ## LineageOS 19.1

    ## Google Apps
    • NikGapps
    • The other Gapps will work too, but I only confirmed that NikGapps working

    ## TWRP Recovery

    # How to install
    1. Unlock the bootloader.
    2. Download TWRP and flash the recovery image via Odin.
    3. Download LineageOS 19.1 for Galaxy Tab S3.
      • Be aware of the board name.
    4. Download GAPPS for Android 12L and the others you want to flash.
    5. Enter TWRP recovery.
      • The first boot to TWRP might be very slow because of the unmatched file systems.
    6. Format the whole system, data, cache partitions using the format menu.
      • You will type `yes` to do that.
    7. Flash the images.
      • If you're going to install GApps or something, you have to install the LineageOS first.
    8. Reboot the system.
    9. Done.

    # Known issues
    • Camera somewhat buggy
      • The built-in camera application (Camera2) is not working well. You can use another camera application like OpenCamera
      • Sometimes the camera doesn't work after booting. You can fix that back by just rebooting
      • On webcam chat apps, there is a vertical green bar and the color is not properly displayed
    • Audio bugs
      • No sound for the microphone and speaker in voice calls, such as the regular phone call or voice chat with a meeting app
    • OTG drives may show nothing even if it mounted
    • The side button on S-Pen is working but you must use the proper application that can handle the button event
    • Fast charging works (15W) but currently the kernel reports the wrong charging voltage and current
    • Thank all of you for the feedback

    # Sources

    # Telegram Groups
    • If you are interested in developing this potential machine, please tell me through PM then I will send you the invitation link.
    • If you need a general discussion channel for this potential machine or want to share the news of its Android projects from anyone to everyone, you can join our discussion group chat.

    # Buy me a coffee

    # Credits / Special thanks to
    • Android Open Source Project
    • LineageOS Team
    • LOS17.1) @Valera1978 for his amazing previous work including his MSM8996 kernel
    • LOS18.1) @supermike86 and @samsuffit for testing LineageOS 18.1 for T820, which is I don't have one
    • LOS18.1) @bmwdroid and @cherepanov for confirming the LTE works
    • LOS18.1) @sebmue for letting me know that the useful information for palm rejection, and @ghostwheel for sharing its working source codes on Android 9
    • General) @switchgott for helping me in the development discussion and creating Telegram groups
    • General) All from our Telegram discussion channel, @EonOfBlack , Sands, David Becker, ...
    • LOS18.1) @LuK1337 for giving me a hint to fix the quad-speakers
    • LOS19.1) @followmsi , @html6405 , @ThE_MarD for giving me a hint to bring up Android 12
    • LOS19.1) @masdaster for the fix of MDFPP Keystore on our device
    ## Changelogs
    • 2023. 9. 20
      • gts3l-common: Syned with the latest LineageOS source
        • Applied the new security patch on September 5, 2023
      • gts3l-common: Switch to LineageOS's Samsung light HAL
      • gts3l-common: Switch to LineageOS's Samsung LiveDisplay HAL
      • gts3l-common: Fix camera torch-related weird behaviors
      • gts3l-common: Add support for OTA update
    • 2022. 9. 23
      • Synced with the latest LineageOS 19.1 repositories
        • Security patch by September 5, 2022
    • 2022. 8. 15
      • Synced with the latest LineageOS 19.1 repositories
        • android-12.1.0_r22
        • Security patch by August 5, 2022
      • About Keystore, switch to use MDFPP skeymast files again.
        • This will break your lock screen. Please remove `/data/system/locksettings.db` file using TWRP, then lock screen will be fixed and your biometric information will be removed. Please reset your biometric lock method again. Sorry for the inconvenience.
        • Thank you for the idea and contribution for the proper use of our MDFPP Keystore, @masdaster :)
    • 2022. 7. 15
      • Synced with the latest LineageOS 19.1 repositories
        • android-12.1.0_r11
        • Security patch by July 5, 2022
      • Added support for Sony DualShock 4 gamepad
      • Increased headphone jack volume by about 20%
      • Updated USB HAL to v1.3
    • 2022. 6. 11
    • 2022. 4. 16
      • Synced with the latest LineageOS 19.1 repositories
        • android-12.1.0_r4
      • Fixed the boot failure issue for some users
        • It is related to the Keystore of the Android system, I did a little compromise to make it work for all users
        • If you are using the first version (220320), you have to clean install to this version or you may fail to unlock the screen , you have to boot into TWRP and remove the file `locksettings.db` under `/data/system` directory. This will resolve the unlock failure issue after dirty-flashing it.
          • Thanks for this information, David Becker. :)
    • 2022. 3. 20
      • Initial release
    ## Special Notes
    • You must do clean-install if you are willing to upgrade from another ROM such as an Android 11 based one
    • I have tested Magisk 24.3 working
      • You can fix SafetyNet using Magisk modules, SafetyNet Fix and PropsConfig
    • You can hide the soft nav buttons on the bottom bar. This is the workaround.
      • 1. Go to "System -> Buttons" and check "Enable on-screen nav bar" to enable soft nav bar temporarily
      • 2. Go to "System -> Gestures" and set "System navigation" to "Gesture navigation"
      • 3. Go back to "System -> Buttons" and check "Enable on-screen nav bar" again to disable soft nav bar and enable hardware key.
    • You can hide the bottom Taskbar. This is the workaround.
      • 1. Go to "System -> Buttons" and check "Enable on-screen nav bar" to enable soft nav bar temporarily
      • 2. Go back using navigation bar and go to the "Buttons" menu again
      • 3. Then we can see the "Enable taskbar" option that we couldn't see before. Disable that option.
      • 4. And disable "Enable on-screen nav bar" option again to use the hardware buttons back.
    Hello all,

    After numerous tries, I could fix the camera and the Bluetooth/Headphone jack audio working.

    The camera is back, but still has some bugs, unfortunately.
    First, we can't use the default camera app, Camera2. It takes a shot but the result is cracked. But we can use a third party app like OpenCamera.
    And, there is something weird on the Torch. After using the camera with the flashlight, sometimes the Torch tile on the quick settings is broken, it just said "camera in use". But we still can use the camera.
    Lastly, sometimes the camera doesn't work at all after rebooting. Fortunately, it is easily fixed by rebooting again. I don't know why it is well.

    Now our audio HAL is built from the source. Previously, we were using audio HAL version 4.0 which is for Android 9 but now we're using version 6.0 which is for Android 11. I can move on to version 7.0, yeah, which is for Android 12, but from this version the configurations have to be modified in many ways so I just pended it.
    I had to supplement some audio configurations because of the compatibility of each version, maybe some audio scenarios were broken compared to our LineageOS 18.1. But I confirmed for most used scenarios like the quad-speaker, Bluetooth audio, headphone jack, and wireless display audio, so in most cases it will work well.

    I think, we can deprecate our LineageOS 18.1 now because our LOS 19.1 has no fewer features than LOS 18.1. :)
    The new version of LineageOS 19 is uploaded now.

    This version has upstream LineageOS changes that comes with Android 12.1 r22, and a fix for Keystore to use hardware encryption in Samsung way properly.

    In the first LineageOS 19.1 version, it uses some special files from the other partition but for some reason, it broke the boot sequence because of the delay and the permission issues. So I broke the loading of that special files and it would fix that boot failure problem.

    Now, thanks to @masdaster , I can fix the boot failure and finally we can use the proper hardware encryption.

    Thank you, and please note that the changelogs to fix the lock screen issue caused by changing the Keystore method.