[ROM][UNOFFICIAL][13.0][OTA][Signature Spoofing][Open Source][Encryption] LineageOS 20 for Galaxy Note10/Note10+/Note10+ 5G Exynos

Search This thread


Dec 5, 2020
@Linux4 lovin' your work bro :D currently on your official 19 build with no probs at all 😇 can I upgrade 19 official -> 20 unofficial with overwrite or do I need to start over? will 20 go official?


New member
Feb 15, 2023
Bug Report: Just installed on my N976B.
Top speaker sounds great, bottom speaker sounds terrible, tin like and somewhat distorted.
Audio was fine on Android 12.
Can anyone else confirm?


Jan 13, 2023
Banking apps working (100% For me...)
First I flashed the ROM + Gapps then did the basic config by connecting to wifi but without logging into my Google account. Then I installed magisk in normal mode (Magisk 25.2 APK + patching image). Then I flashed Lygisk by the recovery (Rename the “app-release.apk” file in .zip then flash). I then, after checking "systemless Host" but not "zygisk" in the configuration menu, installed (without restarting between each) the modules "MagiskHide Props Config" + "Shamiko" + "Universal SafetyNet Fix" (V2. 4 Kdrag0n) + "zygisk - LSPosed".
After reboot I checked "zygisk" in the configuration menu then installed the modules "Diia Tweaks" and Play integrity bypass" in LSPosed. Reboot.
In the blacklist of magisk (Do not impose the exclusion list !) i checked the boxes for the following system apps :
- Google play store: "Com.android.vending"
- Google play services: "Com.google.android.gms" and "Com.google.android.gms.unstable". Reboot.
After that I finalized the configuration of my google account and installed my banking applications through the play store. Finally (before even trying to open them) I checked my banking applications in the Lygisk blacklist as well as in the 2 modules of LSPosed. Reboot.
Et voila (I hope...)!

PS : This procedure is there to help you but I do not in any way guarantee its reliability or that it is the right thing to do. This is the method that worked for me after multiple failures...


Sep 2, 2008
Has anyone had any issues with the recording of voice, using the standard camera software? Records the picture fine, but the sound is like a dalek lol


Nov 22, 2017
Which camera (stock or g-cam) has been used in this ROM?

And is there any issue regarding VOI/ VOLTE/VoWIFI ?

My device is Samsung Galaxy Note 10+


Senior Member
May 18, 2011
hi guys, i have lygisk installed with shamiko and i tried to update shamiko from the ligisk app but my phone is now bootlooping. what can be done ? i tried to rename the lygisk app to uninstall.zip and flash it by the recovery as i have read online this fix but the phone still bootlooping.

LOS 20.0 latest build

Another question: is there any way to make a full backup in the future and restore if something like this happen ? Maybe you guys use some app?

any help is appreciated
Last edited:


New member
Dec 3, 2020
Can i dirty flash the official build of LineageOS for Note 10 +? (link)
Thanks in advance.

Reply to myself: no.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 12

    LineageOS is a free, community built, aftermarket firmware distribution of Android 13, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    • Follow the instructions here


    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • DO NOT Report bugs if you're using TWRP
    • DO NOT Report bugs while having Magisk installed (especially with Zygisk enabled)
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    Did you--
    restore with titanium backup:
    reboot after having the issue:
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    Telegram group

    Source Code: https://github.com/LineageOS
    Kernel source: https://github.com/Linux4/android_kernel_samsung_exynos9820/tree/lineage-20.0
    Pre-Install Instructions

    Warning: The following instructions will unlock the bootloader and wipe all userdata on the device.

    1. Connect the device to a Wi-Fi network.
    2. Enable Developer Options by pressing the “Build Number” option in the “Settings” app within the “About” menu
      • From within the Developer options menu, enable OEM unlock.
    3. Power off the device, and boot it into download mode:
      • With the device powered off, hold Volume Down + Volume Up and connect USB cable to PC.
      • Now, click the button that the onscren instructions coorelate to “Continue” and/or “Unlock Bootloader”.
    4. Your device will reboot, you may now unplug the USB cable from your device.
    5. The device will demand you format userdata, please follow the onscreen instructions to do so.
    6. Run through Android Setup skipping everything you can, then connect the device to a Wi-Fi network.
    7. Re-enable Development settings by clicking the “Build Number” option 10 times, in the “Settings” app within the “About” menu, and verify that “OEM Unlock” is still enabled in the “Developer options” menu.

    Installing LineageOS for the first time
    1. Flash lineage recovery
      Only the provided lineage recovery will be supported,
      using TWRP might result in a possible data loss!!

      If using Odin rename the lineage recovery image for your model to recovery.img and add it to a .tar archive using e.g 7zip.
      If using Heimdall use: heimdall flash --RECOVERY recovery.img --no-reboot
    2. Boot lineage recovery
      IMPORTANT: Do not boot into system again before booting recovery, or system will restore stock recovery!
      If using Odin untick auto-reboot before flashing.
      After flashing reboot by pressing Volume Down and Power for approximately 7 seconds,
      immediately hold Volume Up and Power to boot recovery
      IMPORTANT: As of OneUI 3 your device needs to be connected to a PC via USB cable in order to be able to
      boot recovery via Volume Up, Bixby and Power.
    3. Factory reset using Factory reset -> Format data/factory reset
      Warning: Unlike TWRP this will also erase internal storage!
    4. Sideload LineageOS by enabling sideload via Apply Update -> Apply from ADB
      Then run adb sideload <path to your lineage.zip> on your PC
    5. Sideload GApps and magisk by repeating above step
      with their zip/apk

    As this ROM has a working ramdisk sideloading the magisk apk is enough, just as it is
    on every other device, no bootimage with magisk included or installing to recovery is needed!
    I also strongly recommend to use Lygisk instead,
    which is a fork of Magisk that aims to improve support for devices with FBE that can't (and shouldn't anyways!) decrypt userdata in recovery,
    this will also fix OTAs getting stuck while having installed Magisk.

    • SELinux enforcing
    • AES-256-XTS FBE encryption
    • All cameras are working
    • Ramdisk is working

    Known issues

    • VoLTE/VoWiFi
    • You tell me
    • Likely more
    Hello, I have read a lot but I do not understand. Why is there a firmware part? I don't know how to set this up.
    Do you need odin for the .tar format? I would appreciate any information you give on this issue.
    The system works without installing it, but if it will work better when I install it, I'm thinking of installing it as well. if you tell me how to do it.

    You do not need and should NEVER update your firmware yourself anymore on T (for why I said "NEVER" see the recent issues with HVJ* firmwares). That was a leftover of when firmware was not yet shipped with the builds. Removed, thanks for making me aware of that.

    Main phone is fold 4 and I wanna try this on my note 10+.
    So after reading here I understand that v20 is slightly buggy and v19 works flawlessly.
    Have I understood this correctly ?