[ROM][UNOFFICIAL][13.0][OTA][Signature Spoofing][Open Source][Encryption] LineageOS 20 for Galaxy S10e/S10/S10+/S10 5G Exynos

Search This thread

ZmisiS

Senior Member
Dec 23, 2011
3,066
711
59
Livno
On which firmware can be installed a new version of this unofficial Lineage OS 20 of 20221204?
 

cappuccini

Senior Member
Nov 16, 2022
133
27
The installed stock firmware seems to be important, currently I am on HVG. should I upgrade to HVI, possible would be even HVK. Which is the best base?
 
@Linux4
I have E bootloader which I can switch between android 11 and 12. today i installed lineage os 20 with lineage recovery in your here, then i wanted to revert to again android 11 one ui 3.1 sw rev check fail(bootloader) device 16 binary 14 error, otherwise... otherwise... this.. .this... i guess it means that the bootloader version is upgraded? so i won't be able to go back to android 11 again? 😢😭
did you put the file that upgraded the bootloader version in the rom package? 🥺
 
Last edited:
  • Like
Reactions: Ryu--X

Pilzinsel64

Member
Mar 29, 2017
11
0
Is is possible/supported to update from your Official LinageOS 19 build to this Unofficial LineageOS 20 build?
Or are you plaing to bring an official build for LineageOS 20 in the future too?
Because regarding your comment here it probably isn't. I'm also not sure if there is any big difference between your unofficial and official build.

Not sure if this has been asked here before, but I can't find anything about in all the posts.

(Btw, thank you a lot for keep working on that builds at all! ♥ It's not a matter of course.)
 
Last edited:

cappuccini

Senior Member
Nov 16, 2022
133
27
The battery consumption increased noticeably:
stock overnight in airplane mode 3-4%.
LOS20 overnight in airplane mode about 6%

no root
 
  • Like
Reactions: Ryu--X

euphore

Senior Member
Jun 16, 2017
77
17
guys, need your help :( , I'm stuck in bootloop and I have no Idea why.

Yesterday my battery was drained to 0%.
I charged it only for a minute (it boots!), and after it shuts down for second time, I'm causing a bootloop.
I tried to dirtyflash latest LOS, but still bootloop.

recovery is stock los, not twrp.
lygisk installed instead magisk.

nothing more, nothing less. did nothing unexpected..

any ideas? i thought maybe boot into twrp and swith a/b slots?
 

Top Liked Posts

  • 1
    Can on this rom to have working Google wallet (former google pay) ?
    No, it is not working.
  • 4
    Speaking of the new update (2023-01-15), am I the only one that get "system spoofs signature" unchecked after updating in microG?
    And of course all app complaining about no gms found
    I am observing same behavior. Signature spoofing seems to be not working in Jan 15 2023 update.
    3
    Speaking of the new update (2023-01-15), am I the only one that get "system spoofs signature" unchecked after updating in microG?
    And of course all app complaining about no gms found
    Same here, reinstalled MicroG, but same issue. Think the update broke the sig. spoofing mechanism.
    3
    New update with signature spoofing back !!

    Than-you for the amazing foolow-up and work @Linux4 👏👏
    2
    @Linux4 Thanks a lot for this! Any chance this will become the official LOS 20?
    2
    Speaking of the new update (2023-01-15), am I the only one that get "system spoofs signature" unchecked after updating in microG?
    And of course all app complaining about no gms found
  • 18
    1607247455067.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 13, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions:
    • Follow the instructions here

    Downloads:

    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • DO NOT Report bugs if you're using TWRP
    • DO NOT Report bugs while having Magisk installed (especially with Zygisk enabled)
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log

    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
    
    Did you--
    wipe:
    restore with titanium backup:
    reboot after having the issue:
    
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
    
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:


    Support
    Telegram group

    Contributors
    Linux4
    Source Code: https://github.com/LineageOS
    Kernel source: https://github.com/Linux4/android_kernel_samsung_exynos9820/tree/lineage-20.0
    12
    Pre-Install Instructions

    Warning: The following instructions will unlock the bootloader and wipe all userdata on the device.

    1. Connect the device to a Wi-Fi network.
    2. Enable Developer Options by pressing the “Build Number” option in the “Settings” app within the “About” menu
      • From within the Developer options menu, enable OEM unlock.
    3. Power off the device, and boot it into download mode:
      • With the device powered off, hold Volume Down + Bixby and connect USB cable to PC.
      • Now, click the button that the onscren instructions coorelate to “Continue” and/or “Unlock Bootloader”.
    4. Your device will reboot, you may now unplug the USB cable from your device.
    5. The device will demand you format userdata, please follow the onscreen instructions to do so.
    6. Run through Android Setup skipping everything you can, then connect the device to a Wi-Fi network.
    7. Re-enable Development settings by clicking the “Build Number” option 10 times, in the “Settings” app within the “About” menu, and verify that “OEM Unlock” is still enabled in the “Developer options” menu.

    Installing LineageOS for the first time
    1. Flash lineage recovery
      Only the provided lineage recovery will be supported,
      using TWRP might result in a possible data loss!!

      If using Odin rename the lineage recovery image for your model to recovery.img and add it to a .tar archive using e.g 7zip.
      If using Heimdall use: heimdall flash --RECOVERY recovery.img --no-reboot
    2. Boot lineage recovery
      IMPORTANT: Do not boot into system again before booting recovery, or system will restore stock recovery!
      If using Odin untick auto-reboot before flashing.
      After flashing reboot by pressing Volume Down and Power for approximately 7 seconds,
      immediately hold Volume Up, Bixby and Power to boot recovery
      IMPORTANT: As of OneUI 3 your device needs to be connected to a PC via USB cable in order to be able to
      boot recovery via Volume Up, Bixby and Power.
    3. Factory reset using Factory reset -> Format data/factory reset
      Warning: Unlike TWRP this will also erase internal storage!
    4. Sideload LineageOS by enabling sideload via Apply Update -> Apply from ADB
      Then run adb sideload <path to your lineage.zip> on your PC
      Optional:
    5. Sideload GApps and Lygisk by repeating above step
      with their zip/apk

    Magisk
    As this ROM has a working ramdisk sideloading the magisk apk is enough, just as it is
    on every other device, no bootimage with magisk included or installing to recovery is needed!
    I also strongly recommend to use Lygisk instead,
    which is a fork of Magisk that aims to improve support for devices with FBE that can't (and shouldn't anyways!) decrypt userdata in recovery,
    this will also fix OTAs getting stuck while having installed Magisk.
    8
    Features

    • SELinux enforcing
    • AES-256-XTS FBE encryption
    • All cameras are working
    • Ramdisk is working

    Known issues

    • VoLTE/VoWiFi
    • You tell me
    • Likely more
    7
    Updated with September securitypatch and more lineage features
    6
    For everyone who upgraded to HVJ1 firmware, for all models there's a HVI4 build that has binary version 'G' too, at least for some CSCs, you should be able to downgrade to that and have it working again.
    I'd recommend to use samfw.com over sammobile tho since that one has faster free download.
    FYI that problem cannot be resolved without first getting new kernel sources from samsung... and next time: Don't update your firmware manually anymore, I will take care of it on 20.