• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][8.1.0][tb8703f/x/r/n] LineageOS 15.1 for Lenovo TAB 3 8 plus P8

Search This thread

highwaystar_ru

Senior Member
Sep 17, 2016
342
2,354
http%3A%2F%2Ffiles.paulfasola.fr%2FCyanogenMod%2FLineageOS.png


Code:
/*
 * I'm not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed (like it did for me...). 
 * Please do some research if you have any concerns about features included in the products you find here before flashing it! 
 * YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you. 
 * Your warranty will be void if you tamper with any part of your device / software.
 * Same statement for XDA.
 */

LineageOS is a free, community built, aftermarket firmware distribution of Android 8 (oreo), which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.


What works:
Calls/SMS/Mobile data
Wifi
Bluetooth
GPS
Camera
Audio
FM radio
Torchlight
USB and WLAN tethering

Broken
You tell me

Source code:
device : https://github.com/HighwayStar/android_device_lenovo_TB8703/tree/lineage-15.1
kernel: https://github.com/HighwayStar/android_kernel_lenovo_msm8953/tree/lineage-15.1-common
vendor: https://github.com/HighwayStar/android_vendor_lenovo_TB8703/tree/lineage-15.1

2018-09-26
  • Updated audio configs
  • Updated mount options for /data partition, should increase performance and prolong flash life
  • Added missing powerhint.xml, should improve powersave in idle mode and more performance in demanding apps.
mailru: lineage-15.1-20180926-UNOFFICIAL-TB8703.zip
gdrive: lineage-15.1-20180926-UNOFFICIAL-TB8703.zip

Previous versions:
2018-08-26
  • Updated kernel
  • Added support for exfat sd cards
mailru: lineage-15.1-20180826-UNOFFICIAL-TB8703.zip
gdrive: lineage-15.1-20180826-UNOFFICIAL-TB8703.zip

2018-08-25
  • Fixed long time to wakeup screen
mailru: lineage-15.1-20180825-UNOFFICIAL-TB8703.zip
gdrive: lineage-15.1-20180825-UNOFFICIAL-TB8703.zip

2018-08-24
  • Fixed system crash when using WiFi hotspot mode
  • Updated Lineage code
mailru: lineage-15.1-20180824-UNOFFICIAL-TB8703.zip
gdrive: lineage-15.1-20180824-UNOFFICIAL-TB8703.zip

2018-08-18
  • Fixed MAC and long time to enable Wifi
  • Fixed MAC and long time to enable Bluetooth
  • Fixed calling with BT headset
  • Fixed Buttons settings
  • Partially fixed LED
mailru: lineage-15.1-20180818-UNOFFICIAL-TB8703.zip
gdrive: lineage-15.1-20180818-UNOFFICIAL-TB8703.zip
2018-08-16
  • Initial release
  • Full sources published
mailru: lineage-15.1-20180816-UNOFFICIAL-TB8703.zip
gdrive: lineage-15.1-20180816-UNOFFICIAL-TB8703.zip

How to install
To install this you have to install TWRP using by QFIL utility, follow this instruction: https://forum.xda-developers.com/general/general/twrp-lenovo-p8-tb-8703f-tb-8703x-t3689442/post76277192

Special TWRP build
To install and boot any custom roms and to boot it after installing mods that change boot partitition like Magisk please use this TWRP:
2018-08-25
  • Fixed long time to wakeup screen in TWRP
  • Added NTFS filesystem for sdcards
mailru: twrp-tb8703-3.2.1-20180825-bootsign.img
gdrive: twrp-tb8703-3.2.1-20180825-bootsign.img

Previous version

[*] Первая версия
mailru: twrp-tb8703-3.2.1-bootsign.img
gdrive: twrp-tb8703-3.2.1-bootsign.img

This TWRP build has special function Sign boot which you have to click after install new version of ROM or mod like Magisk. It will append stock boot signature to your boot partition. This allows to boot with locked bootloader.
TWRP with Boot Sign function screenshots:

Fortunately you dont need to unlock bootloader, because not every Lenovo tab can be unlocked. Custom kernel and ROM can be runned by appending boot.sig signature extracted from stock rom to boot.img like
Code:
cat boot.img boot.sig > boot-signed.img
It still cant be loaded by fastboot, but you always can flash it from TWRP. You can get boot.sig in my repo https://github.com/HighwayStar/android_device_lenovo_TB8703/blob/cm-14.1/twrp/recovery/root/boot.sig

XDA:DevDB Information
[ROM][UNOFFICIAL][8.1.0][tb8703f/x/r/n] LineageOS 15.1 for Lenovo TAB 3 8 plus P8, ROM for the Lenovo Thinkpad Tablet

Contributors
highwaystar_ru
Source Code: https://github.com/HighwayStar/android_kernel_lenovo_msm8953/tree/lineage-15.1-common

ROM OS Version: 8.x Oreo
ROM Kernel: Linux 3.10.x
Based On: LineageOs

Version Information
Status: Testing

Created 2018-08-16
Last Updated 2018-09-26
 

hehk1234

Senior Member
Apr 10, 2014
475
232
You're rock, thanks. If you give for us custom kernel with overclock, the community will aprecciate. Thanks Sir for your hard work here.

---------- Post added at 02:19 PM ---------- Previous post was at 02:17 PM ----------

One bug I found on LOS 14.1, please look at topic from LOS 14.1, and you will see.
 

wbn1

Senior Member
Nov 29, 2016
78
55
8703F
Hotspot doesn't work. I can turn it on but my computer and phone don't see the network; if I turn it on-off-on it causes the tablet to crash into a soft restart. It will then show 'Error'. There is no 5GHZ option when creating a hotspot. I posted this in the other thread aswell.
System/Buttons/Show arrow keys while typing doesn't work in landscape mode. They will appear in the middle of the navigation bar on top of the circle and will make the nav bar unusable.
I don't know if this is a feature, but in landscape mode if I swipe from the right end of the screen towards the center the status bar drops down.
 
  • Like
Reactions: midterm_2003

Loganlogin

New member
Aug 5, 2018
4
1
Awesome! Thanks for the great effort!
LOS15.1 works perfectly:good: (18/8 version)

The only problem which I can find is gapp camera's shutter button shift down to the home button bar, half of the shutter button is hided.:fingers-crossed:
 
  • Like
Reactions: joop76

lu99ke

Senior Member
Aug 20, 2014
377
150
Newcastle
I get
"updater process ended with ERROR: 7
Error installing zip file "xxxxxxxxxx"

I was coming from the your 14.1 ROM - latest update from August. did a full wipe beforehand... made no difference.

Tried to dowload the file from both g-drive and mailru .. same result.. :(

any ideas?
 

maikalex96

Member
Jan 3, 2018
16
4
I finally install Lineage OS in My Tablet. I try to install gapps version 8.1.0 ARM 64 from opengapps and then sign the boot partition after flash the gapps. System boots normally but gapps crashes constantly. Any gapps working? Or any information about how to install correctly gapps. Thanks. :confused:

**Update**

I just Wipe Data and then sign boot again. Then I configure my device and Now is Working with the Whole Google Apps and is now Android 8.1.0. Thanks for the developer for the Rom
 
Last edited:

tomas.vala

Member
Aug 19, 2018
9
6
Thanks a lot for your work on this ROM!

I've had exactly same experience with gapps crashing (MindTheGapps-8.1.0-arm64-20180223_195845.zip) as maikalex96 above. Wipe fixed the problem. Not feeling adventurous enough to try Open gapps yet.

good:
  • usual stuff works
  • WiFi 5GHz works
  • WiDi / Miracast, Chromecast works
  • Apk installations/updates are lightning fast compared to 6.0.1 stock

not so good:
  • bluetooth (albeit disabled) drains battery like crazy in standby - either that or andriod battery stats are not working right (WLAN, display items are not even listed)
  • no Dolby Atmos in LOS
  • some useful features removed in Oreo (google seem to be dumbing the system down) - no more WiFi band option (2.4/5), no more WiFi in standby option (on, off, charger on)
  • not a fan of some Oreo or LOS aesthetics
  • sound is not routed back to speakers after disconnecting headphones (not always)
  • not sure about performance, stock 6.0.1 might be a tad more responsive (touch, scrolling)

untested:
  • phone, lte data
  • sd card

That's on tb8703x.
 

lu99ke

Senior Member
Aug 20, 2014
377
150
Newcastle
post /tmp/recovery.log

here it is..

*** Update****

So I just realised I hadn't updated TWRP to the new boot-signed version.

It won't let me do flash that via fastboot as it says " FAILED (remote: Partition flashing is not allowed " - I assume this is because my bootloader is not unlocked.

I did try using 'fasboot oem unlock" but that does not work.

I tried to use QFIL to flash the updated TWRP but it won't recognise the device on any port as obviously it is not going into stock recovery when - it is going into TWRP...

Any other ideas?

Any help is most appreciated - many thanks in advance.

:)

*******Update #2*****

Thanks to WBN1 as below, all sorted and installed - many thanks!

Will let you know how it goes!

Many thanks again for all your hard work!
 

Attachments

  • recovery.log
    26.7 KB · Views: 74
Last edited:

ziggy815

Member
Jan 18, 2017
31
5
Cologne
Hey there, great ROM! Everything works good here. I only have one question, not directly about the ROM itself... but does anyone know if there is a version of the LOS 14.1 Trebuchet Launcher for using under LOS 15.1 ? I realy hate that new Launcher!
 

Frusciantism

Member
Jul 29, 2018
11
0
Congratulations on the job.

any way to use otg and power at the same time? want to use the tablet in the car you need to have the power connected as well as the easycam with the recoil camera

thanks a lot
 

Top Liked Posts