• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][9.0][tb8704f/x] LineageOS 16.0 for Lenovo TAB4 8 plus

Search This thread

highwaystar_ru

Senior Member
Sep 17, 2016
342
2,355
http%3A%2F%2Ffiles.paulfasola.fr%2FCyanogenMod%2FLineageOS.png


Code:
/*
 * I'm not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed (like it did for me...). 
 * Please do some research if you have any concerns about features included in the products you find here before flashing it! 
 * YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you. 
 * Your warranty will be void if you tamper with any part of your device / software.
 * Same statement for XDA.
 */

LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (pie), which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.


What works:
Calls/SMS/Mobile data
Wifi
Bluetooth
GPS
Camera
Audio
FM radio
Torchlight
LED
USB and WLAN tethering
Fingerprint sensor
Broken
You tell me

Source code:
device : https://github.com/lenovo-devs/android_device_lenovo_TB8704, https://github.com/lenovo-devs/android_device_lenovo_tb-common
kernel: https://github.com/lenovo-devs/android_kernel_lenovo_msm8953/tree/lineage-16.0
vendor: https://github.com/lenovo-devs/proprietary_vendor_lenovo

2020-03-20
  • Enable DT2W
  • Update Lineage code
mailru: lineage-16.0-20200320-UNOFFICIAL-TB8704.zip
gdrive: lineage-16.0-20200320-UNOFFICIAL-TB8704.zip
boot.img for TB-8704V: boot-los16.0-tb8704v-test20200320.img (source code)

Previous versions:

2019-12-27
  • Fixed fingerprint scaner issue
mailru: lineage-16.0-20191227-UNOFFICIAL-TB8704.zip
gdrive: lineage-16.0-20191227-UNOFFICIAL-TB8704.zip
boot.img for TB-8704V: boot-los16.0-tb8704v-test20200316.img (source code)

2019-12-25
  • Fixed OTG mode
  • enable target ttl for thethering with some operators
  • Updated Lineage code
mailru: lineage-16.0-20191225-UNOFFICIAL-TB8704.zip
gdrive: lineage-16.0-20191225-UNOFFICIAL-TB8704.zip

2019-08-11
  • Fixed insert/remove detection for 3.5'' headset plug
  • Updated Lineage code
mailru: lineage-16.0-20190811-UNOFFICIAL-TB8704.zip
gdrive: lineage-16.0-20190811-UNOFFICIAL-TB8704.zip

2019-07-14
  • Initial release
mailru: lineage-16.0-20190721-UNOFFICIAL-TB8704.zip
gdrive: lineage-16.0-20190721-UNOFFICIAL-TB8704.zip


How to install
You have to had TWRP installed from this thread TWRP and ROOT for Tab 4 8/10 (Plus) (TB-8704X/F/V,TB-X704L/F, TB-8504X/F, TB-X304L/F)

In TWRP clean Data if you coming from stock ROM and do Install of this ROM. If you have android 8 stock rom installed you have to format Data with data loss, because used encryption is incompatible with android 7.1

TB-8704V (Verizon)
If you have TB-8704V tablet, you have to additionaly flash boot.img from link above after rom intsallation. This tablet has some hardware differences from x and f and requires custom kernel to work,

Thanks
Big thank to @mistersixt, who donated $$ for device.

XDA:DevDB Information
[ROM][UNOFFICIAL][9.0][tb8704f/x] LineageOS 16.0 for Lenovo TAB4 8 plus, ROM for the Lenovo Thinkpad Tablet

Contributors
highwaystar_ru
Source Code: https://github.com/lenovo-devs/android_kernel_lenovo_msm8953/tree/lineage-16.0-wip

ROM OS Version: 7.x Nougat
ROM Kernel: Linux 3.10.x
Based On: LineageOs

Version Information
Status: Testing

Created 2019-07-21
Last Updated 2019-08-11
 
Last edited:

cal028

Member
Jul 5, 2010
9
2
Can't seem to get it boot on tb8704v (boot loop). I have unlocked rebooted and made sure oem unlock was still checked and installed twrp-3.2.3-0-tb_8704v and then installed rom and gapps. But it just boot loops on restart. I'm missing something?
 

andyskelly

Senior Member
Mar 28, 2013
53
14
Yes, I'm on TB-8704F. Previously installed 14.1 without issue.
Did a clean install: format DATA and cache; again tried with clearing SYSTEM folder as well.

After installing, reboots as normal thenstuck on Lineage ARC loading with no end; left it alone for 30mins but never load into OS.
I did the same . but I had stock 8.1 installed. I installed mindthegapps as well as the ROM and rebooted and everything seems to be working fine.
 

lunytune89

Member
Jul 22, 2019
7
1
I also had 14.1 installed before. Unfortunately I have the same problem as Acel337. I have the tb8704x.

Has anyone found a solution yet?
14.1 starts without problems after flashing again.
 

kc12

Senior Member
Aug 10, 2013
491
128
Sarasota
I dirty flashed over los 14. Then flashed openGapps 9 pico. Then reflashed the latest magisk. ROM boots after about 5 minutes without any issues.
Chrome reloads on occasion. I have root, don't have rw. The remount script doesn't work. Netflix casts well. That's as far as I've got.

Thank you for this!

Update: rw now working
 
Last edited:
  • Like
Reactions: suhridkhan

hunnia41

Member
Apr 16, 2015
32
8
Yes, I'm on TB-8704F. Previously installed 14.1 without issue.
Did a clean install: format DATA and cache; again tried with clearing SYSTEM folder as well.

After installing, reboots as normal thenstuck on Lineage ARC loading with no end; left it alone for 30mins but never load into OS.

For me evrythin works
8.0 stock rom
install magisk
install twrp
system writable
erase system data.
sideload pie and gapps.
Everyhing works perfectly.
Maybe the difference, that I started from 8.1 stock
Just a thought. It could be, that indirectly the (wrong) encryption cause the problem. Since when booting, the program tries to populate the data partition, and if it cannot do it, since it appears as 0 storage, it might just stuck in a loop.
 
Last edited:
  • Like
Reactions: Acel337

Hemphiz

Senior Member
Sep 12, 2015
923
312
Bristol
m.9gag.com
Installed from stock 8.0 plop to Los16 with Pico gapps. Format data - reboot to recovery then continue with flash procedures (wipe system/cache dalvik etc) I'll be sending a Donation over the next day or so. Having LineageOS for this device is an absolute GodSend @drizzle123 flash the remount rw magisk.zip. I had problems with it previously on stock roms but it seems to be working ok atm fingers crossed. (here's link to post/file) https://forum.xda-developers.com/showpost.php?p=77781453&postcount=1014
 
Last edited:
  • Like
Reactions: kc12

hunnia41

Member
Apr 16, 2015
32
8
Installed from stock 8.0 plop to Los16 with Pico gapps. Format data - reboot to recovery then continue with flash procedures (wipe system/cache dalvik etc) I'll be sending a Donation over the next day or so. Having LineageOS for this device is an absolute GodSend @drizzle123 flash the remount rw magisk.zip. I had problems with it previously on stock roms but it seems to be working ok atm fingers crossed. (here's link to post/file) https://forum.xda-developers.com/showpost.php?p=77781453&postcount=1014

"I'll be sending a Donation "
I did too. The first time in my life for firmware. I have no problem so far. (Used it 24 hours.)

---------- Post added at 06:51 AM ---------- Previous post was at 06:34 AM ----------

Yes, I'm on TB-8704F. Previously installed 14.1 without issue.
Did a clean install: format DATA and cache; again tried with clearing SYSTEM folder as well.

After installing, reboots as normal thenstuck on Lineage ARC loading with no end; left it alone for 30mins but never load into OS.
Seemingly you did everything, which had to be done. If it is a problem with the firmware, maybe it has to do with the encryption. (Cannot encrypt the data.) Just a guess, since it works for so many people.
maybe you should reflash the 8.1 stock rom. If it works, try again to reinstall lineage pie. If it still fails, go back to stock until problem is solved.
 
  • Like
Reactions: Hemphiz and Acel337

Acel337

Member
Aug 17, 2013
8
1
The tablet was on latest official 8.1 then changed to LineageOS 14.1. Tried to install to this 16.0 then this issue started.
I have sucessfully installed 14.1 but not to latest 16.0. It's a strange issue.
 

robidick

New member
Jul 16, 2019
3
1
same here, TB-8704F stuck on lineage bootanimation too

The tablet was on latest official 8.1 then changed to LineageOS 14.1. Tried to install to this 16.0 then this issue started.
I have sucessfully installed 14.1 but not to latest 16.0. It's a strange issue.

coming from latest 8.1 (TB-8704F_S0010xx_190606_ROW with security update from April 5th) doing the following:
- installed recovery: fastboot flash recovery twrp-3.2.3-0-tb_8704x.img
- booted into recovery and format /data
- again rebooted recovery and wiped /system, /data /cache and /dalvik
- installed "lineage-16.0-20190721-UNOFFICIAL-TB8704.zip" , directly afterwards "open_gapps-arm64-9.0-pico-20190720.zip"

Now, TB-8704F stuck on bootanimation :confused::eek:
 

hunnia41

Member
Apr 16, 2015
32
8
coming from latest 8.1 (TB-8704F_S0010xx_190606_ROW with security update from April 5th) doing the following:
- installed recovery: fastboot flash recovery twrp-3.2.3-0-tb_8704x.img
- booted into recovery and format /data
- again rebooted recovery and wiped /system, /data /cache and /dalvik
- installed "lineage-16.0-20190721-UNOFFICIAL-TB8704.zip" , directly afterwards "open_gapps-arm64-9.0-pico-20190720.zip"

Now, TB-8704F stuck on bootanimation :confused::eek:

I did exactly the same thing with the following exceptions. (whether they are significant or not I do not know.
1. Went into twrp without installing it and unrooted with Magisk. (side load)
(Then I do not remember whether I booted up in stock, to check by magisk whether dm-verify was off. It should be)
then I rebooted into fastboot and installed twrp and in my case I made system writable.
After this I proceeded as you discribed.
 

Top Liked Posts