• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[ROM][UNOFFICIAL][9.0][tbx304f/l/x] LineageOS 16.0 for Lenovo TAB4 10

Search This thread

hk96

Senior Member
there is issue with touch in the 12-12-2020 file the touch is mal aligned in my tab by two inches. im not complaining, it says you tell me whats broken so writing here. and Thanks a Lot for the ROM man


Edit: I tried the other release and I have the same problem, any help would be appreciated!

I am using this rom for the past few days, and i dont face any such issue.
May be there some problem with your device or may be you have a different display hardware, as in few other devices....
 
Last edited:

genziutek

Senior Member
May 14, 2010
117
23
Working great 👍

Screenshot_20201229-141653_Ustawienia.png
 

alou S

Member
Jul 23, 2017
22
2
Its working perfectly on my Tab 4 10.

Fixed the /data not mounting on TWRP and also CPU governer not working properly.

The only thing not working is the notification LED (it works for charging and low battery, but not notifications.)

Also yeah is it possible for you to fix the issue when android crashes when /system is remounted as RW.
The magisk remount module just ends up stopping the tab from getting past the lineage os boot up screen.
 

jsgraphicart

Senior Member
Nov 25, 2011
6,289
1,879
OnePlus 7T
I have been using my Tab 4 10 (wifi only) with stock OS since I bought it. My OEM unlock was also greyed out so I haven't bothered coming into these forums much. But now, I see there is instructions to fix that, there is a working TWRP for us and now there is a Lineage OS build. You guys made my day. I will be doing some work on my tablet and installing this ROM on it this weekend. Can't wait. Thank you.
 

Baron_Von_J

New member
Feb 13, 2021
4
0
Trying to try this out, having an issue flashing the zip in TWRP though. Has been "installing" for multiple hours now, with the progress bar very near the end for most of that time. Doesn't look like an error is occurring, just doesn't want to finish. I booted the 3.4.0 TWRP image from this post, rather than the 3.3.1 TWRP from the linked TWRP and Root for ... post.


PXL_20210213_230329436.jpg
 

Sagnik 123

Member
Feb 4, 2021
7
0
ROM work good for me since 1 month 👍 Anybody get solutions to resolve problem with system rw?
I flashed all the files correctly. After that when I rebooted to system, it is continuously showing the logo of lineage os for a very very long time for 4-5 hrs. But it is still not starting. My tablet is not starting. Please help me anyone please please.
 

oonegative

Member
Dec 25, 2015
5
0
Trying to try this out, having an issue flashing the zip in TWRP though. Has been "installing" for multiple hours now, with the progress bar very near the end for most of that time. Doesn't look like an error is occurring, just doesn't want to finish. I booted the 3.4.0 TWRP image from this post, rather than the 3.3.1 TWRP from the linked TWRP and Root for ... post.


View attachment 5220857
did you get anywhere with this? ... i am stuck at the exact same point. I have X304F.
 

oonegative

Member
Dec 25, 2015
5
0
I had the same issue and waited for ~ an hour. Then I stopped, simply reinstalled again and it worked without any further problems.
ok thanks for the update @Akron_ - I'll give this another try and just leave it for as long as it takes.

edit: went to try again and found unlock bootloader greyed out. managed to unlock this using the instructions in an earlier post. Booted into TWRP 3.4.0 and wiped data. Installed lineage zip from sd card and got stuck at the same point again. Left it running for a full day and it's still stuck at the same spot.
 
Last edited:

Muad.Dib

Senior Member
Hey guys,

By any chance would any of you have a fastboot 7.1 stock image for X304F? I recently lost my backups due to a crash and I'd like to get those images before they get lost forever. Already hard to find on the web... still struggling.

Any help would be much appreciated.

Thanks in advance,

Regards,
 

Top Liked Posts

  • There are no posts matching your filters.
  • 11
    http%3A%2F%2Ffiles.paulfasola.fr%2FCyanogenMod%2FLineageOS.png


    Code:
    /*
    * I'm not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed (like it did for me...).
    * Please do some research if you have any concerns about features included in the products you find here before flashing it!
    * YOU are choosing to make these modifications, and if you point the finger at me for messing up your device, I will laugh at you.
    * Your warranty will be void if you tamper with any part of your device / software.
    * Same statement for XDA.
    */

    LineageOS is a free, community built, aftermarket firmware distribution of Android 9 (pie), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.


    What works:
    Calls/SMS/Mobile data
    Wifi
    Bluetooth
    GPS
    Camera
    Audio
    FM radio
    WLAN and USB tethering
    Broken
    You tell me

    Source code:
    device : https://github.com/lenovo-devs/android_device_lenovo_TBX304, https://github.com/lenovo-devs/android_device_lenovo_tb-common/tree/lineage-16.0-msm8937
    kernel: https://github.com/lenovo-devs/android_kernel_lenovo_msm8953/tree/lineage-16.0-tbx304
    vendor: https://github.com/lenovo-devs/proprietary_vendor_lenovo/tree/lineage-16.0-msm8937

    2020-12-12
    • Added double tap to wakeup option
    • Added hall sensor
    • Fixed error in sepolicy
    mailru: lineage-16.0-20201212-UNOFFICIAL-TBX304.zip
    gdrive: lineage-16.0-20201212-UNOFFICIAL-TBX304.zip

    Previous versions:


    How to install
    You have to had TWRP installed from this thread TWRP and ROOT for Tab 4 8/10 (Plus) (TB-8704X/F/V,TB-X704L/F, TB-8504X/F, TB-X304L/F or one from link below

    In TWRP clean Data if you coming from stock ROM and do Install of this ROM. If you have android 8 stock rom installed you have to format Data with data loss, because used encryption is incompatible with android 7.1

    TWRP
    Built from omnirom android 9.0 source (twrp 3.3.1), includes same kernel as Lineage build, with support for pstore (kernel logs after crash), exfat, ntfs, reboot to EDL mode.
    mailru: tbx304-twrp-3.4.0-20201207.img
    gdrive: tbx304-twrp-3.4.0-20201207.img

    XDA:DevDB Information
    [ROM][UNOFFICIAL][9.0][tbx304f/l/x] LineageOS 16.0 for Lenovo TAB4 8, ROM for the Lenovo Thinkpad Tablet

    Contributors
    highwaystar_ru
    Source Code: https://github.com/lenovo-devs/android_kernel_lenovo_msm8953/tree/lineage-16.0-tbx304

    ROM OS Version: 9.x Pie
    ROM Kernel: Linux 3.10.x
    Based On: LineageOs

    Version Information
    Status:
    Testing

    Created 2020-03-04
    Last Updated 2020-03-19
    6
    Updated:
    2020-12-12
    • Added double tap to wakeup option
    • Added hall sensor
    • Fixed error in sepolicy
    3
    Have you got anywhere with this? I have exact same issue you have on X304F and I am very unsure why and if it could possibly be fixed. I'll be very sad if I cannot make this work.... Love LOS....

    Please let me know.

    Regards,

    EDIT1:
    From what I am reading in this thread, it would look like this LOS package would be actually intended for the L version and not working properly on the F version, both of them probably sharing some but not all hardware.
    I am unsure but It would like screen might be different hardware, maybe even resolution.
    I had the same problem using the TWRP version provided without the 'F' at the end (just x304 no letter) and touch was not aligned right.
    Now could this be fixed easily? I dont know of LOS enough to tell that, maybe someone do? @highwaystar_ru ?
    I'd be more than happy to test on my device or provide data which could help fix the ROM for the F device.
    Could you please test this TWRP build https://cloud.mail.ru/public/AU29/uv1CLEfEs

    x304 source code really helps, fixed fast charger and fixed some code in touchscreen driver. Please check if test twrp fixes touchsreen issue. Lineage 17.1 with updated kernel is on the way.
    2
    Twrp works well without touchscreen issue but i, the same touch screen issue is now in rom itself, please tell how to fix ?
    You have to use new rom. Here is Lineage 17.1 (android 10) build https://forum.xda-developers.com/t/...8-rom-for-the-lenovo-thinkpad-tablet.4259205/
    1
    I dont get it, why arent you switching to android Q then? Its higher android version right? Or am i not getting somthing?
    Well moving to latest version available is not always the wisest thing to do. Things that worked for you may end up not working anymore (let's say you use a specific app which does not have an update for Q yet), even more for old devices which were not really designed to support such a new release (some drivers may be missing or not updated and such). New versions of OS usually need more Ram to function, leaving you will less Ram for you to use, and again that can be a problem.
    As goes the famous saying : 'When it works, don't fix it' ;)

    However you are right at some point you have no other choice but to update, even if that comes with a tradeoff. For example once NetFlix (or any of the few other apps I want to keep using) will drop P support, I wont have a choice but to move. But I still have time. But at the moment there is no appealing feature on Q which makes me want to update unconditionally.

    At the time being, I am just happy with applying google security patches every now and then. Probably more often as soon as I can figure out how to build for multiple devices on same LOS version.

    Cheers!