[ROM][UNOFFICIAL-ABANDONED][11] LineageOS 18.1 for Samsung Galaxy S5 (klte*)

Search This thread

kurtn

Senior Member
  • Jan 28, 2017
    3,996
    1,728
    Small town in Bavaria
    @jimsters for WiFi calling install stock ROM or stock based. No aosp based ROM has WiFi calling or VoLTE on any Samsung smartphone.
    Here is someone with money and motivation to attack VoLTE
     

    @Lister Of Smeg

    Its KLTE variant so g900f will work....Someone actually uploaded to Android host file this week....

    now i had to reeducate myself on the old days so..... I downgraded to the last kitkat firmware for 900T G900TUVU1CNK2_G900TTMB1CNK2_G900TUVU1CNK2_HOME.tar.md5 which i downloaded from the local repo on xda.. i did quick search and found this kitkat for 900f https://androidfilehost.com/?fid=95857557620392991.. flash the kitkat firmware boot update security update reboot to bootloader/odin.... flash TWRP now i used the OG 2.81 TWRP because anything over version 3.0.0 wont work....the rom comes rooted and has exposed magisk halfway works...i tried to use but it wasnt happy so old school supersu is preloaded.... gapps i got from open gapps website use pico .... it has a custom kernel installed with the original cynagonmod....i forgot how cool this rom is and best part is i had no issues with new apps running on kitkat... you will get the red warning when boot recovey for selenux not enforcing but thats just in recovery....boots fast... also it has old dsp mgr installed for audio it random crashes when using headphones so i just unistalled it....it wont run new viper 4 but im going to look for the old viper 4 because the volume sucks unless you mod like everyother rom for our device
     

    Attachments

    • twrp-2.8.1.0-klte.tar
      13 MB · Views: 3
    Last edited:
    Here is someone with money and motivation to attack VoLTE
    you should check out phh GSI github or telegram chat because they found workaround for volt on samsung with GSI asop builds so maybe it can be forked in your builds and I believe S9 is treble base so it shouldnt be too hard
     

    haggertk

    Senior Member

    RE: VoLTE Support Impossible On Galaxy S5 klte Family



    Is it because of Samsung proprietary manufacturer's framework or implementation not included in LineageOS?

    Just curious.
    ***
    It's due to proprietary/customized implementations, but I don't want to place that at the feet of Samsung - there just was no "standard implementation" in that era. It's not until appx 8998 that things started to become more standardized.
     

    SGS5Korea

    Member
    Feb 26, 2021
    13
    8
    FYI dirty flashing my G900K LineageOS 18.1 kltekor unofficial build 2021-04-09 + OpenGApps Test Pico + Magisk 22.1 to official nightly build 2021-04-22 using official Lineage Recovery 2021-04-22, everything smoothly after second boot and Magisk-22.1 survive the update.

    Thank you Mr. haggertk, LineageOS Team and everyone that contribute to this project.
     

    dynamo1950

    Senior Member
    Jan 8, 2010
    60
    23
    Las Vegas, NV
    FYI dirty flashing my G900K LineageOS 18.1 kltekor unofficial build 2021-04-09 + OpenGApps Test Pico + Magisk 22.1 to official nightly build 2021-04-22 using official Lineage Recovery 2021-04-22, everything smoothly after second boot and Magisk-22.1 survive the update.

    Thank you Mr. haggertk, LineageOS Team and everyone that contribute to this project.

    I can also confirm a dirty flash of this ROM over Official LOS 17.1 on my Samsung Galaxy S5 SM-G900F running the "lineage-17.1-20210518-nightly-klte-signed.zip" ROM.

    My steps were as follows:

    1. Reboot to TWRP
    2. Flashed "lineage-18.1-20210409-UNOFFICIAL-recovery-klte.img" image as Recovery
    3. From TWRP main menu reboot to the Recovery
    4. From LOS Recovery flashed the "lineage-18.1-20210409-UNOFFICIAL-klte.zip" ROM
    5. Flashed the "open_gapps-arm-11.0-pico-20210130-TEST.zip" GAPPS found at https://sourceforge.net/projects/opengapps/files/arm/test/20210130/
    6. Flashed "Magisk-v22.1.zip" for ROOT
    7. Reboot to system

    Phone booted without issues to logon screen and all existing apps appear to function fine. Happy to be running Android 11 on the old Galaxy S5.

    Thanks to @haggertk and everyone that contribute to this project.
     
    Last edited:
    I can also confirm a dirty flash of this ROM over Official LOS 17.1 on my Samsung Galaxy S5 SM-G900F...lineage-18.1-20210409-UNOFFICIAL...

    Thanks for your report but did you noticed in the post that you quoted that it is about flashing official LineageOS 18.1 over unofficial 18.1 on a S5 G900K kltekor and it's not out yet for your S5 G900F as you can see here https://download.lineageos.org/klte ?

    It should be available on 2021-04-25 if ll goes well with the LineageOS automated builder. ;)

    klte 25 april
    klteactivexx 22
    kltechn 24
    kltechnduo 24
    klteduos 25
    kltedv 25
    kltekdi 23
    kltekor 22
    ***
     
    Last edited:
    • Like
    Reactions: dynamo1950

    SGS5Korea

    Member
    Feb 26, 2021
    13
    8
    I can also confirm a dirty flash of this ROM over Official LOS 17.1 on my Samsung Galaxy S5 SM-G900F running the "lineage-17.1-20210518-nightly-klte-signed.zip" ROM.

    My steps were as follows:

    1. Reboot to TWRP
    2. Flashed "lineage-18.1-20210409-UNOFFICIAL-recovery-klte.img" image as Recovery
    3. From TWRP main menu reboot to the Recovery
    4. From LOS Recovery flashed the "lineage-18.1-20210409-UNOFFICIAL-klte.zip" ROM
    5. Flashed the "open_gapps-arm-11.0-pico-20210130-TEST.zip" GAPPS found at https://sourceforge.net/projects/opengapps/files/arm/test/20210130/
    6. Flashed "Magisk-v22.1.zip" for ROOT
    7. Reboot to system

    Phone booted without issues to logon screen and all existing apps appear to function fine. Happy to be running Android 11 on the old Galaxy S5.

    Thanks to @haggertk and everyone that contribute to this project.
    Thank you for pointing that out. Perhaps when the klte official LOS 18.1 is released, I will do a "clean" install instead since this "dirty" install may be the reason that the phone is somewhat laggy....
    Yaps, i don't recommended dirty flash over different version of Android

    As an example in my experience dirty flashing official lineage 17.1 over official 16.0 after that the phone become laggy.
     
    Last edited:

    Droid9684

    Senior Member
    May 9, 2011
    405
    26
    I can't get Magisk to work on this or pass safety net on any version of Magisk. Magisk 22 keeps saying "Requires Additional Setup" to work properly.
     
    Magisk 22.1 & SafetyNet Test

    I can't get Magisk to work on this or pass safety net on any version of Magisk. Magisk 22 keeps saying "Requires Additional Setup" to work properly.

    Try with Magisk 22.1 which fix some bugs: https://github.com/topjohnwu/Magisk/releases

    Does it say "Requires Additional Setup" and reboot? If not, reboot anyway.

    It's just a bug with the SafetyNet test API in Magisk 22.0 & 22.1 & that has been reported many times in the XDA Magisk support thread.

    Test with apps like SafetyNet Test or SafetyNet Helper Sample for example.

    Try canary Version. Safetynet is a cat-and-mouse game
    The most recent Canary fixed the SafetyNet test but is not required to make Magisk root work.

    I installed stable Magisk 22.1 on both my S5 G900M LineageOS 17.1 & S3 i9300 LineageOS 14.1 & they both pass the SafetyNet test with other apps as you can see in the attached screenshots.
    ***
     

    Attachments

    • SafetyNet_attest_S5_curiousrom.png
      SafetyNet_attest_S5_curiousrom.png
      164.7 KB · Views: 16
    • SafetyNet_Check_S5_curiousrom.png
      SafetyNet_Check_S5_curiousrom.png
      148.3 KB · Views: 16
    • SafetyNet_Test_S3_i9300_curiousrom.png
      SafetyNet_Test_S3_i9300_curiousrom.png
      112.8 KB · Views: 14
    Last edited:
    • Like
    Reactions: Droid9684

    Sobhan Mazaheri

    Senior Member
    Feb 28, 2018
    129
    64
    Khorasan
    Magisk 22.1 & SafetyNet Test



    Try with Magisk 22.1 which fix some bugs: https://github.com/topjohnwu/Magisk/releases

    Does it say "Requires Additional Setup" and reboot? If not, reboot anyway.

    It's just a bug with the SafetyNet test API in Magisk 22.0 & 22.1 & that has been reported many times in the XDA Magisk support thread.

    Test with apps like SafetyNet Test or SafetyNet Helper Sample for example.


    The most recent Canary fixed the SafetyNet test but is not required to make Magisk root work.

    I installed stable Magisk 22.1 on both my S5 G900M LineageOS 17.1 & S3 i9300 LineageOS 14.1 & they both pass the SafetyNet test with other apps as you can see in the attached screenshots.
    ***
    Hi
    Please attach the suggested gapps ARM Pico download link for lineageos 18.1
    And Magisk 22.1 download link (Flash)
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 1
      @jimsters sure it's ok to post but might get more attention if not posted in an abandoned thread. 😉
      This is official now.
      1
      @jimsters sure it's ok to post but might get more attention if not posted in an abandoned thread. 😉
      This is official now.
      ah ok thanks
    • 53
      2okPze5.png


      LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

      LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. You will need to provide your own Google Applications package (gapps) . LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

      Base source code is available in the LineageOS Github repo. And if you would like to contribute to the project, please visit our Gerrit Code Review.

      Device source code:
      Kernel source code:
      My picks:

      Build Compatibility:
      The noted models are the only ones supported. If you have a model that isn't listed and ask politely then I might work to add compatibility.​
      BuildModel
      klteSM-G900F, SM-G900M, SM-G900R4, SM-G900R7, SM-G900T, SM-G900V, SM-G900W8
      klteactivexxSM-G870F
      klteaioSM-G900AZ, SM-S902L
      kltechnSM-G9006V, SM-G9008V
      kltechnduoSM-G9006W, SM-G9008W, SM-G9009W
      klteduosSM-G900FD, SM-G900MD
      kltedvSM-G900I, SM-G900P
      kltekdiSC-04F, SCL23
      kltekorSM-G900K, SM-G900L, SM-G900S

      Downloads:
      Installation Instructions:
      • Download latest build
      • Boot into recovery
        • Lineage recovery images are included in the download section and that's what I support. If you feel like using TWRP and something isn't working then take it up with the TWRP maintainer
      • If not updating from one of my earlier unofficial builds, then format/system, /data, and /cache
        • For Lineage recovery:
          • Format -> Format data/factory reset (this does /data and /cache)
          • Format -> Format system partition
        • For TWRP figure it out. And no, "wipe data" isn't the same as formatting data
      • Install LineageOS zip
      • If this is your initial installation of LineageOS 18.1, then flash any addons (e.g., gapps)
      Reporting Bugs:
      • DO NOT even think about reporting bugs if you are running a custom kernel, Magisk, or Xposed
      • Grab a logcat after the problem has occurred
      • If there is a random reboot then grab /proc/last_kmsg. A logcat AFTER the reboot will be worthless
      • Note which build AND device you have
      • Read the thread, at least the last month's worth of posts. Don't report things that others already have.
      Compatibility Notes:
      • Bootloader version doesn't matter. Anyone who tells you so doesn't know what they are taking about. My Developer Edition G900V is still running the original 4.4.2 KK aboot. My G900W8 is running the latest 6.0.1.
      • All builds except for klteactivexx MUST be running a marshmallow (6.0.1) radio for RIL to work. If you are about to report that RIL/radio isn't working then I pretty much guarantee this is your issue.
      • You MUST be running a marshmallow (6.0.1) NON-HLOS for the fingerprint reader to work. If you are about to report a fingerprint reader problem then you either have old firmware (update it), your /data was previously encrypted and you performed a "clean" flash without FORMATTING /data (start over and FORMAT /data), or your reader is just broken.
      • External SD cards don't support POSIX (ext*, f2fs) or NTFS filesystems anymore. It was kind of broken in 17 and we likely won't merge the changes to add it back in for 18. I'm not going to pick the open changes to re-add support because I'm not going to deal with "but it worked on haggertk's unofficial builds" bug reports after we eventually go official. If this affects you then just bite the bullet, copy any data off you really want to save, and reformat as exfat.
      Donations:
      • I absolutely don't personally accept them. If you really feel that this work deserves it, then find a local food bank or animal shelter/rescue and throw some money their way. You can also throw some the way of LineageOS, but we're actually doing pretty well right now.
      23
      Note that the Galaxy S5 klte family is not included in the initial promotion but should follow eventually.

      I'll probably ship in the coming week. They're ready, but I don't want to be the first set our the door on the infra. As it is, we're already flying this thing in direct law tonight.
      9
      Official LineageOS 18.1 for the Galaxy S5 klte family Launched!

      FYI these haggertk's commits are now marked as Merged so it should be available in the next update if all goes well with the Lineage automated builder:
      And it's confirmed in the LineageOS build target list and the wiki pages https://wiki.lineageos.org/devices/ also.

      The respective wiki pages include an upgrade guide.

      Thank you to the Lineage Team & Mr. haggertk for keeping our old S5 up to date. :cool: 👍
      ***
      9
      Official LineageOS 18.1 Launched!

      FYI the Official LineageOS 18.1 is launched as you can read in this official blog: Changelog 25 - Exemplary Eleven, Ravishing Recorder, Captivating Calendar, Beaming Backup

      The first batch of builds should be available starting 2021-04-01 if all goes well with with the LineageOS automated builder. Click on nightly even if the lineage-16.0 label has not been updated yet.

      Note that the Galaxy S5 klte family is not included in the initial promotion but should follow eventually.
      ***
      7
      Hey @haggertk, I have a SM-S902L. Can I use the rom for SM-S900L for my device? If not would you be so kind and add support for my model? I had been waiting for lineage 17.1 for quite some time now and installed an unofficial build to get android 10. I just found this amazing thread which is a way for me to get android 11. :love: Please consider my request. Thanks ;)

      Yeah, that's easy -- I dropped G900AZ and S902L during 17.1 bring-up because I wasn't about to formally fork a device tree and create a new build for those devices that needed <M RIL stack without any evidence of a continuing userbase. I have the work already done locally for 17. One commit in that device tree and then importing the vendor blobs will have it done for 18.