[ROM][UNOFFICIAL][guacamole][11] LineageOS 18.1

hawkeyexp

Senior Member
May 26, 2006
216
40
58
Hi @LuK1337 ,

is for LineageOS 18 the kernel tree from LineageOS 17.1 used? I had a look to the soruces to build directly from source (like my current 17.1) and kernel for 8150 has no branch for 18.0.

Thx
 
I just installed Lineage 11 on my Guacamole 1+7pro. I booted into recovery, did the wipe, installed the rom, rebooted into recovery which obviously failed after flashing rom, so I tried to reboot into fastboot mode, but Lineage started to boot. I let it continue, but it never finished after a long wait. So I powered off the phone, and continued to try to boot fastboot mode, but it kept booting Lineage, not fastboot. After numerous failed attempts to load twrp-3.4.0-10, the phone finally booted into fastboot mode, but that is all it does anymore. after booting into fastboot, my attempts to fastboot boot twrp results in error message "FAILED (remote: 'Failed to load/authenticate boot image: Load Error')".
I'm stuck. Ive tried different downloads of twrp, but nothing changes.
This is the lineage i used
[ROM][UNOFFICIAL][guacamole][11] LineageOS 18.1

This the TWRP i used
TWRP 3.4.0-10 Unified Unofficial Q by mauronofrio

This is the Gaps I downloaded
https://forum.xda-developers.com/android/software/arm64-nikgapps-t3915866/post83676281 But never got to flash yet
 
Last edited:

djsubterrain

Senior Member
Jan 4, 2012
3,605
3,454
253
Livingston
I just installed Lineage 11 on my Guacamole 1+7pro. I booted into recovery, did the wipe, installed the rom, rebooted into recovery which obviously failed after flashing rom, so I tried to reboot into fastboot mode, but Lineage started to boot. I let it continue, but it never finished after a long wait. So I powered off the phone, and continued to try to boot fastboot mode, but it kept booting Lineage, not fastboot. After numerous failed attempts to load twrp-3.4.0-10, the phone finally booted into fastboot mode, but that is all it does anymore. after booting into fastboot, my attempts to fastboot boot twrp results in error message "FAILED (remote: 'Failed to load/authenticate boot image: Load Error')".
I'm stuck. Ive tried different downloads of twrp, but nothing changes.
This is the lineage i used
[ROM][UNOFFICIAL][guacamole][11] LineageOS 18.1

This the TWRP i used
TWRP 3.4.0-10 Unified Unofficial Q by mauronofrio

This is the Gaps I downloaded
https://forum.xda-developers.com/android/software/arm64-nikgapps-t3915866/post83676281 But never got to flash yet
"Failed to load/authenticate boot image"

That means you don't have a boot partition for the rom, you said you can get in fastboot, can you get into recovery? Either TWRP or the built in one for the rom, if you can get the LineageOS recovery you should be able to flash TWRP and the rom.
 

deejaycarras

Senior Member
Apr 5, 2011
346
122
73
I just installed Lineage 11 on my Guacamole 1+7pro. I booted into recovery, did the wipe, installed the rom, rebooted into recovery which obviously failed after flashing rom, so I tried to reboot into fastboot mode, but Lineage started to boot. I let it continue, but it never finished after a long wait. So I powered off the phone, and continued to try to boot fastboot mode, but it kept booting Lineage, not fastboot. After numerous failed attempts to load twrp-3.4.0-10, the phone finally booted into fastboot mode, but that is all it does anymore. after booting into fastboot, my attempts to fastboot boot twrp results in error message "FAILED (remote: 'Failed to load/authenticate boot image: Load Error')".
I'm stuck. Ive tried different downloads of twrp, but nothing changes.
This is the lineage i used
[ROM][UNOFFICIAL][guacamole][11] LineageOS 18.1

This the TWRP i used
TWRP 3.4.0-10 Unified Unofficial Q by mauronofrio

This is the Gaps I downloaded
https://forum.xda-developers.com/android/software/arm64-nikgapps-t3915866/post83676281 But never got to flash yet
Try to do it with FlameGapps
 

giga502

Senior Member
Aug 17, 2011
99
9
28
Great rom, loving it.
Minor question though.

I've noticed the system updater always fails to connect. Is this by design because this isn't an official version of Lineage?

Also, anyone having trouble with the fingerprint reader? I find it either works perfectly, or it just won't work at all for a little.
 

bokchoi2020

Senior Member
Jul 24, 2013
362
236
73
Ottawa
Great rom, loving it.
Minor question though.

I've noticed the system updater always fails to connect. Is this by design because this isn't an official version of Lineage?

Also, anyone having trouble with the fingerprint reader? I find it either works perfectly, or it just won't work at all for a little.
Yeah system updater doesn't work for me either, prob BC it is unofficial.

Fingerprint is kinda wonky but on the latest 20210110 build I think it has gotten better.
 
  • Like
Reactions: giga502

bokchoi2020

Senior Member
Jul 24, 2013
362
236
73
Ottawa
In regards to updating, do you just download updates and use the LineageRecovery to perform the update?
Yea pretty much. I use TWRP but I feel that lineage recovery is decent enough.

Just make sure to reflash Magisk after you install the update zip.

I also needed to reflash NikGapps for some reason cause it wouldn't boot, maybe you might not encounter that issue.
 

mgear356

Senior Member
Jun 13, 2008
1,367
152
83
anyone experiencing chrome and webbased apps freezing frequently on latest build?

Edit: it is magisk fault. Removed and all good

One big issue is Android auto doesn't launch when plug in to car USB and doesn't work on car head unit
 
Last edited:

MrBlead

New member
Jan 18, 2021
4
0
1
Hey whats up everyone,
I finally took the time to install this ROM on my One plus 7 pro european version.
Everythings works great except GPS wich is pretty annoying... :/
I tried flashing Global Optimized GPS file replacer from magisk, and I tried reseting A-GPS XTRA data but with no succes yet.
Any idea ?
 

LuK1337

Recognized Developer
Jan 18, 2013
8,162
16,422
253
Official Android 11 beta is out. Any way we can incorporate the telephony over and fix Verizon/T-Mobile and MVNO sim problems?
1) OnePlus is probably not going to release kernel src for 11 beta for quite some time
2) Newer blobs aren't not going to fix vzw issues. FYI op8* has same issues thus it's just that your cursed carrier is broken by default on AOSP.
 
  • Like
Reactions: skythian and EVOLw

giga502

Senior Member
Aug 17, 2011
99
9
28
Updating is a real pain, I can't figure out a way to update to a newer build without having to wipe everything.
Anyone know the process?
 

bokchoi2020

Senior Member
Jul 24, 2013
362
236
73
Ottawa
Updating is a real pain, I can't figure out a way to update to a newer build without having to wipe everything.
Anyone know the process?
If you don't wipe everything is it bootlooping?

How I do it:
1. Download lineage update zip file. Optional: have Nikgapps zip, magisk zip, twrp zip ready.

2. Reboot to recovery. For example, let's say you are currently on slot A. If you use twrp, install the update zip only. It will install the update to the inactive slot, slot B. Once it is done, install the twrp zip. Go to Reboot tab, switch the slot to slot B. Then choose to reboot recovery. This will boot you back to twrp, but now on slot B.

3. Install the Nikgapps, magisk and twrp zips now that you've rebooted to slot B. This is required because the preserving add.on scripts tried to run on slot A after you installed the update zip, but they should've run on slot B.

4. Reboot to system. It should work without having to wipe your data.
 

giga502

Senior Member
Aug 17, 2011
99
9
28
If you don't wipe everything is it bootlooping?

How I do it:
1. Download lineage update zip file. Optional: have Nikgapps zip, magisk zip, twrp zip ready.

2. Reboot to recovery. For example, let's say you are currently on slot A. If you use twrp, install the update zip only. It will install the update to the inactive slot, slot B. Once it is done, install the twrp zip. Go to Reboot tab, switch the slot to slot B. Then choose to reboot recovery. This will boot you back to twrp, but now on slot B.

3. Install the Nikgapps, magisk and twrp zips now that you've rebooted to slot B. This is required because the preserving add.on scripts tried to run on slot A after you installed the update zip, but they should've run on slot B.

4. Reboot to system. It should work without having to wipe your data.
Ahh I think my problem is I had no idea what was going on with this slot business.

I'll go look up how it all works and I think i'll be fine from that point forward - thanks.
 

Kirolod

Member
Jun 3, 2015
5
3
23
If you don't wipe everything is it bootlooping?

How I do it:
1. Download lineage update zip file. Optional: have Nikgapps zip, magisk zip, twrp zip ready.

2. Reboot to recovery. For example, let's say you are currently on slot A. If you use twrp, install the update zip only. It will install the update to the inactive slot, slot B. Once it is done, install the twrp zip. Go to Reboot tab, switch the slot to slot B. Then choose to reboot recovery. This will boot you back to twrp, but now on slot B.

3. Install the Nikgapps, magisk and twrp zips now that you've rebooted to slot B. This is required because the preserving add.on scripts tried to run on slot A after you installed the update zip, but they should've run on slot B.

4. Reboot to system. It should work without having to wipe your data.
i've a custom rom already installed, Is there a way to install LineageOS without clearing all my data ?
 

bokchoi2020

Senior Member
Jul 24, 2013
362
236
73
Ottawa
i've a custom rom already installed, Is there a way to install LineageOS without clearing all my data ?
You need to wipe. You can backup and try if you want, but I would not recommend .

Can anyone tell me if the Proximity sensor is fixed in the lineageOS ?
And the speaker microphone is working good or not ?
I haven't felt any issue with either of those, not sure if others feel the same.
The fingerprint sensor is kinda weird.