[ROM][UNOFFICIAL][instantnoodlep][10] LineageOS 17.1

Search This thread
Jul 6, 2020
12
1
Post a screenshot of your speed test app showing that you are on LTE getting speeds of over 200mbps. Pretty sure you're on 5G but it just shows as a different band
 

Nielzsen

Senior Member
May 11, 2016
54
5
Hey there !
I keep getting into crashdump mode after the recovery flash. When using the "fastboot reboot fastboot" command I get to the dreaded page, each time.
Any idea of what I could be doing wrong ?
Edit : nvm, I'm an idiot and restored an OOS 11 ROM instead of OOS 10, my apologies
 
Last edited:

Nielzsen

Senior Member
May 11, 2016
54
5
@ac3theone It's pretty stable, no complaint. The fingerprint scanner will look weird when using inside an app (banking, mails or anything else), but works fine. Battery life seems great (at least on the non-gms build).

I however have a question. Compared to OOS, some apps will not work in complete fullscreen, and will have some borders which are not even covering the punch hole. Happens in some apps and games I used.
A screenshot is available here. Definitely wasn't there on OOS. Any idea of why would this happen ? Just curious about how it works.
Edit : Tried with some more apps. Almost every single app is trying to hide the camera cutout in fullscreen mode. Any way to change this ?
 
Last edited:

bruelltaube

Senior Member
Oct 10, 2015
53
49
$ fastboot reboot fastboot

unknown reboot target fastboot <- if you see this, update your adb tools [SIC!]

the rest of the flash commands need to be run against fastboot found in lineage recovery, not bootloader

Tried to flash yesterday for several times with no success at all. Reread the whole thread and stumbled upon the possible neccessity to update fastboot (@DJ thx left). After "sudo apt-get update" did not change anything for good, I forced the mandatory update (guidance how to do so provided by internet search) and finally was ready to go.

Now happy user of lineage on my instantnoodle. Can confirm compatibility with OP 8 (non pro) as well.

Thanks and respect to LuK1337!
 

JW09I4

Senior Member
Jan 5, 2016
161
80
Google Pixel 6 Pro
@LuK1337 For compiling Lineage, are you essentially just using the Lineage wiki for how to compile for the OP7 Pro? Is there anything different I need to do to compile (excl. codename)? Thanks! =]
 

Zinux

Senior Member
May 17, 2016
404
76
Thanks for responding,

Can you tell me about the other two?
No one can answer your first question, because "SOT" depends on your usage and you can't compare between your usage and others. It's like a whole different experience, everyone has their own apps and different daily usage patterns.
 

Lazar81

Senior Member
Aug 31, 2012
115
19
Flashing ROM via fastboot for the first time, getting the following error


PS E:\android\platform-tools_r30.0.3-windows\platform-tools> fastboot -w
Erase successful, but not automatically formatting.
File system type f2fs not supported.
Erase successful, but not automatically formatting.
Can't determine partition type.
FAILED (remote: GetVar Variable Not found)
erasing 'userdata'...
OKAY [ 5.457s]
erasing 'cache'...
FAILED (remote: Check device console.)
finished. total time: 5.466s
PS E:\android\platform-tools_r30.0.3-windows\platform-tools>


PS: proceeded to flash the files anyway and it is stuck in OOS bootanimation.

Hello ... Yesterday I wanted to install lineage on my instantnoodlep :D... Got the same message... I read on and the dev said that maybe fastboot update would solve the problem... Correct me if I got that wrong.

My question: did others have this problem and could verify this is a fastboot problem?
 

areyouanand

Senior Member
May 22, 2014
647
228
mysore
Xiaomi Poco F3
Hello ... Yesterday I wanted to install lineage on my instantnoodlep :D... Got the same message... I read on and the dev said that maybe fastboot update would solve the problem... Correct me if I got that wrong.

My question: did others have this problem and could verify this is a fastboot problem?

Was not able to use this method, in place of lineage recovery I used PA recovery and instead of "fastboot -w" I did a format in PA recovery.
 

Lazar81

Senior Member
Aug 31, 2012
115
19
Was not able to use this method, in place of lineage recovery I used PA recovery and instead of "fastboot -w" I did a format in PA recovery.

Ahm.. I didn't understand that... PA recovery is from Paranoid Android? I thought they are not developing anymore for OP8P?.... Could you give short summary of the steps you made?

Until now i wasn't unable to get through installation process... hell what i am missing out?...
 
Last edited:

bickfordman

Senior Member
Oct 14, 2010
254
38
Depends if you want customization or not. Like, I am on Resurrection Remix rom. It has every feature out there and I get 11+ hours screen on time. It's still being updated every few days and the dev and I will be bringing android 11 to RR in the coming months. If you like to just leave stock from and don't care about features, LOS IS the way to go. Great battery life, stable, but less updates(tho if no issues, no true reason to update rom)
What are your settings for 11 hours plus
 

Lazar81

Senior Member
Aug 31, 2012
115
19
Hello..
i tried fastboot update...
i also tried install procedure in windows and linux...
but no success...

i still get this error message, that wiping does not work and for system - partition not found...

are there any other ways but fastboot to install lineage?

----------------------------------------------------------------------------
edit:
as always.. sooner or later i managed it!
So for everyone who still has problems with installing:
I used the terminal integrated in the AIO TOOL by mauronofrio - wipe worked - system installation worked - lineage booted - fingerprint is ok
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 23
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    Instructions :
    • Download the latest build
    • $ adb reboot bootloader
    • $ fastboot -w (this will wipe your data)
    • $ fastboot flash recovery recovery.img
    • $ fastboot reboot fastboot
    • $ fastboot erase scratch
    • $ fastboot flash boot boot.img
    • $ fastboot flash dtbo dtbo.img
    • $ fastboot flash system system.img
    • $ fastboot flash product product.img
    • $ fastboot flash vbmeta vbmeta.img
    • $ fastboot flash vbmeta_system vbmeta_system.img
    • $ fastboot reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][UNOFFICIAL][instantnoodlep][10] LineageOS 17.1, ROM for the OnePlus 8 Pro

    Contributors
    LuK1337
    Source Code: https://github.com/luk1337

    ROM OS Version: Windows 8 Mobile
    ROM Kernel: Linux 4.x

    Version Information
    Status: Testing

    Created 2020-06-25
    Last Updated 2020-11-20
    4
    I was getting slow charging so i did some gogleling finding and experimenting with magisk modules & I found this one and sure worked it charges rapidly now instead of slow.

    Huh so all this module does is `echo 1 > /sys/kernel/fast_charge/force_fast_charge` but said path does not exist. Really makes you think (TM).

    BTW 'Charging slowly' is just a visual bug with DASH chargers. It still charges fast lol.
    3
    Are gapps included or do we need to flash separately?

    Look at downloads list and answer this question yourself.
    3
    Anyone tell me what the difference between the gms and non gms versions are while downloading the zip?
    The GMS version includes Google apps like the Play Store and Google Play Services. The non-GMS version does not include any Google services.
    2
    "ROM OS Version: Windows 8 Mobile" dafuq? ?