[ROM][UNOFFICIAL][kebab][11] LineageOS 18.1

LuK1337

Recognized Developer
Jan 18, 2013
8,167
16,424
253


LineageOS is a free, community built, aftermarket firmware distribution of Android 11, which is designed to increase performance and reliability over stock Android for your device.

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

Instructions :
  • Download the latest build
  • $ adb reboot bootloader
  • $ fastboot boot recovery.img
  • Factory reset -> Format data/factory reset -> Format data ( skip if needed )
  • Advanced -> Enter fastboot
  • $ fastboot update {filename}.zip ( use up to date platform tools for this step )
Downloads :
Reporting Bugs
  • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
  • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
  • If it is a random reboot, grab /proc/last_kmsg. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
  • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

Code:
What is your--
LineageOS version:
LineageOS Download url:
Gapps version:

Did you--
wipe:
restore with titanium backup:
reboot after having the issue:

Are you using--
a task killer:
a non-stock kernel:
other modifications:

Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:
 
Last edited:

sharkie405

Senior Member
Dec 22, 2008
2,751
1,872
193
Earth
Oh snap! LuK got an 8T! It's on! Much love and thank you! Will be flashing this weekend.

Sent from my OnePlus8T using XDA Labs
 
Last edited:

GraveDigger176

Senior Member
Oct 17, 2011
1,555
1,578
153
Koblenz
Ok thx and which file is the right one ? And for install we have to unzip the package and put in the adb folder and flash it as it mentioned in the instructions?

Sent from my OnePlus8T using XDA Labs
 

card13

Senior Member
Nov 27, 2008
393
107
68
31
Tacoma
Has anyone been able to get root working? Booting a manually patched boot.img (using canary magisk) gives me a Qualcomm Crash Dump Attempted to kill init! exitcode=0x0000000b do_exit. I need any way to run root long enough to restore my apps.

As for what has been tested and worked: WiFi, 5G, calls on 5G.
 
Last edited:

jwarrior319

Senior Member
Aug 22, 2015
671
200
73
Black Creek, wi
Is there AOD available on this version of lineage? Any missing features from stock OOS other than the obvious theme related stuff? Also does it support dual sim?

Sent from my OnePlus8T using XDA Labs