[ROM][UNOFFICIAL][leland][8.1] LineageOS 15.1

Search This thread
Dec 2, 2012
31
2
WOOOOOT
I've tried the tool with the link I gave and it worked! Stock rom is working.
I'll try to flash again tomorrow, but with a more gentle wipe :) Thanks guys for all the help so far!
 
  • Like
Reactions: MateUserHHTT
Dec 2, 2012
31
2
After you successfully boot into your stock ROM, do the following:
Install and bootto twrp
Swipe to allow modifications
Click on wipe
Swipe to Factory Reset
Format Data (this is next to "Advanced")
Type in yes and confirm
Flash the lineage.zip
Flash the MindTheGApps.zip
Reboot
This works!

---------- Post added at 09:47 PM ---------- Previous post was at 09:44 PM ----------

If I install a new version, do I need to wipe anything?
 

hackintosh5

Senior Member
Sep 15, 2017
1,246
957
Aaaargh!

It won't boot any more.

The hisi blackbox says that zygote keeps crashing. There are many errors including the system being unable to set .prop properties and the system server is crashing too!

Any ideas?

Sent from my kminiltexx using XDA Labs
 

MateUserHHTT

Senior Member
Aug 2, 2014
143
50
Hamburg
Magisk Hide doesn't work anymore, with builds later than 18th May or 20th May (not sure yet).
It disables itself after every app-restart. No app in the "hidelist" is being saved. I couldn't even find the file, which is stored at /sbin/.core/img/.core according to Digeridoohan.
Furthermore, Magisk Hide isn't enabled by default whenopening Magisk Manager the first time.

The issue seems to be related to this one from the Moto Z which was caused by a broken f2fs implementation, as user Didgeridoohan points out.

Currently I've installed your build from 10th May and it works. Magisk hide is enabled by default and also saves the hidelist. Works with the STOCK Rom as well.
Did you do changes to the f2fs implementation and already know what could cause this, or do you need logs?

---------- Post added at 10:28 PM ---------- Previous post was at 10:04 PM ----------

Great! Glad that I could help you.

If I install a new version, do I need to wipe anything?
Do you mean, if you flash a newer build? ( lineage-15.1(...)zip )
Nope, you don't have to wipe anything. Just flash it and you should be fine.
 

jintae03

New member
Jun 8, 2018
2
0
Is that possible on LLD-AL00???

sorry...my english is bad,,,,,,,

can i flash on lld-al00 (chinese domestic ver)??
 
Last edited:

noobington

Senior Member
Feb 23, 2018
50
11
Are there any plans for LineageOS to include native support of UMS (USB Mass Storage)?
Meaning, the sdcard drive letter when connected to PC.
This feature was included in CyanogenMOD natively.
 

Manish54

Senior Member
May 14, 2011
295
76
New Orleans
so i did full wipe n installed this rom, after reboot it gets me to stock recovery and everything disappears. bootloop!
i've tried it multiple times, what am i doing wrong?
 

noobington

Senior Member
Feb 23, 2018
50
11
Bug Report (SD Card)

Bug Report (SD Card)

LineageOS: lineage-15.1-20180619-UNOFFICIAL-leland.zip
GApps: MindTheGapps-8.1.0-arm64-20180320_011441.zip

Frequent, after booting, I get an SDCard corruption error (false reporting) in notification bar.
At first I thought it was really a faulty sdcard, so I reformatted and performed check disk, many times.
I am currently resigned to clearing notifications and rebooting once or twice, for the error (false reporting) to go away.
Under MTP, the sdcard is always labelled as "S" (one letter), instead of "SD Card".
Under Settings/Storage, it is also labelled as that one letter.

PS: I always choose External Storage every time the OS recognises a new sdcard.
 
Last edited:

AndropaX

Senior Member
May 18, 2014
351
1,019
San Escobar
Due to encryption you must format /data, any custom rom won't boot without this...

Wysłane z mojego LLD-L31 przy użyciu Tapatalka
 

Manish54

Senior Member
May 14, 2011
295
76
New Orleans
Due to encryption you must format /data, any custom rom won't boot without this...

Wysłane z mojego LLD-L31 przy użyciu Tapatalka

Did that too.. still won't boot this rom.
I tried flashing the generic AOSP treble build and it booted successfully but Bluetooth/wifi/calling didn't work. I'm stuck now, I can't even go back to stock. When I try flashing the stock rom, I get an error at 5%.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 23
    2okPze5.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 8.1 (Oreo), which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review. You can also view the Changelog for a full list of changes & features.

    What's working :
    Almost everything

    What's not working :
    • VoLTE (?)
    • AudioFX on headphones
    • Maybe something else...

    Instructions :
    • Download the latest build and gapps
    • Reboot to recovery
    • Make full wipe
    • Flash the latest build and gapps
    • Reboot
    Downloads :
    Reporting Bugs
    • DO NOT Report bugs if you're running a custom kernel or you installed Xposed
    • Grab a logcat right after the problem has occurred. (Please include at least a few pages of the log, not just the last few lines, unless you know what you're doing.)
    • If it is a random reboot, grab /sys/fs/pstore/console-ramoops and /sys/fs/pstore/dmesg-ramoops-0. (Do not bother getting a logcat unless you can get it just before the reboot. A logcat after a reboot is useless)
    • If the problem disappears after running "setenforce 0" from a root shell, grab /data/misc/audit/audit.log
    Remember to provide as much info as possible. The more info you provide, the more likely that the bug will be solved. Please also do not report known issues. Any bug not reported in the bug report format below may be ignored.

    Code:
    What is your--
    LineageOS version:
    LineageOS Download url:
    Gapps version:
     
    Did you--
    wipe:
     restore with titanium backup:
    reboot after having the issue:
     
    Are you using--
    a task killer:
    a non-stock kernel:
    other modifications:
     
    Provide any additional information (observations/frequency of problem/last version it worked on/etc) as needed:

    XDA:DevDB Information
    [ROM][UNOFFICIAL][leland][8.1] LineageOS 15.1, ROM for the Honor 9 Lite

    Contributors
    AndropaX, LuK1337, surdu_petru
    Source Code: https://github.com/AndropaX/android_device_honor_leland/tree/leland-8.1

    ROM OS Version: 8.x Oreo
    ROM Kernel: Linux 4.x

    Version Information
    Status: Testing
    Beta Release Date: 2018-04-25

    Created 2018-04-22
    Last Updated 2018-04-25
    4
    This issues will be fixed in 2 weeks, 3 days, 7 hours, 25 minutes and 53 seconds...
    C'mon guys...

    Wysłane z mojego LLD-L31 przy użyciu Tapatalka
    3
    my way
    - modify updater-script (erase line 1+2 "assertion")
    - boot to twrp
    - wipe
    - twrp install lineage-15.1-20180422-UNOFFICIAL-leland.zip
    - twrp install open_gapps-arm-8.1-pico64-20180414.zip
    - twrp install magisk
    - twrp wipe cache
    - twrp reboot to system
    - phone boot as a "new phone" (settings...) and WORK !
    only problem with TB (no SU), is problem with magisk - not LOS. now i must search "why"
    Wishes:
    - modify updater-script before you upload
    - how much work is modify button-layout ? i wish rotate from "return,home,oversight" to "oversight,home,return" (is Tradition on my phones) :)
    Now i am LOS15.1 on my phone and test in next day's.

    This is very good work ! Many thank's !!!
    3
    Install Magisk and you'll have passing Safetynet.

    If Magisk doesn't help, I've got a trick up my sleeve.
    Basically you modify the kernel fs/proc/cmdline.c to set androidboot.enable_dm_verity,secboot,verifiedbootstate,veritymode to the stock values without BL unlock. Then the safetynet will detect androidboot.verifiedbootstate=green, and allow the system to continue.

    Magic.:cool:

    EDIT: Well ive decided that I will compile a patched kernel right now, as I have a build machine just idling on 125 TDP
    1
    Is there any fix for VOLTE ? How long we can expect to get it working ?
    Grrrr. We will never have VoLTE. Shut up and read the rules.

    Sent from my kminiltexx using XDA Labs