[ROM][UNOFFICIAL]Lineage-17.1[ANDROID-10][A6000/A6000 PLUS][STABLE]

Search This thread

Lord_Escanor

New member
Jan 22, 2019
2
0
Harsh i am currently using your AOSPextended Pie and i am thinking of going to Android 10. I saw your AOSP 10 rom on AFH. But i am not able to download the file as it says "no mirrors found". Is there any help you can provide me with the link.
 

EdwardDideles

New member
Mar 30, 2018
4
0
Sim 1 can't read sim card

Well my device is actually globe lock here in the Philippines then i flashed this rom cuz im hoping that i can remove a carrier lock but no luck can someone help me?

TIA
 

awalsnake

Member
Jan 22, 2019
7
2
i am having mic issue in this rom...
i have tried flashing this rom many times but still the issue didn't get solved.
i was in lineage pie version and i didn't find this issue in it...
help me out for this issue..
 

rdpk7

Member
Jul 2, 2020
6
2
I'm on KitKat 4.4.4 stock ROM.

How to install the latest TWRP?

Edit: I installed TWRP 2.8.6.1 by SevenMaxs, then installed stock ROM to Lolipop 5.0.2, then the latest TWRP-3.3.0-A6000-ARM-20190506 and then Lineage 17.1.
 
Last edited:

santoshwins

Member
Dec 31, 2010
25
2
Security patches

Hi everyone,

Is it likely that we will get a security patch for this rom? I use this as a daily driver and wondered if it is still safe to do so with the patch being a few montsh old?

Cheers!
 

santoshwins

Member
Dec 31, 2010
25
2
i cant install latest TWRP, Its just stuck on lenovo , did u have some advice about it?

Sorry, mate. Unfortunately, I do not. Instead of the latest TWRP, try using the recommended TWRP version for this phone. This might help: https://forum.xda-developers.com/le...ecovery-twrp-3-1-1-lenovo-a6000-plus-t3649589

Cheers!

---------- Post added at 10:10 AM ---------- Previous post was at 10:09 AM ----------

Hi everyone,

Is it likely that we will get a security patch for this rom? I use this as a daily driver and wondered if it is still safe to do so with the patch being a few montsh old?

Cheers!

Any help or update would be appreciated. The security patch for this is many months old now. Cheers!
 

prath99

New member
Aug 2, 2020
3
0
Hello again, dev_harsh1998.

I flashed the hex patch again. No luck. I reflashed the ROM and the hex patch again. Still no luck.

I tried a different SIM and it worked! I seem to have diagnosed the issue. The original SIM has a network provider that does not support 2G networks. But somehow the phone defaults to 2G network and prevents me from being able to change the preference to 3G or LTE. Even when I try, it just cyclically connects and disconnects from the network.

The other probable cause is that the original SIM uses a partner network infrastructure. So it is a Warehouse Mobile SIM but uses 2Degrees cell towers. Could that be an issue?

Any thoughts? I have never faced this issue ever in any other phone - both Android and iOS.

Any help would be most appreciated :) Thanks in advance.

Cheers,
S
Did you find any solution for this ?

Installed the rom , and facing similar issue on Jio sim .
Phone literally wont connect to anything , cannot even make or receive calls .
 

Top Liked Posts

  • There are no posts matching your filters.
  • 18
    1200px-Lineage_OS_Logo.png


    LineageOS is a free, community built, aftermarket firmware distribution of Android 10, which is designed to increase performance and reliability over stock Android for your device.

    LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

    All the source code for LineageOS is available in the LineageOS Github repo. And if you would like to contribute to LineageOS, please visit out Gerrit Code Review.


    What's working :
    • Boots
    • Camera
    • RIL (Calls, SMS, Data)
    • Wi-Fi
    • Bluetooth
    • Video Playback
    • Audio
    • Sensors
    • GPS
    • Sepolicy [Yes you can use banking apps]



    Known issues:
    • You can't upgrade from lineage if encrypted.

    Don't report about known issues, It will be ignored

    Screens
    [/HIDE][/SIZE]

    Follow Instructions Carefully otherwise you will get error :
    • Flash latest TWRP Else you will get errors
    • Boot into your recovery
    • Wipe cache, dalvik's cache,system,data,internal storage
    • Flash ROM-Flash Gapps
    • Done-Reboot Now
    • Enjoy the clean rom


    Downloads :
    Don't forget to press thanks
    Follow This Link Get The Build


    Source code:
    ROM: https://github.com/lineageos/android
    Device: dev-harsh1998/android_device_lenovo_a6000
    Kernel: dev-harsh1998/kernel_lenovo_msm8916
    Proprietary Vendor: dev-harsh1998/prorietary_vendor_lenovo

    Our telegram group: Official Lenovo A6000 Dev & User Interaction chat

    XDA:DevDB Information
    Lineage-17.1 Lenovo A6000/ A6000 Plus, ROM for the Lenovo A6000/Plus

    Contributors
    dev_harsh1998
    Source Code: http://github.com/dev-harsh1998

    ROM OS Version: Android 10
    ROM Kernel: Linux 3.10.x
    ROM Firmware Required: Hex Firmware Patch
    Based On: CyanogenMod

    Version Information
    Status: Stable

    Created 2020-02-07
    Last Updated 2020-02-07
    8
    Screenshots

    These are some screenshots, courtesy of Bikram and Sher Singh, This wouldn't have been possible without them.
    8
    Frequently Asked Questions!

    Q : I get error 255/7 while flashing from recovery
    A : Flash using correct TWRP.

    Q : How do i flash rom?
    A : No rocket science Just wipe /system /cache /dalvik's cache & internal storage from twrp, Then simply flash the rom package and reboot.

    Q : Can I dirty flash the next build?
    A : If you are upgrading from previous builds of this rom to the current builds then O'course you can dirty flash by just flashing the new rom package , gapps package and wiping both the cache partition however i advice you to refrain from doing dirty flash. Follow the instructions if posted after a build drop and flash the package accordingly if instructions explicitly mention about clean flashing.

    Q : Where do i get compatible gapps/ I can't signIn into google play?
    A : Get your Gapps from OpenGapps.org, only use Pico or nano! If you want my support.

    Q : Is root access included in this Rom?
    A : No it is not. Some testers have had success with Magisk though.

    Q : Can I flash ABC mod? Does the ROM support it?
    A : Yeah sure, but I will not support you. And no, the ROM probably does not support it.

    Q : Android go, when?
    A : Decided to disable it for now for good

    Q : Livedisplay broken/not working ?
    A : Don't touch that section, The support was removed from the kernel because Lenovo's mdss don't go quite well with live display implementation and won't be supported.

    Q : Is VOLTE supported ?
    A : No.

    Q : Is the ROM suited for daily usage ?
    A : Yes, Looks like all basic daily usage stuff is functional.

    Q : WHEN UPDATE?? GIB UPDATE PL0X.
    A : I only post updates when there's a decent list of changes. I'm a college student and there's only so much I can do. Please do not spam my PM regarding this.
    I will not respond to any messages demanding ETAs
    4
    Thanks to the dev for bringing Android 10 to A6000 :)

    Clean installed the ROM a couple of hours ago. Everything seems to be stable and pretty. Love it. The phone was not laggy or slow even after the very first boot. Excited about exploring all the features of Android 10.

    Two issues that I have noticed so far -

    1. The phone is not latching on to the network. Tried both SIMs and both Automatic and Manual setting. It latches on - full five bars, then drops it, then latches on, then drops it. So on.
    2. The 'Live Display' setting crashes the settings app - the settings within the 'Live Display' section cannot be changed apparently?

    Thanks for any help in resolving the above two.
    Cheers,
    S

    Network depends upon area to area, If problem is genuine please drop "adb shell logcat -b radio logcat.txt" here so that I can look to it.

    LiveDisplay was removed from A6000's builds since Los-15.1's last build because lenovo's changes to mdss don't seem to go well with the kernel implementation of livedisplay, So the feature had to be dropped and since there's no live display driver it crashes when one tries to poke it from settings, Thanks for reminding me, I'll add it to faq
    2
    Thanks for the prompt response. I have verified with multiple SIMs and multiple locations - it will not latch on to any network.
    I ran the command you mentioned but the command appears to run indefinitely and no .txt file is output. I exported the CMD log anyway and is attached. I only let the command run for a few seconds as the log file was quickly exceeding the forum limit of 512KB for txt files.
    Help, please?

    Thanks, dev.
    Cheers,
    S

    Somehow the telephony is failing and it looses connection again and again that don't happen for others could you again flash hex firmware patch and pull the logs again if the issue persists