[ROM] [UNOFFICIAL] LineageOS 14.1 for Kinzie [Apr. 20.2018]

Search This thread

wei200041

Member
Jul 27, 2010
33
18
harbin
Thanks.

P3UnxWJ.png
Unofficial LineageOS 14.1 for Kinzie​

Hi, everyone I'm from Taiwan! First, I have a BIG thumb up to @Arasthel for helping me out some mirror bugs which is really tough to fix, and he also did so many test on this. Without him this project will not make it.
This is the successor to my CM13 ROM: https://forum.xda-developers.com/droid-turbo-2/development/cyanogenmod-13-0-unofficial-kinzie-port-t3503053

What works:
Everything except:
  • Problem with power-off charging. (It will power on when plug in the cable.)
  • GPS over Wi-Fi will only works when Gapps installed.
  • IR sensor stop working when screen off(Works when charging.)
  • Torch tile won't work sometimes after reboot, it is because the moto sensor isn't initialize properly.(To fix this bug, you have to pull down the statusbar and press edit icon.)
    [*]First time select to video recording will have FC(This will only happen once.)
    [*]Photo can't share, video can't play.(Here's how to fix: rename DCIM to DCIM.old, take a picture to create new folder to fix the photo can't share or video can't play; rename Picture to Picture.old to fix the screenshots can't share)
    [*]Camera launch very slowly(it is seriously slow, so it is recommended to install MOTO camera from play store or download the modded one from Moto Camera 6.0.43.10 Modded)
  • Wi-Fi hotspot is not working

Kernel feature:

  • NTFS support
    CIFS support
    Westwood TCP congestion algorithm (enabled by default)
    the kernel is not stable for patching these addons, will ad back these features when ready.

Compatibility:
This ROM is MAINLY for MOTO X Force, not recommend to flash in Droid Turbo 2
Confirmed working on CN variant(XT1581), EU variant (XT1580) and Brazil (XT1580, timbr and tefbr) Moto X Force.
Some Chinese user reported they can flash this ROM from stock 5.1.1 ROM without having any problem.
If you have any modem problem such as no signal or no Wi-Fi connection, flash clean stock ROM base on your variant and then flash this ROM.

Downloads:
ROM:
Latest LineageOS14.1 ROM for Kinzie

OpenGapps: Platform: "ARM64", Android: "7.1", Variant: "pico" or "nano" is recommended
Addon SU: https://download.lineageos.org/extras Flash su (arm64) for install and su removal (arm64) for uninstall.

Installation instructions:
  1. Unlock bootloader, if you don't know how to do it, please check the posts or search from Droid Turbo 2 section.
  2. Flash TWRP from bootloader. @Xadro's is strongly recommended.
  3. First and the most important is to do a nandroid backup from TWRP! Then do a clean install (wipe /data, /cache and /system from TWRP.) After flashing the ROM, flash a Google apps package or su, and then reboot.

Source code:
https://github.com/lineageos-for-kinzie

Credits:
  • CyanogenMod/LineageOS and its contributors
  • Open GApps
  • Specially thanks to @Arasthel and @Xadro for their works on initially porting cm12.1 to Kinzie

XDA:DevDB Information
LineageOS 14.1, ROM for the Droid Turbo 2

Contributors
jwchen119
ROM OS Version: 7.x Nougat
ROM Kernel: Linux 3.10.x
Based On: Project from Clark with 3.10.x kernel, ROM for the Moto X force

Version Information
Status: Alpha

Created 2017-01-11
Last Updated 2017-03-08

Thanks!
Very good!
XT1581,China Mobile and China Telecom 。
 

Attachments

  • Screenshot_20170310-132656.png
    Screenshot_20170310-132656.png
    132.3 KB · Views: 488
  • Screenshot_20170310-132408.png
    Screenshot_20170310-132408.png
    110.6 KB · Views: 494
  • Screenshot_20170310-132350.png
    Screenshot_20170310-132350.png
    110 KB · Views: 490
  • Screenshot_20170310-132321.png
    Screenshot_20170310-132321.png
    132.6 KB · Views: 482
Last edited:
  • Like
Reactions: jwchen119

Markweiser

Senior Member
Mar 14, 2013
71
13
Unofficial LineageOS 14.1 for Kinzie

XDA:DevDB Information
LineageOS 14.1, ROM for the Droid Turbo 2

Contributors
jwchen119
ROM OS Version: 7.x Nougat
ROM Kernel: Linux 3.10.x
Based On: Project from Clark with 3.10.x kernel, ROM for the Moto X force

Version Information
Status: Alpha

Created 2017-01-11
Last Updated 2017-03-08
Mate, I've noticed a problem, don't know if you seen it before. It seems sync() is not properly completing after removing huge files (such as 2gb+ movies). When I delete them the OS is not reporting back that the file has been removed and although I've double checked the file existence, the OS doesn't "reclaim" the deleted space. I have to restart to make it happen. Filesystem is ext4 btw.

Anyway, changing the subject, is there anyway I can save the profiles I've previously created? Because everytime I update it, I lose the configuration (the profiles that we can trigger conditions, built-in feature)

Thanks a lot for the help and effort :)

---------- Post added at 05:07 AM ---------- Previous post was at 05:05 AM ----------

Can your sync your device code to github?and the kernel source
I want to build by myself just for fun :p
Github tree is in first page
 

rickliu2000

Member
Dec 13, 2014
31
18
NanJing
Mate, I've noticed a problem, don't know if you seen it before. It seems sync() is not properly completing after removing huge files (such as 2gb+ movies). When I delete them the OS is not reporting back that the file has been removed and although I've double checked the file existence, the OS doesn't "reclaim" the deleted space. I have to restart to make it happen. Filesystem is ext4 btw.

Anyway, changing the subject, is there anyway I can save the profiles I've previously created? Because everytime I update it, I lose the configuration (the profiles that we can trigger conditions, built-in feature)

Thanks a lot for the help and effort :)

---------- Post added at 05:07 AM ---------- Previous post was at 05:05 AM ----------


Github tree is in first page
I see that , but i don't think its updated :cowboy: there's only the first commit in Feb
 
Last edited:

Jonnyquezt

Member
Mar 17, 2017
9
2
Can I flash this if I'm in marshmallow with the SD card formatted as adoptable storage? I mean, do I have to reverse the adoptable storage thing first or does TWRP will see the SD card as part of internal storage?
 

ben0551

Senior Member
Mar 12, 2010
61
7
Sydney
What works:
Everything except:
  • Problem with power-off charging. (It will power on when plug in the cable.)
  • GPS over Wi-Fi will only works when Gapps installed.
  • IR sensor stop working when screen off(Works when charging.)
  • Torch tile won't work sometimes after reboot, it is because the moto sensor isn't initialize properly.(To fix this bug, you have to pull down the statusbar and press edit icon.)

    Hey jwchen119

    Installed today and was pleasantly surprised to see
    a) the IR sensor working, even when it's not charging. I can swipe my hand over and display notifications.
    b) LED notification light is working as you'd expect. I read that it wasn't working with custom Moto Roms.

    Thanks for the great work!
 

aka70698

Member
Jul 22, 2013
15
3
Everything works perfectly. Just the YouTube video delays every time.i tried reflashing the ROM but it starts lagging after one or two videos. Is there a way to avoid it.same happens when I view Facebook app the video delays
 

Markweiser

Senior Member
Mar 14, 2013
71
13
Everything works perfectly. Just the YouTube video delays every time.i tried reflashing the ROM but it starts lagging after one or two videos. Is there a way to avoid it.same happens when I view Facebook app the video delays
Do you think this is related to the ROM? Same happens with stock ROMs?
Have you charged network configuration since you've installed it? Maybe you have a network problem?
I don't want to assume things, I've had problems in the past because I have been using another gateway, exactly your problem, sometimes Facebook videos took ages to play
 

jwchen119

Senior Member
May 12, 2013
208
287
Tainan
I just want to report a bug that I did not find in the forum. When I reboot fast ... no normal reboot I get a damaged SD card.

It also sends slow for Bluetooth and is very slow and unstable to download over WiFi. When you try to download the last rom yesterday it was interrupted 3 times in the middle of the download

Corrupted SD card problem should be fix now. Your SD card is fine, don't worry. :)
WiFi D/U speed is quite normal here, nothing I can help. Can you provide logcat?

Can your sync your device code to github?and the kernel source
I want to build by myself just for fun :p

Hi,
Source code updated!
Hope you can contribute the code there, you can PM me with Chinese if having any problems.

Mate, I've noticed a problem, don't know if you seen it before. It seems sync() is not properly completing after removing huge files (such as 2gb+ movies).
is there anyway I can save the profiles I've previously created?

1. Not sure if updated kernel fix the problem, latest clark's kernel source adapted some sdcardfs related commit, you can try it in 0319 version and report back if it works.
2. Sorry I have no idea about this.

Can I flash this if I'm in marshmallow with the SD card formatted as adoptable storage? I mean, do I have to reverse the adoptable storage thing first or does TWRP will see the SD card as part of internal storage?

Didn't tried it, but it should have no problem to flash it upon the adoptable storage, here's the REF :https://github.com/TeamWin/Team-Win-Recovery-Project/issues/878
but don't forget to report back to us the result :)

What works:
a) the IR sensor working, even when it's not charging. I can swipe my hand over and display notifications.
b) LED notification light is working as you'd expect. I read that it wasn't working with custom Moto Roms.

a. You might noticed you have to wave your hand closer than usual, it is because the proximity sensor still working, but IR sensor isn't :(
b. LED is always fine, some users was asking for the blinking and multi color problem which I explained recently. Also makes the color unadjustable.
 
Last edited:

Markweiser

Senior Member
Mar 14, 2013
71
13
is there anyway I can save the profiles I've previously created?

2. Sorry I have no idea about this.

.
It's regarding the "System profiles" feature present since latest CM versions (Settings -> System profiles), how can I preserve it between installs? Do you mind telling me the location the configuration files are kept?

Thanks a lot!
 

aka70698

Member
Jul 22, 2013
15
3
Do you think this is related to the ROM? Same happens with stock ROMs?
Have you charged network configuration since you've installed it? Maybe you have a network problem?
I don't want to assume things, I've had problems in the past because I have been using another gateway, exactly your problem, sometimes Facebook videos took ages to play
No I moved back to stock there is no problem there .
I think may be it has to do with hardware acceleration. Because the same problem exists with MX player but switching from hardware HW to software SW acceleration the problem solves
 
  • Like
Reactions: Markweiser

arturox

Senior Member
Mar 12, 2012
126
117
Lima
Hi @jwchen119, I have updated with the build from yesterday and now I have some things that are not working.

1. Notifications are not showing on the phone, the notification led is working and notifications are displayed on Android Wear but not on the phone.
2. When you swipe down from taskbar only can swipe once, the second time, that displays all the quick settings, is not working.
3. Configuration > Users is not working anymore..
4. All apps permisions where deleted, I have to allow permissions like it was the first time I open the app after installing it.
5. After playing a Youtube video in full screen, I can't go back to the app because the navigation buttons are not displayed, also notification bar cant work after you play the video in full screen.
6. Home and multitask buttons are not working.

Please people can you tell me if I'm the only one or is a general issue.

Thanks
 
Last edited:

wei200041

Member
Jul 27, 2010
33
18
harbin
Hi @jwchen119, I have updated with the build from yesterday and now I have some things that are not working.

1. Notifications are not showing on the phone, the notification led is working and notifications are displayed on Android Wear but not on the phone.
2. When you swipe down from taskbar only can swipe once, the second time, that displays all the quick settings, is not working.
3. Configuration > Users is not working anymore..
4. All apps permisions where deleted, I have to allow permissions like it was the first time I open the app after installing it.
5. After playing a Youtube video in full screen, I can't go back to the app because the navigation buttons are not displayed, also notification bar cant work after you play the video in full screen.
6. Home and multitask buttons are not working.

Please people can you tell me if I'm the only one or is a general issue.

Thanks

1.do a nandroid backup
2.wipe /data, /cache and /system from TWRP
3.reflash the ROM、Google apps and su
ps: two fingers swipe down taskbar once display all quick settings .:cyclops:
 
  • Like
Reactions: jwchen119

jwchen119

Senior Member
May 12, 2013
208
287
Tainan
It's regarding the "System profiles" feature present since latest CM versions (Settings -> System profiles), how can I preserve it between installs? Do you mind telling me the location the configuration files are kept?

Thanks a lot!
I know the system profile, but I'm afraid I don't know how to reserve the setting after every install...

No I moved back to stock there is no problem there .
I think may be it has to do with hardware acceleration. Because the same problem exists with MX player but switching from hardware HW to software SW acceleration the problem solves

First, do you use WhatsApp? It cause the bug by play voice recording along with any other media playing.
We also have trouble in playing HW decode video along with any other media playing.
The bug will cause the video lagging or out of sync with audio.
Last night I've fixed the bug but need more testing, I will likely upload a hotfix tonight if everything goes well!

Hi @jwchen119, I have updated with the build from yesterday and now I have some things that are not working.

1. Notifications are not showing on the phone, the notification led is working and notifications are displayed on Android Wear but not on the phone.
2. When you swipe down from taskbar only can swipe once, the second time, that displays all the quick settings, is not working.
3. Configuration > Users is not working anymore..
4. All apps permisions where deleted, I have to allow permissions like it was the first time I open the app after installing it.
5. After playing a Youtube video in full screen, I can't go back to the app because the navigation buttons are not displayed, also notification bar cant work after you play the video in full screen.
6. Home and multitask buttons are not working.

Please people can you tell me if I'm the only one or is a general issue.

Thanks

I'm always do "clean" compilation, so it will cause some bugs by dirty flash, you might need to do a clean install.
 

LoTableT

Senior Member
Nov 23, 2010
170
26
La Spezia
This rom works wel. But i have only one little issue.
I have installed Hearthstone and when i swich to another application like Discord, audio seems to goin on crash or something.
 

arturox

Senior Member
Mar 12, 2012
126
117
Lima
I'm always do "clean" compilation, so it will cause some bugs by dirty flash, you might need to do a clean install.
After doing a clean install everything is working OK as it used to be. Thanks.

As a suggestion, I don't know if you can make updates that don't need a clean install, just like official nightlies of LineageOS.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 72
    P3UnxWJ.png
    Unofficial LineageOS 14.1 for Kinzie​

    Hi, everyone I'm from Taiwan! First, I have a BIG thumb up to @Arasthel for helping me out some mirror bugs which is really tough to fix, and he also did so many test on this. Without him this project will not make it.
    This is the successor to my CM13 ROM: https://forum.xda-developers.com/droid-turbo-2/development/cyanogenmod-13-0-unofficial-kinzie-port-t3503053

    What works:
    Everything except:
    • GPS over Wi-Fi will only works when Gapps installed.
    • IR sensor stop working when screen off(Works when charging.)
    • Torch tile won't work sometimes after reboot, it is because the moto sensor isn't initialize properly.(To fix this bug, you have to pull down the statusbar and press edit icon.)

    Kernel feature:
    • Westwood TCP congestion algorithm (enabled by default)
    • ZRAM
    • SWAP
    • NTFS support
    • CIFS support
      the kernel is not stable for patching these addons, will ad back these features when ready.

    Compatibility:
    This ROM is MAINLY for Moto X Force. Now we confirmed Droid Turbo 2 also working.(20170312)
    Confirmed working on CN variant(XT1581), EU variant (XT1580) Brazil (XT1580, timbr and tefbr) Moto X Force and Verizon Droid Turbo 2 (Reported by a Chinese with his unlocked version of DT2.)
    Some Chinese user reported they can flash this ROM from stock 5.1.1 ROM without having any problem.
    If you have any modem problem such as no signal or no Wi-Fi connection, flash clean stock ROM base on your variant and then flash this ROM.

    Downloads:
    ROM:
    Latest LineageOS14.1 ROM for Kinzie

    OpenGapps: Platform: "ARM64", Android: "7.1", Variant: "pico" or "nano" is recommended
    Addon SU: https://lineageos.mirrorhub.io/su/addonsu-14.1-arm64-signed.zip Flash "addonsu-14.1-arm64" for install and "addonsu-remove-14.1-arm64" for uninstall.

    Installation instructions:
    1. Unlock bootloader, if you don't know how to do it, please check the posts or search from Droid Turbo 2 section.
    2. Flash TWRP from bootloader. @Xadro's is strongly recommended.
    3. First and the most important is to do a nandroid backup from TWRP! Then do a clean install (wipe /data, /cache and /system from TWRP.) After flashing the ROM, flash a Google apps package or su, and then reboot.

    Source code:
    https://github.com/lineageos-for-kinzie

    Credits:
    • CyanogenMod/LineageOS and its contributors
    • Open GApps
    • Specially thanks to @Arasthel and @Xadro for their works on initially porting cm12.1 to Kinzie

    XDA:DevDB Information
    LineageOS 14.1, ROM for the Droid Turbo 2

    Contributors
    jwchen119
    ROM OS Version: 7.x Nougat
    ROM Kernel: Linux 3.10.x
    Based On: Project from Clark with 3.10.x kernel, ROM for the Moto X force

    Version Information
    Status: Beta

    Created 2017-01-11
    Last Updated 2018-04-23
    23
    Changelog:

    April 20, 2018:
    ROM:
    *Latest upstream from LineageOS 14.1
    *Upmerge commits from Clark
    *Android Security Patch Level: April 5, 2018
    ** If you have SIM card can not recognize, it is recommand to do a clean flash, this update have some modification about the RIL

    Kernel:
    *Upmerge commits from Clark

    March 17, 2018:
    ROM:
    *Latest upstream from LineageOS 14.1
    *Upmerge commits from Clark
    *Enable SWAP and ZRAM(I guess none have noticed.)
    *Android Security Patch Level: March 5, 2018


    Kernel:
    *Upmerge commits from Clark

    August 10, 2017:
    ROM:
    *Latest upstream from LineageOS 14.1
    *Android Security Patch Level: August 5, 2017

    June 11, 2017:
    ROM:
    *Latest upstream from LineageOS 14.1
    *Android Security Patch Level: June 5, 2017

    Kernel:
    Re-enable ZRAM and SWAP for better ram handling.


    May 28, 2017:
    ROM:
    *Latest upstream from LineageOS 14.1
    *Android Security Patch Level: May 5, 2017
    *Fixed over heat problem related to OOS thermal manager. Using stock closed source thermal manager now.
    *Dropped Gello, welcome Jelly.

    April 29, 2017:
    ROM:
    *Latest upstream from LineageOS 14.1
    *Android Security Patch Level: April 5, 2017
    *Android version is now 7.1.2 with various of AOSP commits merged.
    *Fixed low mic volume when using video chatting apps.

    April 08, 2017:
    ROM:
    *Latest upstream from LineageOS 14.1
    *Fixed mic not working when speakerphone mode on in call.
    *Fixed the other side hear their echos when speakerphone mode on in call.
    *Fixed volume not adjustable in call by updating ACDB ids by acdb_get tool.(BIG thanks to @luca020400)
    *Enabled QCOM AEC(Acoustic Echo Canceler) and NS.(Noise Suppressor)
    *Tweaked cpu4 to stay awake for userspace tuning.
    *Tweaked vendor files which significantly makes our overall system runs more smoothly, but drops the VoLTE for now.
    *Totally drop QCOM memory enhancements for more efficiency task management.

    Kernel:
    *Disabled some useless debug flag.
    *Disabled some lowmemorykiller flag for more efficiency task management.
    *Revert some of the ASOC commits for fixing echo issue when speakerphone enabled in call.
    *Add and change default TCP congestion algorithm to Westwood.



    March 21, 2017:
    ROM:
    *Fixed play WhatsApp voice record causing audio crash. After the bug present, Youtube, Facebook or any other media will out of sync with audio.
    *Fixed play video in HW decode with any other background audio cause crash.
    *Might fix any other audio related issues.
    *Disable SWAP and ZRAM which could bring a bit more performance.
    *Stop using Snapdragon LLVM Compiler, this might cause some known bugs, will bring it back when stable enough.
    *Two finger swipe down the statusbar will trigger quick pull down, thanks @wei200041
    *Many tiles have added, you can check it by pull down statusbar->edit icon.

    March 19, 2017:
    ROM:
    *Latest upstream from LineageOS 14.1 and clark
    *Source code updated! You can now check the source from Github.
    *Updated the mixer paths for ultra low latency audio playback to fix some audio problem such as no sound in specific games.
    *Added proximity sensor support in cmaction to prevent Chop-Chop active when proximity covered.(the torch keeps on and off in my pocket when I go down stairs)
    This feature cherry-picked from motorola_msm8916-common, big thanks to [email protected]
    *Fixed "Corrupted SD card" message shows up after soft reboot.
    *Fixed power-off charging. It will now shows current battery percentage.
    *Tweaked Wi-Fi speed by bounding 2.4 GHz, theoretically it will double throughput of your device.
    (Note: your Wi-Fi router AP have to be configured to use HT40 mode.)
    **LineageOS 14.1 confirmed to be working on Verizon Droud Turbe 2 bootloader unlocked version. Everything works fine.

    Kernel:
    *Merged CVE security vulnerabilities source from latest Clark's commit to fix various security hole.
    *Added Westwood TCP congestion algorithm.

    March 8, 2017:
    ROM:
    *Latest upstream from LineageOS 14.1 and clark
    *Android Security Patch Level: March 5, 2017
    *Added 3G/4G support for SIM2 (Confirmed working! check post#141)
    *Disable multi color options of LED, we only have bright green LED by hardware limitation; we also have no blink support due to the same reason.
    I think this is why Motorola disable the LED notification by default.
    *Tuned LiveDisplay default profile more fit to our display's color temperature.
    *Updated latest Widevine blobs from bullhead N4F26I.
    *Updated latest graphic blobs from angler N4F26J.

    About the new feature One-hand mode, quote from LineageOS blog:
    This feature is enabled in all LineageOS 14.1 builds from 6th March 2017. To use it on devices with on-screen navigation buttons, swipe right or left on the home button. On devices with hardware keys.
    I figure out that swipe right or left anywhere on the "navigation bar" can also enable this feature.

    February 24, 2017:
    ROM:
    *Latest upstream from LineageOS 14.1 and clark
    *Add timbr and tefbr for Brazilian variant. This should fix the SIM not recognized problem!
    *Add VoLTE support. (Not tested, please report if it works.)
    *Add aptX and aptX HD support(Not tested, please report if it works properly.)
    *Fix GPS drifting issue by updating GPS HAL to latest version, LA.BF64.1.2.3-01310-8x94.0 from CAF.
    *Fix GPS drifting issue by updating the latest GPS blobs from ether.
    *GPS's locking quality is now more fast, stable and accurate!
    *Re-enable sdcardfs for better performance.
    *Compiled ROM by Snapdragon LLVM Compiler for better performance.

    Kernel:
    Remove kernel features until it is stable.

    *LineageOS will not ship SU by default, please check OP for the download link to LineageOS's download page for SU install/uninstall package.

    January 27, 2017:
    ROM:
    *Latest upstream from LineageOS 14.1 and clark
    *Fix call recording not working.
    *Fix GPS drifting(jumping location when using navigation) issue. It is still unstable.
    *Fix media sharing and playing issue.
    *Fix exfat format SD card read/write issue
    *Camera only have slow open at the first launch after reboot
    *This build have no SU pre-installed, flash SuperSU if you need root permission.


    January 13, 2017:
    ROM:
    *We will rebrand to LineageOS in next release.

    Kernel:
    *Fix Wi-Fi hotspot not working.


    January 11, 2017:
    ROM:
    *Initial release alpha version.

    Kernel:
    *Initial release alpha version.
    10
    Latest LineageOS 15.1 compiled and booted fine. This is extremely buggy though.
    modem, camera, audios are broken, I'm trying to fix these issues.
    But since we are still sharing the same device tree with moto x pure, our camera may have to be fix after x pure.

    vaGsves.jpg



    @gyarados025 it took me about 80 GB to compile and took me at least 7 hours.
    Suggest you at least have 120 GB to install needed packages.
    It is weird that LOS15.1 use a lot more time while LOS14.1 only took me 3-4 hours for clean compile...
    8
    Hi! Thanks for great job! I have one trouble in latest build (21/03/2017). When i'm in a call i can no longer adjust the voice volume. The volume slider moves when I press the volume toggles but the volume doesn't increase or decrease either way. XT1580.
    @jwchen119 Where is the update?:D

    New build is up, fixed several audio related in call problems. Check changelog at #2 for more detail.

    And I'm not working on ROM 24/7, it takes time for me to debug and solving the issues. Please be patient and understand.
    8
    Good afternoon...

    Sorry for the time, my Life is a bit rushed so i didn't make any updates for the ROM, but i'm sure until the weekend we will have a new build of it, still Android 7.1.2...

    Thanks anyway for all the people still using this ROM...