[ROM][UNOFFICIAL]LineageOS-14.1 for N7100 | Android 7.1.2 Nougat [MAY 2022]

Search This thread

M4Master96

Senior Member
OShAoVv.png

LineageOS is based on the Android Open Source Project with extra contributions from many people within the Android community. It can be used without any need to have any Google application installed. Linked below is a package that has come from another Android project that restore the Google parts. LineageOS does still include various hardware-specific code, which is also slowly being open-sourced anyway.

Code:
/*
* Your warranty is now void.
*
* I am not responsible for bricked devices,
* thermonuclear war, or you getting fired because the alarm app failed. Please
* do some research if you have any concerns about features included in this ROM
* before flashing it! YOU are choosing to make these modifications, and if
* you point the finger at me for messing up your device, I will laugh at you.
*/

What's working :

Everything that worked in last OFFICIAL build.

Instructions :
  • Download build and copy it to Internal Memory
  • Reboot to TWRP recovery
  • Create TWRP Backup (Recommended)
  • Flash the latest build (Clean Flash if coming from any other build)
  • Flash Magisk (Optional)
  • Flash GApps/MicroG (Optional)
  • Reboot

Downloads :

Source Code: https://github.com/LineageOS
Device Tree: ComicoTeam/android_device_samsung_n7100 (Thanks @ComicoX for maintaining separate device tree)
Proprietary Files: TheMuppets
Kernel Source: Here

ROM OS Version: 7.1.2 Nougat
ROM Kernel: Linux 3.0.101
Security Patch: May 2022

Created 2020-11-08
Last Updated 2022-05-15
 
Last edited:

M4Master96

Senior Member
GOOD!
BUT why 14.1 in this time?
14.1 is good enough than other version?

Why not ?
May I ask why do you need latest Android as Nougat is still receiving latest security patches?

It depends from person to person. I am using it as a backup device. I don't want latest android, just wanted latest security patch so that in case my daily driver fails, I still have this.

You are free not to use this :)
 
  • Like
Reactions: i5510

higger

Member
Feb 28, 2018
10
0
You are right~ You are right~ So far Android 7 seems to be the most suitable system for note2~ Maybe I never know the meaning of Android security~ This is my problem
 

AbdAbd10

Member
Apr 23, 2012
38
5
thank you for the rom .
is their away for the option kill app by holding the back button in this rom
because i couldn't find it in he buttons or the developers sections
 

patria o muerte

Senior Member
Sep 23, 2013
50
5
hello, I have a n7100 with the stock rom. I tried to install this rom via twrp 3.4.0.0 t03g but when flashing it gives me error 7. What did I do wrong?
Thanks.
 

hasekev99

Senior Member
Dec 12, 2013
100
7
Nexus 7 (2013)
HTC One (M8)
Clean or dirty flash ?

---------- Post added at 07:47 PM ---------- Previous post was at 07:29 PM ----------

Yesterday I installed the version from November 6th, 2020 with TWRP 4.0. Worked without errors. Today I wanted the version from November 19th. install dirty. Aborted with error code 7. Any idea ...

---------- Post added at 07:48 PM ---------- Previous post was at 07:47 PM ----------
 
Last edited:

M4Master96

Senior Member
thank you for the rom .
is their away for the option kill app by holding the back button in this rom
because i couldn't find it in he buttons or the developers sections

Scroll down to the end of Developer Options. You will find the option there.


Option Enabled in Developer Options
eVndoag.png


App Killed
7o9ThzB.png




Clean or dirty flash ?

---------- Post added at 07:47 PM ---------- Previous post was at 07:29 PM ----------

Yesterday I installed the version from November 6th, 2020 with TWRP 4.0. Worked without errors. Today I wanted the version from November 19th. install dirty. Aborted with error code 7. Any idea ...

---------- Post added at 07:48 PM ---------- Previous post was at 07:47 PM ----------


I clean flashed without any issues (Check Attached Screenshot in first post)
 

AbdAbd10

Member
Apr 23, 2012
38
5
hello, I have a n7100 with the stock rom. I tried to install this rom via twrp 3.4.0.0 t03g but when flashing it gives me error 7. What did I do wrong?
Thanks.

in v 3.4.0.0 after wiping your phone u have to reboot the phone again to the recovery than install the rom or you will get this error

---------- Post added at 12:59 PM ---------- Previous post was at 12:30 PM ----------

Scroll down to the end of Developer Options. You will find the option there.


Option Enabled in Developer Options
eVndoag.png


App Killed
7o9ThzB.png






I clean flashed without any issues (Check Attached Screenshot in first post)

thank you
i reinstall the rom but i guess now i couldn't find the Developer Options but i google it than i fond that i have to click 7 times on the build number for it to appear than i fond the option
thank you again and sorry if i bothered you with my question
 
Last edited:

hasekev99

Senior Member
Dec 12, 2013
100
7
Nexus 7 (2013)
HTC One (M8)
Today I flashed the version from 19.11 dirty over the version from 06.11 and it worked. First booted into recovery then cache and dalvik cache deleted then rebooted into recovery and then flashed .... works...
 

AbdAbd10

Member
Apr 23, 2012
38
5
is it just me or .. any apps that have videos in it cant show let say like youtube app or the browsers like firefox or any app with videos the videos cant show or work
and i tried everything give permissions . nothing work
 

konzi

New member
Feb 10, 2017
4
44
is it just me or .. any apps that have videos in it cant show let say like youtube app or the browsers like firefox or any app with videos the videos cant show or work
and i tried everything give permissions . nothing work

I have the same issue with video ... I also couldn't figure out why :( Sorry to here I'm not the only one with this issue. If somebody has an idea how to solve it, i would appreciate it.
 

sid2109

Member
Sep 7, 2018
44
22
A friend who installed it mentioned that this ROM has several bugs. Sensors aren't working. No GPS, No Proximity, No light sensors. The only working sensor is acceleration. As others have reported, videos don't play in apps like youtube. Works only on chrome. Quite a buggy ROM even for a backup phone. Hopefully the dev looks into it in the next release (if any).
 

konzi

New member
Feb 10, 2017
4
44
I have the same issue with video ... I also couldn't figure out why :( Sorry to here I'm not the only one with this issue. If somebody has an idea how to solve it, i would appreciate it.

Now I have the video working. I did a clean flash instead of a dirty one and restored some apps from backup (oandbackup/titanium backup).

GPS works for me fine with the old and the new security patches.

Thanks for sharing the ROM with use M4Master96 and that you put the work into it just for a backup phone.
 
  • Like
Reactions: M4Master96

Top Liked Posts